Page Cover.html

Cover


Page 1

1
Concepts

Contents

1.1 Sampling and bias | 2
1.2 Why unbiasedness is desirable | 3
1.3 Sources of bias in microscopy | 4
1.4 The hierarchical nature of microscopical investigations | 6
1.5 Stereology—geometrical quantification in 3D | 7
1.6 Think in three dimensions—a macroscopic analogy by thought experiment | 7
1.7 Dimensions and sectioning | 9
1.8 Geometrical probes | 11
1.9 Ratios and densities | 12
1.10 The reference space | 12

Box

1.1

Dimensionality and scaling effects

14

A quantitative scientific analysis of any sort requires a higher level of objectivity and rigor in methodology than a comparable qualitative assessment. This rigor should extend from the planning of a study, through sampling of fundamental units and sub-samples to the actual measurements made. Perhaps counter-intuitively the need for rigor increases in importance as the proportion of the total object being studied decreases. If a microscope is used to resolve the structures of interest it is almost inevitable that only a tiny fraction of the original object will actually be analyzed. For example, consider what proportion of an object is actually examined when a light microscope is employed in a histopathological analysis. An object the size of a neo-natal human kidney (about 12000 mm3 in volume) will often be used to generate three or four blocks from each of which a single 5-μm-thick section will be microtomed and mounted. On each of these sections a small number of fields of view will be examined. This sampling regime would therefore involve the examination of a few hundreds of cubic microns of tissue, which is a million millionth (10−12th) of the volume of the original organ. Whilst such a tiny fraction may suffice to give a reasonable qualitative feel for the condition of the organ it is unsuitable for quantitative analysis unless it has been obtained with a statistically sound sampling method.

It would appear that many scientists involved in quantitative microstructural analysis rarely consider this ‘reducing fraction’ problem. Unfortunately the problem increases non-linearly with an increase in linear magnification. For example, consider Figure 1.1 where each succeeding field of view is a magnified portion of the previous field with each increment of linear magnification being by five times. Even at a modest magnification of ×125 only 1/30000th of the two-dimensional (2D) object is in the field of view. In three-dimensional (3D) objects the ‘reducing fraction’ problem is even more acute than for this 2D example. Once the magnification required enters the range covered by electron microscopy the ‘reducing fraction’ problem


Page 2

Figure 1.1

This figure illustrates how the effect of increasing magnification decreases the proportion of the original object being sampled. At each stage the linear magnification has been increased by five times. The square at the right of the figure represents a field of view of the object at 625 times magnification, it also represents a fraction of 1/730000th of the 2D object and illustrates the rate of increase of the ‘reducing fraction’ problem of quantitative microscopy.

becomes quite frightening. For example, it has been calculated that if all the material that had ever been in focus in any of the transmission electron microscopes in the world were gathered together it would total less than 1 cubic centimeter in volume. Whereas this calculation may not be strictly correct it is probably accurate to within an order of magnitude. Consider how many hypotheses have been made and conclusions drawn from the microscopic examination of such a minute proportion of the total from which it was taken.

Clearly then, in all scientific work involving microscopy the whole of the object of interest cannot be examined and a sample of some description must be taken. For example, if we want to quantify the number of nerve cells in a human brain (many billions) it is obvious that they cannot all be counted. It is therefore necessary to take a sample of the material and make an estimate of the number required. The nature of the sampling that is carried out is absolutely fundamental in determining the quality of the estimate and therefore the overall validity of the investigation. For example, if the nerve cells were concentrated in one particular region of the brain and that part was oversampled then an overestimate of the total number would be obtained. The answer would in fact be biased. It should be noted that the act of ‘choosing’ interesting material to report, which is the usual way to proceed in a qualitative investigation, is expressly excluded if a quantitative investigation is to be valid.

1.1 Sampling and bias

A good everyday example of the crucial part that sampling plays in an estimation method is provided by public opinion polls. By taking as few as 1000 people from a population numbering many millions it is possible to gain surprisingly accurate forecasts of the outcome of elections. For these forecasts to be accurate (or unbiased) two separate and equally important stages must be performed.

1. The sampling should be uniform random—that is, every member of the population needs to have an equal chance of being selected for the sample. Polling organizations go to great lengths to try to ensure that their sample is suitably random. It is clear that if a pollster collected a sample by standing inside the lobby of a five-star hotel he would be likely to get an entirely different set of opinions about satisfaction


Page 3

Figure 1.2

An illustration of how the averages of unbiased and biased estimator of N behave as an experiment is replicated. In both cases as the number of replicates increases the average of the series settles down to a steady value. In the case of the unbiased estimator (Y) the average that is settled on is equal to the true value. In the case of the biased estimator (X) the average settles to some value which is not equal to (i.e. systematically different from) the true value. The different between the average of the biased estimator and the true value is the degree of bias in the estimator (B). This bias is invisible in a given set of experimental data because the ‘true value’ is unknown.

with life than if he sampled people solely at an advice bureau for the unemployed. Either of these notional samples would be judged to be prone to sampling bias.

2. Once a uniform random sample has been collected from the population the sample must be interrogated in some way to obtain information. We all know that there are biased and unbiased ways of asking questions. If leading questions are employed, for example, then the answers may well lead to systematic bias in the results of the survey.

In a microscopical analysis both of these stages are equally important if the final estimate is going to be free of sampling and systematic biases.

1.2 Why unbiasedness is desirable

We have just introduced the idea that an estimate of an unknown quantity can be either biased or unbiased. It is clear what these words mean in the context of a court of law or newspaper report but what does unbiased mean in the context of quantitative microscopy? In particular why are we interested in seeking unbiased estimates of structural quantities?

In any experimental method where the answer we obtain is a number, it is not possible to establish from this number alone whether it represents the truth. For example, consider Figure 1.2. This shows the moving average of values arising from two experimental methods, X and Y, which are used to estimate the same quantity. The line marked X settles down rapidly to a stable value, which is not equal to the true value. The line marked Y takes longer to settle down, but when it does so it is at a value that is equal to the true value. The Y method shows unbiased behavior. The line marked X shows the behavior of a biased method. The magnitude of the bias in method X is


Page 4

Figure 1.3

A graphical illustration of the difference between precision and accuracy in an experiment. The top row of targets shows high precision, that is the hits are closely clustered together. The bottom row shows low precision and there is a marked scatter of hits. In the left-hand column the average of the cluster of hits tends toward the bull’s-eye, which means that they are accurate. The right-hand column shows the converse case, these hits are inaccurate or biased. In a given experiment we want to be in the left hand column. This can be achieved using correct sample design and measurement methods. Whether we are in the high- or low-precision box is dependent upon the object of interest and in many cases can be controlled by working harder.

shown on the graph as B. It is very important to understand that:

● the magnitude of the bias B is totally invisible at the end of an experiment, you simply have a numerical estimate;

● the presence or absence of bias depends upon the experimental or sampling method used.

The reader should not confuse unbiasedness (accuracy) with efficiency (precision). It is possible to have a biased estimator which is ‘efficient’, in that it converges on to a stable value quickly and has a very small standard deviation, just as it is possible to have an inefficient unbiased estimator, as shown in Figure 1.3.

We have at this stage not described some of the more subtle aspects of unbiasedness. These are explained more completely in Chapter 10. However, the overall message remains unchanged. Unbiasedness is perhaps the most desirable attribute a scientific method can have.

1.3 Sources of bias in microscopy

In common with opinion poll surveys there are two principal sources of bias found in quantitative 3D microscopy, sampling bias and systematic bias. The systematic


Page 5

biases can be divided into theoretical and practical varieties. In particular there are a number of ‘technical errors’ that give rise to systematic bias in microscopy. The methods we describe below are ‘theoretically’ capable of delivering unbiased results. The methods are, by their construction, mathematically rigorous. They cannot, nor do they need to be ‘calibrated’. However, we live in a real, non-ideal, world and there are many potential sources of error, which come under the general heading of systematic bias. These include tissue shrinkage, inaccurate set-up of microtomes, incorrect optical set-up of microscopes, staining uniformity, calibration errors, variable section thickness, camera distortions, etc. The list is extensive. Throughout the text we will point out where there are likely to be major impacts on results from these influences and ways of minimizing them.

Sampling bias

Before sampling commences, every part of the original specimen should have the same chance of becoming part of the final sample on which measurements are to be made. This is strictly analogous to the requirements for sampling people in an opinion poll. Therefore uniform random sampling should be employed at every level of the sampling hierarchy. At no stage should anything within the defined reference space be ‘chosen’. Suitable sampling schemes will be introduced in Chapter 2 and addressed repeatedly throughout the rest of this book.

Systematic bias

The only way to avoid systematic bias is to use the correct ‘measurement tool’. For example if a ruler 1 meter long was graduated in kilometers rather than millimeters its use would incur a massive systematic bias (in fact a million-fold!) and nobody in their right mind would use it as such. A more subtle example is provided by instrument calibration errors. The driver of a car on a motorway reads from his speedometer that he is travelling at 100 kilometers per hour. A correctly calibrated police radar gun records that the car is in fact travelling at 110 kilometers per hour. The car’s speedometer is subject to a systematic bias of 10 kilometers per hour. As this is the only information that is available to the driver the bias is completely invisible. The only way, in this example, to be sure of the speed would be to use an unbiased speedometer. There is a fundamental difference between accuracy and precision. In many stereological studies it is possible, in general, to control the precision of the estimates that are being made. The sampling intensity can be increased by taking more blocks, sections, and so on, per individual. However, accuracy cannot be ‘bought’ by working harder. Accuracy can only be guaranteed by using ‘tools’ (i.e. methods) that are inherently imbued with unbiasedness. In the case of stereology this starts with the experimental design and uniform random sampling and then proceeds to the application of a set of unbiased ‘geometrical questions’ in 3D which are called ‘probes’. The a priori guarantee of accuracy of these methods, without the need for validation studies, is a major advantage. They can literally be ‘taken off the shelf’ and used in any situation.

Many mathematicians and statisticians are quite open to the idea of a method that is guaranteed to yield an unbiased answer prior to sampling. However, in our experience experimentalists have a resistance to accepting a method a priori. This simply reflects the different training received by mathematicians and experimental scientists. Experimentalists have usually been trained to scrutinize their methods carefully before using them and if possible to validate them against other methods. Whereas this is excellent practise in many situations it is unnecessary in design-based stereology. If the stereological methods described in this book are applied strictly to the


Page 6

sampling designs then they are rigorously mathematically sound and cannot be validated with data (Cruz-Orive, 1994). These methods in fact are the ‘gold standard’ against which other morphometric methods should be compared.

With biased estimators none of the attractive properties described above hold. No matter how much effort is expended if the method is biased then the estimate will not approach the true answer. In fact by measuring a biased estimator precisely it is guaranteed that you do not get the true answer (on a slightly sardonic note—when measuring a biased estimator imprecisely you might, by chance, stumble across the true answer, although you wouldn’t know, for bias is invisible and undetectable within any one experiment).

Stereological methods that rely on sampling designs for their unbiasedness have become known as ‘design-based’ or ‘unbiased’ Stereology. These methods do not rely upon restrictive assumptions concerning feature shape or randomness. Prior to 1980 many of the methods used in Stereology did require unrealistic assumptions to be made.

1.4 The hierarchical nature of microscopical investigations

The procedure for preparing specimens for microscopy is essentially hierarchical. Blocks are taken from the main specimen, sections are cut from blocks, fields are examined on sections and (finally) measurements are made on fields (see Figure 1.4). Because each block, section and field is not identical there is a variability introduced into the estimate which is purely an artefact of the preparative procedure. A detailed analysis of the variance found in this type of hierarchical experiment will be presented in Chapter 10 but at this stage it will be instructive to consider the relative contributions of variance at the different levels (Gundersen and Østerby, 1981). In a typical biological experiment the overall observed variance often consists of the following relative components:

Inter-individual (biological) variability | 70%
Variability between blocks | 20%
Variability between sections | 5%
Variability between fields | 3%
Variability between measurements | 2%
Total observed experimental variability | 100%

Figure 1.4

A demonstration of the hierarchical nature of sampling for microscopy. For quantitation it is important that the selection of objects, blocks, sections, and so on at each level is uniform random.


Page 7

The message from this distribution of variability is that concentrating on making very precise measurements, for example with an automatic image analyzer, at the level of the micrograph will at best only increase the precision of the overall experiment by about 2%. With relative variances such as those given above, an efficient way to increase precision would be to look at more individuals and/or take more blocks per individual.

In biological experiments the distribution of variability described above means that the actual measurements required in assumption-free stereology are generally sparse at the micrograph level. From a practical point of view then, the bulk of the effort should be spent on taking blocks, sampling sections, and so on and not in making measurements on micrographs. For this reason the methods are very efficient, in fact the rule of thumb in many biological studies is to count or measure only 200 points, intersections, and so on per animal (e.g. Gundersen et al., 1988a,b). In our experience the use of sparse geometrical probes at the micrograph level often causes unease amongst novice stereologists. In particular many people simply don’t accept that the random casting of a few point, line or frame grids into space can lead to a precise estimate of 3D properties. Grasping the underlying hierarchical nature of the sampling design outlined above is one key to accepting this.

In materials science applications it may well be that the distribution of variability is quite different from that in the typical biological situation described above. In these circumstances a higher workload at the micrograph level may be required. In these situations a small pilot experiment can often be used to determine how the sampling effort should be distributed in the larger experiment. Calculation of the overall precision of a stereological experiment is quite easy to carry out and will be described in Chapter 10.

1.5 Stearology—geometrical quantification in 3D

Stereology is concerned with making quantitative estimates of the ‘amount’ of a geometrical feature within the object of interest. The features that are therefore available for quantification are feature number, length, surface area and volume. If these features are associated with a population of particles then it may be the average of these features per particle that will be of interest, for example mean particle volume. The geometrical properties of features in 3D space can be quantified by ‘throwing’ random geometrical probes, of various dimensions, into the space and recording the way in which they intersect with the structures of interest. These probes include volumes, 2D planes (i.e. sections), lines and points. There is an intimate relationship between the feature being quantified and the type of probe that is used, which will be described later in this chapter. However, for the time being it is sufficient to know that in classical stereology geometrical ‘probes’ are applied in 3D by cutting an object physically into thin sections and then using a 2D grid on the section. Depending on the dimensionality of the grid (points, lines, planes) unbiased estimates of volume, surface and length can be obtained. The process of sectioning the object to apply grids necessarily destroys the specimen. In some special cases non-invasive methods such as computerized tomography, ultrasound scanning, magnetic resonance imaging or confocal microscopy can be used for stereology.

1.6 Think in three dimensions—a macroscopic analogy by thought experiment

We all live in a 3D world and are quite used to thinking three dimensionally. However, the 3D thinking we require in our macroscopic world often evaporates


Page 8

when we are confronted by the apparently 2D images obtained from a microscope. Therefore for the time being we will stay at a macroscopic scale. Consider the room that you are sitting in to be the equivalent of a block from your specimen and the objects therein to be features of interest.

Points probe volume

If the room was filled with a regular quadratic 3D lattice of points, each say 10 cm apart, then it should be easy to appreciate that the number of points falling within objects would be in strict proportion to their volume. For example, the filing cabinet would contain more points within it than a computer monitor, which in turn would contain more than a floppy disc. On further reflection we could add that neither the shape nor orientation of the objects would have any effect on this result, only the volume. Stereologists often say that points act as probes for feature volume.

In standard histological and metallurgical microscopy, probing the specimen with points is actually achieved in two stages; first by cutting a section and then by applying a grid of points to the section, the latter act being rather 2D in nature. However, those who are thinking in 3D will immediately see that this two-stage process is analogous to throwing the points directly into a volume. In this case the section becomes the ‘vehicle’ for a grid of zero-dimensional probes.

Lines probe surface

Next consider surfaces. Imagine the room has a grid of parallel lines travelling between floor and ceiling, again arranged in a regular quadratic pattern. The number of times a particular object is hit by the lines will be related both to the surface area of the object and its orientation. For example, even if the carpet and curtains in the room had identical surface areas, the carpet, being normal to the direction of the lines, would be hit more often than the curtains, which are parallel to the lines. Therefore, in order to use linear probes to estimate the area of a surface, the orientation of the lines with respect to the surfaces must be taken into account. Imagine now that a rug has been placed on the carpet. Any line cutting the rug will also have an intersection with the carpet and therefore the number of intersections along any one given line will have doubled. This draws attention to the fact that the surface area of a feature in a given space will be related in some way to the density of intersections along the test lines.

In common with point grids we can also superpose a line grid on to suitable sections through the specimen. The combination of a line on a 2D slide is exactly equivalent to putting the line directly into 3D. Figure 1.5 shows a 3D potato being intersected by a linear probe (which is, for clarity, drawn on a plane) and the exactly equivalent case of a linear probe on a 2D section through the potato.

Planes probe length

The most commonly used geometrical probe in microscopy is actually the 2D section, though it is all too rarely thought of as such. In your room imagine a ‘false ceiling’ that can be moved to any position between the floor and the real ceiling, being parallel to those surfaces. For a number of random positions of this false ceiling it is easy to imagine that it would intersect your body with higher probability if you were standing up rather than lying flat on the floor. In other words the false ceiling will hit objects in proportion to their height normal to it. This means that the orientation of the object, as well as its height, is important. When dealing with structures that have


Page 9

Figure 1.5

In (a) a 3D object, for example a potato, is penetrated by a line probe. This is entirely equivalent to taking a section through the object and placing the linear probe on the section, as illustrated in (b).

length but which are not particulate (e.g. tubules in biology or heating pipes in your room) these features will be cut in proportion to their length. In common with surfaces the number of intersections between a section plane and a linear feature will depend on orientation and therefore the caveats concerning orientation remain important.

Volumes probe number

Now suppose that you wish to count the number of pieces of furniture in the room. In three dimensions this is not difficult. Each piece is assigned a ‘weight’ of ‘1’ if it is present and of ‘0’ if it is not. This weight doesn’t depend upon the shape, color, mass, surface area, orientation, and so on of the object, it merely indicates the presence or absence of the object. This weight is sometimes known as the cardinality of the object. Because each object has a weight of 1 this type of selection is known as uniform selection. In order to assign weights correctly the pieces of furniture need to be seen in their full glory, that is they need to be seen in 3D. In fact it is easy to imagine how difficult it would be to try to estimate item number from a single section through the room. As stated above, objects in the room would be hit by the section in proportion to their size and orientation, not in proportion to their presence. Furthermore, a single object can give rise to multiple profiles. For example, a table may be sectioned in such a way that all four table legs are seen but nothing else.

Notice that in this ‘thought experiment’ we have not actually physically ‘sectioned’ the room but have observed how a set of geometrical probes have interacted with features in a 3D ‘world’. In practise then we must give further consideration to the sectioning and in particular to what we see on the sections.

1.7 Dimensions and sectioning

In 3D it is not usually possible to put geometrical probes into an object in a way that can be observed. This problem can be overcome for point, line and area probes by


Page 10

using a 2D section as a way of getting the probes into the object (e.g. Figure 1.5). However, in order to keep thinking in 3D it is important to realize that the act of sectioning an object causes a peculiar and marked problem:

The dimensionality of the geometrical information that we obtain from a thin section through an object is not the same as in the real 3D world.

Consider Figure 1.6 where a solid apple has been cut with a 2D plane. The volume of the apple is seen on the section as a 2D transect, while its surface is seen as a one-dimensional (1D) boundary trace. The unfortunate worm that was wandering through the 3D space of the apple is seen as a transect consisting of three small profiles, which in this context we might call countable events. Notice that in each case the dimensionality seen on a 2D section is equal to the dimensionality of the feature in 3D minus 1. These relationships are made clearer in Table 1.1 and Figure 1.6. It should be noted that number is not seen on sections because it is zero-dimensional in nature.

If this sectioning effect is ignored then we will undoubtedly make mistakes in 3D quantification. For example, we might start reporting particle size as an average 2D

Table 1.1 The relationship of dimensions in 3D to those seen on sections

Real world (3D) | Section (2D)
Volume (L3) | Transect (L2) (may be multiple profiles)
Surface (L2) | Boundary (L1)
Length (L1) | Countable event (L0)

Figure 1.6

An apple is used to illustrate how the dimension of a feature seen on a section is related to the dimension of the feature in 3D space. The volume of the apple (which has dimensions of length cubed, i.e. L3) is seen as a 2D transect through the apple (L2). The surface of the apple (L2) is seen as a boundary trace (L1) and the linear worm (L1) is seen as a transect (L2), composed of three countable profiles. Note that:

(i) A section through a non-convex object can give rise to a transect which consists of more than one profile.

(ii) The transects through the apple and worm both have area. However, the worm in this example represents a linear feature, and the area is therefore approximated as a countable event (or point). Clearly in a real 3D object it is impossible to have a structural feature which possesses only length.


Page 11

measure such as area or Feret diameter rather than the real 3D measure volume. More commonly we will confuse particle number (defined only in a 3D sense) with profile number (a 2D property unrelated to number!).

1.8 Geometrical probes

Most of the stereological methods described in this book rely upon simply counting the number of times a feature is intersected by a suitable geometrical probe. To ensure that the intersections are zero-dimensional (0D) (i.e. can be counted rather than being measured) the dimension of the probe and feature must sum to three. For example, points (0D) fall within volumes (3D), lines cut surfaces, planes cut linear features and volumes ‘capture’ a number of features. The relationship between feature dimension and probe dimension is shown graphically in Figure 1.7 and Table 1.2.

Figure 1.7

Illustration of how features and geometrical probes are intersected to yield a series of countable events. In each case the dimensions of the feature and probe sum to three and the intersections are zero-dimensional (shown here as black points).

Table 1.2 Relationship between probe dimension and feature dimension

Dimensions of geometrical probe | Dimensions of feature sampled
Point (L0) | Volume (L3)
Line (L1) | Suface (L2)
Plane (L2) | Length (L1)
Volume (L3) | Number (L0)


Page 12

The first three probes listed in Table 1.2 can be introduced into 3D space on a randomly positioned section. The fourth probe, volume, requires at least two planar sections, a small distance apart (the so-called ‘disector’ described in Chapter 5).

1.9 Ratios and densities

An estimator is a tool (e.g. callipers or a mathematical rule), which leads to an estimate. In general the commonly used estimators in stereology provide estimates of the amount of a feature per unit reference volume. These are examples of ratio quantities and are generally known as densities (by analogy with mass density which is kg/m3). Examples are given below.

● Volume density, Vv, is the volume proportion of one phase within a reference volume; for example, the volume of stones in a cubic meter of concrete. Volume density is also known as volume fraction and porosity.

● Surface density, Sv, is the area of an interface within a unit reference volume; for example, the area of gas exchange surface per unit volume of lung.

● Length density, Lv, is the length of a linear feature within a unit reference volume; for example, the length of glass fibers per cm3 of a composite material.

● Numerical density, Nv, is the number of discrete objects in a unit reference volume; for example, the number of synapses per μm3 of cortex or the number of molecules per dm3 of solution (i.e. molarity).

In materials science the densities listed above are often the parameter of primary interest. However, in biology, ratios only become fully interpretable when they are combined with an estimate of the total reference volume to obtain an estimate of total quantity.

1.10 The reference space

The Preface alludes to the necessity of defining a reference volume (the ‘reference space’) within which a particular stereological measure is to be estimated. For some systems this is rather more crucial than for others. The first question to answer is therefore ‘What is the fundamental sampling unit (FSU)?’. In biological systems, where the definition of the reference space is absolutely crucial, the FSU must clearly relate to the organism. This might be, for example, the animal, plant or patient; it is at the level of the individual that the final results of Darwinian selection are manifest and therefore where stereological measures should normally relate. It is because of this that in biology total quantities should be reported.

One of the attractive features about stereological results in biology is that they can be appreciated by the man in the street. For example, if normal rats have about 24 million nerve cells in the neocortex of their brain but, when they are exposed to substance X while developing in the womb, they turn out to have only 12 million it is easily seen that X has had a significant negative effect. Note that what was reported in this synthetic example was a total quantity. If the results had been presented as a numerical density of nerve cells per cubic millimeter, then a much higher level of specialist knowledge would be required to interpret the information. Additionally the information would have been incomplete and open to more than one interpretation.


Page 13

Assume for argument that the normal and treated rats had nerve cells present at equal numerical densities within their respective cortices but that the volume of the cortex in the group treated with substance X was half of that of the controls. From an inspection of the numerical densities of nerve cells alone, the fact that there had been a 50% reduction in overall nerve cell number in the treatment group would be completely missed and is indeed undetectable. This is true of all the common stereological ratio estimators of densities given above. In isolation it is simply not possible to know if the amount of the feature of interest or the volume of the reference space is varying (or indeed both!). It is only in the knowledge of the size of the reference space that the nature of any variation (or lack of variation!) can be fully understood. This phenomenon has been termed the ‘reference trap’ (Braendgaard and Gundersen, 1986). The scientific literature is littered with examples where investigators have fallen into this reference trap and the wrong conclusion has been reached by relying on ratio estimators alone.

Consider which of the parameters given in Table 1.3 would be the most informative and functionally relevant in a biological system. In each example there is an obvious correlation between the function and the total quantity, just as each time the caveat about the interpretation of a ratio in the absence of the reference volume remains. For these reasons we cannot stress too strongly that in biology, stereological ratios only become fully interpretable when the volume of the reference space is known. To quote the Danish stereologist Hans Jørgen Gundersen, when dealing with biological systems: ‘Never ever not measure the reference space’.

In order to illustrate how to do things incorrectly consider the following. Some 30 year’s worth of research money and scientific careers were wasted on trying to discover why old people lost a proportion of their neurones progressively as they got older. The studies on which this hypothesis was based reported that the number of neuronal profiles per unit area was higher in young brains than in old brains. This begged the conclusion that the old brains must have lost cells.

However, the mistake of equating a density (in this case profile number per unit area) with total number was realized when Haug et al. (1984) measured the shrinkage of brains in the chemical fixative formalin. Young brains were found to shrink more than old brains. When this differential shrinkage was corrected for, the cell loss between young and old brains was found to be minimal. This finding has been confirmed subsequently by a number of design-based stereological studies.

To convince you further, perform the following thought experiment. Put four grains of rice into a balloon. Make a table with two columns and three rows. Name column 1 ‘rice grain density’ and column 2 ‘number of rice grains’. Now fill in both columns for three levels of inflation of the balloon (e.g. low, medium and high).

Table 1.3 Comparison of information yielded by ratio estimators versus total quantities

Ratio | Total quantity | Function
Volume density of islet cells per unit volume of pancreas | Total volume of islet cells in the whole pancreas | Related to total insulin production capacity of the body
Surface/unit volume of gas exchange interface in lung | Total lung gas exchange surface | Related to maximal respiratory gas diffusion capacity
Number of lymphocytes per unit volume of body | Total number of lymphocytes in the body | Related to body’s ability to fight infection


Page 14

Box 1.1 Dimensionality and scaling effects

One of the basic skills required as a stereologist is the ability to deal with quantities of different dimensions and convert quantities from one set of units into another. A very useful tool in this task is that of dimensional analysis. This is a branch of measurement science that deals with correct specification of units. A fascinating Insight into the history of this science is given by Klein (1988). There are three related Issues that are dealt within this box: dimensionality, units and magnitude.

All modern scientific units are based upon a coherent approach to dimensionality. There are a limited number of fundamental dimensional quantities that can be combined in various ways, For example, three of the most fundamental dimensions are length L, time T and mass M. These can be combined to produce other dimensions, for example volume has the dimensions of length cubed (i.e. raised to the third power) which is denoted as L3.

Each of these dimensions can be represented in different sets of units. For example length, L, can be measured in units of meters, inches, furlongs and so on. For serious scientific work the decimal system of units known as the SI system is used. This system is also known as the International System of Units. In this system each dimensional quantity has a corresponding standard unit, for example the SI unit of length is the meter, usually abbreviated to m. The SI system is based upon the following six basic units:

meter | m
kilogram | kg
ampere | A
kelvin | K
second | s
candela | cd

In addition to these basic quantities the ‘amount of a substance’ (mole) is also treated as a basic quantity. The mole is defined as the amount of substance in a system which contains the same number of molecules or atoms as there are atoms in exactly 12 g of carbon 12.

In the context of stereology we are primarily concerned with dimensions derived from length, L, which has the standard unit of the meter, or some multiple of it. The prefixes in the following table are used to Indicate decimal (i.e. powers of 10) fractions or multiples of a unit.

Prefix | Abbreviation | Powers of 10
Tera | T | 1012
Giga | G | 109
Mega | M | 106
Kilo | k | 103
Deci | d | 10−1
Centi | c | 10−2
Milli | m | 10−3
Micro | μ | 10−6
Nano | n | 10−9
Pico | p | 10−12


Page 15

For example, a millimeter (mm) is 1/1000th of a meter and a micrometer (μm—also known as a micron) is a millionth (1/1000000th) of a meter. Once a unit has been prefixed it is considered to be a new discrete symbol. For example a centimeter, cm, can be raised to a given power; cm3 indicates one cubic centimeter (also known incorrectly as a c.c.).

The basic set of units can be combined to provide a whole series of other named units. For example speed is the distance a body travels in a given period of time, the dimensions are therefore L/T or L T−1 (length per unit time). The standard unit of this would be one meter per second, m/s or m s−1.

Many of the quantities estimated using stereological methods are referred to as densities. This indicates that the quantity has been referenced to a unit volume. The term density is used to show the similarity between this type of unit and mass density, which is usually given in kg m−3 or g cm−3. As an aside it should be noted that chemical concentration in molarity, which is defined as the number of moles per cubic decimeter, mol dm−3, can also be thought of as a number density, in each mole of a chemical substance there are 6.023×1026 molecules, atoms, ions and so on of the substance, therefore a 1 molar solution is equal to 6×1026 discrete items per dm3 (a decimeter cubed, which is equal to 1000 cm3, is also known as a liter), if a given volume of this solution is considered, for example 1 cm3, then the total number of molecules can be calculated.

The dimensionality of a range of stereological parameters is shown in the next table, along with examples of the units that would normally be encountered in light microscopy.

Parameter | Dimension | Units | Notation
Volume density | L3/L3=L0 | None | Vv
Surface density | L2/L3=L−1 | μm−1 | Sv
Length density | L1/L3=L−2 | μm−2 | Lv
Number density | L0/L3=L−3 | μm−3 | Nv
Volume | L3 | μm3 | V
Surface | L2 | μm2 | S
Length | L1 | μm | L
Number | L0 | None | N
Connectivity | L0 | None | X
Profile density | L0/L2=L−2 | μm−2 | QA
intersection density | L0/L1=L−1 | μm−1 | lL

For dimensional quantities it is often required to convert from one set of units to another. For example, the mean particle size may have been estimated in μm3 and the value is required for further calculation in, say, mm3. Another commonly used conversion is from surface density, expressed in μm−1, to surface density expressed as mm−1. These conversions are best carried out by considering the units expressed as powers of 10 of a meter. For example, 1 mm is 10−3 of a meter and 1 μm is 10−6 of a meter. This then allows conversion to proceed by adding or subtracting the exponents. Below are a few examples.


Page 16

Length

Conversion of mm to m

1 mm=1×10−3 m

Conversion of μm to m

1 μm=1×10−6 m

Area

Conversion of mm2 to m2

1 mm2=(1×10−3 m)2=(10−3 m)2=(10–3 m)(10−3 m)=10−6 m2

Conversion of μm2 to m2

1 μm2=(1×10−6 m)2=(10−6 m)2=(10−6 m)(10−6 m)=10−12 m2

Volume

Conversion of mm3 to m3

1 mm3=(1×10−3 m)3=(10−3 m)3=(10−3 m)(10−3 m)(10−3 m)=10−9 m3

Conversion of μm3 to m3

1 μm3=(1×10−6 m)3=(10−6 m)3=(10−6 m)(10−6 m)(10−6 m)=10−18 m3

Reciprocal length (L2/L3=L−1, e.g. surface density)

Conversion of mm−1 to m−1

1 mm−1=(1×10−3 m)−1=(10−3 m)−1=1/(10−3 m)=103 m−1

Conversion of μm−1 to m−1

1 μm−1=(1×10−6 m)−1=(10−6 m)−1=1/(10−6 m)=106 m−1

Alternatively these relationships can be read right to left, for example

1 m3=109 mm3

1 m3=1018 µm3

The above discussion helps when checking the dimensions and units reported for a structural quantity. However, the final issue to be dealt with is magnitude. For example, if the mean particle volume of a population of neurones was reported as 120 mm3 the results would have correct dimensions and valid units, but the magnitude is wrong (no one has a mean neurone volume equal to that of an average garden pea!). The checking of results for dimension, units and magnitude should become a routine aspect of stereological work.


Page 17

2
Random sampling and random geometry

Contents

2.1 Stereology and randomness | 17
2.2 Two simple experiments | 18
2.3 Take a sweet, any sweet | 19
2.4 A uniform random (UR) sample | 20
2.5 A single UR point in 1D, 2D and 3D | 21
2.6 Repeat the process… | 23
2.7 A systematic random sample in 2D and 3D | 26
2.8 Random geometry | 26
2.9 Randomizing directions—isotropy in the plane | 30

Box

2.1

Use of random number tables

21

All design-based stereological methods rely upon extensive use of random and systematic random sampling. This chapter describes these concepts in a non-mathematical way and provides a basis for understanding the remainder of the book. We include several thought experiments and exercises to help non-mathematical readers to familiarize themselves with these concepts. Once grasped the methods used for random sampling can easily be applied to new situations. The remainder of this book describes how the concepts in Chapter 1 can be applied using the methods described here. Although later chapters can be followed without reading this chapter they cannot readily be understood. We therefore recommend that you make the effort to read and understand this chapter before you carry on; it will illuminate the ‘why’ as well as the ‘how’ of the methods described later.1

2.1 Stereology and randomness

Stereology is fundamentally statistical in its nature, the methods rely upon careful sampling design and a robust sampling theory. The methods cannot properly be applied unless a random sample of one form or another has been taken. Random sampling must be applied in animal selection and at all the sampling levels required within an individual animal, for example blocks, sections, fields of view and individual measurements. It cannot be stressed too strongly that, in common with other sampling-based statistical methods, Stereology requires randomness—it is not optional (see Stuart,

1 In Stereology you usually simply have to ‘throw’ grids at random on to micrographs. If you feel that this chapter is getting too heavy—Don’t Panic—it is simply explaining why you can just ‘throw’ the grid. You could go straight to Chapter 3 and return to this later.


Page 18

1984 for a very readable introduction to sampling theory). The theoretical basis of design-based stereology was laid by Miles and Davy (1976). Increasingly, stereology is being seen as a geometrical variant of survey sampling theory (Baddeley, 1993).

2.2 Two simple experiments

Now for the first exercises in stereology. Imagine you are sitting at your microscope with a slide mounted and in focus. Now imagine you close your eyes and shift the microscope stage a small amount in both the x and y directions. Now look down the eyepiece. What you see is a ‘random’ field of view of your specimen. Random fields may not be optimum for winning a ‘beautiful micrograph’ competition but they are absolutely ideal for a quantitative analysis. The idea of selecting a field of view in a random way is, to many newcomers to stereology, quite unsettling. However, this is what is required.

The second exercise is provided in Figure 2.1 , which should be copied on to an overhead projector transparency and then cut along the dotted line. The small square, which will now be on a strip, should be translated up and down and side to side over the center of the grid of points with your eyes closed (for this exercise try not to rotate the small square too much). After this random translation the small square will contain one point. Mark the position of this point with a suitable pen and repeat the process five or ten times. As you proceed you will generate a ‘random’ distribution of points in the small square (although this is called a uniform random sample, the points will not look uniform).

These two exercises contain the essence of this chapter. They represent the random sampling of a slide and the random translation of geometrical probes which are essential in stereology. The vast majority of the methods described later in this book are simply refinements of these two basic procedures.

Figure 2.1

An exercise in randomizing geometry. Photocopy this figure on to an overhead projector transparency. Then cut along the dotted line. ‘Throw’ the square at random on to the grid of points in a way that ensures that the square is totally within the grid of points. Try not to rotate the square too much. Record the position of the single point that lands within the square with a marker pen. Repeat this process five or ten times, randomly throwing the square each time. The pattern of points you will see emerging is uniform random in 2D.


Page 19

2.3 Take a sweet, any sweet

To the layman ‘randomness’ means simply that something is unpredictable. In scientific terms the idea of randomness can be made more formal. However, for the time being we will err on the side of the layman. Suppose that we had a collection of objects, such as a bag of seven assorted sweets. We are blessed with an indecisive nature and can’t choose which sweet to eat. Therefore we rely upon a random selection of the sweets, simply dipping our hand in to pick one out with eyes closed. The sweet has thus been selected using a random sampling mechanism. This means that (i) it would have been impossible in advance to have predicted which sweet was going to be pulled from the bag and (ii) before dipping into the bag each sweet had the same probability of being selected. We say that there was a uniform probability of selection, or we have taken a uniform random sample (Stuart, 1984). A uniform random sampling mechanism is also known as simple random sampling. To illustrate this suppose that we label each of the seven sweets with letters a to g. Before we pick a sweet we have no reason to believe that any sweet will be more likely to be selected than any other and we therefore say that the sweets have an equal probability of being selected (which in this case is equal to 1/7). Mathematically this is written as

(2.1)

where Pr(a) is shorthand for ‘The probability of selecting a’.

The important consequence of using a simple random sampling mechanism is that the randomly selected sweet is a statistically typical sweet. This means that the characteristics of the sampled sweet can be used to make inferences about the whole population of sweets in the bag. The use of a sample to make inferences about a population is the real essence of statistics (see Chapter 10 for more detail). It should be noted that virtually all of classical sampling theory depends upon the use of simple random sampling. If an arbitrary sample (i.e. one you choose) is taken then much of the theory is invalidated. Thus simple random sampling is mandatory for us to be able to apply the usual statistical ideas of means, standard deviations, confidence intervals, and so on. It is perhaps clear now why statisticians are so insistent upon random sampling—in its absence virtually nothing can be done in statistics. This reliance upon randomness pervades stereology and in common with more usual statistical methods, randomness is mandatory. One interesting feature of simple random sampling is that once a sample has been taken, such as one of our sweets, it is impossible to tell by inspection of the sample whether it was taken with a uniform random sampling mechanism or not. This fact is sufficiently unusual and important that it has been given the special name of ‘the central paradox of sampling’.

The idea of taking a uniform random sample can be applied more generally than simply to collections of discrete objects. In particular it can be applied to continuous quantities and collections of items that can’t be placed in a bag and ‘dipped’ into. In stereology we are interested in generating random samples that are related to spatial position. The spatial equivalent of uniform random sampling is that each and every element of an object has the same probability of being in the sample as all other elements. In order to illustrate how to take a uniform random spatial sample consider the following problem. Suppose that we have a piece of string of length 1 meter. We would like to make a chemical analysis of the string from a random sample of it. For the analysis we require a piece of string 1 mm long. There are two equivalent ways to do this:

1. cut the string up exhaustively into 1000 segments each 1 mm long, place them all in a bag and pick one out at random; or

2. choose a random number between 1 and 1000, which we shall call z. Measure z mm from the end of the string and extract a 1 mm segment.


Page 20

Although conceptually and mathematically these procedures are strictly equivalent, in general it would be impractical to adopt method (1). The following methods are all based on variants of method (2).

2.4 A uniform random (UR) sample

In order to generalize the string example consider a line 1 unit long. We wish to choose just one point on this line with uniform random probability. Imagine that the line has been broken into a large number, N, of very small segments each of which is the same length, Δ=1/N units. We wish to choose one of these elements of length with uniform probability. This means that each segment has an equal probability of being sampled. The probability of selecting the ith segment, si, is written as Pr(si), if the selection is uniform and all probabilities are the same, that is

(2.2)

Clearly for this example, where a limited number of discrete numbered objects is available, a random number table could be used. However, a more instructive way to think of this problem is to imagine a well-trained monkey throwing a point at the segmented line. Although we can train the monkey to aim roughly towards the line we can’t guarantee, nor predict, where along the line the point will end up. We use the simple rule that if the ‘monkey-point’ lands in a particular segment it has been selected. This procedure is illustrated in Figure 2.2a for a line divided into 100 segments of equal length.

Perhaps counter to intuition the process of throwing a point randomly at the segmented line produces the same type of sample as a random number table! It is also a uniform random sample. In other words a uniform random number can be ‘mapped on to’ a unique position in a given geometrical space.

As it stands this example is very similar to the sweet example because there is only a finite number of discrete elements of length. However, if the size of the segments is reduced, with a consequent increase in the number of segments, the problem becomes a continuous one. In this case we want the probability that a point will hit an infinitesimally small element of length, dz, to be the same for all elements of

Figure 2.2

(a) A line of length 1 unit has been divided into 100 segments of equal length. A random point, z, is free to translate anywhere between 0 and 1. The probability that this point lands within any one of the segments, for example segment 79, is the same for all segments and is equal to 1/100. (b) If the number of segments increases then each segment becomes smaller. If the segments become small enough the discrete situation shown in (a) is said to become continuous. This means that all infinitesimally small segments, dz, have the same probability of being hit by the random point z.


Page 21

length ( Figure 2.2b ). This is achieved by taking a uniform random decimal number between 0 and 1 and using it as the Cartesian coordinate of a point along the 1D line. A point distributed along the unit line in this way is said to be uniform random (UR) in the interval 0 to 1.

2.5 A single UR point in 1D, 2D and 3D

A uniform randomly distributed number can be generated by using a random number table (see Box 2.1). In many circumstances the line of interest will not be exactly one unit long. However, this is no problem. For example, if the line has a length of F units then

Box 2.1 Use of random number tables

The cornerstone of the uniform random sampling methods described in this book is the use of uniform random numbers. These can be generated successfully using ‘pseudo-random’ number generators in computer programs but can also be obtained manually from tables of random numbers. This box describes how to use a random number table and also discusses some of the potential problems found when using computer-generated random numbers.

In many practical circumstances the random translation or rotation of a systematic grid is achieved informally by throwing the grid on to the images of interest. This box describes how to choose a random number in a more formal manner.

Suppose that we needed a random value from between 0 and 19 inclusive. This means that in an Infinitely long run the number of times each of the numbers 0 to 19 appeared would be the same. Using a random number table, for example from a statistics textbook, a random value between 0 and 19 is obtained by making a random start in the table somewhere in the middle of one of the pages. This can be achieved by closing your eyes and poking your finger down on the page. Now starting from the first number move up, down, left or right as you please and read off each two-digit number. For example, we may have the following portion of table to hand:

85 11 34 76 60 | 76 48 45 34 60
99 29 76 29 01 | 33 34 91 58 93
83 85 62 27 89 | 30 14 78 56 27
21 48 24 06 93 | 91 98 94 06 49
00 53 55 90 27 | 33 42 29 38 87

We continue reading through the values, in this case left to right and top to bottom, giving a stream of numbers 85, 11, 34, 76, 60, 76, 48, 45, 34, 60,… Each time one of these two-digit numbers is found to be between 0 and 19 we use it, If the number has been used before it is ignored. So, for example the first value we find between 0 and 19 in this table using the above scheme is 11 followed by 14, 06, 00 and then 06. Note that the final 06 would be ignored as it had previously been sampled. In practise it is often useful to photocopy the random number table and indicate the start position and direction so that


Page 22

other experiments using similar sampling schemes can use a different sequence of numbers. If a decimal number is required then the numbers are considered to be decimal values between 0 and 0.99 to the required number of decimal places. For example, the values in the portion of the table shown would be two-digit decimal numbers 0.85, 0.11, 0.34, 0.76, and so on.

The generation of random variates using a computer program relies upon taking a seed value and generating a very long sequence of numbers that have known properties of unpredictability and uniformity. However, for any given starting seed value the sequence of random numbers is identical! For example, if a seed of 4321 is always used it will always give the same sequence of numbers. Generally a random-number-generating program should be seeded with a number that changes rapidly, for example the time of day in milliseconds. This ensures that each successive sequence of numbers is different. A note of warning should be sounded. The random number generators found in spreadsheet programs and hand-held scientific calculators can be of poor quality. If you want to use a computer-generated random number then use a well-characterized algorithm, for example those described by Press et al. (1990). Some of the pitfalls of using random number generators in spatial statistical applications are described by Ripley (1987).

Figure 2.3

(a) A random point of the line of length F units can be sampled by taking a uniform random number from between 0 and F. This is achieved by multiplying a uniform random number z between 0 and 1 by F. (b) The process in (a) is extended to a 2D area of width F units and height G units by the generation of two uniform random number z1 and z2.

the random variate z (UR between 0 and 1) multiplied by the length F (written z·F) becomes the coordinate of the random point on the line. This is illustrated in Figure 2.3a.

A similar approach can be applied for generating uniform random points in 2D or 3D space. For example, Figure 2.3b shows how a random position over a 2D area of width and height F and G units respectively can be generated. In this case two


Page 23

Figure 2.4

(a) A uniform random point of a non-convex 2D area, shown shaded, can be sampled by enclosing it completely within a bounding box, here shown as a rectangle of size F by G. The process is the same as used in Figure 2.3b. If the point does not hit the area of interest the process is repeated. (b) The area of interest need not be simply connected.

uniform random digits are selected from a random number table, z1 and z2, and the x,y coordinates of the random point are then z1·F and z2·G, respectively. Note that the random numbers are independent of each other and therefore either a random position along F can be chosen first and then one along G or vice versa. This is exactly what you did in the exercise on Figure 2.1 at the start of this chapter.

Suppose that the 2D area of interest was not a simple rectangle. In this case how can a uniform random point be generated? The answer is simply to put a rectangular bounding box around the object and generate a uniform random point in the box, as before. If the point hits the object it is a uniform random point of that object. If it misses the object it is ignored and another random point is generated in the box. This process is repeated until a point hits the object. Figure 2.4a shows this process. It should be noted that the ‘object’ need not be simply connected; for example Figure 2.4b shows two profiles that we consider to be the same object. A uniform random point within this object can be generated in the same manner as above. Clearly this general approach can also be extended to 3D.

2.6 Repeat the process…

Returning to the string problem suppose now that we needed to make a repeat analysis from the string. We could repeat the previous process and select another segment of string with our random number table. If the process of taking uniform random samples were repeated it would be observed that the second and subsequent random samples may well, by chance, be very close together. To the non-mathematician this appearance of order in a random distribution of points along a line can be counter-intuitive. We might expect that a random selection of points would be maximally spread out. However, a genuinely random series of points on a line produces both clusters of points and gaps.

The tendency for spatial samples generated in a random way to be clustered together is well understood mathematically (e.g. Diggle, 1983). This is illustrated in Figure 2.5. One result of this tendency to clustering is that uniform random spatial samples tend unpredictably to sample some regions of space more heavily than others. Such clustering can lead to some redundancy in the information gathered. For example in the 1D case if two samples are very close together the samples might


Page 24

Figure 2.5

(a) A unit line showing how 19 uniform random samples between 0 and 1 give the impression of clustering of points and gaps. (b) A unit square showing 50 uniform random 2D positions.

be expected to be similar in their properties. Thus although two samples have been taken, and in the case of the string analyzed for chemical make-up, not much more information is gained from the two closely spaced samples than from a single sample in that region of the string. Thus repeated use of uniform random sampling can lead to wasted effort. In general a more efficient method for taking replicated spatial samples is to use a systematic random sample.

The idea of a random sample that is also systematic is contrary to the popular notion of randomness. However, it is perfectly valid mathematically and, more importantly, it is both easier to apply in practise than repeated uniform random sampling and often gives estimates that have a lower variability (Cochran, 1977; Gundersen and Jensen, 1987). A systematic random sample is unsurprisingly made of two components, a systematic component and a random component. Let us reconsider the string example. Say that we wanted to take a systematic random sample of string segments and further wanted to sample about eight segments in total, which constitutes a fraction of 8/1000 of the whole string. The spacing between segments will thus be about 1000/8 m, which is 125 mm. For simplicity we will round this off to 120 mm. To generate a systematic random sample with this sampling period we need a random number between 1 and 120. This can be obtained by multiplying a uniform random variate, z, from between 0 and 1 by 120 (see Box 2.1). For example, if the random number was 0.392 the first segment would be 120×0.392=47. That’s the random component dealt with. The other segments will be a systematic distance of 120 mm from the 47th. Thus we will sample the 47th, 167th, 287th, 407th, 527th,…, 887th segments ( Figure 2.6a ). These eight segments make up a systematic random sample of the string.

Clearly exhaustively numbering each segment in turn of an object will not be carried out in practice. A simpler method is available for generating a systematic sample. Consider the string example again. Instead of counting along 47 segments, then 120 for each subsequent sample, we could simply make a ruler that was marked into 120 mm divisions. Now if the first division is randomized in an interval of


Page 25

Figure 2.6

(a) A piece of string of length 1 m showing a systematic uniform random sampling scheme with sampling period of 120 mm. The first sampling point has been chosen in the interval 0 and 120 mm. In the example shown the random number used to generate this position was 0.392, hence the first position is 0.392×120=47 mm. In this case eight samples have been generated, but the number of samples is unpredictable, being either eight or nine. (b) The same piece of string is shown with a ruler of length greater than 1 m that has been marked into divisions of length 120 mm. If any one of the divisions is randomized in a segment of the string of length 120 mm then all ruler divisions that ‘hit’ the string can be used to generate a systematic uniform random sample.

0–120 mm from one end of the string we can obtain a systematic random sample without having to number all the segments. This is illustrated in Figure 2.6b.

The key element in this approach is to randomize the starting point of the ruler in an interval equal to the inter-marking distance, say T, from one end of the string (i.e. 120 mm in the example above). This could be carried out using a random number table but in practice ‘throwing’ the ruler on to the string at random suffices. At the starting point of the ruler and at each position that is an integer multiple of T units along the string we take a sample. There are two important features of this method. First, the points on the ruler are not random with respect to each other (they’re at a fixed inter-point spacing) but if any one of the ruler markings is randomized with respect to the object then all of them are. Second, the sampling coverage provided by the randomized ruler is now much more even than for a uniform random sample using the same total number of sampling points.

To generalize the above, consider a linear feature that is F units long. We wish to take about n samples from this feature. Therefore we require a uniform random number in the interval 0 to F/n units. If z is a uniform random variate between 0 and 1, this is given by z·(F/n) units. We now wish to sample at this position plus i multiplied by (F/n) where i=1, 2, 3, 4,…, n. It should be noted that the number of samples actually generated using this scheme will not always be exactly n and will fluctuate slightly. This approach is now very close to a useful method for taking a systematic random sample of an object.

The only real problem inherent in systematic sampling is if there is a natural periodicity in the structure being sampled which happens to coincide with the period of the systematic sample. This can be illustrated by considering the US army, which has a personnel numbering scheme such that every 10th number is a sergeant. If a systematic sample is taken of every 50th US soldier using their serial numbers as a way of identifying them then the sample will consist either entirely of sergeants or entirely of enlisted men. Clearly these samples are biased. In many cases biological tissue and natural materials do not have such marked periodicities.


Page 26

2.7 A systematic random sample in 2D and 3D

To extend the above idea suppose now that we wish to generate a systematic sample of positions from a 2D area, say a cross-section from a larger organ. To do this a grid of orthogonal lines can be used. If one of the crossing points is randomized in a rectangle equal to one of the fundamental rectangles of the grid then all other crossing points are randomized with respect to the object (Figure 2.7 ; see also Figure 2.1). For each crossing point that hits the object a sample is taken. This sample represents a systematic random sample of the 2D area. It is no surprise that the same idea can be extended to 3D as well. However, in 3D it is generally easier to break the problem down into two stages. First, take a systematic sample of slabs from the object, then for each slab take a systematic 2D sample of the slab (remember that uniform random numbers are independent and therefore the order in which we carry out the sampling in 3D doesn’t matter). For example, suppose that we wish to take a systematic sample of small blocks of material from a large object. First, we will slice the object into a number of thick slabs approximately T units thick. The position of the first cutting plane should be uniform random in the interval T from one end of the object. On each slab in turn a 2D grid of lines is now randomized. For each crossing point that hits the object a sample in the form of a cylindrical core can be taken. In practice a series of uniform random samples of a 3D object would be almost impossible to take directly as it would require the object to be repeatedly ‘re-glued’ together before each sample was taken.

2.8 Random geometry

The idea of taking a random sample, as described above, is sufficient for extracting a block or section of material from a larger object. However, as explained in Chapter 1

Figure 2.7

(a) A 2D object is placed in an arbitrary position with respect to a fixed square. A random point is generated in the square. (b) A repeating grid pattern made up of squares, equal in size to the fixed square, is now placed so that one of the crossing points is located at the random point. The collection of crossing points that hit the object represents a systematic uniform random sample of the object.


Page 27

we also need to use a series of random geometrical probes, primarily points and lines, to make the estimates we are interested in. Randomizing a geometrical probe with respect to a set of features is very similar to the systematic random sampling of a feature that we have described above.

The basic idea of a systematic random geometrical sample is that a uniform random location for one fixed element of a point or line grid is generated (the random component). If this one point is random then all other geometrical elements in the grid will be random.

Consider the 1D object in Figure 2.8a. Suppose that a systematic point grid with a point to point separation of T units is now translated uniform randomly along the object, which can be achieved by taking a uniform random number z between 0 and 1 and moving the end of the object until it is z times T units from one of the grid points. If the number of points that land within the object is counted, which we shall call P, then an unbiased estimate of the length of the object (L) is given by P multiplied by T, that is

(2.3)

The ‘hat’ over L is shorthand for ‘estimator of’. If this procedure were repeated using a new random number z each time, the average of the estimates would be equal to L (i.e. it is unbiased). This is heuristically understandable. Consider Figure 2.8b. If the grid of points is moved up and down the object then a maximum of five and a minimum of four points can be fitted into the object. Thus if the process is repeated the average number of points landing within the object will definitely be between four and five (in fact, from inspection of Figure 2.8 , we would expect the average to be nearer four than five). The estimator in Equation 2.3 formalizes this observation. In effect each point in the grid has T units of length associated with it. And the number of points multiplied by the length per point (T) gives an estimate (not a measurement) of the length of the object. This type of estimation procedure is very common in stereology where we often have a fixed object or feature and a uniform randomly translated (and sometimes rotated) systematic grid of points or lines.

Figure 2.8

(a) A 1D systematic point grid (i.e. a ruler) of inter-point spacing T units is shown randomized with respect to a linear object. There are four points, P, from the grid which hit the object. An unbiased estimate of the length of this object is equal to four times T. (b) The point grid can fall in such a manner that either four or five points hit the object. If the experiment is repeated the average number must be between four and five.


Page 28

Figure 2.9

A 2D systematic grid of crosses is shown which has been randomly thrown on to a 2D object. The inter-cross spacing in the x and y direction is ∆x and ∆y units respectively. This means that each cross has an associated area of a/p units2 (i.e. a/p=∆x multiplied by ∆y). The number of crosses that hit the object multiplied by a/p is an unbiased estimate of the object’s area.

This same idea can also be extended to 2D and 3D. For example in Figure 2.9 the area (A) of the 2D object can be estimated by randomly translating a 2D point grid in both the x and y directions over an area equal to the fundamental tile of the point grid (remember Figure 2.7!). The inter-point distance of the point grid in both the x and y directions needs to be known (i.e. ∆x and ∆y respectively), so that the area associated with each point (a/p) can be calculated. If the number of points hitting the object is P then an unbiased estimate of the area of the 2D object is given by

(2.4)

This is of the same form as Equation 2.3, namely it is the number of points hitting the object times the ‘amount of space’ associated with each point. Clearly the idea can also be extended to 3D where the volume per point (i.e. the amount of space) in a 3D point grid is equal to the area per point of the 2D point grid times the distance between grids (i.e. T·a/p; see Figure 2.10). The estimation of volume using this method is described in more detail in the next chapter, it is known as the Cavalieri method.

Before continuing it is worth discussing how the point counting is carried out for the 2D area estimation method shown in Figure 2.9. A zero-dimensional point cannot be printed so in practise a grid of crosses is used. These crosses are not zero-dimensional. However, by convention we can associate a zero-dimensional point with a unique feature on each cross in the grid. This point is generally taken as the top right-hand corner of the crossing point (shown in Figure 2.11a). Once a decision


Page 29

Figure 2.10

A 3D grid of crosses with an inter-planar spacing of T units and an area associated with each cross of a/p units2. The volume of space associated with each cross in the 3D grid is T multiplied by a/p units3.

Figure 2.11

(a) For area estimation using a grid of crosses a unique zero-dimensional point needs to be associated with each cross. In this case the top right-hand corner of the crossing point is indicated as being the point. (b) An illustration of how the counting rule works. Both of the crosses marked (i) and (ii) are neither completely inside nor outside the 2D object. The cross marked (i) has its associated point inside the object and is a valid count. The cross marked (ii) has its associated point outside the object and is not counted.

has been made about which corner to use this must be adhered to consistently for a particular set of counts. If a defined point lands within a profile it adds 1 to the count of points. For example, Figure 2.11b shows a 2D feature with a randomly translated grid of crosses. Two crosses are highlighted that are neither completely in nor out of the feature. The cross labelled (i) has its associated point in the feature and is counted. The cross labelled (ii) has its associated point outside


Page 30

Figure 2.12

Three uniform random positionings of a point grid with respect to the same object. In each case count the number of points that hit the object using the counting rule described in Figure 2.11. For each case this number times the area associated with each point in the grid is an unbiased estimate of the object’s area.

the feature and thus does not contribute to the point count. As an illustration of repeated throws of a point grid over a 2D figure see Figure 2.12. If you wish, you may now proceed to Chapters 3–5. You should return to this chapter before reading Chapter 6.

2.9 Randomizing directions—isotropy in the plane

The idea of using a systematic uniform random grid of points can be extended to other types of geometric probe. For example, Figure 2.13 shows systematic grids of both line probes and sampling frames. Consider in more detail the line grid. In order to randomize the grid with respect to an object both translational and directional randomness are required. The translational randomness is straightforward. If the spacing of the grid is T units then any fixed point of the line grid needs to be randomized in an interval of between 0 and T units perpendicular to the line grid ( Figure 2.14a ). The direction of the line grid can be described by the direction the lines in the grid have with respect to an arbitrary but fixed direction in the plane ( Figure 2.14b ). In order to randomize the direction of the grid, translation is clearly not sufficient. We actually need to define and use a directional equivalent of uniform randomness. When applied to a grid this type of randomness is known as isotropy. The generation of an isotropic direction in the plane is quite straightforward and is closely related to the methods used to generate uniform random positions along a line.

In the same way that a random point within an interval along a line can be generated with a random number so can a direction around an axis. One easy way of doing this is to get an empty wine bottle, place it on the ground and give it a good spin. The direction that the bottle ends up pointing in is effectively a random direction in 2D space. This means that the direction could not have been predicted in advance, exactly in agreement with the layman’s idea of randomness used above. Another way of thinking of it is to consider a line of length 1 unit. We can pick a random point, z, on this line using the methods described above ( Figure 2.15a ). Suppose that instead of having a straight line we curled the line around to form a semicircle ( Figure 2.15b ). A random point z can also be generated along this curved line. The curvature of the line does not affect the randomness of the point’s position although it would clearly be harder to measure the position along the line. If a line was now drawn through the point z and the origin of the semicircle, the uniform random position z along the circumference of the semicircle also describes a uniform random direction in the plane ( Figure 2.15c ). Thus the truth is laid bare; there is a very close relationship between a


Page 31

Figure 2.13

(a) A systematic test grid of lines. (b) A systematic grid of 2D sampling frames.

Figure 2.14

(a) A random translation of a systematic line grid along an axis that is normal (i.e. perpendicular) to the direction of the lines making up the grid. (b) A random rotation and translation of the line grid shown in (a). The direction of the line grid is described by the angle made between a line parallel to the lines in the grid and a fixed but arbitrary direction in the plane O-N (i.e. North). This angle is shown in this figure as [image], which is measured in a clockwise direction from North.

uniform random sample of discrete objects, uniform random positions in space (in 1D, 2D and 3D) and uniform random directions in the plane (uniform random directions in 3D are discussed in Chapter 6). In practise then we can choose an isotropic direction in the plane, [image], between 0 and 180° by generating a uniform random variate z and multiplying it by 180. Figure 2.15d shows that for an isotropic direction all infinitesimal elements of direction, d [image], in the interval 0–180° are equally probable.

Returning to the randomization of a systematic line grid we need to select an isotropic direction in the interval 0–180° and orient the line grid so that it is parallel to this direction. Then independently the grid is translated perpendicular to this


Page 32

Figure 2.15

(a) A unit line showing a uniform random point along the line, z. (b) The same line shown curved into a semicircle, again showing a uniform random position along the line, z. (c) An illustration of how a uniform random position on the circumference of a semicircle can be used to describe a uniform random angle [image]. (d) The isotropic direction [image] has an equal probability of landing within an infinitesimal element of angular deviation d [image] between 0 and 180°.

direction so that it is uniform random within an interval of T units ( Figure 2.14b ). A line grid that is both isotropic in direction and uniform random in position is known as an isotropic uniform random (IUR) grid of lines.

An IUR line grid in a plane can be used to estimate the length of any arbitrary curve in 2D. If the line grid, of spacing T units, is placed with isotropic direction and uniform random position over an object and the number of intersections between the line grid and boundary are counted (I), an unbiased estimate of the boundary length of the object (B) is given by the ‘Buffon’s needle’ relationship (Buffon, 1777)

(2.5)

See Figure 2.16 for an example.

In this chapter we have shown that the intuitive idea of randomness can be extended beyond the randomness of selection of discrete objects to include random positions in space, and randomness of systematic grids of geometrical probes. There is clearly a strong link between these ideas and even a strong similarity between the


Page 33

Figure 2.16

A 2D object is shown with a line grid of isotropic direction and uniform random position (IUR) superposed. The inter-line spacing of the grid is T units. The intersections between the object’s boundary and the line grid are shown as small circles. The length of the object’s boundary can be estimated by multiplying the number of intersections by the distance between the lines, provided the lines are isotropic. This estimation method is an application of the celebrated ‘Buffon’s needle’ relationship.

equations that are used to convert intersections between a feature and a geometric probe into the quantity of interest. For example, Equations 2.3–2.5 all have the same form. In each case the quantity of interest is estimated by the number of times a grid hits or intersects the feature multiplied by a grid constant. In fact the estimators described in Equations 2.3–2.5 are the 1D and 2D precursors of the stereological methods described later in this book.


Page 34

This page intentionally left blank.


Page 35

3
Estimation of reference volume using the Cavalieri method

Contents

Exercise 3.1 | 43
Exercise 3.2 | 44
Exercise 3.3 | 45
Exercise 3.4 | 47
Exercise 3.5 | 50

Boxes

3.1 | Sections, slices and slabs | 36
3.2 | Magnification corrections | 40
3.3 | Image analysis and stereology | 41

We stressed in Chapter 1 the importance of estimating the volume of the reference space for stereological studies in biomedical applications. Here we describe the most commonly used stereological method for estimating reference volume, the Cavalieri method (Cavalieri, 1635; Gundersen and Jensen, 1987). Other methods that maybe suitable include simple weighing and water immersion. If an organ is of constant and known density then weighing gives a direct method of estimating volume. Volumetry using water immersion relies upon the Archimedean principle of fluid displacement. For large organs such as livers and lungs the method developed by Scherle should be adopted (Scherle, 1970; Weibel, 1979). One problem with water immersion volumetry is that if the object has internal cavities that are open to the outside (such as lung), then when the organ is immersed the cavities fill with water, leading to an underestimate of volume. Therefore, before immersion, the holes in the organ need to be plugged in a watertight manner. For objects that are completely enclosed within another object or matrix, for example the hippocampus within the brain, then water displacement is not feasible.

The Cavalieri estimator of volume is very straightforward to apply. An exhaustive series of parallel sections are cut through the object a fixed distance, T units, apart. This sectioning gives rise to a series of thick slices, or slabs (see Box 3.1). For the Cavalieri method the first section should be uniform random in an interval of 0–T (see Chapter 2). This procedure is illustrated in Figure 3.1. In this diagram eight parallel sections hit the object, thus generating nine slabs. Each of the slabs is laid the same way up and the cross-sectional area of the object transect on each of the cross-sections is measured or estimated. The volume of the object is estimated by summing


Page 36

Box 3.1 Sections, slices and slabs

A section, in the strict geometrical sense, is an infinitely thin plane,

A slice is a sheet of material cut from a larger block, Often the thickness of the sheet will be very small compared with both the lateral extent of the slice and the size of features intersected by the slice. Thus there is a discrepancy between the use of the term ‘section’ as it is used in light microscopy and in stereology. The common usage, which we employ in this book, is that a thin slice in histology (say 1–10 μm) is referred to as a section.

If a slice has an appreciable thickness compared with the size of features within it we will refer to it as a thick section or a slab.

Examples

1. The polished face of a metallurgical specimen imaged in reflectance qualifies as a true section.

2. An optical section, for example in a confocal microscope, is actually an optical slice of finite (but small) thickness. An optical section (0.5–1 μm) is usually scanned through a thick section (25–40 μm).

3. Sectioning an object with serial sections will generate a series of slabs.

Figure 3.1

Illustration of the Cavalieri method. An object of arbitrary shape is shown intersected by a series of parallel cutting planes (i.e. serial sections) a known and fixed distance apart of T units. The number of sections hitting the object in this example is eight, which gives rise to nine slabs of the object. The 4th slab is shown extracted from the object. The thickness of the slab is T units, and the volume is given approximately by the cross-sectional area of the 3rd transect times the distance T. If the position of the first cutting plane is uniform random in an interval of T units then Equations 3.1 and 3.2 are unbiased estimators of the object volume.


Page 37

the areas and multiplying by the slice thickness, T:

(3.1)

where Ai is the cross-sectional area of the object transect seen on the ith slice.

This approach can be understood heuristically by considering Figure 3.1. The fourth slab of the object has been extracted and laid so that the third transect is shown uppermost. The volume of the object contained in this slab is given approximately by the area of the transect seen on the third section multiplied by the thickness of the slab T. It should be noted that the Cavalieri estimator of volume is guaranteed to be unbiased if the position of the first section hitting the object is uniform random. This is explained more fully in Chapter 2 and in this context means that the position of the first section should be uniform random in an interval 0–T.

Contrary to intuition the cross-sectional areas do not need to be measured to a high degree of precision. In nearly all practical cases these areas can be estimated with suitable precision by using a randomly translated point grid which has a known area associated with each point a/p (Equation 2.4 and Figure 3.2). If this method is applied the volume is estimated using the following equation:

(3.2)

where Pi is the number of points landing within the object transect on the ith section. As noted in Chapter 2 the use of a point grid on a series of serial sections amounts to a 3D grid of points in space, where each point is assigned a volume element of a/p×T.

There have been numerous applications of the Cavalieri method published over recent years, including determinations of rat heart ventricle volume (Mattfeldt, 1987), rabbit lung volume (Michel and Cruz-Orive, 1988), brain volume (Mayhew and Olsen, 1991; Pakkenberg et al., 1989), neurone volume (Howard et al., 1993), leaf volume (Kubínová, 1993), lung volume (Pache et al., 1993), human body volume (Roberts et al., 1993) and fetal volume (Roberts et al., 1994b).

The best way to understand how the Cavalieri method works is to see it demonstrated. Figure 3.2 shows a non-convex object that has been serially sectioned with a distance T of 7.5 mm between each section. Each slab has been laid the same way up and on each slab a point grid has been randomly translated. For each slab the number of points landing within the object transect is recorded and these raw data are used in Equation 3.2 to estimate the object volume. This procedure can be carried out in practise in Exercise 3.1. The combination of a randomly translated point grid on a randomly translated section is equal to a randomly translated 3D grid of points; this is shown graphically in Figure 3.3. In effect each point in the grid has been uniform randomly translated in x, y and z directions within 3D space.

The precision of a Cavalieri estimate of volume quantified as coefficient of error (CE) can be predicted using the list of point counts (Gundersen and Jensen, 1987; Roberts et al., 1993, 1994b). This method is described fully in Chapter 10. For the time being it is sufficient to note that from both theoretical considerations and a good deal of practical experience it is known that even for an object that has a complex 3D shape, a maximum of about 200 points on 10–15 sections need to be counted in total per object (not per section) for an estimate to have a coefficient of error of 5–10%. For objects that are nearly ellipsoidal in shape both the number of sections and number of points per section can be reduced (Roberts et al., 1994b).

In practice the Cavalieri estimator can be used for objects varying in size from individual cells (Howard et al., 1993), via small organs such as fetal kidneys


Page 38

Figure 3.2

In this illustration of the Cavalieri method a non-convex object (a) is shown intersected by a series of parallel sections. On each cross-section a point grid (b) has been uniform randomly translated in the x and y directions. (c) The full series of cross-sections generated by this sectioning design are also shown. Exercise 3.1 describes how the volume of the object can be estimated using the Cavalieri principle.

Figure 3.3

An illustration of the Cavalieri method as a 3D spatial grid of points (Cruz-Orive, 1997). (a) Each point grid is uniform randomly translated in x and y directions on the sections and these sections are uniform randomly translated in z. (b) In effect each point in the set of grids has been shifted uniform randomly in x, y and z directions in 3D space.


Page 39

(Hinchliffe et al., 1991), to large organs such as human brains (Mayhew and Olsen, 1991; Pakkenberg et al., 1989), human fetuses (Roberts et al., 1994b) and even whole adult human bodies (Roberts et al., 1993).

If the volume of a small object is required, for example rodent organs or fetal kidneys, it is often possible to embed the object completely and then exhaustively section it. For example, to obtain ten sections through a fetal kidney roughly 5000 μm in length, each section should be about 500 μm apart. If the section thickness is set to 5 μm on the microtome then this would be every 100th section. To ensure a uniform random position of the sections within the object, a random number table or generator should be used (see Box 2.1). The sampling distance between sections is to be 100 sections, and so a random number between 0 and 99 should be obtained. This could be, for example, 71. Sections are counted as soon as the block is started to be cut (i.e. before actually reaching the tissue) and, in this case, take sections 71, 171, 271, and so on until the whole kidney has been sectioned exhaustively. Each of these sections is then mounted, in order, on to slides and a microfiche reader used to provide enough magnification for point counting (see Box 3.2). This approach is illustrated in Figure 3.4.

The Cavalieri estimator of volume is perhaps the most straightforward of the design-based estimators to apply. In common with many other stereological techniques the key to the unbiased nature of the estimate is careful randomization and correct mathematical principles. The use of either a fully automated image analysis computer or a digitizing pad is totally unnecessary for this method (see Box 3.3) and manual tracing in particular is actually both less efficient and less precise than point counting (Gundersen et al., 1981; Mathieu et al., 1981). It is worth becoming familiar with the Cavalieri method, for almost all quantitative biological studies will begin with estimating the volume of the relevant reference space.

Figure 3.4

A small object such as a fetal kidney of overall length 5000 μm is shown embedded within a block. Exhaustive sections 5 μm thick are taken through the block. In order to obtain about ten sections for Cavalieri volume estimation every 100th section is required. A random start between 0 and 99 is thus required, which in this case is 71. The sections obtained with this sampling regime are shown in (b).


Page 40

Box 3.2 Magnification corrections

Stereology is concerned with making quantitative estimates. In microscopical work therefore one key aspect is knowing the magnification of the images used for measurements. These images may be traditional photomicrographs, or more commonly these days, digitized video images. The most reliable method for determining the final linear magnification of an image is to capture an Image of a calibrated graticule at the same magnification used for the images. The image of the graticule can then be used to measure the linear magnification directly.

The figure below shows a portion of a micrometer graticule slide (a). The distance between each graduation is 10 μm. At the same magnification is shown a counting frame and a point grid (b). The aim of the exercise is to calculate the linear magnification of the images on the printed page (M) and the area associated with each point (a/p) and each frame (a/f). The following procedure is recommended.

1. Measure a portion of the graticule directly in millimeters with a goodquality ruler. This should be carried out over a fairly large number of graticule divisions to improve precision and should be from the left-hand edge to left-hand edge (or right-hand edges) of the graticule divisions. for example, we measure 10 graticule spacings to be 34.5 mm at the final

Figure 3.5


Page 41

printed magnification. Therefore

Note that the units used for each measurement must be the same, in this example we convert from measured mm to μm, and therefore the units cancel to give magnification (which is dimensionless) (see Box 1.1).

2. On the point grid measure the distance between a known number of grid spacings. In this example we measured five grid spacings to be 30 mm. Therefore each grid spacing, ∆x, is 39/5=7.8 mm. The area per point in mm2 is now given by

Converting this to μm2 (see Box 1.1) is accomplished by multiplying by 106.

Therefore, the area associated with each point (a/p)=511 μm2.

This procedure should be carried out for the frame shown in (b). We calculate the area per frame to be 2430 μm2.

It should be noted that many electronic magnification systems, particularly video cameras, flat bed scanners and so on can introduce a differential magnification in the x and y directions. In fact the pixels (picture elements) of most commercially available video cameras are not square and have an aspect ratio of greater than 1. Therefore if a video camera has been used to obtain images from a microscope it is very important to calibrate magnification in both x and y directions. This can be carried out in practise by taking an image of a graticule parallel to the x axis then rotating it by 90°, taking another Image and carrying out the calculation shown above for x and y separately.

As a matter of policy it is generally best to avoid indirect calculation of magnification from objective and eyepiece quoted magnifications. When quoting magnification for publications it is generally more satisfactory to indicate a scale bar on each micrograph or quote the full width of the image in real units. Simply quoting a magnification can cause problems if the image needs to be reduced or enlarged for publication.

Box 3.3 Image analysts and stereology

Throughout this book we have stressed that stereology is primarily concerned with ensuring that random samples are taken and correct geometrical probes applied. In many cases Image analysis facilities are not required to make unbiased and efficient estimates of 3D structural quantities from 2D cross-sections. What relationship then is there between image analysis and stereology?

The relatively recent development of fast, cheap desktop computers has led to the wide availability of ‘image analysis’ software of various types. These


Page 42

software packages can often be downloaded from the Internet for a small charge and provide wide access to the image-processing algorithms that were once only accessible to the ‘initiated’. However, the adoption of better computer technology does not, in and of Itself, guarantee progress. In the case of 3D measurement the Increasing availability of Image analysis has not led to a discernible improvement in the scientific quality of 3D microstructural characterization. How can this be?

Image analysis as a discipline is almost wholly concerned with what should be done to a series of images once they have been acquired. The basis of image analysis is consideration of the pixel by pixel structure of an image and how to manipulate these pixels. One primary goal of image analysis (as opposed to simple image processing) is to threshold the image into two components: the objects of interest and the background. An image in this state is known as a segmented binary image. Once an image has been ‘thresholded’ measurements can be made relatively trivially with an image analysis computer. Hence the key problem in image analysis is to develop a reliable and accurate segmentation method. In some application areas this can be trivial and the images can be segmented on the basis of gray level intensity. However, in almost all biomedical applications, and particularly histology, the images are of low and variable contrast. The development of reliable segmentation for this type of image represents an outstanding problem.

Even if an image has been segmented it still may not be suitable for making correct 3D measurements. If either the sampling design is incorrect or the measurements made are incorrect, then the numbers obtained will be meaningless. Thus even for fully automatic image analysis the sampling designs and measurement tools described in this book should be applied. In our experience the image analysis route into microstructural quantification tends to engender art image-centered approach to measurements, Stereology on the other hand tends to develop an object-centered’ or ‘problem-centered’ approach.

If a clearly defined question in 3D is asked then the methods of stereology provide a clear and unambiguous way of deciding what should be measured to solve that problem. For example, suppose it is suspected that an environmental toxin can disrupt the normal development of the testes in mammals. One way of trying to answer this question is to make a direct estimate of the number of Sertoli cells per testis in a controlled group and treated group of animals. The problem dictates the parameter required, total number. All else follows from this, it should now be clear from Chapter 5 that if total numbers are required a fractionator sampling scheme could be applied with the critical requirement that the final stage is a complete count of Sertoli cells in 3D sampling volumes (either physical or optical disectors). Compare this with the ‘image-centered’ approach that might use sophisticated algorithms to segment the images automatically, find Sertoli cell profiles, count them, measure their Feret diameter, and so on. Unfortunately no combination of these strictly 2D parameters can give unambiguous and reliable information about the real question, which is how many Sertoli cells are in each testis!


Page 43

Exercise 3.1

AIM

The aim of the exercise is to estimate the absolute volume of the object shown in Figure 3.2.

BACKGROUND

A small object has been serially sectioned and the resulting slabs are shown face up in Figure 3.2c ; a scale bar 10 mm long at the level of the object is also shown. A point grid has been randomly translated over each of the six slabs. The inter-section distance, T, is 7.5 mm.

PROCEDURE

1. Calculate the linear magnification, M, of the image (see Box 3.1).

2. Calculate the inter-point spacing (∆x) of the point grid.

3. Calculate the area per point of the point grid at the level of the object.

4. For each section count the number of points hitting the object transects.

RESULTS

Distance between sections (T) | =______mm
Magnification, M | =______
Distance between points in grid (∆x) | =______mm
Area associated with each point (a/p) | =______mm2
Slice | Points hitting transect (Pi)
1 |
2 |
3 |
4 |
5 |
6 |
Sum |

Estimate of volume of object:


Page 44

Exercise 3.2

AIM

The aim of the exercise is to estimate the absolute volume of the rat kidney shown in Figure 3.4.

BACKGROUND

A fetal kidney has been embedded and exhaustively sectioned into 5 μm sections. Every 100th section has been sampled with a random start. In this case the random starting value is 71, thus the 71st, 171st, 271st and so on sections were taken. Tracings of these sections are illustrated, laid same side up, in the figure.

PROCEDURE

1. Calculate the linear magnification, M, of the image.

2. Make a copy of point grid P1 (see Appendix B). Calculate the interpoint spacing (∆x) of the point grid.

3. Calculate the area per point of the point grid at the level of the kidney.

4. For each section count the number of points hitting the kidney transects, Pi.

RESULTS

Distance between sections (T) | =_____μm
Magnification, M | =_____
Distance between points in grid (∆x) | =_____μm
Area associated with each point (a/p) | =_____μm2
Slice | Points hitting transect (Pi)
1 |
2 |
3 |
4 |
5 |
6 |
7 |
8 |
9 |
Sum |

Estimate of volume of kidney:


Page 45

Exercise 3.3

(Courtesy of Professor T.Mattfeldt, University of Ulm)

AIM

The aim of this exercise is to estimate the absolute volume of the internal cavity of the left cardiac ventricle of a Wistar rat. This is an example of volume estimation of a structure wholly embedded within another which cannot be estimated using water immersion (Mattfeldt, 1987).

BACKGROUND

The left ventricle was fixed by vascular perfusion of glutaraldehyde, filled with carbon-black impregnated agar and then embedded in agar-agar. A random start was taken outside the embedded ventricle then a series of sections were taken with a constant distance T of 1.28 mm. In total, 12 cross-sections (a–l) were generated which were photographed with reflected light. Tracings of the cross-sections are shown in Figure 3.6 The scale bar indicates 20 mm.

Figure 3.6

See text for details.


Page 46

PROCEDURE

1. Calculate the linear magnification, M, of the image.

2. Make a copy of point grid P1 (see Appendix B). Calculate the interpoint spacing (∆x) of the point grid.

3. Calculate the area per point of the point grid at the level of the rat ventricle.

4. For each section count the number of points hitting the internal cavity transects.

RESULTS

Distance between sections (T) | =_____mm
Magnification, M | =_____
Distance between points in grid (∆x) | =_____mm
Area associated with each point (a/p) | =_____mm2
Slice | Points hitting transect (Pi)
a |
b |
c |
d |
e |
f |
g |
h |
I |
Sum |

Estimate of volume of ventricle:

Now repeat the exercise using a coarser grid. How do the estimates of ventricular volume compare? What were the respective times taken for estimation with the fine and coarse grids?


Page 47

Exercise 3.4

(Courtesy of Professor L.M.Cruz-Orive, Santander, Spain.)

AIM

The aim of the exercise is to estimate the absolute volume of a rabbit’s lung taken from the study reported by Michel and Cruz-Orive (1988).

BACKGROUND

The lungs were fixed by vascular perfusion and the right lung stratified into four anatomically coherent strata (details in Michel and Cruz-Orive, 1988). Each stratum was then separately embedded in agar and serially sectioned into thin slabs approximately 1.5 mm thick, a constant distance of 7.5 mm apart. The resulting series of sections is shown as tracings in Figure 3.7.

PROCEDURE

1. Calculate the linear magnification, M, of the image.

2. Make a copy of point grid P2 (see Appendix B). Calculate the interpoint spacing (∆x) of the point grid.

3. Calculate the area per point of the point grid at the level of the lung.

4. For each section within each stratum count the number of points hitting the lung transects.

RESULTS

Distance between sections (T) | =_____mm
Magnification, M | =_____
Distance between points in grid (∆x) | =_____mm
Area associated with each point (a/p) | =_____mm2
Stratum | Sections |  |  |  |  |  | Total points | Volume of stratum
 | 1 | 2 | 3 | 4 | 5 | 6
A |
B
C
D
Total


Page 48

Figure 3.7

See text for details.


Page 49

Now enlarge grid P2 (see Appendix B) and estimate the total volume of the lung from all sections.


Page 50

Exercise 3.5

AIM

The aim of the exercise is to estimate the absolute volume of the cortex of the right hemisphere of an adult male human brain.

BACKGROUND

The brain was formalin fixed, embedded in 4% agar and exhaustively serially sectioned into slabs of 5 mm thickness. Every fourth slab was extracted from the full set of slabs with a uniform random start. Tracings of the cortex of the right hemisphere are shown as a stippled region in Figure 3.8. A 10 cm scale bar, which was photographed with the original material, is also shown.

PROCEDURE

1. Enlarge the image.

2. Calculate the linear magnification, M, of the enlarged image.

3. Make a copy of point grid P2 (see Appendix B). Calculate the interpoint spacing (∆x) of the point grid.

4. Calculate the area per point of the point grid at the level of the brain.

5. For each section count the number of points hitting the cortex (stippled region including solid black lines).

RESULTS

Distance between section (T) | =______mm
Magnification, M | =______
Distance between points in grid (∆x) | =______mm
Area associated with each point (a/p) | =______mm2
Slice | Points hitting cortex (Pi)
1 |
2 |
3 |
4 |
5 |
6 |
7 |
8 |
9 |
10 |
11 |
Sum |


Page 51

Figure 3.8

See text for details.

Estimate of volume of cortex:

Convert the estimate obtained in mm3 into cm3.

This example highlights two aspects of Cavalieri estimation:

1. the volume of an anatomically defined region of an organ can be estimated, even though it can’t be isolated;

2. the volume of objects, or 3D regions, of extremely complex shape can be estimated with this method.


Page 52

This page intentionally left blank.


Page 53

4
Estimation of component volume and volume fraction

Contents

4.1 Estimation of volume fraction | 53
4.2 Estimation of total volume of a defined component | 55
Exercise 4.1 | 62
Exercise 4.2 | 63
Exercise 4.3 | 64

This chapter describes how the volume fraction of one phase in relation to either the reference volume or another phase can be estimated from uniform random sections. Volume fraction is a basic and very widely used parameter in both biomedical applications and materials science. The ubiquity of the parameter is indicated by its many names. It is known variously as volume fraction, volume density and porosity.

The volume fraction of a phase Y within a reference volume is simply the proportion of each unit volume of the reference space taken up by Y, that is

(4.1)

where the notation VV(Y, ref) indicates volume fraction. The brackets are used to specify which phase of interest (e.g. Y) and which reference volume the volume fraction refers to. Examples include VV(alveoli, lung), VV(cherries, fruit cake) and VV(hot air, politician). Volume fraction ranges from 0 to 1 and is often expressed as a percentage. It should be noted that in common with other densities described in this book volume fraction is a globally defined quantity and doesn’t give any indication of the spatial arrangement of the different phases within the reference space.

4.1 Estimation of volume fraction

Estimation of volume fraction using a stereological method was first proposed by the French mining engineer Delesse in 1847. Delesse noted that on polished sections the area of the phase of interest per unit area of the section was an excellent predictor of the volume of that phase per unit volume of the crushed rock. His principle is an unbiased method for estimating volume fraction from sections. In modern notation his relationship can be stated as

(4.2)

that is, the volume of Y per unit volume of reference space is estimated by the area of Y per unit area on the section. In practise Delesse measured area fraction by tracing the shape of the phase of interest on thick paper using a camera lucida, cutting out


Page 54

the pieces corresponding to the phase of interest and then weighing them. Clearly this method could be applied using image analysis facilities, though point counting is often much easier on complex histological tissue as will be described below.

Delesse’s method was modified in 1898 by another geologist, Rosiwal, who showed that if a series of random lines was superposed on the section the length of line landing within the phase of interest divided by the total length of test line used was again an unbiased estimator of volume fraction, that is

(4.3)

This method was the basis of many early planimeters (e.g. Huggins, 1956; Hurlbut, 1939).

The method developed by Rosiwal was further refined by the geologist Thompson (1930), who showed that for a randomly positioned point grid the number of points hitting the phase of interest divided by the number hitting the whole section gave an unbiased estimate of volume fraction, that is

(4.4)

where P(Y) indicates the number of grid points hitting the phase Y and P(ref) the number of points hitting the reference space (i.e. either the phase Y or the background). If a grid of crosses is used for the estimation the definition of the ‘point’ associated with each cross is identical to that given in Chapter 2 for area estimation. An example of this approach is shown in Figure 4.1.

The point-counting technique is the method still most commonly used today. Perhaps counter to intuition, point counting is much more efficient for manual estimation than either line measurement or area measurement (Gundersen et al., 1981; Mathieu et al., 1981). In common with the Cavalieri method point counting is used to estimate areas, which are themselves estimators of volume. Note that because volume fraction is a dimensionless ratio, i.e. L3/L3=L0, neither the linear magnification nor

Figure 4.1

An illustration of the basic idea of volume fraction estimation using a point grid. The number of points hitting the reference space, in this case either the dark gray phase of interest Y or the light gray matrix, are counted (i.e. 18). The number of these points that land just in Y (dark gray) are also counted (i.e. 9). The ratio of the number of points in Y divided by the number in the reference space is an estimate of the volume fraction (i.e. 9/18=0.5 or 50%). You should note that points that land within Y also by definition fall within the reference space!


Page 55

the area per point in the grid need to be known. An example of volume fraction estimation for rat spinal cord tissue is given in Exercise 4.1.

4.2 Estimation of total volume of a defined component

If the total volume of a particular phase is required, for example the total alveolar air space within a lung, then the volume of the reference space is estimated first using the Cavalieri method. Subsequently the volume fraction of alveolar air space per unit reference volume is estimated using point-counting on random cross-sections. Using these two quantities the volume of the air space can be estimated from

(4.5)

where [image] is an estimate of the total volume of alveolar air space, [image] is an estimate of the total volume of the lung and [image] is an estimate of the volume fraction of alveolar air space per unit volume of lung. More generally the total volume of a phase is estimated by the volume fraction multiplied by the volume of the reference space

(4.6)

It is good practise when using stereological equations to check that the dimensionality of the estimated quantity is equal to the dimensionality of the parameter of interest (see Box 1.1). If the total volume of a phase is required the parameter has dimensions L3 (e.g. mm3, μm3, etc.). As the volume of the reference space is also in units of L3 and volume fraction is in units of L0 the dimensionality of the estimated quantity is correct (remember that exponents add when quantities are multiplied, e.g. L3×L0=L(3+0).

Although volume fractions are generally defined with respect to a unit volume of the reference space, in biological cases a unit volume of the organ of interest, this does not have to be the case. For example in a multi-phase material, such as the microstructure shown in Figure 4.2 , the volume fraction of nucleus per unit volume of nerve cell body can be estimated rather than per unit reference volume. This approach is illustrated in Exercise 4.2.

If the volume fraction of a rare phase has to be estimated then the method employed in Exercises 4.1 and 4.2 is unduly time consuming. For example, consider the spinal cord tissue images shown in Figure 4.2. The blood vessels (darkest phase) represent a small proportion of the reference volume. In order to estimate the volume fraction of blood vessel per reference volume with adequate precision a fine grid is therefore required. However, also using a fine grid to estimate the reference volume may lead to many 100s of points landing within the reference space. A much more efficient method is to use a point grid that combines two sets of points of different densities in the same grid (e.g. Cruz-Orive, 1982). This approach is illustrated in Figure 4.3b with a point grid containing nine fine points (crosses and circled crosses) per coarse point (circled crosses only). The area per point associated with each coarse point is thus nine times that of each fine point. Circled points thus act as both fine and coarse points.

The volume fraction of the phase of interest can now be estimated by throwing the grid on with uniform random translation, counting the number of coarse points hitting the reference space, PC(ref), and the number of fine points hitting the phase of interest, P(Y). As the ratio of fine to coarse points is 9:1 each coarse point counts as nine fine points, thus a slightly modified version of Equation 4.4 can be used to estimate volume fraction:

(4.7)


Page 56

Figure 4.2

Six schematized images derived from light microscope images of rat spinal cord tissue. The sections were taken with uniform random position and isotropic orientation. The scale bar is 50 μm long. The various components of the tissue are shown in the key. Neuropil is a complex multi-component phase which, for the purposes of these images, can be considered a homogeneous matrix. (Redrawn from original images courtesy of Professor T.M.Mayhew, Nottingham.)


Page 57


Page 58

This is illustrated in Figure 4.3 and an example of this type of estimation is given in Exercise 4.3.

In the exercises shown so far in this chapter the micrographs have happened to land completely within the reference space in each case. However, in general, if genuinely uniform random fields of view are taken, some will overlap the edge of the specimen, where this edge may be a genuine object edge or one generated when the object was cut into blocks. In cases such as this volume fraction can be estimated but now the number of points that land within the reference space, P(ref), can vary from one field of view to another.


Page 59

Figure 4.3

An Illustration of how a combined, or multi-purpose, point grid can be used to increase the efficiency of volume fraction estimation. (a) A simple point grid is used to estimate the volume fraction of the dark phase. In this example 32 points hit the reference space and three hit the dark phase. The estimate of volume fraction is thus 3/32=0.09. (b) A combined point grid which has a set of fine points (i.e. plain and circled) and a set of coarse points (just the circled ones). There are nine fine points per coarse one. The volume of the reference space is estimated by counting the number of coarse points and multiplying by nine (in this example 4×9=36). The volume of the dark phase is estimated by counting the number of fine points that hit it (in this example three). The volume fraction of the phase of interest is estimated by the ratio of these two quantities (i.e. 3/36=0.08). The multi-purpose grid is much faster to use in practise than the simple grid in (a).

If the number of points landing within the reference space varies then the estimator of volume fraction becomes an example of a ‘ratio estimator’ (Cochran, 1977). In this type of estimator both the numerator (top line) and denominator (bottom line) of the ratio can vary from field to field. In ratio estimators it is not correct simply to average the individual estimates of volume fraction (or whatever) over all the fields. If this method is adopted a biased estimate is obtained. The correct way to deal with a ratio estimate is to sum all the points hitting the phase of interest over all fields analyzed, then divide by the sum of all points hitting the reference space over all fields analyzed.


Page 60

Figure 4.4

An illustration of volume fraction estimation when the number of points hitting the reference space is variable. The numbers of points hitting the reference space in the images shown are 20, 28, 9 and 28 for (a) to (d) and the numbers of points hitting Y (the darker phase) are 7, 3, 1 and 3 respectively. The volume fraction for these images is thus estimated from

(4.8)

where m is the number of fields analyzed. This type of ratio estimator gives an estimate that has a small bias that rapidly decreases as the number of fields of view, m, increases.

As an example of this approach consider Figure 4.4. The numbers of points hitting the reference space in the four images shown are 20, 28, 9 and 28 for (a) to (d) and the numbers of points hitting Y (the darker phase) are 7, 3, 1 and 3 respectively. The volume fraction for these images is thus estimated from

(4.9)

This chapter has shown that, using a point-counting method, unbiased estimates of volume fraction are very easy to make. However, there are a few pitfalls that can trap the unwary stereologist. Volume fraction estimates are guaranteed to be


Page 61

Figure 4.5

An illustration of the problem of over-projection. In this example the phase of interest is relatively more opaque than the surrounding matrix and the section is quite thick. The projected area of the phase is higher than the true cross-sectional area. This over-projection would lead to a systematic overestimate of the volume fraction of the darker phase. The problem is best avoided by using the thinnest sections possible. If the situation were reversed the associated problem of under-projection (i.e. over-projection of the background) would be encountered.

unbiased only if the sections are uniform random with respect to the object. In practise this means that every portion of the object must have an equal probability of being imaged in the microscope before any sectioning takes place (see Chapter 2). As noted above genuinely uniform random fields of view on a uniform random section may well overlap the edges of the object.

One other important problem with volume fraction estimation is that of over-projection. The Delesse principle, and the derived line and point methods, are only strictly unbiased for an infinitely thin section or polished section (see Box 3.1). If the phase of interest is relatively more opaque than the surrounding matrix (e.g. the rat spinal cord images) and the section is quite thick, then the observed (i.e. projected) areas of the phase of interest will be too high ( Figure 4.5 ). Over-projection leads to a systematic overestimate of volume fraction. This problem is best avoided by using the thinnest sections possible. A rule of thumb is to aim for a section thickness that is less than one-tenth of the height of the average 3D particle or object within the matrix being sectioned.

Image analysis machines are capable of estimating volume fraction automatically on ‘thresholded’ images. If the images that are to be analyzed routinely are of repeatably high contrast then an automatic thresholding and estimation of volume fraction is possible. However, currently the vast majority of biological microscopy images are of low and variable contrast and often phase identification requires both light intensity information and texture and context (i.e. a human’s knowledge). In these circumstances the investment in time and money required to segment images reliably is probably prohibitive (see Box 3.3 and Moss and Howard, 1988). Therefore, in the majority of biological applications that use conventional transmitted light microscopy, image processing and analysis are easily outclassed in terms of statistical and practical efficiency by manual point-counting methods. The fact that the ‘tools of the trade’ required for volume fraction estimation boil down to a range of transparent point grids shouldn’t mask the fact that the method is well founded mathematically and very efficient practically.


Page 62

Exercise 4.1

AIM

The aim of this exercise is to estimate the volume fraction of nerve cells within rat spinal cord.

BACKGROUND

Several isotropic uniform random sections have been taken from the cervical spinal cord of a Wistar rat. The volume of the spinal column was estimated to be 49 mm3. Sections of thickness 1 μm were prepared for light microscopy and stained with toluidine blue. Six images are shown in Figure 4.2a –f. A scale bar and key to the images are also shown.

PROCEDURE

1. Copy grid P2 (see Appendix B) on to a transparency.

2. Throw the grid randomly over each of the six images in turn. On each image count the total number of points falling within the image, P(sc), where sc=spinal cord. Also count the number of points falling within nerve cell bodies, P(nc), which consist of both cytoplasm and nucleus. Note that some transects are incomplete and that others do not contain a nuclear transect.

RESULTS

Image | Points hitting nerve cell bodies [P(nc)] | Points hitting image [P(sc)]
a |
b
c
d
e
f
Sum | ∑P(nc)= | ∑P(sc)=

Estimate of volume fraction of nerve cells:

Estimate the total volume of nerve cell body within the spinal cord.


Page 63

Exercise 4.2

AIM

The aim of the exercise is to estimate the volume fraction of nucleus within the nerve cell bodies of rat spinal cord. This exercise uses the images shown in Figure 4.2a –f.

PROCEDURE

1. Copy grid P2 (see Appendix B) on to a transparency.

2. Throw the grid randomly over each of the six images in turn. On each image count the number of points falling within nerve cell bodies, P(nc), which consist of both cytoplasm and nucleus. Now count the number of points that fall within the nuclei, P(nuclei).

RESULTS

Image | Points hitting nuclei [P(nuclei)] | Points hitting nerve cell bodies [P(nc)]
a |
b
c
b
e
f
Sum | ∑P(nuclei)= | ∑P(nc)=

Estimate of volume fraction of nuclei in nerve cell bodies:

Estimate the total volume of nerve cell nuclei in the rat spinal cord.


Page 64

Exercise 4.3

AIM

The aim of the exercise is to estimate the volume fraction of blood vessel within rat spinal cord. This exercise uses the images shown in Figure 4.2 a –f.

PROCEDURE

1. Copy grid P5 (see Appendix B) on to a transparency.

2. Calculate the ratio of coarse (circled) to fine points, q.

3. Throw the grid randomly over each of the six images in turn. On each image count the number of coarse points falling within the images, P(sc). Also count the number of fine points that fall within the blood vessels, P(vessel).

RESULTS

Image | Points hitting blood vessels [P(vessel)] | Points hitting reference space [P(sc)]
a |
b
c
d
e
f
Sum | ∑P(vessel)= | ∑P(sc)=

Estimate of volume fraction of blood vessel per unit volume of spinal cord tissue:

Estimate the total volume of blood vessel in the rat spinal cord.


Page 65

5
Number estimation

Contents

5.1 Some useful ‘definitions’ | 66
5.2 Some ‘non-definitions’ | 66
5.3 A cautionary tale | 66
5.4 On the right road | 68
5.5 Continuous scanning of a plane | 68
5.6 The disector principle | 69
5.7 From theory to practise | 71
5.8 Implementation of the physical disector | 74
5.9 Typical sampling regime for the physical disector | 77
5.10 Optical section ‘scanning’ methods—the unbiased brick and optical disector | 78
5.11 The unbiased brick-counting rule | 82
5.12 Application of the optical disector counting rule | 82
5.13 Typical sampling regime for the optical disector | 83
5.14 Direct estimation of number—the fractionator | 85
5.15 A 2D example of the fractionator principle | 85
5.16 The multi-stage fractionator | 87
5.17 The optical fractionator | 87
5.18 Some special designs for counting in 3D | 89
Exercise 5.1 | 94
Exercise 5.2 | 96
Exercise 5.3 | 98
Exercise 5.4 | 99

Box

5.1

Correcting for the effects of tissue shrinkage

80

This chapter describes how to estimate the number of discrete objects, for example, particles or cells, that are within a well-defined reference space. It can be achieved by estimating the number of particles per unit volume (numerical density) and then multiplying by the volume of the reference space. Alternatively total number can be estimated by use of the ‘fractionator’ technique. In many ways this is the core chapter of this book because it is in the area of number estimation that stereology has had its largest impact to date. An editorial in the Journal of Comparative Neurology stated in 1996 (Coggeshall and Lekan, 1996; Saper, 1996):

Beginning with this issue, we would like to establish a policy that we will attempt to apply to all papers that are henceforth submitted to the journal… that stereologically based unbiased estimates are always preferable for establishing absolute counts or densities of structures in tissue sections. We expect


Page 66

that any papers that use simple profile counts, or assumption-based correction factors, will provide adequate justification for these methods, which will stand up to critical review. Referees are urged to consider this justification, and to insist on unbiased counts when it is not adequate.

The quote from Journal of Comparative Neurology given above has had its authors’ desired effect. There is now a vigorous and ongoing debate in the neuroscience literature on the relative merits of stereological and assumption-based counting methods (Baddeley, 2001; Benes and Lange, 2001; Hedreen, 1999; West, 1999). This debate will continue, however, the fact remains that the fundamentally 3D approach to counting described in this chapter is scientifically more robust than any 2D, assumption-based, method.

It has been difficult to learn how to apply these techniques solely by reference to the published literature, which is diffuse and remains silent on a number of key technical points. To date the most efficient way to obtain expertise in this technology has been to attend a practical course. In this chapter we try to bring together all the information required for the unbiased estimation of the number of particles in a bounded 3D space (i.e. an object) and have attempted to make it possible to learn these methods through self study. A word of caution. Because counting objects requires three-dimensional probes it entails considerably more effort in sampling and measuring than, for example, estimating volume. Make sure that it is really necessary to know the number of objects to answer your scientific question before you start counting. Often the total volume or surface area of a phase or tissue component is of more functional significance than particle number. The singular contribution of one person, Hans Jørgen Gundersen, to all aspects of modern design-based stereological counting techniques should be acknowledged.

5.1 Some useful ‘definitions’

1. A ‘particle’ is a discrete three-dimensional object in 3D space. For example, this could be a neurone in the brain or a quartz crystal in granite.

2. A ‘transect’ is a 2D profile, or set of profiles, through a particle.

3. ‘Number’ or cardinality has no units.

5.2 Some ‘non-definitions’

1. A ‘profile’ is not a ‘particle’.

2. ‘Number’ is not reported by profile number per unit area (which has units L−2).

3. ‘Number’ is not reported by particle number per unit volume (which has units L−3).

5.3 A cautionary tale

When counting objects it is usual to give each of them the same chance of being included in the count. Objects (or particles) in 3D space that are cut by a 2D section, as with a histological or metallurgical section, will be seen as transects. However, the objects hit in 3D by the section will definitely not have been hit with equal probability. In fact a 2D geometrical probe, such as a section, will hit objects in proportion to their size, specifically their height normal to the section. This is illustrated in Figures 5.1 and 5.2. Therefore counting transect number per unit area of section will not give a meaningful estimate of number for real objects.

The ridiculous nature of such measurements is illustrated in Figure 5.3. In this experiment the reference volume of the object was estimated to be 1000 mm3.


Page 67

Figure 5.1

Imagine the plane moving from the top to the bottom of the box at a constant speed. The ‘time’ that the plane spends within any particular particle will be proportional to its height normal to the section. If the plane was halted at a random position in its journey down the box it is therefore more probable that it would be cutting the large particle than the small one.

Figure 5.2

An illustration of a 3D object being intersected by a series of systematic uniform random planes, represented by the set of lines. The number of times a particle is hit by the set of planes will depend upon its height normal to the plane of sectioning. Thus although particles c and d are of approximately the same dimensions, c is cut four times, whilst d is cut only once, purely as a consequence of their orientation.


Page 68

Figure 5.3

A naïve, and incorrect, method for estimating total number. An object of estimated volume 1000 mm3 is shown in (a). A field of view from this object is shown in (b). The average number of profiles per unit area (NA) counted from this and other sections is 3 mm−2. If this ‘numerical density’ is multiplied by the reference volume the (incorrect) estimate of the number of particles is 3000 mm!!!

Several sections were taken and the transect number per unit area was estimated to be 3 profiles/mm2. If this profile density is multiplied by the reference volume (you might not believe this but it has actually been done!) the result is 3000 mm! As stated above number has no units and clearly this cannot be an estimate of the number of particles in the object.

BE WARY OF ANY PUBLICATION REPORTING ‘NUMBER’ WITH UNITS OF ANY DESCRIPTION FOLLOWING THE RESULTS!

5.4 On the right road

Given that profile counting cannot give estimates of number, how can this be achieved? Return to the concept of counting people discussed in Chapter 1. The requirement for unbiased counting is simply to choose some attribute that is possessed by everyone, for example a head, and then count the number of those particular attributes present in the sampling universe, for example a room (clearly if there is a possibility that someone will have two or more heads, then caution is called for!). This method is known as the ‘associated point’ counting rule (see Figure 1.7).

5.5 Continuous scanning of a plane

Another approach might be to hold a ruler in front of your face and ‘scan’ it continuously across the room, counting each person on the first occasion that the ruler ‘touches’ them. For some this first touching point might be the tip of a finger, for others the head and yet others a foot, depending entirely upon the orientation of each individual and the direction of the ‘scan’. Note that neither the orientation of the individual or ruler nor the direction of the ‘scan’ will influence the number of people counted when using the ‘first time I hit an object’ rule. This rule is shown in practise in Figure 5.4. For example, Figure 5.4a represents a 3D object containing five


Page 69

Figure 5.4

An illustration of the scanning plane method for counting objects. (a) In this representation of a 3D object containing five particles a scanning plane is viewed edge on (so it appears as a line). As this plane is scanned through the object each particle is counted when the plane first touches it (shown by the short lines). (b) Use a ruler to carry out the scanning plane counting rule on this object. Indicate for each particle when the plane first touches it. Note that for the right-most particle, which is very non-convex, one orientation of the ruler will generate a first-time hit which consists of two hitting points.

particles. If a plane, represented by the line in the figure, is swept continuously through the object, it hits each of the particles in turn and at the first hitting point each is counted.

In practise a continuous scan through a 3D volume can be achieved by a number of different technologies; these include confocal microscopy, magnetic resonance imaging and, under certain circumstances, conventional transmission light microscopy using high numerical aperture oil immersion lenses. The scanning approach for counting objects in 3D was first used in the confocal microscope by Howard et al. (1985). Continuous scanning methods will be discussed further later in this chapter.

5.6 The disector principle

In many application areas of microscopy it is either impossible, or extremely difficult, to scan a plane continuously through a volume. A ‘brute force’ approach to overcome the problem might be to serially section the whole object and reconstruct it, which is certainly not a new idea (Katschenko, 1886). However, serial sectioning without reconstruction can also be used to count objects. This method was proposed by Cruz-Orive (1980a) in what may be considered the first modern design-based stereological paper. The method of serial sectioning without reconstruction as an unbiased technique for number estimation is illustrated practically by DeGroot and Bierman (1983). However, even without reconstruction, exhaustive serial sectioning is extremely tedious and has proven too labour intensive to be used routinely.

Although serial sectioning without reconstruction represented a real unbiased and assumption-free approach to counting in 3D, the major breakthrough in stereological


Page 70

Figure 5.5

The 3D object shown in Figure 5.4a has been exhaustively sectioned by a series of systematic uniform random planes (again shown as lines). The particles are counted by moving down the stack of sections and applying the rule that a particle is counted if it appears in one section but not the next. For example, the uppermost particle is seen in section a, but not in section b. Note that for unbiased counting it is necessary to know when a particle transect consists of more than one profile in a section (e.g. section g).

counting was provided by the publication of the ‘disector’ paper (Sterio, 1984). This paper was published under the pseudonym of D.C.Sterio (an anagram of disector) by a well-known Viking stereologist. The disector represents the ultimate minimalist approach to a 3D probe: it consists of a pair of serial sections a known distance apart. The method relies upon the principle that if a particle’s transect is seen in one section and not the next, it is counted.

The application of the disector principle is illustrated in Figure 5.5. If a particle is seen in one section, but not the next, it is counted. For example, the particle seen in section a is not seen in section b and is therefore counted. Note that if the transect of a non-convex particle contributes two profiles within the same section then that must be known, otherwise there will be a spuriously high count (see section g in Figure 5.5). In common with continuous scanning the disector is a directional counting rule.

Figure 5.5 shows that if the disector principle is applied exhaustively then each particle is counted only once. This means that such a count would not be an estimate, in mathematical terms it would be an identity, that is, the true answer. Therefore the method is inherently free from systematic bias. The disector is in effect an approximation to the continuous scan. It is not known for sure what happens between the two disector planes, but if the planes are closely spaced, a reasonable deduction can be made. In reality the disector is an ingenious gambit for counting the number of times a continuous scan would have hit particles for the first time (i.e. it counts the ‘tops’ of particles). The disector is open to certain biases, however, as illustrated in Figure 5.6 ; but for most practical purposes, these can be reduced to a negligible level.


Page 71

Figure 5.6

Possible sources of bias found using the disector principle. (a) When travelling from section (i) to section (ii) no change of status is observed, that is, applying the disector counting rule has led to an incorrect deduction. (b) With an opaque section, such as a polished rock or metal surface, the distance between sections can be very critical for it is possible for a particle to be ‘hidden’ between the two section planes. (This is not usually a problem for transmission microscopy.)

5.7 From theory to practise

In practise the number of objects to be counted will usually far exceed the ability of the investigator to enumerate them exhaustively. For example, the human neocortex has about 25×109 neurones! Therefore it is necessary to sample and move from the certainty of an identity to the relative uncertainty of an estimate. The disector principle can still be applied to the sample, which should be uniform random, but now it becomes necessary to be able to relate any particular count to a known sampling volume.

First consider the problem of associating a count with a given sampling area in the 2D case. In Figure 5.7 , a number of 2D objects are shown in a 2D field of view. This pattern can be assumed to extend to infinity and that the figure represents a uniform random sample. It is clearly simple to count the number of complete objects present but how can they be unbiasedly related to an area? What about the objects that cut the edge, are they to be ignored? There are several solutions to this problem but the one that is most readily applicable and in general use in microscopy was proposed by Gundersen (1977) and addresses the ‘edge effect’.

An unbiased counting frame of known area with an acceptance line (dashed) and an infinite ‘forbidden’ line (fully drawn) is illustrated in Figure 5.7. Any object that is cut anywhere by the forbidden line is not counted (i.e. objects b, g and h). Objects falling fully inside the counting frame (object e) or those that cut the acceptance line without also cutting the ‘forbidden’ line (objects c and f) are counted. The application of this rule leads to an unbiased estimate of the number of 2D objects per unit area. In effect we have associated a definite count with the area of the counting frame.

The unbiased counting frame shown can in fact be moved in an area-filling tessellation (like the tiles in a bathroom) and no 2D object would be counted more than


Page 72

Figure 5.7

A 2D field of view containing several 2D objects is shown with an unbiased counting frame surrounded by a guard area. The counting frame consists of a solid forbidden line, which extends above and below the field of view to infinity, and a dashed acceptance line. The area of the counting frame is ∆x multiplied by ∆y units squared. Any 2D object that is cut by the forbidden line is not counted (i.e. b, g and h). 2D objects falling fully inside the frame (i.e. e) or those that cut the acceptance line without also cutting the ‘forbidden’ line (i.e. c and f) are counted. The application of this rule leads to an unbiased estimate of the number of 2D objects per unit area. (Figure redrawn from Gundersen, 1977, with permission from the Royal Microscopical Society.)

once, whatever its shape; this is illustrated in Figure 5.8. Therefore in 2D this counting frame, and its associated counting rule, is free from systematic bias. Note that it would be impossible to implement this rule unless there was a ‘guard area’ around the counting frame. Therefore this counting rule cannot be applied, for example, to a complete television monitor image.

The next step in 3D counting is to extend the unbiased 2D counting rule to a directional 3D particle-counting rule. This is illustrated in Figure 5.9 which shows two perfectly registered serial sections through an object of interest. The left-hand section contains a 2D counting frame and is referred to as the ‘reference’ section. The right-hand section is known as the ‘look-up’ section. For each of the transects correctly sampled by the counting frame in the reference section (i.e. transects a, b and c) a corresponding transect is sought in the look-up section (the dashed frame on the look-up section is included to help the eye in this task and has nothing to do with the counting rule). If no corresponding transect is found anywhere in the look-up section (in this example, transect a) then this particle is counted in 3D. Note that although the transect from particle b in the look-up section is outside the dashed line this particle is not counted in 3D because it is still present in the look-up section. It should also be noted that the count is associated with a volume of space equal to the area of the counting frame multiplied by the distance between the sections. This counting rule is an unbiased estimator of numerical density. The combination of the disector principle described above and the 2D counting frame is the ‘disector’ (Sterio, 1984).


Page 73

Figure 5.8

An illustration of the unbiased counting frame and its associated counting rule. The bounded 2D object contains five 2D particles. If the unbiased counting frame is tessellated over the object, so that the whole area of the object is completely covered by the tessellation, each 2D particle is counted only once.

Figure 5.9

An illustration of the disector counting rule. The left-hand section contains a 2D counting frame and is known as the ‘reference’ section. The right-hand section is known as the ‘look-up’ section. For each of the transects correctly sampled by the counting frame in the reference section (a, b and c) a corresponding transect is sought in the look-up section (the dashed frame on the look-up section is included to help the eye in this task and has nothing to do with the counting rule). If no corresponding transect is found anywhere in the look-up section (in this example transect a is missing, indicated by the asterisk) this particle is counted in 3D. Note that although the transect from particle b that is seen in the look-up section is outside the dashed line this particle is not counted in 3D because it is still present in the look-up section.


Page 74

5.8 Implementation of the physical disector

The first published example of the disector (Pakkenberg and Gundersen, 1988) used the comparison of two physical sections in the manner illustrated in Figure 5.9. In this paper two projection microscopes were used so that the images from the pair of disector sections could be viewed simultaneously. One of the most time-consuming aspects of the technique is the requirement for perfect registration of the sections. In some circumstances there is a more efficient method of counting which employs thin optical sections within thick sections (see Section 5.10). However, for large objects, such as renal glomeruli, there is no alternative to the physical disector.

It can be noted at this stage that, because relatively thin sections are used and the distance between them is dictated by the microtome (as fully described below in Section 5.9), use of preparative techniques that induce collapse in section depth, such as deparaffination or dehydration, do not induce bias. Therefore the physical disector can be used with paraffin or frozen sections. Similarly for media such as metals, when it is often not possible to use transmission microscopy, the physical disector can be applied to serial polished sections (Karlsson and Cruz-Orive, 1991; Liu et al., 1994).

For ease of counting in the physical disector it is more efficient to select a frame size and disector height, which lead to a small number of particles being counted per frame. This means that the number per frame can be counted ‘at a glance’. Thus in many cases a test system composed of four or more small frames per sectional image is much easier to use than a single larger frame of the same total area (e.g. grid F4 in Appendix B).

In practise it is found that most of the time spent in applying the physical disector is dedicated to registering the two sections. Therefore to increase overall practical efficiency, the maximum amount of information should be extracted once sections have been successfully registered. Bearing in mind that the disector is a directional counting rule, the efficiency of the physical disector can be nearly doubled by making separate counts in both directions, that is, by going up and down between the two sections. This is achieved for a pair of sections by first using one as a reference section and the other as a look-up section and then swapping the roles played by the reference and look-up sections. This approach is illustrated in Figure 5.10.

In order to reduce the cost of implementing the physical disector, a double tandem projection microscope has been developed in which section pairs are mounted on a single microscope stage (Appendix A). Each slide holder has rotation and x, y translation so that the slides can be perfectly registered, usually using some obvious anatomical feature such as a large blood vessel. Thereafter the slides are moved in tandem over the front focal planes of two separate projection light microscopes. The single tandem stage can be moved to uniform random positions and the section pairs maintain registration. This has major time-saving implications for the application of the physical disector. An alternative implementation of this idea could be achieved by the use of two completely separate microscopes, each with a digital camera and its own video monitor. The tandem movement could then be produced by linking two accurate, computer-controlled x, y motorized stages to a single command system.

If a uniform random sampling scheme is applied then in practise it is found that some fields of view actually cross the edge of the object ( Figure 5.11 ). In this example two of the small sampling frames are partially within the reference space of the organ of interest. To estimate the number of particles per unit volume it is necessary to count objects and to relate the count to a known volume. The latter is carried out by multiplying the volume of the disector (area of the frame multiplied by distance to


Page 75

Figure 5.10

An illustration of the two-way use of the physical disector. Both (a) and (b) show the same pair of perfectly registered sections a known distance apart. In (a) the left-hand section has a pair of unbiased counting frames superposed and thus acts as the reference section. The count is made from this section to the right-hand section in the direction of the arrow, that is, transects properly sampled in the frames are sought in the look-up section. In this example we count two particles. In (b) the roles of reference and look-up section have been reversed. The count now takes place from right to left, in the direction of the arrow. In this case we count one particle. Thus, in total, three particles have been counted. It is impossible for a particle counted in one direction to also be counted in the opposite direction. In (a) the volume of disector used is twice the frame area times the distance between sections. In (b) the volume of disector used is the same. Thus, in total the volume of disector used is four times the frame area times the distance between sections.

next section) by the number of disectors that ‘hit’ the reference space. Whilst this is easy when all the disectors lie completely within the reference space there is a problem if some lie only partially within the reference space. One solution might be to measure the area of the portion of the frame within the reference space and multiply that by the disector height and add it to the total volume of disector used. However, this would be tedious to apply in practise and is unnecessary.

A far simpler solution is to allocate a point to each counting frame. For each position of each counting frame, the point in the frame is judged to be either ‘in’ or ‘out’ of the reference space. For example, in Figure 5.11 the top right-hand frame on the reference section would be judged to be out and the other three to be in. A cumulative


Page 76

count is recorded for the number of counting frame points that hit the reference space (P). This count, multiplied by the area of a single frame and the disector height, is an unbiased estimate of the total volume of disector that has been used. Independently of deciding whether a frame-associated point is inside or outside the reference space, disector counts of particles (Q−) must be performed on all parts of all frames hitting the reference space. This means that even if a frame’s associated point is outside the reference space a particle can be correctly sampled and counted by that frame. For example, in Figure 5.11 , although the point associated with the top right-hand frame is outside the reference space, a particle is counted in this disector and thus contributes to the total particle count (Q−). The counts of frame-associated points hitting the reference space (in this example the organ) and correctly sampled and counted particles are used to estimate numerical density using the equation shown in Figure 5.12.

Figure 5.11

An illustration of how to estimate the volume of disector used. Each of the sampling frames has an associated point at its center. If the point lands within the reference space the volume of that disector is added to the total. Conversely, if the point falls outside the reference space no such addition is made. For example, in this figure the top right-hand frame on the reference section would be judged to be out and the other three to be in. Independently of deciding whether a frame point is inside or outside of the reference space, disector counts of objects must be performed on all parts of all frames hitting the reference space. For example, in the figure although the point associated with the top right-hand frame is outside the organ, a particle is counted in this disector and contributes to the total particle count. The counts of points hitting the reference space (in this example the organ) and particles are used to estimate numerical density using the equation shown in Figure 5.12.

Figure 5.12

The formula for estimation of numerical density.


Page 77

5.9 Typical sampling regime for the physical disector

The aim of the procedure is to obtain pairs of sections, a known distance apart, with uniform random probability from the object of interest. For example, consider a human fetal kidney about 5 mm long, which is small enough to embed and section exhaustively ( Figure 5.13 ). For the Cavalieri estimate of kidney volume about ten sections are generally required to obtain a reasonably precise estimate (Chapter 3). For every section taken another section a known distance apart is required; these pairs of sections are collected, mounted on separate slides and marked to indicate they are a pair. As a rule of thumb the distance between the sections that will be used as disectors should be about 30% of the average projected height of the objects to be counted. For example, for renal glomeruli optimal distances are found to be in the range 30–45 μm.

To further elaborate this scheme for a fetal kidney which is roughly 5000 μm long (i.e. 5 mm) then to obtain roughly ten ‘Cavalieri’ sections, one should be taken every 500 μm (with a random start). If the section thickness is set to 5 μm on the microtome then this would be every 100th section. In addition, after every ‘Cavalieri’ section an additional ‘disector pair’ section should be taken. If the disector height was chosen to be 35 μm this would be the seventh section after each ‘Cavalieri’ section.

To ensure a uniform random position of the pairs of sections within the specimen a random number table or generator should be used ( Box 2.1 ). The sampling distance

Figure 5.13

A schematic illustration of a typical physical disector sampling scheme. The object, in this case a kidney, is sectioned so that pairs of sections a known distance apart are sampled throughout the object (a). In the case of a fetal kidney these section pairs may be separated by 35 μm with each pair being 500 μm apart. Each pair is mounted on separate slides. One set of slides is used to estimate the volume of the kidney using the Cavalieri method (see Chapter 3). Then each pair of sections is examined by registering the sections and generating registered systematic uniform random fields of view (b). Two registered fields of view (i) and (ii) are shown with superposed sampling frames in (c).


Page 78

between pairs is to be 100 sections, and so a random number between 0 and 99 should be obtained. For the sake of simplicity of explanation let us assume that this turns out to be 50. Start counting sections as soon as you start cutting the block (i.e. before actually reaching the tissue) and, in this case, take sections 50 and 57; 150 and 157; 250 and 257, and so on until the whole kidney has been sectioned exhaustively. Each pair of sections containing tissue should be mounted and stained on separate glass slides and marked in number order as pairs. The first of each pair of sections (the ‘Cavalieri’ section) can now be used to estimate the volume of the cortex of the kidney, in which the glomeruli reside, as described in Chapter 3. This approach is described and applied by Hinchliffe et al. (1991, 1992).

To estimate the numerical density of glomeruli each pair of sections is mounted in the double projection microscope and registered. A sampling regime should now be adopted in which each part of each section of the pair has the same chance of appearing in the fields of view. Choose a sampling distance to step in x and y which can then be applied as a regular pattern or raster across the whole section. Start the scan outside the specimen and then accept anything that appears in the field of view for making disector measurement. Under no circumstances should fields of view be ‘chosen’. If you find yourself choosing you are doing it incorrectly!

From estimation of volume [image] and numerical density [image] an estimate of the total number of glomeruli is given by

(5.1)

For published applications of the physical disector in neuroscience see Bedi (1991), Korbo et al. (1990), Møller et al. (1990), Benham-Rassoli et al. (1990) and West et al. (1988). This approach has been superseded by the optical disector. The physical disector has been employed in studies of tissue/organ growth by Baandrup et al. (1985), Mayhew and Simpson (1994), Mayhew et al. (1994), Mulvany et al. (1985) and Simpson et al. (1992). The use of the disector in biomedical applications has been reviewed by Mayhew and Gundersen (1996).

5.10 Optical section ‘scanning’ methods—the unbiased brick and optical disector

In some circumstances a considerable increase in the practical efficiency of counting can be obtained by using a continuous scanning method. In light microscopy a continuous scan can be obtained using an ‘optical section’ and the phenomenon of ‘optically sectioning’ within a thick slice provides an excellent way to count things directly. The first practical application of this approach was the ‘unbiased brick’ demonstrated by Howard et al. (1985) in a confocal microscope. However, the use of optical sectioning in conventional transmission light microscopy for counting has become known as the ‘optical disector’ technique (e.g. Braendgaard et al., 1990; Gundersen, 1986).

In a light microscope of either confocal (Wilson, 1990) or conventional design the depth of field of the microscope, that is, that part of the sample that is in sharp focus, decreases as the numerical aperture (NA) of the lens increases. Therefore in order to obtain the thinnest possible optical section a lens of high numerical aperture should be used. In a conventional transmission light microscope this effect explains why thin physical sections are required to have the whole of the section in focus. The inverse of this problem manifests itself as a very familiar effect in photography, where it is often important to ‘stop down’ the lens diaphragm to get a better depth of field.


Page 79

Figure 5.14

A schematic illustration of the structures through which light must travel from the condenser lens to the specimen when optical sectioning is carried out in a conventional transmission light microscope. The diagram is not drawn to scale.

In light microscopy the highest NA lenses are diffraction-limited, high-magnification (greater than ×60) oil-immersion lenses. When these lenses are used in conjunction with a matching condenser it is possible to achieve a depth of focus of about 0.5 μm with a ×100 1.4 NA oil-immersion lens. Thus when applied to a ‘thick’ histological section (say greater than 25 μm thickness) only a thin slice within the ‘slab’ will actually be in focus ( Figure 5.14 ). As the microscope stage is moved up and down with respect to the objective the thin ‘optical section’ also moves up and down within the slab (Haug, 1955). In practise this means that the observer will see objects coming into focus and then disappearing again as they move through focus.

The major advantage of optical sectioning compared with physical sectioning is that all the positions of a single ‘scan’ of the optical section are perfectly registered. This continuous scan can thus be employed to obtain an unbiased estimate of numerical density. In practise this is achieved by superposing an unbiased counting frame on an image of the optical section and then the frame is scanned down through the slab by ‘taking a ride’ on the optical section. By sweeping a frame down through the slab a volume is generated.

There are several ways of combining an optical sectioning microscope with a sampling frame. The simplest approach would be to project the microscope image through the eyepiece on to a white surface through the use of a prism or mirror. However, this is almost never done because the intensity of illumination required for a projection image from a ×100 oil-immersion lens is very high and, if achievable, tends to cause severe specimen bleaching.

A relatively cheap and practical solution is to use a drawing tube on the microscope. Most academic institutions have a ‘camera lucida’ hidden away somewhere. The counting frame is placed under the drawing arm, usually illuminated by a lamp with a rheostat. The specimen is then viewed through the eyepiece(s) and, by adjusting the illumination of the grid, it can be seen superimposed on the image of the optical section. In fact when counting small objects, whose size approaches the resolving power of the microscope, this may be the configuration of choice because the direct microscope image does not suffer from the loss of resolution experienced with digitized television images.


Page 80

However, by far the commonest implementation, and the one that will be described, is to use a video camera on the microscope to display the microscope image on a high-resolution video monitor. A computer-generated counting frame is then overlain on the video image. For most practical cell-counting operations this suffices.

For any implementation of the optical disector one additional piece of equipment is mandatory. This is a microcator, which is used to measure the depth travelled in the z direction by the microscope stage. Very accurate opto-electronic microcators, with or without RS232 electronic readout, are the most commonly used instruments. However, low-cost alternative mechanical microcators can perform perfectly adequately (as described in Appendix A). A more expensive alternative would be to use a programmable high-precision x, y, z stage. It should be noted that the standard screw-thread drive-focusing mechanism fitted to microscopes cannot usually be relied upon to measure small movements of the stage, for two reasons: (i) there is considerable backlash in the mechanism and (ii) the graduations on the focusing knob are not sufficiently fine.

An additional important practical consideration for applying optical sectioning is that the refractive indices of the lens, immersion oil, cover slip and embedding medium must be matched as closely as possible. If these are matched then the distance travelled by the optical section in the z direction within the slab is identical to the distance moved by the stage (i.e. that reported by the microcator). For example, the use of an objective lens optimized for use in air would lead, by application of Snell’s law, to the optical section travelling a shorter distance within the slab than is shown on the microcator. This effect would result in a systematic (and invisible) overestimate of numerical density. Refractive index matching is best achieved in biological applications by using oil-immersion lenses with resin embedding (e.g. methyl methacrylate).

There is another important reason why a resin should be used for embedding when using the optical disector. When a paraffin section is deparaffinated, prior to mounting a collapse of up to 60% of the height of the section occurs. Similarly when a frozen section is dehydrated a collapse in height occurs (see Box 5.1). This type of tissue shrinkage will automatically lead to a severe overestimate of numerical density. Unfortunately the exact extent of tissue shrinkage is both variable and difficult to measure. Embedding in a resin such as methyl methacrylate minimizes shrinkage effects.

Box 5.1 Correcting for the effects of tissue shrinkage

If a total structural quantity is estimated by multiplying the volume of the reference space by a stereological ratio (e.g. Vv, Nv), then care must be taken to ensure that the material has neither expanded nor contracted between the estimation of the reference volume by Cavalieri and estimation of the ratio of interest. For example, often the Cavalieri method is performed on wet slabs or agar-embedded tissue. However, the ratio is subsequently estimated from wax or resin-embedded sections after histological preparation such as dehydration and staining. The microtomy Itself can also cause dimensional changes to the section.

Processing-induced volume changes, or ‘shrinkage’, can be defined as

which is a dimensionless ratio. Note that shrinkage can be either positive, that is, the object has become smaller, or negative, so that the object has become larger.


Page 81

In any particular study the details of how to quantify the degree of shrinkage in a preparative method will vary. Here we describe a general approach. The figure below represents a slab of material that has been used to estimate the reference volume using the Cavalier! method. A small block is shown cut from the larger slab. The volume of this block can be estimated directly by

block volume=width×depth×mean height.

This block is then processed, embedded and sectioned such that sections from two orthogonal ends of the block are obtained and mounted. From one of these ends the height and width after processing can be estimated, from the other the height and depth can be estimated. These values can then be used to estimate the effective volume of the block after all relevant processing steps. Using the estimates of the block volume before and after processing the first equation can be used to calculate the shrinkage induced by the processing. Once the shrinkage has been estimated the volume of the reference space, estimated using the Cavalieri method on the unprocessed tissue, needs to be corrected using

For example, if the volume had been estimated as 547 cm3 from the Cavalieri method and the shrinkage estimated as 0.1 the corrected volume would be given by

If a total quantity is required the density estimated on the processed and mounted sections multiplied by the corrected volume would give an estimate of the total quantity properly corrected for shrinkage, for example

For further details and an example of the application of this approach to neocortex see Braendgaard et al. (1990).


Page 82

Figure 5.15

A schematic illustration of the unbiased brick described by Howard et al. (1985). The brick consists of the central volume, bounded by three acceptance surfaces. All other surfaces are forbidden and at the edges of the diagram extend to infinity. Any particle that is wholly within the brick, or cuts the acceptance planes without anywhere cutting any forbidden surface is counted. (Redrawn from Howard et al., 1985, with permission Royal Microscopical Society.)

5.11 The unbiased brick-counting rule

The unbiased brick is depicted in Figure 5.15. It consists of three acceptance planes and five forbidden surfaces. A particle is counted if it is totally inside the brick or if it intersects any of the acceptance planes and does not intersect any of the forbidden surfaces anywhere. This rule is perfectly general and can be applied to any discrete non-convex particle. In this terminology the ‘brick’ refers to the volume of space generated by sweeping a 2D unbiased counting frame down through 3D space. In practise the application of the unbiased brick rule requires the use of guard volumes to the sides of the frame and below the brick. A full explanation of the unbiased brick rule and a formal proof of its unbiased nature is given by Howard et al. (1985). The unbiased brick is in fact the exact 3D analogue of the 2D counting frame shown in Figure 5.7. From a historical perspective it was Gundersen (1981) who first recognised that the 2D counting rule of Gundersen (1977) could be directly extended to 3D.

5.12 Application of the optical disector counting rule

The unbiased brick-counting rule is a general 3D counting rule that is applicable for particles of any shape or size. If the particles of interest are convex, for example nerve cell nuclei, then the optical disector can be used (Gundersen, 1986).

To apply the optical disector counting rule the thick section should be mounted on the microscope stage and uniform random fields of view generated as discussed above. In each field of view sampled the following procedure is adopted.


Page 83

1. Set the optical section at some random distance within the first, say, 10 μm of the thick section.

2. Zero the microcator.

3. Decide how deep the optical disector will be, for example, 15 μm.

4. Scan downwards in the thick section using the fine focus knob of the microscope. As the nuclear membrane of each cell nucleus comes into sharpest focus within the field of view two decisions must be made.

(a) Is the nuclear profile correctly sampled by the unbiased sampling frame?

(b) If it is, is the optical section containing that nuclear profile within the height of the optical disector? This is carried out by reading the microcator, if the reading is greater than zero, but less than or equal to the maximum depth of the optical disector (in this case 15 μm), the optical section is judged to be ‘in’. (Note that this applies the convention of discarding the uppermost face of the optical disector and including the lower face.)

This counting procedure is illustrated schematically in Figure 5.16. The numerical density of particles is estimated from the equation given in Figure 5.12. Each frame should have a point associated with it, as with the physical disector, to cope with frames straddling the edge of the reference space. In practise, because of the high magnification used for the optical disector, such events are very rare.

Although the term ‘optical disector’ has become widely known on first acquaintance this name can cause confusion for the following two reasons. First, the ‘disector’ method published by Sterio (1984) explicitly requires two sections a fixed distance apart (leading to the di part of its name). However, the optical disector never requires the comparison of a pair of registered planes. Second, the use of a pair of planes in the physical disector dictates that a deduction must be made. The optical disector does not rely upon deduction and in fact gives a direct count of objects in 3D space.

The optical disector requires that the objects are convex, and nearly spherical. Under these circumstances it is possible to define a unique ‘associated plane’ with each particle. Thus the optical disector decomposes the 3D counting rule of the unbiased brick into two distinct processes: the first is deciding if the planar profile is sampled by the 2D counting frame and the second is confirming that the projection of the associated plane on to the z axis is within the height of the optical disector. Because the particles are convex, once a particle’s associated plane has been counted correctly it is not necessary to examine that particle at any other depth. This makes the optical disector extremely efficient to apply. However, any appreciable departure of particle shape from near sphericality can introduce difficulty in defining an unambiguous plane of maximal focus. In such circumstances the unbiased brick rule should be applied.

5.13 Typical sampling regime for the optical disector

A typical application would initially use an identical approach to the physical disector. However, the regimes diverge when sectioning commences. In particular, section pairs are not required, as described above in the physical disector. It is simply adequate to take uniform random single thick (usually about 30 μm) sections. In a preliminary investigation the following issues need to be addressed.

1. The size of the sampling frame. Rule of thumb—on any one ‘scan’ of the sampling frame in z it is best to have between about two and five ‘events’ or counts. This means that they can be counted in the head and there is no difficulty in keeping track and, for example, avoiding counting something twice. If the count per


Page 84

Figure 5.16

A schematic illustration of the optical disector. A series of optical sections through a thick section of resin-embedded nerve tissue is shown. In each section cell nuclei are indicated as the dark phase, those cell nuclei that are in maximal focus within the sections are shown with a black outline. The stack at the left of the figure illustrates the relative stopping positions of the optical sections. The following counts are recorded for each section.

(a) (0 μm). A nuclear profile is sampled by the 2D frame, but because the depth of focus is 0 microns (i.e. the topmost plane of the optical disector) this cell is not counted.

(b) (3.5 μm). A nuclear profile is sampled by the 2D frame and because the focal plane is within the optical disector the cell is counted (note that it is the cell nuclei not the cell bodies that must be correctly sampled by the 2D sampling frame).

(c) (6 μm). A nuclear profile is in maximal focus, but is not correctly sampled by the 2D frame (i.e. it cuts the forbidden line) and is therefore not counted.

(d) (7.5 μm). A nuclear profile is sampled by the 2D frame and because the focal plane is within the optical disector the cell is counted.

(e) (11 μm). A nuclear profile is sampled by the 2D frame and because the focal plane is within the optical disector the cell is counted.

(f) (15 μm). A nuclear profile is sampled by the 2D frame. The focal plane is at the bottom of the optical disector but this cell is counted.

optical disector is very low on average, say 0 or 1, then this may be inefficient. However, it is often statistically more efficient to use lots of small optical disectors rather than a few large ones, for it can reduce the variance of the estimate.

2. Decide on a depth for the optical disector, this is often set to about 15 μm, though it can be any suitable value. This fixed depth should then ideally be applied to all sampling bricks in the study.


Page 85

3. The use of optical microscopes for optical sectioning, and therefore the application of the optical disector, is critically dependent upon correct microscopy. Therefore make sure that the microscope is optimally set up for maximal resolution with a matched condenser.

An estimate of total cell number can be obtained by multiplying the estimate of numerical density, obtained with the optical disector, by an estimate of the volume of the reference space (e.g. Equation 5.1).

Applications of the optical disector include Bjugn (1991, 1993), Bjugn and Gundersen (1993), Braendgaard et al. (1990), Jansson and Møller (1993), Regeur et al. (1994), Tandrup (1993), Tandrup and Braendgaard (1994) and West and Gundersen (1990). Since the first edition of this book we have re-visited some aspects of the optical disector counting rule (Reed and Howard, 1999). For practical purposes these do not alter the approach to counting in three dimensions outlined above.

5.14 Direct estimation of number—the fractionator

The physical disector, unbiased brick and optical disector methods make estimates of total number via an estimate of numerical density. However, if total particle number is the only result that is required then the ‘fractionator’ technique offers a direct and robust method to estimate total number. The method is unaffected by shrinkage and even the magnification need not be known! The fractionator was first described in the context of quantitative microscopy by Gundersen (1986). The sampling principle underlying the fractionator is, however, a very widespread approach that is adopted in a number of scientific disciplines. In common with the disector the fractionator exists in two forms, the ‘physical fractionator’ and the ‘optical fractionator’ (West et al., 1991). The former was the first to be described (Gundersen, 1986) but the latter is now much the most widely used, and therefore the optical fractionator will be outlined here.

The basic principle of the fractionator is beautifully simple. Take a known fraction of the whole object, for example one-thousandth. Count every particle in that fraction. An unbiased estimate of the total number in the original object would be the total number counted in the fraction multiplied, in this case, by 1000. The only caveats are that the fraction sampled should be explicitly known and that it should have been obtained with uniform random probability, that is every part of the object had the same chance of being included in the sample before sampling began.

5.15 A 2D example of the fractionator principle

Before explaining the implementation of the fractionator for 3D situations we will describe how the principle can be applied in 2D. Consider Figure 5.17 ; how many spots are on the 2D object? Clearly, they can simply be counted directly. However, the number of spots can also be estimated using the fractionator principle.

The object in Figure 5.17 has been cut into ten strips of arbitrary width. From this set of strips three systematic samples with sampling fraction 1/3 have been taken (see Chapter 2). For example, sample 1 contains strips 1, 4, 7 and 10. By counting the number of spots contained in this sample and multiplying by 3 we obtain an unbiased estimate of the total number. In this case the sum of spots in the sample is 11, thus giving an estimate of total number of 33. This procedure can be carried out for the other two samples (giving estimates of 12 and 24 respectively). If the three estimates are added together and divided by 3 we find that the average of the estimates


Page 86

Figure 5.17

In this illustration a 2D example of the fractionator is shown. The object has been cut up into ten slices of uneven width and size. Three samples, each obtained with a sampling fraction of 1/3, are shown. Sample 1 consists of slices 1, 4, 7 and 10. Sample 2 consists of slices 2, 5 and 8 and sample 3 consists of slices 3, 6 and 9. For each sample an unbiased estimate of the total number of spots is obtained by counting the number of spots in the sample and multiplying by the reciprocal of the sampling fraction. For example, in sample 3 there are eight spots, thus giving an estimate of total number of 24. The average of the three possible samples shown is equal to 23, which is the true number.

is equal to the true number of spots. The fact that the average of the estimates equals the true value shows that the estimation method is unbiased.

This 2D example highlights some very important aspects of fractionator estimation which often cause confusion.

1. The fraction that is sampled from the object is decided in advance and then obtained by stepping along the ordered list of strips the required number of steps (in this example, three). It is unimportant how many strips were in the original list or the number of strips that end up in a given sample. For example, the fraction of the object represented by sample 1 is 1/3 not 4/10.

2. The strips do not have to be the same size or shape, though striving for this will reduce the variance of the estimate.

3. The number of strips in each sample will, in general, not be the same (though they may be the same, if for example the object had been cut into nine strips then each sample would have contained three strips).


Page 87

4. The property of unbiasedness means that on average the estimates will equal the true value, it does not mean that each estimate is exactly equal to the true value. For example, in this case none of the individual estimates (i.e. 33, 12 and 24) are equal to the true value of 23.

In the example shown in Figure 5.17 the three separate estimates are rather variable. In practice the variability of the fractionator can usually be brought under control by altering the sampling design, for example by cutting more strips.

5.16 The multi-stage fractionator

The 2D example given here highlights all of the important aspects of the fractionator that need to be understood. To apply the technique in 3D the fractionator often requires several layers of fractionation to be used. However, at each level the same principles apply. (See Figure 5.18 and Ogbuihi and Cruz-Orive, 1990.)

In general to estimate the total number of particles within a bounded object we first cut it into a few fragments. These fragments do not need to be of the same size or shape. If we pick every fth fragment, with a random start between 1 and f, and measure for all these fragments the quantity of interest, then we only need to multiply this measured quantity by f to obtain an unbiased estimate of the total quantity in the whole object.

The idea of the fractionator can be extended to several sub-sampling stages: every f1th fragment of the first fractionation step is cut into sub-fragments, of which every f2th fragment is picked, and so on. To obtain an estimate of the total quantity we multiply the quantity estimated in the last (kth) sub-sample by 1/f1×1/f2× …×1/fk (see Figure 5.18). The fractionator works best when the average total number for a series of individuals is required. For single objects the fractionator remains unbiased but there is an appreciable probability that one of the fragments containing a significant proportion of the quantity of interest could be discarded.

5.17 The optical fractionator

The optical disector and a fractionator sampling scheme can be combined to give the optical fractionator (Antunes, 1995; West et al., 1991). This technique involves counting particles with optical disectors in a uniform and systematic sample that constitutes a known fraction of the region to be analyzed. The estimator is not affected by tissue shrinkage or expansion and can be applied to frozen, vibratome, celloidin and paraffin sections. For example, West et al. (1991) estimated the total number of neurones in sub-divisions of the rat hippocampus using the optical fractionator.

The optical fractionator is generally applied in three stages.

1. The object is embedded and exhaustively sectioned. A known fraction, the slice or section sampling fraction, ssf, of the sections is then sampled using systematic random sampling ( Figure 5.19a ).

2. For each sampled section, optical disectors are used to count the number of particles in a regular grid of x,y positions. In each of the sections the first of these counting frames is uniform randomly translated over the x,y interval, the remainder of the positions in the grid are moved to using a stepping motor microscope stage. The area of the unbiased counting frame making up the optical disectors (a/f) must be known and the area associated with each x,y movement (∆x multiplied


Page 88

Figure 5.18

An illustration of the multi-stage fractionator. Stage 1: the object is sliced into thick slabs and a fraction of 1/3 is obtained with a random start. In the example the random 7start was 3 and the three slabs obtained are shown. The total number of particles in these slabs is 676, thus giving an estimate of the total number of 2028. Stage 2: a quarter of the ‘fingers’ obtained from the slabs in stage 1 are extracted with a random start (here 3). The total number of particles in this fraction (176) multiplied by 3×4 is an estimate of the total number of particles, i.e. 2112. Stage 3: finally a fifth of the remaining material is extracted. The total counted in this fraction is 36. Therefore an estimate of the total number of particles is given by 3×4×5×36. It should be noted that as a smaller and smaller fraction is sampled the total number of particles counted in the final fraction reduces. This is compensated for by multiplying by a larger reciprocal fraction. Therefore the final estimate in each case remains of the same order of magnitude. However, the amount of effort involved in counting for the third stage of fractionation is about 200 times less than at the top level! For a real example of this type of fractionation scheme see Ogbuihi and Cruz-Orive (1990).

First stage sampling fraction (f1)=1/3 (Random start here is 3)

Total count in sampled slices at first stage, Q1=125+300+251=676. Estimate of total number in object is given by

Second stage sampling fraction (f2)=1/4 (Random start here is 3)

Total count in sampled fingers at second stage, Q2=66+12+45+53=176. Estimate of total number in object is given by

Third stage sampling fraction (f3)=1/5 (Random start here is 4)

Total count in sampled blocks at third stage, Q3=9+2+6+11 +8=36. Estimate of total number in object is given by


Page 89

by ∆y) should also be known. From this information the area sampling fraction (asf) can then be calculated (Figure 5.19b).

3. The height (h) of the disector should also be known relative to the mean thickness of the sections (T). These distances can usually be estimated easily with a microcator.

From these three sampling fractions the total number of particles in the object is estimated directly from

(5.2)

where Q refers to the total number of particles actually counted in any of the optical disectors that hit the transects of the object within any section.

5.18 Some special designs for counting in 3D

The single section or ‘cheating’ disector!

If the objects to be counted are very small then a model assumption can be made which greatly simplifies counting. The assumption is that if an object appears in one section it is so small that it would very seldom be seen in the next section. Under this assumption then all that is required is to count the number of objects appearing, according to the 2D unbiased counting frame rule, in a section of known thickness and this will be the disector count Q−. With this method it is not even necessary to examine the next section because under the model assumption no transects seen in the ‘reference’ section will be observed in the ‘look-up’ section ( Figure 5.20 ).

Attractive though the single section disector is, the reader should be aware that such an approach is not unbiased. The degree of bias in the estimate will depend principally on the actual size of the objects being counted with respect to the section thickness. Møller et al. (1990) have used this approach in counting nucleoli. Sectioning can give rise to split nucleoli but the size of the bias in that study was


Page 90

Figure 5.19

An illustration of the optical fractionator. An object is cut exhaustively into sections, of thickness T units, and a known fraction of the sections taken. In this example one-fifth has been taken, the first section sampled was chosen randomly between 1 and 5 (in this case section 4) and then every 50 sections subsequently. For each section that has been sampled a 2D raster of the microscope stage is used, with known step lengths ∆x and ∆y in the x and y directions respectively, starting from a random position outside the object transect. At each of the points in the raster a sampling frame of known area, a/f, is scanned down into the section to form an optical disector of depth h. To determine the fraction of the physical slice of the object sampled it is necessary to know the product of the area sampling and height sampling fractions. The overall fraction of the object sampled is ssf×asf×hsf.

estimated to be 2–3%. Whether or not such a bias is acceptable or not will depend on many factors including the variance of the estimate, the size of the sample, the magnitude of the difference between experimental groups, confidence required in the detection of a difference, and so on.

The single section disector is most likely to be of use in protocolized industrial toxicological testing, where large sample numbers have to be measured on a regular basis. However, before such assays would become acceptable they should be carefully validated against unbiased measurements with the Cavalieri/disector or fractionator approaches.

The double disector

Objects beyond the resolving power of the light microscope may nevertheless be counted in the electron microscope. A major problem in quantitative electron


Page 91

Figure 5.20

An illustration of how the ‘single section’ disector can be used for objects that are smaller than the typical section thickness. In this sampling scheme the number of sections hitting an object is proportional to the size of the object. The nucleolus is small enough to be included completely in a single section.

microscopy is that it is difficult to determine the thickness of the ultrathin sections. For stereological Nv estimation with the disector it is only necessary to know the mean section thickness.

Gundersen (1986) has described an ingenious gambit for unbiasedly estimating the ratio of ‘small things’ to ‘big things’ without needing to know the section thickness. This is called the double disector. A ribbon of ultrathin sections of known number is collected. The first and last sections from the ribbon are used as a ‘large physical disector’ to estimate the numerical density of large objects at low magnification, for example nerve cell nuclei. Adjacent sections can then be used as ‘small physical disectors’ to estimate the Nv of small objects at high magnification, for example synapses. It can be shown that the section thickness cancels out and does not need to be known (Gundersen, 1986). This approach has been demonstrated by Marcussen (1992); it is illustrated in Figure 5.21.

The ‘molecular’ or ‘golden’ disector

The biochemist John Lucocq (1992) has proposed and implemented an intriguing combination of the ‘double disector’ and the ‘single section disector’ to gain estimates of the average number of molecules per cell in biological sections.

Using immuno-colloidal gold labelling in transmission electron microscopy it is possible to label molecules and examine their location. Lucoq has pointed out, as described above, that the double disector can be used to estimate cell density from the outer sections of the ribbon. However, molecule density can also be estimated from single sections using the assumption that if a molecule appears on one section it most certainly won’t appear on the next.

There are many problems associated with the reliability of immuno-cytochemistry, the one of steric hindrance being a possible major confounder. The method implicitly depends on every molecule present being stained and there being no false-negative staining events for its unbiasedness. However, these problems exist for qualitative studies using this technique as well. The approach is very elegant and it may well become more widely used in receptor expression and binding studies.


Page 92

Figure 5.21

An illustration of the ‘double disector’. For electron microscopy a ribbon of ultrathin sections is generated by the microtome and floated on to a water bath. If the first and last are collected and used for a large disector and the number of sections comprising the ribbon (k) is known then the height of the large disector is k multiplied by the average section thickness t. This disector can be used to estimate the numerical density of large objects. The single sections, of thickness t, can be used to estimate the numerical density of small objects. Because both the large and small disectors have a height that is a multiple of t units the ratio of numerical density of small objects to large objects can be estimated with knowing t. (See Marcussen (1992) for an application.)

Counting closed space curves—Terminal bronchial ducts in lung

Not all three-dimensional features of interest can be thought of as particles. For example, the sharp discontinuity in epithelial type between the terminal duct and the alveolar airspace in mammalian lung describes a closed space curve. If viewed ideally in three dimensions these space curves would be relatively easy to count. However, when seen on histological sections they are seen as curves composed of separated sections of cubical and squamous epithelium. A counting rule, based on the physical disector principle has been developed which can correctly count these 3D space curves from pairs of serial sections a known distance apart (Beech et al., 2000).


Page 93

Counting complex shaped objects in 3D and connectivity estimation

For systems that consist of highly connected continuous phases the classical stereological parameters such as porosity (Vv) and surface density (Sv) only provide partial information. A more complete characterization can be obtained by combining estimates of these quantities with an estimate of the connectivity of the continuous phase. In sandstone and limestone it has been shown that the connectivity of the pore space is an important factor in the hydrocarbon recovery process (see Zhao and MacDonald, 1993 and references therein).

In 3D the connectivity of a group of objects is equal to the number of discrete objects and enclosed cavities minus the number of ‘handles’. Connectivity is an extension of the concept of number and as such is zero-dimensional quantity. The estimation of connectivity therefore requires a 3D probe. On pairs of closely spaced parallel planes (i.e. disectors) the ‘Conneulor’ method developed by Gundersen et al. (1993) provides a suitable 3D probe. The Conneulor has been applied to cancellous bone (Youngs et al., 1994). For a tutorial article on connectivity and a worked application of the Conneulor in materials science see Roberts et al. (1997b).


Page 94

Exercise 5.1

AIM

The aim of the exercise is to estimate the number of 2D ‘particles’ per unit area (NA) from the images shown in Figure 5.22a –d.

PROCEDURE

1. Calculate the linear magnification of the images.

2. Calculate the area associated with each frame (a/f).

3. For each image record the number of 2D particles correctly sampled by the unbiased counting frames.

Figure 5.22

See text for details.


Page 95

RESULTS

Magnification, M | =______
Area associated with each frame (a/f) | = ______μm2
Image | 2D particles sampled
a |
b |
c |
d |
Sum | ∑Q=

Estimate of number per unit area:


Page 96

Exercise 5.2

AIM

The aim of the exercise is to estimate the numerical density (Nv) of 3D particles using the disectors shown in Figure 5.23a –c.

Figure 5.23

See text for details.


Page 97

PROCEDURE

1. Calculate the linear magnification of the images.

2. Calculate the area associated with each frame (a/f).

3. For each image record the number of frame-associated points hitting the reference space (P).

4. For each image record the number of profiles correctly sampled by any part of any sampling frame on the reference section that is not seen in the look-up section (Q−).

5. Using the distance between sections, h, of 35 μm calculate the numerical density of the particles.

RESULTS

Magnification, M | =______
Area associated with each frame (a/f) | =______μm2
Image | Frame-associated points | Particles counted
a |  |
b |  |
c |  |
Sum | ∑P= | ∑Q−=

Estimate of number per unit volume:

The volume of the object from which the disectors were sampled was estimated to be 8.1 mm3. Estimate the total number of particles within the object.


Page 98

Exercise 5.3

AIM

The aim of the exercise is to calculate the final sampling fraction used in an optical fractionator experiment.

BACKGROUND

An object was embedded in resin and exhaustively sectioned into 25-μm-thick sections. Every seventh section was sampled beginning with a random start. Each of the sampled sections was mounted and stained for optical microscopy. An electronic stepping stage was used to move in x steps of 400 μm and y steps of 550 μm. At the center of each field of view a square grid of side length 65 μm was used as an optical disector of depth 12 μm. The total number of cells sampled by all optical disectors that hit the object transects was counted to give ∑Q−.

PROCEDURE

1. Calculate the slice sampling fraction (ssf).

2. Calculate the area associated with each frame (a/f).

3. Calculate the area sampling fraction (asf).

4. Calculate the height sampling fraction (hsf).

5. If ∑Q− was found to be 345 estimate the total number of cells contained within the object.


Page 99

Exercise 5.4

AIM

The aim of the exercise is to estimate the numerical density (Nv) of neocortical neurones using the three optical disectors shown in Figure 5.24a –c.

BACKGROUND

The brain tissue had been stored in 0.1 M sodium phosphate-buffered formaldehyde (pH 7.2, 4% formaldehyde) for at least 6 months with the fixative being changed every 2 months. The right hemisphere was removed, embedded in 6% agar and cut into thick slices for volume estimation using the Cavalieri method (Chapter 3). Vertical sections of the neocortical gray matter were prepared using the sampling scheme described in Braendgaard et al. (1990). The agar-embedded tissue was dehydrated and embedded in glycol methacrylate Historesin®. From the resin-embedded tissue 25-μm sections were cut, mounted and stained with a Giemsa stain. The tissue was imaged using a ×100 1.4 NA oil-immersion lens with matched condenser. The full width of the images shown in Figure 5.24a –c is 75 μm. A random start within the thick sections was taken as the top of the optical disector and the microcator zeroed. In each case the optical disector was set to be 15 μm. The figures show all of the neurones that have their nuclear profile in clearest focus within the optical disector height. In each case the first image shown is at height 0 μm. (Images courtesy of Dr T Ansari.)


Page 100

Figure 5.24(a)

See text for details.


Page 101

Figure 5.24(b,c)

See text for details.


Page 102

PROCEDURE

1. Calculate the linear magnification of the images.

2. Calculate the area associated with each frame (a/f).

3. Calculate the volume of each optical disector.

4. For each optical disector examine each optical section and count the number of neurones sampled using the optical disector rule (Q−).

RESULTS

Magnification, M | =______
Area associated with each frame (a/f) | =______μm2
Volume of each optical disector (a/f·h) | =______μm3
Image | Particles counted
a |
b |
c |
Sum | ∑Q−=

Estimate of number per unit volume:

The volume of the neocortex was estimated to be 257 cm3. Estimate the total number of neurones within the neocortex.


Page 103

6
Estimation of total surface area and surface density

Contents

6.1 Estimation of surface density | 104
6.2 Random directions and orientations in 3D space | 105
6.3 Generating isotropic line probes—1 Vertical sections | 108
6.4 Generating isotropic line probes—2 Isotropic sections | 110
6.5 Estimation procedure | 110
6.6 Examples of vertical sectioning protocols | 111
Exercise 6.1 | 113
Exercise 6.2 | 117

This chapter describes how the surface area or surface density of a set of features can be estimated. Unlike either volume or number estimation the methods require sections that have some degree of randomness in their 3D orientation.

The surface area of an object or set of features is often a valuable indicator of the capacity of a surface-limited process to function. For example, the efficiency of gas exchange in the mammalian lung is dictated to a large extent by the total amount of gas exchange surface. With materials science systems, where total quantities are often less important, surface density is a parameter widely used; for example, to characterize a catalytic system, or to quantify the pore geometry in an oil-bearing sandstone (Scheidegger, 1974).

The surface density of a set of interfaces is the surface area of interface per unit volume of the reference space, that is

(6.1)

The dimensions of surface density are L2/L3, which simplifies to L−1. It should be noted that the reference volume may be the whole of the object of interest or a well-defined sub-section of it. For example in lung studies the reference volume could refer to the whole lung or to the volume of the alveolar air spaces only.

In common with both volume and numerical densities, an estimate of total surface can be derived from the surface density multiplied by the volume of the reference space, for instance

(6.2)

Where [image] refers to the total surface area of the interface of interest.


Page 104

6.1 Estimation of surface density

Estimation of surface requires a series of linear test probes (see Table 1.2). Basically the higher the surface area per unit volume of the feature of interest, the larger the number of intersections between the surface and the set of linear test probes. The relationship between the number of intersections and the surface area per unit volume is given by the equation

(6.3)

which means that surface density is equal to twice the number of intersections between the surface and the linear probe, per unit length of test line in the reference space (Saltykov, 1946; Smith and Guttman, 1953). This equation is an unbiased estimator of surface density only if either the surface is isotropic, the lines are isotropic or both are isotropic. In this context the lines must be isotropic in 3D space. You will recall that in Chapter 2 the concept of isotropy in 2D space was introduced.

The fact that the number of intersections between a linear probe and a feature is proportional to the surface area of the feature has been introduced in Chapter 1 in the thought experiment concerning a room. Consider dropping a blob of putty on to a ‘Fakir’s bed’ of thin nails. The number of holes that are punched through the putty is proportional to the surface area of the putty rather than its volume. For example, if the putty is made into a round ball it may produce, say, four intersections. If the ball of putty is flattened out and then dropped, the number of intersections might be much higher. When the putty is flattened the main thing that has changed is that its surface area has been increased (note that although the surface area has been increased by rolling it out, the volume of putty hasn’t changed).

The nails on the Fakir’s bed all point in the same direction. We say they are perfectly anisotropic. Note that the number of intersections isn’t only dependent upon the surface area of the putty but also on its orientation with respect to the bed of nails. When the putty is a spherical ball then its surface is isotropic and in this case the anisotropy of the bed of nails is unimportant (a ball looks the same from all directions). However, the flattened piece of putty is itself anisotropic. Thus if it is dropped on to the bed of nails with its flattened surface perpendicular to the nails ( Figure 6.1a ) the number of intersections will be considerably higher than if it was parallel to the bed of nails ( Figure 6.1b ). A better estimate of surface would be obtained by taking an average of the number of intersections between the Fakir’s bed and the putty surface, over all possible orientations.

If we do not know that the object has an isotropic surface then we must make the line probes themselves isotropic in 3D for unbiased estimation. In practical microscopy we rarely know the shape of the features that we are measuring. By using isotropic linear probes knowledge of feature shape is not required. The next few sections describe how to generate lines on 2D sections that are isotropic lines in 3D.

First, review the problem introduced in Chapter 2 of generating an isotropic direction in 2D space. One easy way of doing this is to get an empty wine bottle and give it a good spin on a table top. The final direction that the neck of the bottle points in is a random direction in 2D space, which is known as an isotropic direction. The mathematical equivalent of the bottle approach would be to choose a uniform random number between 0 and 360°. In summary, a single random angle can specify any isotropic direction in 2D space.


Page 105

Figure 6.1

A flattened lump of putty is dropped at different orientations with respect to the direction of the nails on a ‘Fakir’s bed’. In (a) the putty is hit by eight nails when dropped with its flattened side normal to the nails. In (b) one hit is recorded when the flattened surface is dropped parallel to the nails.

6.2 Random directions and orientations in 3D space

The basic requirement for surface estimation is that line probes on microscopical sections have an isotropic orientation in 3D space. In practise, as you will soon see, this is very easily achieved. However, some people find the concepts that we are going to describe in the next few pages quite difficult to understand at first acquaintance. We recommend that you persevere and, if necessary, read this section a few times. However, the sampling protocols described in Section 6.6 are extremely straightforward.

In 3D a direction can be defined by drawing an arrow or vector from the center of a sphere out to a point on its surface. One way to consider this is to imagine that your right shoulder is at the center of the sphere and that you can point to any element of the sphere’s surface with your arm held straight ( Figure 6.2a ).

Now restrict the movement of your right arm so that it can on ly move up and down in the plane through your shoulders and feet ( Figure 6.2b ). With this restriction in place, then, in order to be able to point at any element of the sphere’s surface you now, in addition, need to rotate your whole body ( Figure 6.2c ). By adopting this approach the problem of pointing to any element of the sphere’s surface has been decomposed into two simpler steps: (a) rotating your body and (b) pointing your arm up or down. In practise step (a) corresponds to how you orient your block in the microtome and (b) corresponds to how the lines of your grid are oriented on your micrographs. Henceforth the angle your arm makes with the vertical will be known as the co-latitude (θ) and the angle of rotation of your body will be known as longitude ( [image]) ( Figure 6.2d ).

To generate an isotropic direction in 3D you therefore require two random angles. Using the co-latitude and longitude just introduced we want to generate an isotropic series of directions, that is, they should pepper the surface of the sphere with equal intensity ( Figure 6.3a ). In practise this is accomplished by choosing the longitude ( [image]) with uniform random probability in the interval 0–360° (using either a spinning bottle or a random number generator). Next a co-latitude (θ) must be chosen in the range 0–180°.

At first we might expect that the co-latitude, like the longitude, should be chosen with uniform random probability. However, this is not the case. If the co-latitude is chosen with uniform probability the sphere is eventually covered with a higher density of points near the North and South poles than at the equator ( Figure 6.3b ). This


Page 106

Figure 6.2

(a) The right shoulder is fixed in space but the right arm with elbow extended has freedom to point anywhere in front, behind, above and below (clearly some directions in this situation are impossible because the body is in the way!). To illustrate this choose some features around you (on your right hand side) to point at, keeping your feet firmly fixed and allowing no rotation of the trunk of your body. (b) Now anchor your right foot to a position on the floor and allow your right arm to swing up and down only in the plane through your shoulders and feet, that is, you must not point in front of or behind the plane. (c) If you try to point at the same objects as before you will now need to rotate on your right foot to gain the correct longitude ( [image]) and then swing your arm to the correct co-latitude (θ) for any particular direction. Do it! (d) A formalization of (c). To generate an isotropic direction, u, in 3D space fix the center of a sphere to the origin of an arbitrarily oriented Cartesian coordinate system, x,y,z. Generate a random angle ( [image]), between 0 and 360°, with respect to the positive x axis in the x–y plane. Now generate a sine-weighted angle (θ), between 0 and 180°, with respect to the positive z axis.

distribution of directions is definitely not isotropic. The distribution of directions is anisotropic with the North and South poles being the preferred directions. The reason that a uniform longitude and uniform co-latitude can give rise to a non-uniform distribution of directions is quite subtle and is a quirk of the coordinate system. Consider Figure 6.4 which shows a sphere, with a 10° segment of longitude (∆ [image]). It is immediately obvious that this segment is wider at the equator than at the North or South poles (imagine a segment cut from an orange). Now consider a co-latitude near the equator, say 80°, and let it vary by plus or minus 3° (∆θ). The area swept out here will be larger than the area swept out by a similar perturbation at a smaller co-latitude of, say, 5°. In fact the respective areas swept out by ∆θ are proportional to the sine of the co-latitude θ. Thus if values of θ are uniformly selected, a higher density of directions will be generated near the North and South poles. However, if a co-latitude is selected that is proportional to sine θ then the resulting distribution of directions will be uniform, so that an isotropic distribution will be obtained ( Figure 6.3a ). If a line is extended out from a sphere’s center in two diametrically opposite directions it is referred to as an orientation.


Page 107

Figure 6.3

Spots punched Into the surface of a sphere by random directions generated from its center. In (a) the distribution of spots is uniform in density over the whole of the sphere’s surface. This is an ‘isotropic’ distribution, generated using uniform values of longitude and sine-weighted values of co-latitude. In (b) the distribution of spots has a higher density at the North and South poles. This anisotropic distribution was generated using uniform values of both longitude and co-latitude.

Figure 6.4

Two specimen random directions, A and B, are allowed to ‘wander’ through ±5° of longitude (∆ [image]) and ±3° of co-latitude (∆θ). The areas swept out by these wanderings are shown in gray. The area swept out by the wandering of A, at small θ, is smaller than that swept out by B. If three random directions had been generated within each of these shaded areas, there would be a higher density of directions (i.e. number per unit area) within A. This effect is removed by weighting θ by its sine.

An isotropic line probe is a line that has been generated with isotropic orientation in 3D space. In practise there are two ways of generating isotropic line probes: (i) on vertical uniform random (VUR) sections and (ii) on isotropic uniform random (IUR) sections. Historically, IUR sectioning pre-dates VUR sectioning. However, in practise VUR sectioning is, in the vast majority of cases, the method of choice for design-based


Page 108

studies. One particularly attractive aspect of vertical sectioning is that it is often as easy to apply in practise as it is to take sections of arbitrary orientation.

6.3 Generating isotropic line probes—1 Vertical sections

A practical method suitable for generating isotropic lines on vertically sectioned material was first developed by Baddeley et al. (1986).

1. For the object of interest, select an arbitrary horizontal reference plane (e.g. the laboratory bench). This reference plane can be chosen by the scientist and can either coincide with a useful plane within the object or be totally arbitrary. Once a reference plane has been selected for a particular object it is then considered as fixed.

2. Generate an isotropic orientation in the horizontal plane.

3. Section the specimen with uniform random position along this orientation.

This section is a VUR section ( Figure 6.5 ). The key elements of the sectioning protocol are that the orientation around the vertical axis is genuinely isotropic and that the position is random. Clearly this type of sampling protocol is very easy to apply in practice and a selection of practical methods for generating VUR sections is described below.

A VUR section is not an isotropic section in 3D space. Furthermore, lines of arbitrary orientation in a VUR section do not constitute a set of isotropic lines. What is required is a set of lines oriented so that their length density is proportional to sine θ.

Figure 6.5

An illustration of a VUR sectioning protocol through an arbitrary object. The object is placed on an arbitrary, but fixed, horizontal plane. In the term ‘vertical uniform random’ the vertical (V) refers to orientation, in that the section must be perpendicular to the horizontal plane and therefore contain the known vertical axis. The uniform random (UR) refers to the position of the section, which should be uniform random with respect to the object. The object is given an isotropic rotation on the horizontal plane (a). A series of planes a fixed distance apart, T, and with UR position are shown intersecting the object (dotted lines in b). The collection of planes is VUR with respect to the object. In (c) a ‘cake’ is shown. If all sections from the cake passed through the center they would not qualify as VUR sections. Although the sections have the correct randomness of orientation they are not UR in position.


Page 109

When a cycloid is aligned so that its minor axis is parallel with the vertical direction it has a direction distribution proportional to sine θ (Baddeley et al., 1986; Hilliard, 1967). A cycloid can be generated by following one point on the circumference of a circle as that circle is rolled along a line ( Figure 6.6 ). In practise a cycloid grid has a series of associated points, such that there is a known length of line per point. The combination of a plane generated with a VUR protocol as above and a grid of cycloids oriented in this manner is equivalent to a collection of IUR lines in 3D space.

When using VUR sections it is important to know explicitly the direction of the vertical axis when the section is finally prepared and mounted on the microscope slide. In practise a rotating stage or slide holder can be purchased or made for the microscope in order that the slide can be oriented correctly (Appendix A).

Figure 6.6

(a) A cycloid is a curve described by the locus of a point on the periphery of a disc rolling along a straight edge. The length of line present in a particular segment of cycloid is proportional to the sine of its angle with respect to the normal to the straight edge. (b) If a cycloid arc is bounded in a rectangle, the short and long sides of the rectangle describe the minor and major axes of the cycloid respectively. The length of the cycloid is equal to twice the length of the minor axis. (c) In practical estimation of surface density from vertical uniform random sections, cycloid arcs are arranged with their minor axes parallel to the defined vertical direction. Points are associated with the cycloids to allow for estimation of the total length of cycloid used.


Page 110

6.4 Generating isotropic line probes—2 Isotropic sections

An isotropic section is simply a plane that is perpendicular to an isotropic orientation. If an isotropic plane also has uniform random position with respect to the object it is known as an isotropic uniform random (IUR) plane (Miles and Davy, 1976; Weibel, 1980). To generate an isotropic line on an IUR section the line should be given an isotropic rotation in the section.

In practise for specimens where there is no obvious axis of anisotropy (e.g. liver), approximately IUR sections may be obtained by cutting the block of material and informally ‘randomizing’ the orientation before further embedding and sectioning. However, if the material has, or is suspected to have, an appreciable degree of anisotropy, a more formal method is required. The orientator developed by Mattfeldt et al. (1990) is a formal sampling protocol that guarantees IUR sectioning even in anisotropic material. This method is described in Chapter 7. For small objects that can be embedded totally in resin the isector (Nyengaard and Gundersen, 1993) is an ingenious practical method for generating IUR sections.

6.5 Estimation procedure

To illustrate the estimation of surface density from VUR sections, consider the vertical section shown in Figure 6.7. A cycloidal test system, with its minor axis parallel to the vertical direction, has been randomly translated in the x and y direction on the image. The test system has a known length of cycloid per point (l/p). In order to estimate surface density, two counts need to be made on this image

1. the number of intersections between the cycloid lines and the boundary of interest (I),

2. the number of points that land within the reference space (P).

Figure 6.7

A vertical section is shown with a cycloidal test grid superposed. The minor axes of the cycloids are parallel to the known vertical direction and the grid has been uniform randomly translated in both x and y. In this case six points land within the reference space (both light and dark gray phases). Each point is associated with two cycloid arcs. In this example the top edge of the cycloids has been used to represent the ‘true’ cycloid arc. Each time this top edge passes through the boundary of interest, in this case the interface between dark and light gray, an intersection is counted. There are four intersections in this example, indicated by arrows.


Page 111

In theory the cycloidal lines should be of zero thickness, in practise therefore a consistent rule must be adopted for defining an intersection. Either the top or bottom edge of the cycloid line is taken to represent the linear probe. In the example shown in Figure 6.7 we have chosen the top edge. If the chosen edge crosses the boundary of interest an intersection is counted. For the points the counting rule used for volume fraction estimation is used.

If a number of micrographs are used for surface density estimation a separate count is made of the number of intersections (Ii) and points hitting the reference space (Pi) on each image. Surface density is then estimated from

(6.4)

where l/p is the length of test line per grid point at the level of the tissue (i.e. corrected for linear magnification). Exercise 6.1 illustrates this procedure for VUR sections and Exercise 6.2 for IUR sections.

6.6 Examples of vertical sectioning protocols

The vertical sectioning approach was originally developed for estimating surface but has become a more widely used method (see Chapter 11). The method is quite generic and can be applied for both light and electron microscopical studies. In this section several examples are given to illustrate how a series of correctly sampled VUR sections can be generated.

In the case of a layered structure such as epithelium, cortex or a layered composite the obvious vertical direction to choose is perpendicular to the layering (see Chapter 8). Suppose that a specimen has been obtained and that VUR sections need to be generated. The specimen is laid flat on the laboratory bench and a perspex template consisting of a series of holes drilled in a regular square lattice is randomized in both x and y directions over the specimen (Appendix A). For each hole that falls on the tissue, either completely or incompletely, a core of tissue is cut out using a trocar. Each of the tissue cores is then processed, rotated about the vertical axis, embedded and microtomed. A uniform random section taken from the core will represent a properly sampled VUR section ( Figure 6.8 ). An application of this method for generating ultrathin sections of retinal tissue has been described by Anderson et al. (1995).

If the system of interest is of tubular form then a vertical sectioning protocol requires that the tube is first cut and opened into a flat piece of tissue. This flat tissue is then treated as if it were a simple epithelium as above (Baddeley et al., 1986).

For a large solid organ, such as the lung, one very efficient way of generating vertical sections is via slabs. The organ is cut into a small number of thick slabs, say 10–20, with a random start. These are laid face up and the cross-sectional areas are estimated to give a Cavalieri estimate of the organ volume (Chapter 3). For each of the slabs a small number of cores is then generated using the template and punch approach described for epithelium. Note that in this approach the vertical direction is a global one, that is, it is the same for all slabs.

In some circumstances the vertical direction should be chosen to coincide with a biologically important direction. In the case of the neocortex of the brain the biologically interesting direction is perpendicular to the surface of the pia mater. However, clearly the perpendicular to the pia is locally defined and cannot be generated in a global way. In this situation a series of ‘local’ vertical directions is required. A vertical sectioning sampling protocol for neocortex is described by Braendgaard et al. (1990).


Page 112

Figure 6.8

An illustration of a generic sampling scheme suitable for layered slabs of material. (a) A Perspex template and trocar (see Appendix A) have been used to generate a series of systematic random cores of material from the slab. The central axis of each cylindrical core is the vertical axis. (b) Each core is randomly rotated, embedded and then sectioned. A section taken from the embedded core with uniform random position constitutes a VUR section.


Page 113

Exercise 6.1

AIM

The aim of the exercise is to estimate the surface density of gas exchange surface per unit volume of lung.

BACKGROUND

In this exercise vertical sections of piglet lung were generated from slabs of lung tissue using the sampling protocol described in Figure 6.8. The cylindrical cores were split into two half cylinders and embedded in Historesin® (Leica, UK). Light microscopy sections of the tissue 1 μm thick were prepared by microtome. These sections were then mounted on microscope slides and stained with 1 % toluidine blue solution. The vertical sections were observed with an Olympus BH-2 microscope using a ×10 magnification 0.30 NA objective. The images were captured using a Sony XC-77E black-and-white charge-coupled device (CCD) camera. Four images from one animal are shown as Figure 6.9a –d. In each micrograph the vertical direction is indicated and the full width of the micrograph is 804 μm. (Images courtesy of Dr Darren Beech.)


Page 114

Figure 6.9

See text for details.


Page 115


Page 116

PROCEDURE

1. Calculate the linear magnification of the images.

2. Copy cycloid grid C2 (see Appendix B).

3. Calculate the length of cycloid associated with each point (l/p).

4. For each image in turn throw the cycloid grid on with uniform random translation in x and y whilst keeping the vertical direction indicated on the grid parallel with the vertical direction indicated on the micrographs.

5. Record the number of points hitting the reference space (Pi) and the number of intersections between the top (or bottom) of the cycloids and the gas exchange surface (li).

RESULTS

Magnification, M | =______
Length associated with each point (l/p) | =______μm
Image | Points in reference space | Intersection between cycloid and gas exchange surface
a |
b
c
d
Sum | ∑P= | ∑l=

Estimate of surface area of gas exchange surface (g.e.s.) per unit volume of lung:

The volume of the lung was estimated to be 10750 mm3. Estimate the total surface area of gas exchange tissue in the lung.


Page 117

Exercise 6.2

AIM

The aim of the exercise is to estimate the surface density of nerve cell bodies in Wistar rat spinal cord.

BACKGROUND

Several isotropic uniform random sections have been taken from the cervical spinal cord of a Wistar rat. The volume of the spinal column was estimated to be 49 mm3. Sections of thickness 1 μm where prepared for light microscopy and stained with toluidine blue. Six images are shown in Figure 4.2a –f. A scale bar and key to the images are also shown.

PROCEDURE

1. Calculate the linear magnification of the images.

2. Copy line grid L1 (see Appendix B).

3. Calculate the length of test line associated with each point (l/p).

4. For each image in turn throw the line grid on with uniform random translation in x and y, and an isotropic rotation.

5. Record the number of points hitting the reference space (Pi) and number of intersections between the top (or bottom) of the test lines and the nerve cell bodies (li).

RESULTS

Magnification, M | =______
Length associated with each point (l/p) | =______μm
Image | Points in reference space | Intersection between test lines and nerve cell surface
a |
b
c
d
e
f
Sum | ∑P= | ∑l=

Estimate of surface area of nerve cell body (n.c.b.) per unit volume of spinal cord (s.c.):

Using the value of total spinal cord volume given estimate the total surface area of nerve cell body in the spinal cord.


Page 118

This page intentionally left blank.


Page 119

7
Length estimation

Contents

7.1 Generation of IUR sections—the orientator and isector | 122
Exercise 7.1 | 125

This chapter describes the estimation of feature length and length density. Examples of application areas include the length density of glass fiber in a composite material, the average length of neurite per neurone in a region of the brain and the total length of capillary blood vessel in an organ. The estimation of length has fewer obvious uses in biology than say for surface, volume or number. However, at the ultrastructural level revealed by electron microscopy there is a plethora of potentially interesting linear features.

The length density of a feature is its length per unit volume of the reference space:

(7.1)

The dimensions of length density are L1/L3, which simplifies to L−2. The estimation of length density is the inverse or ‘dual’ of the problem of surface density estimation. For surface area (dimension L2), linear probes (dimension L1) are required for unbiased estimation by intersection counting (recall that the dimensions of probe and feature must sum to three). Therefore for feature length (dimension L1) a 2D probe (dimension L2) is required for unbiased estimation by simple counting.

A 2D probe, such as a plane or section, hits objects in proportion to their height normal to the plane. This point was emphasized in Chapter 5, Figure 5.1 , where it can be seen that the taller a particle is, normal to a plane, the greater the chance it has of being hit. When a linear feature is continuous, such as a tubule, the probability that the feature will be hit by a plane can be used to estimate length density.

Consider Figure 7.1 which shows a simple linear feature ( Figure 7.1a ) and a more convoluted linear feature ( Figure 7.1b ) intersected by a plane. While the simple feature intersects the plane only once, the convoluted feature does so several times. It is intuitively clear that the number of intersections of the linear feature per unit area of the probe is in some way related to the length of feature packed into a unit volume of the reference space. However, in common with surface estimation, the orientation of the feature with respect to the probe can cause problems. In Figure 7.2 a series of parallel rods are intersected by planes of differing orientation. Note that the number of intersections per unit area of the plane is related to the plane orientation. In order to ensure that the number of intersections per unit area is an unbiased estimator of length density, sections that are isotropic with respect to the linear features should be used. In practical microscopy we often have no idea of the orientation distribution of the linear features. We therefore require the planar probes themselves be isotropic. This means that IUR sections must be used for estimating length density in thin sections. It should be noted that thin vertical sections cannot be used for estimating length density.

On IUR thin sections, length density is estimated from

(7.2)


Page 120

Figure 7.1

(a) A random plane intersects a fairly straight linear feature once. (b) A convoluted linear feature is intersected by a random plane three times. Therefore the number of intersections per unit area on plane (b) is higher than on plane (a), which is related in turn to the length of linear feature within a unit volume of 3D space.

Figure 7.2

A series of rods possessing perfect anisotropy intersects a series of planes which are respectively (a) normal, (b) oblique and (c) parallel to the axis of anisotropy. The resulting density of intersections per unit area of plane is seen to be highly dependent upon the orientation of the plane with respect to the rods. This is directly analogous to the discussion of the ‘Fakir’s bed’ of nails in Figure 6.1.

where QA is the number of profiles per unit area of test probe (Saltykov, 1946; Smith and Guttman, 1953). The estimation of length density therefore reduces to the problem of making an unbiased estimate of the number of profiles per unit area. In this context each profile is the intersection of the IUR plane and the linear feature. The counting rule required to estimate QA, and thereby LV, has already been encountered in Chapter 5 and is the unbiased counting rule due to Gundersen (1977). The application of this counting rule for length density requires only single sections and shouldn’t be confused with the physical disector which requires two sections.

To estimate the length density of a feature a number of unbiased counting frames, each with an associated point, is applied with uniform random position to IUR sections.


Page 121

Figure 7.3

An illustration of the counting frame used for estimating profiles per unit area, QA, and hence length density of the blood vessel in rat spinal cord tissue. Each of the frames has an area of 651 μm2 at the level of the tissue. There are three blood vessel profiles correctly sampled by the four frames. An estimate of length density, LV, is given by

The number of frame-associated points (P) hitting the reference space and the number of profiles sampled by the frame (Q) are counted. The length density of the feature is then estimated from

(7.3)

where a/f is the area of a frame at the final magnification used.

An estimate of total feature length can be obtained by multiplying the length density by the volume of the reference space, for example

(7.4)

where [image] refers to the total length of feature.

A simple example of the counting rule used for length density estimation is shown in Figure 7.3. An IUR section of rat cervical spinal cord is shown with a systematic grid of four unbiased sampling frames. The area associated with each frame (a/f) is 651 μm2 at the final magnification of the image. The length density of blood vessel is given by

(7.5)


Page 122

7.1 Generation of IUR sections—the orientator and isector

The orientator is an elegant design-based method for generating IUR sections in practice (Mattfeldt et al., 1990). This method has the same mathematical underpinning as that used for generating IUR linear probes on vertical sections (Chapter 6 and Baddeley et al., 1986). The practical application of the orientator, for generating an IUR section through a carrot, is shown in Figure 7.4. The orientator, as described by Mattfeldt et al. (1990), is a three-stage process.

1. A uniform random slab of the object is removed and a vertical direction defined for that slab. This direction must be identifiable and is fixed for the remainder of the sectioning process. In the example shown in Figure 7.4a the vertical direction has been marked on the side of the carrot and is parallel to its long axis.

Figure 7.4

An unsuspecting carrot is used to illustrate the workings of a systematic sampling version of Mattfeldts orientator.

(a) A series of uniform random slabs of the object are generated using a systematic sampling design. Each of the slabs is removed and a vertical direction defined for that slab. This direction must be identifiable and is fixed for the remainder of the sectioning process. In the example the vertical direction has been marked on the side of the carrot slabs and is parallel to its long axis.

(b) Each of the slabs in turn is placed with arbitrary position and rotation with respect to a uniformly divided ф-clock with the original vertical axis of the slab normal to the plane of the clock. A uniform random number between 0 and 9 is generated using a random number table (e.g. 7 has been selected). A set of systematic cuts perpendicular to the plane of the clock is then generated along the random direction selected (i.e. 7–7). This process will generate a number of ‘slices’ (in this example four).

(c) Each of the slices generated in (b) is placed such that its newly generated flat face is placed with uniform random position, face down with respect to the cosine-weighted θ clock, with the original vertical axis of the piece along the 0–0 line of the clock. Finally a second uniform random number between 0 and 9 is generated using a random number table (e.g. 3). A set of systematic cuts perpendicular to the plane of the clock is then generated along the random direction selected (i.e. 3–3). The final cut faces obtained in this manner are isotropic uniform random plane sections through the original object.


Page 123

2. The slab is placed with uniform random position and arbitrary rotation on a uniformly divided [image] clock with the original vertical axis of the slab normal to the plane of the clock. A uniform random number between 0 and 9 is generated using a random number table. In the example 7 has been selected. The slab is then cut perpendicular to the plane of the clock and along the random direction selected (i.e. 7–7).

3. One of the two pieces of the slab that has been generated by step 2 is chosen at random. The newly generated flat face of this piece is then placed with uniform random position, face down on the cosine-weighted θ clock, with the original vertical axis of the piece along the 0–0 line of the clock. Finally a second uniform random number between 0 and 9 is generated using a random number table. In the example 3 has been selected. The piece is then cut perpendicular to the plane of the clock and along the random direction selected (i.e. 3–3). This final cut face is an isotropic uniform random plane section through the original object.

If the object is small then the ‘isector’ (Nyengaard and Gundersen, 1992) can be applied. In essence the isector is a practical method for generating a spherical mold. The object is placed in the spherical mold and embedded with resin. Once set hard the spherically embedded object is removed from the mold. If this small resin ball is now rolled around on the laboratory bench and then re-embedded in a rectangular mold the whole specimen will end up in an isotropic orientation. Uniform random sections through the rectangular block will now represent IUR sections through the object.

If thick vertical uniform random sections are available, for example methyacrylate embedded tissue, then there is another approach to the unbiased estimation of length density that uses projections through the thick sections.

As stated above feature length can be estimated by counting the number of intersections between the linear feature and isotropic uniform random (IUR) planes in 3D space. In a thick vertical section a ‘virtual’ IUR surface can be generated by projecting a cycloid through the section if the major axis of the cycloid is parallel with the vertical direction (Gokhale, 1990). Consider Figure 7.5a. A vertical uniform random slab of material of known thickness t, which contains some linear features, is viewed in projection onto a cycloidal test system. The intersections (Q) between the virtual cycloidal surface and the linear feature in the 3D slab are seen on the projection as intersections (I) between 2D linear features and the 2D cycloid curve. The cycloid on the projection has length l units and its projection through the slab of t units gives a surface of total area A=l×t units squared.

(7.6)

Note that, unlike surface estimation, when cycloids are used for length estimation in vertical slabs the major axis of the cycloid is parallel to the vertical direction.

In a practical implementation of this method, a test system of known length of cycloid, l, per point p is randomly translated on the projection of the vertical slab ( Figure 7.5b ). The number of intersections between the cycloidal test system and the linear feature is counted (l), and the number of points hitting the reference space is also counted (P). Note that you will need to adopt a consistent rule for defining an intersection between the linear feature and cycloid curve, e.g. an intersection is counted when the left hand edge of the cycloid curve passes through the center line of the linear feature.


Page 124

Figure 7.5 An example of length density estimation from thick VUR sections.

The test system l/p is 125 μm and t is 20 μm.

Length density of the linear feature is estimated from n images using the following equation:

(7.7)

For example, in Figure 7.5b we have a test system that has a length per point (l/p) of 125 microns. We count 19 points hitting the reference space and 29 intersections between the linear feature and the cycloid. The length density is thus estimated from

An excellent example of the application of this method to capillary length is given in Batra et al. (1995).

It should be noted that equation 7.6 is exactly correct for one-dimensional curves in 3D space. However, real linear features are not truly one-dimensional, as they must have a finite volume. This leads to the problem of making an inference about where the one-dimensional axis of the linear feature is, when making intersection counts. If length estimation is of interest then we recommend the paper by Gundersen (2002) where there is a very thorough discussion of this problem.


Page 125

Exercise 7.1

AIM

The aim of the exercise is to estimate the length density of blood vessels in Wistar rat cervical spinal cord. The images for this exercise are shown in Figure 4.2a –f.

PROCEDURE

1. Calculate the linear magnification of the images.

2. Copy frame system F4 (see Appendix B).

3. Calculate the area of frame associated with each point (a/f).

4. For each image in turn throw the frames on with uniform random translation in x and y.

5. Record the number of frame-associated points hitting the reference space (Pi) and number of blood vessel profiles correctly sampled by the frames (Qi).

RESULTS

Magnification, M | =______
Area per frame (a/f) | =______μm2
Image | Points in reference space | Number of blood vessel profiles
a |
b
c
d
e
f
Sum | ∑P= | ∑Q=

Estimate of length of blood vessel per unit volume of spinal cord (s.c.):

If the total spinal cord volume was 49 mm3, estimate the total length of blood vessel in the spinal cord


Page 126

This page intentionally left blank.


Page 127

8
Stereological analysis of layered structures

Contents

8.1 Stereological ratios | 127
8.2 Vertical sections of layered structures | 127
8.3 Practical example | 129
8.4 Application areas | 130
8.5 Worked example of application | 130

In this chapter we describe some options available when it is impossible to define a reference volume (see Chapter 1 to revise the importance of this in biology). An inability to measure the reference volume can come about for several reasons.

1. There is no easily defined reference volume. This situation is commonly encountered in materials science. For example, the specimen may be taken from a continuous batch process.

2. In biological sciences it might be impossible to get the whole animal, plant or organ for the good reason that it is still alive and wishes to remain so. This is usually also the case in clinical pathology. In these circumstances it is commonly possible to get a biopsy.

3. It may be that very scarce and irreplaceable historical material is to be examined.

8.1 Stereological ratios

Any of the standard Stereological ratios described previously can be estimated on suitable samples. However, as we have been at pains to point out in earlier chapters, the ‘reference trap’ is a nasty one to fall into and can lead to entirely spurious conclusions. Furthermore in biological systems Stereological ratios on their own are, at best, rather insensitive detectors of change when compared with total quantities, at worst they can give the wrong answer. In materials science applications, however, where shrinkage is usually not a problem, Stereological ratios are much more commonly of direct use.

8.2 Vertical sections of layered structures

The following possibility offers itself for an interpretable 3D measurement when working with vertical sections from layered structures. To use such an approach, the horizontal reference plane must be defined as being parallel to the orientation of the layers ( Figure 8.1a ). As explained in Chapter 6, any section that is perpendicular to this horizontal reference plane and has a random position and rotation around the vertical axis constitutes a VUR section. In such sections the full height of the layer of interest should be apparent and it can therefore be measured directly from the micrograph.


Page 128

Figure 8.1

An illustration of how to estimate the number of particles that are beneath each unit area of the topmost surface of a layered structure. (a) Two VUR sections through the sample of layered material are shown. The vertical direction is chosen to be normal to the plane of layering. (b) The reference section of a physical disector pair is shown. The transects sampled by the frames but not seen in the look-up section are ticked. If the distance between sections is known the numerical density, NV, of the particles can be estimated. (c) The mean height, [image] of the top layer is estimated directly from the micrograph by measuring the height of several systematic random vertical lines. (d) The number of cells below each unit area of top surface, NA(cells, proj), is estimated by multiplying the numerical density by the mean height. Note that although in the text we refer to a cylindrical core of material, in (d) we show an equivalent rectilinear core.

By using this height information it is possible to get an estimate of ‘how much’ of a feature, such as interface surface area, feature volume or particle number, lies in a ‘core’ of unit cross-sectional area that is perpendicular to the horizontal reference plane. Consider a circle of unit area lying on a plane that is above the layered structure and parallel to the horizontal reference plane. If this circle is projected down through the layered structure it will ‘punch’ out a cylindrical ‘core’ of material. The amount of feature per unit projected area is defined as the amount of feature per unit volume (i.e. NV, LV, SV, VV) within this core, multiplied by the mean height of the layer.

Consider the small portion of a layered structure shown in Figure 8.1a. Two VUR section positions are shown. For each of these positions a pair of sections can be used as a physical disector. Thus the following estimates can be made:

1. the numerical density of cells in the layer of interest, NV(cells, layer), see Figure 8.1b and


Page 129

2. the mean height of the layer, [image] (layer), from several direct measurements on the vertical section ( Figure 8.1c ).

From these quantities the mean number of cells lying beneath a projected unit area, NA(cells, proj), can be estimated from

(8.1)

This approach can also be applied for any Stereological ratio that can be estimated from vertical sections. Therefore, if the surface density, SV(Y, layer) of the interface of interest was estimated with a cycloidal grid then

(8.2)

would be an unbiased estimate of the surface area of the interface of Y per projected unit area. If the surface of interest happens to be the outermost surface of the layered material this method also provides a direct way to quantify surface roughness (Gokhale and Underwood, 1990; Wojnar, 1992).

Similarly the volume density, VV(Y, layer), of the phase of interest can be estimated with a point grid and

(8.3)

would be an unbiased estimate of the volume of phase Y per unit projected area.

As explained in Chapter 7 length density cannot be estimated in thin vertical sections. However, in thick vertical sections the method of Gokhale (1990) could be applied to measure the length density of linear features of interest. Under such circumstances

(8.4)

would be an unbiased estimate of the length of Y per unit projected area.

8.3 Practical example

While it is always preferable in biological systems to know the volume of the reference space there is no doubt that the estimators described above can be useful. However, we would again emphasize that the approach we describe here does not avoid the ‘reference trap’, described in Chapter 1. It is clearly preferable to employ this sort of approach for examining interesting sub-spaces in specimens where the reference volume has been fully measured. In some circumstances these quantities will also have a direct functional significance. For example, Cruz-Orive and Hunziker (1986) have used this approach to estimate the number, volume and surface area of chondrocytes in the epiphyseal growth plate of rabbit tibia. These quantities are of some functional interest because cartilage is avascular and all nutrient supply and waste product removal has to be achieved by diffusion through the surface of the layered growth plate (see also Mashayekhi, 1996).

Another advantage of the approach described above is that it is less susceptible to the effects of tissue shrinkage than a density defined with respect to a unit volume. For example, if each of the linear dimensions of a cubic block of tissue shrink by 5% the overall reduction in volume would be to 85% of the original volume whereas the overall shrinkage of the top surface area would be to 90% of the original area.


Page 130

8.4 Application areas

In the materials sciences several opportunities for this approach present themselves.

1. Soil scientists could gain valuable insights into the microstructural properties underlying a unit area of the soil surface if samples were collected as vertical sections.

2. Petrographers collect rock samples, such as drilling cores, which are perpendicular to the Earth’s crust. These samples form perfect material for vertical section analysis such as that outlined above.

3. Fatigue analysis in metals and ceramics would be a suitable candidate for vertical section analysis. There is now a large emphasis on non-destructive testing (NDT) by the use of ultrasonic and X-ray technologies. If the images from these devices were taken perpendicular to the top surface of the sample then vertical section techniques could be very simply applied.

4. In general the histopathologist receives specimens of epithelial tumors in a form that lends itself to this approach. In addition they always take vertical sections because it is necessary to be able to assess the degree of invasion of the tumor. Other inflammatory and reactive conditions of epithelia such as Crohn’s disease, ulcerative colitis, eczema, psoriasis and lupus tend to be examined by punch biopsy and are also candidates for this approach.

8.5 Worked example of application

The following example is based on Mashayeki (1996). Figure 8.2 shows a sampling design for generating vertical uniform random (VUR) sections through epiphyseal growth plates. For each of these VUR blocks sections were cut that showed the full depth of the growth plate. This region of the growth plate has a vertical gradient structure that can be conveniently divided into two regions, the stem cell and prolifrative (S&P) zone and the hypertrophic (H) zone. Figure 8.3 shows a schematic of a vertical section. The growth plate is shown split into the two zones using a white line. The cellular structures shown in white within these zones are transects of chrondrocytes.

Using the randomly translated vertical line grid shown in Figure 8.3a we can estimate the mean height h of each of the zones (hint: you can make a ruler using the scale bar in the figure).

We estimate the heights of the S&P zone and the H zone to be

We now estimate the volume fractions of the chondrocytes in the two zones using the point grid overlain in Figure 8.3b and applying equation 4.4.


Page 131

Figure 8.2

Figure 8.3

Now using equation 8.3 we can estimate the volume of chondrocyte per unit projected area of the growth plate as follows,

We now estimate the surface density of chondrocyte/matrix interface in the two zones using the cycloid grid overlain in Figure 8.3(c) and applying equation 6.4.


Page 132

Now using equation 8.2 we can estimate the surface of chondrocyte per unit projected area of the growth plate as follows,


Page 133

9
Particle sizing

Contents

9.1 Step 1—selecting particles | 133
9.2 Step 2—measuring the size of the selected particles | 134
9.3 The difference between the number- and volume-weighted distributions of size | 134
9.4 Direct estimators of mean particle volume | 136
9.5 Indirect estimation of mean particle size from stereological ratios | 141
9.6 Distributions of particle volume | 141

Box

9.1

Matrix of stereological methods

142

In this chapter we present some general stereological principles required for making estimates of mean particle ‘size’ for a population of particles. In common with the techniques described throughout the remainder of the book these methods do not rely upon unfounded ‘assumptions’ about particle shape (e.g. that the particles are ellipsoidal, spherical, etc.). Many of the themes already encountered in the preceding chapters, particularly the idea of using geometrical probes, will be called upon here to sample particles.

In general there are two steps required to estimate the mean size of a population of particles.

1. Select a suitable sample of particles from the population.

2. Make measurements on the sampled particles.

These two steps should be independent of each other. Consider each step in turn.

9.1 Step 1—selecting particles

The usual approach to selecting individuals from a population is to give each and every one the same probability of being in the sample (see Chapter 2). This is called uniform random sampling and is widely used, for example in surveys of opinion in human populations. In fact with this type of sampling every individual in the population is given the statistical ‘weight’ of 1 and any individual who is not a member of the population of interest is given ‘weight’ of 0. The ‘weighting’, however, does not always have to be ‘1’ (most of the choices we make in life are certainly not uniform random, choosing a mate for instance!). All sorts of imaginable (but some may not be mentionable!) preferences could be applied in selecting sub-sections of the population. For example, a sample intentionally made up only of females would not qualify as a uniform random sample of the whole population, it would be a ‘female-weighted’ sample.

It is also possible to ‘weight’ the sampling according to ‘how much’ of some particular measurable feature is possessed, the size of bank balance, mass of hair, height, and so on. In the case of selecting someone with a probability proportional to their height


Page 134

we would obtain a ‘height-weighted’ sample. The taller a person, under this ‘height-weighted’ sampling regime, the higher the probability of their being selected. This type of sampling has already been encountered when considering how a uniform random section hits particles in proportion to their height normal to the section (see Figure 5.1).

If we move on from everyday examples to the specific problems associated with sectioning in microscopy the knowledge gained in previous chapters will allow you to make the following observations with respect to sampling particles in 3D.

1. With pairs of planes, using the ‘disector’ rule, particles will be sampled uniformly or in proportion to number—that is, in the number weighted distribution in which each particle is weighted identically independent of its ‘size’.

2. With single planes, particles will be selected in proportion to their height normal to the plane.

3. With isotropic linear probes, particles will be selected in proportion to their surface area.

4. With point probes, particles will be selected in proportion to their volume—that is from the volume-weighted distribution.

9.2 Step 2—measuring the size of the selected particles

Given a set of particles sampled from a population, it is then necessary to measure each of them and complete the task of estimating the size properties of the particle population. Consider a heap of stones sampled from an aggregate. There are some fairly obvious measures of particle ‘size’ that could be made for each stone:

1. its volume (which would be related to the mass of the stone via density);

2. its surface area; or

3. some linear measure like maximum or minimum diameter of the stone.

In each case both the mean particle ‘size’ and the distribution of this size parameter may be of interest. In the following, we only consider particle volume as size of interest.

While the task of measuring the individual sizes of a series of discrete particles is relatively straightforward, it is at this point worth recalling that in microscopy the problem is to get such estimates from sections through particles that are embedded in a matrix. The methods required to carry this out will be outlined in detail below.

In the remainder of this chapter we will only consider particle volume estimates from particles that have been sampled according either to their presence or to their volume, that is the ‘number-weighted’ and ‘volume-weighted’ distributions respectively. Stereological methods for sampling particles in proportion to their surface area are available (see Gittes, 1990 and Karlsson and Cruz-Orive, 1997). We have not addressed ‘height-weighted’ sampling because we know of no obvious application areas and therefore cannot recommend it.

9.3 The difference between the number- and volume-weighted distributions of size

Return to the example of a pile of stones of differing volumes composed of the same rock. From the complete list of individual stone volumes we can construct histograms of particle volume in two related but distinct ways. First, we define a series of ‘bins’ for particle volume. For example, these bins could each be of 5 units cubed (u3) width. Thus the first bin would contain stones of volume greater than or equal to 0 u3 and less than 5 u3, the second bin would contain stones of volume greater than or


Page 135

Figure 9.1

(a) A collection of stones of varying volumes is shown. This set of stones has been sorted into ‘bins’ according to their volume (b). The raw data represented by this binning process are shown in two ways. The histogram in (c) reports the number of particles in each bin and gives the ‘number-weighted’ distribution of volume. In the histogram in (d) the total volume of rock in each bin is reported, leading to the ‘volume-weighted’ distribution of volume. Note that both distributions are obtained from exactly the same set of stones.

equal to 5 u3 and less than 10 u3 and so on. From the complete list of stone volumes we can then sort the stones into relevant bins. This is shown in Figure 9.1a –b.

From this fundamental sorting on the basis of particle volume we can draw two histograms. First, a plot of how many stones are in each bin and second, the total volume of rock contained in each bin. Examples of these two types of histogram are shown in Figure 9.1c and d respectively. Note that both histograms represent exactly the same raw data, but they each focus on different aspects of the stone volume distribution. Figure 9.1c is a histogram in which each stone has equal statistical ‘weight’ regardless of its volume (the number-weighted distribution) and Figure 9.1d is a histogram in which each stone is ‘weighted’ by its volume (the volume-weighted distribution). Everyday examples of these distributions include the distribution of salaries in a population (number weighted) and the ingredients in a foodstuff which are usually listed in proportion to their volume in the final product.

The shapes of the histograms shown in Figure 9.1c and d are clearly different. In particular consider the bin for the size 15–20 u3; in the number-weighted histogram the bar for this bin is one unit high, but for the volume-weighted histogram the bar is 17 units high. Both of these bars represent the same stone! The volume-weighted distribution shown in Figure 9.1d is also commonly known as the ‘sieving’ distribution, that is, it is the distribution obtained using a series of sieves of different grid size. As a further example of the difference between number- and volume-weighted distributions


Page 136

Figure 9.2

A uniform random plane carrying a quadratic lattice of sampling points intersects two particles. A point falls within particle a, which is therefore selected for measurement. None of the points fall within particle b, which is not selected and is therefore not measured. Particle a has been sampled in proportion to its volume.

consider the following, number-weighted, anecdote published by Serra (1982):

‘Recall the story of the butcher who sells lark pie. Lark meat being expensive, he decides to mix it with horse meat, and advertises ‘Excellent mixed pie: 50 per cent lark, 50 per cent horse’. A few days later, a customer says: “It’s curious that your pie does not taste very much of lark”. “Strange indeed, Madam, but I guarantee you the proportion: one horse to one lark”…’

9.4 Direct estimators of mean particle volume

The ‘point-sampled intercept’ (PSI) method

This is an extremely efficient direct method for measuring [image] , the mean volume-weighted particle volume, from single IUR or VUR sections (Gundersen and Jensen, 1985; Jensen and Gundersen, 1989). The PSI method is a two-step procedure, in the same vein as described above.

1. Sample particles in proportion to their volume. This is done by ‘throwing’ points into 3D space and only measuring a particle if it is hit (i.e. sampled) by a point. This is achieved by taking a uniform random plane and throwing on a grid of points. If a point lands within a particle transect seen on the plane the particle has been sampled ( Figure 9.2 ).

2. Estimate the volume of each of the sampled particles. This is acheived by measuring the length of an isotropic line, l0, passing through the sampling point that lies within the particle transect ( Figure 9.3 ). The zero in the subscript of l0 indicates that these intercepts have been sampled with a zero-dimensional probe (a point).

From a series of l0 measurements the mean volume-weighted particle volume can be estimated without bias from

(9.1)


Page 137

Figure 9.3

Particle a from Figure 9.2 now has to be measured. An isotropic line through the sampling point can be generated if the plane section is either IUR or VUR (see Chapter 6). The intercept of such a line with the particle, through the sampling point is shown in heavy relief. Measurement of the length of this line, l0, leads to an unbiased estimate of mean volume-weighted particle volume.

where n is the total number of point-sampled linear intercepts and [image] is the cube of the ith point-sampled intercept length. Note that in this estimator each intercept length is cubed before being averaged.

The generation of isotropic lines requires either an IUR or VUR sampling regime (Chapter 6) and therefore the PSI method can only be carried out on IUR or VUR sections. On ‘vertical’ sections it will not be possible to use cycloid arcs to measure intercept length. In this case we have to weight the orientations of straight lines by the sine of the angle from the vertical. This can be achieved manually using an orientating frame attributed to Gundersen (personal communication, 1984) and illustrated by Howard (1985) and Cruz-Orive and Hunziker (1986). The manual method can be quite time consuming and tedious to apply. However, both the generation of sine-weighted lines and the measurement of l0 intercept lengths can be carried out simply using interactive computer graphics. Figure 9.4 illustrates the PSI method schematically.

For relatively efficient manual methods for applying the PSI method you are referred to the above papers and that of Braendgaard and Gundersen (1986). However, if the PSI method is to be applied regularly we strongly recommend a software solution (Moss et al., 1989).

The ‘selector’

The linear intercept approach at the heart of the PSI method can also be used to estimate the number-weighted mean particle volume, this combination is known as the ‘selector’ (Cruz-Orive, 1987). In a stack of serial physical or optical uniform random


Page 138

Figure 9.4

An Illustration of the PSI method applied to a VUR section. On the section a point grid is used to select particles in proportion to their volume. In this example two particles have been sampled by the point grid. For each sampled particle a line with a sine weighting with respect to the vertical direction is generated, this constitutes an isotropic line in 3D space. The intercept between the isotropic line and the particle transects are shown in heavy relief.

sections, particles are ‘selected’ if their transect is in one section but not the preceding section, that is, by the disector principle (Chapter 5). When the disector principle is used for particle selection the distance between sections does not need to be known. All particle transects thus sampled are then re-sampled with points. If a point lands within a transect then an isotropic line is generated through the sampling point and the intersection with the transect measured, exactly as for the PSI method. All intercept lengths for a particular particle are then used to estimate its volume, as illustrated in Figure 9.5. Because the particles have in this case been sampled with a disector, then the estimate of mean particle volume will be in the number-weighted distribution.

In practise, even in optical sections, this estimator is rather time consuming and was very quickly superseded by the nucleator, which leads to the same estimate. However, for particles without any obvious and invariably present central feature the ‘selector’ could still be valuable.

The ‘nucleator’

Another very efficient estimator of number-weighted mean particle volume, which is a special case of the ‘selector’, is the ‘nucleator’ (Gundersen, 1988). Instead of taking a random point within a particle, as in the method described above, it is possible to take a uniform random point within a uniquely definable sub-space of the particle, for example the nucleolus of a biological cell, the former having itself been selected with uniform random probability using the ‘disector’ principle.

The nucleator is generally implemented in thick slabs using optical sections on biological cells. In these circumstances the optical disector is used as the particle


Page 139

Figure 9.5

Estimating the mean number-weighted volume of a population of particles using the selector. Particles are sampled with identical probabilities using selectors and then the volume of each sampled particle is unbiasedly estimated using the point-sampled intercept method on a few particle transects. Thus an estimate of mean particle volume, [image] , is obtained without knowing the distance between sections. (a) One particle is sampled by an upper disector with reference and look-up planes 2 and 1 respectively. A second particle (on the right-hand side) is sampled by another selector at the bottom of the block (sections 5 and 6). (b) Point-sampled intercepts are measured only on the previously selected particle transects, in order to estimate the corresponding individual particle volumes. The l0 ruler can be used to classify the intercept lengths. Reproduced from Cruz-Orive (1987) with permission from the author and the Royal Microscopical Society.


Page 140

selection method. The optical section is set at a random depth in the slab with an unbiased counting frame superposed. The optical section is then moved downwards in z, an unknown distance. Ignoring any cell whose nucleolus is in maximal focus at the starting plane, any nucleoli coming into maximal focus within the travelling optical section, while also obeying the unbiased counting rule, are judged to be sampled with uniform probability in 3D space.

For each nucleolus thus sampled, an isotropic direction is generated from a random point within the nucleolus. The distances in each direction out from the point to the boundary of either the nucleus (to estimate nuclear volume) and/or the cell wall (to estimate cell volume) are recorded. From a series of these measurements the mean particle volume in the number-weighted distribution is estimated from

(9.2)

where the ln now refers to the distances from the sampling point within the nucleolus to the edge of the particle (not the linear intercept length as in the PSI method). To increase the efficiency of this estimator, distance measurements are usually performed in two or sometimes three systematic random directions from each sampling point. As with the PSI and ‘selector’ methods either IUR or VUR sections must be used. With IUR sections the directions of lines must be isotropic in the plane while with VUR sections they must be sine weighted with respect to the known vertical direction. In practice the task of generating lines of the correct weighting is best handled by interactive software. This procedure is illustrated in Figure 9.6 and on the front cover.

Figure 9.6

An illustration of the nucleator method for estimating mean particle volume on VUR sections. A nucleolus has been sampled with an optical disector of unknown depth. A uniform random point within the profile of the nucleolus is used to generate isotropic rays (i.e. sine weighted in this case). The distances between the sampled point in the nucleolus and the cell wall are measured separately (i.e. the complete linear intercept is not measured). In this figure these distances are indicated in heavy relief.


Page 141

A related method, known as the rotator, can also be used to estimate mean number-weighted particle volume. It is suggested that this method is slightly more efficient than the nucleator (Tandrup et al., 1997; Vedel-Jensen and Gundersen, 1993).

9.5 Indirect estimation of mean particle size from stereological ratios

It is also possible to measure mean particle size indirectly using a combination of stereological ratio estimators. For example, the mean number-weighted volume of particles can be calculated from estimates of Vv and Nv

(9.3)

If this approach is adopted then care must be taken to avoid the effects of over-projection in sections of finite thickness (see Chapter 4). Over-projection can lead to severe overestimates of volume density which in turn would cause an overestimate of mean particle volume. Another ratio-derived estimator of mean particle size is given by

(9.4)

where [image] is an estimate of the mean particle surface in the number-weighted distribution.

9.6 Distributions of particle volume

While estimates of mean particle volume can be achieved relatively efficiently with stereological methods, estimating the complete distribution of particle volume is very labour intensive. Before embarking on the measurement of particle volume distribution it is important to ask yourself very searching questions about how important such information actually is. An example might be population mixtures leading to multi-modal distributions (e.g. Howard et al., 1980).

Indirect estimation of the second moment of the number-weighted particle volume distribution

If estimates of [image] and [image] are made on the same population of particles then Gundersen and Jensen (1985) pointed out that the coefficient of variation of the particle volumes in the number-weighted distribution is given by

(9.5)

where CVN(V) is the coefficient of variation between particle volumes in the number-weighted distribution. This is a measure of the variability in size, which in the case of nuclear volume has been shown to be of prognostic significance in cancer studies (Artacho-Pérula and Roldán-Villalobos, 1997; McMillan and Sørensen, 1992; Sørensen, 1991). In many other application areas, particularly where the particle


Page 142

volume distribution is uni-modal, the combination of the number-weighted mean volume and coefficient of variation of the distribution represents a considerable amount of useful information. It should be noted that if the PSI method and nucleator (or selector) estimates are used in Equation 9.5 the estimate of the coefficient of variation is unbiased for any particle shape.

Direct estimation of particle volume distributions

A reliable design-based method for estimating the full distribution of particle volumes uses a combination of the ‘disector’ principle and Cavalieri methods. The disector principle is used to select particles and the volume of each particle thus sampled is estimated by the Cavalieri method in serial sections, for an example of this approach see Karlsson and Cruz-Orive (1991). The approach requires a knowledge of shrinkage (as do the other particle volume estimators described here) and of either physical section thickness or the distance traveled by an ‘optical section’. Whilst this approach can be implemented in the light microscope, using for example the optical disector, it is time consuming. However, if a detailed knowledge of the shape of the size distribution is deemed necessary, this might be the only recourse.

Box 9.1Matrix of stereological methods

 | Orientation and randomness
Section type | AUR | IUR | VUR
Single section | Volume density | Volume density Surface density Length density PSI | Volume density Surface density PSI
Pairs of sections | Volume density Number density Connectivity density | Volume density Surface density Length density PSI Nucleator | Volume density Surface density PSI Nucleator
Thick sections | Number density | Surface density Length density PSI Nucleator | Surface density Length density PSI Nucleator
Exhaustive serial sections | Cavalieri Optical fractionator Total connectivity | Spatial grid | Vertical spatial grid


Page 143

10
Statistics for stereologists

Contents

10.1 ‘Quantifying is a committing task’ (Cruz-Orive, 1994) | 143
10.2 Preliminary concepts | 144
10.3 Unbiased estimates | 145
10.4 Elements of good statistical practice | 146
10.5 Quantities of interest | 148
10.6 Application to a single object | 152
10.7 Addition of variances | 152
10.8 Two-stage estimation | 154
10.9 Calculation of CE for the Cavalieri method | 154
10.10 Calculation of the CE of a ratio estimator | 157
10.11 Prediction of CE for two-stage estimation | 159
10.12 Precision of Cavalieri estimation for single objects | 160
Exercise 10.1 | 162
Exercise 10.2 | 163

Box

10.1

How to round numbers for reports

160

In this chapter we introduce a number of statistical methods that are relevant in stereological experiments for optimizing sampling schemes. This chapter is not a substitute for a good introductory text on statistics. There are many excellent introductory books available, for example we have found both Chatfield’s (1996) and Zar’s (1996) to be affordable texts for general use. A more comprehensive book, aimed squarely at the biological scientist, is by Sokal and Rohlf (1981). For more mathematically advanced readers the texts by Chatfield (1995) and Cox and Snell (1981) can both be recommended.

The presentation in this chapter is inevitably more mathematical than previous chapters. However, in common with the rest of the book the emphasis is on introducing ideas. Those seeking rigorous proofs and more detail can pursue these ideas in the references. This chapter is not intended to train stereologists to be top-flight statisticians but to help experimentalists to approach statisticians armed with some understanding of the issues.

10.1 ‘Quantifying is a committing task’ (Cruz-Orive, 1994)

A pathologist making a judgement of cause of death or a metallurgist making an assessment of the cause of machinery failure are examples of situations where a


Page 144

scientist makes a qualitative analysis. In these and similar circumstances that is all that may be required to answer the underlying scientific question. However, in many other fields of applied science a scientist is expected to provide a quantitative analysis. For example, the effect of a new drug regime, a new heat treatment method, the effects of environmental exposure and so on. In these circumstances the fact that a quantitative analysis is required brings with it the responsibility to deal seriously with issues of accuracy, precision and overall confidence in the results of an investigation. In other words a more rigorous approach must be adopted. The earlier chapters in this book have described ways in which the microscope can be used to obtain unbiased estimates of structural quantities. This chapter provides some insight into how the results can be treated and subsequent optimization of stereological sampling designs.

10.2 Preliminary concepts

Before beginning on more specific issues it is worth summarizing some preliminary statistical concepts. This list is not exhaustive.

Population

A well-defined set of individual elements or units about which we require some quantitative information. In general, real populations are too large to be dealt with by complete investigation (which would be a census). Examples include:

• brains of all 35-day-old piglets;

• all adults in the UK at a certain date;

• all possible histological slides from the lung of a single laboratory rat.

Parameter

A numerical quantity that is defined for the population. Examples include:

• mean brain volume of all 35-day-old piglets;

• average income of all adults in the UK;

• total gas exchange surface of the lung from a single rat.

Sampling unit

Fundamental elements making up the population, or non-overlapping sets of elements. The collection of all sampling units is equal to the population. Examples include:

• a brain of a 35-day-old piglet;

• an individual adult who lives in the UK;

• a histological section from the lung of a single rat.

Sample

A collection of sampling units that have been taken from the population. Examples include:

• 12 brains from 35-day-old piglets;

• 432 adults who live in the UK;

• 25 histological sections from the lung of a single rat.


Page 145

Estimate

A numerical approximation of a population parameter calculated from a given sample. Examples include:

• mean brain volume of 12 sampled 35-day-old piglets;

• average income of a sample of 432 adults;

• surface density from 25 sections from the lung of a single rat.

Estimator

A well-specified numerical method that describes how to calculate an estimate for a given sample. Examples include:

• the Cavalieri method for estimating the volume of a piglet brain;

• the arithmetic mean of sampled adults’ incomes;

• the number of intersections per unit length of isotropic test line (IL) multiplied by 2.

Uniform random sample

A sample taken in such a way that all sampling units in the population had the same probability of being within the given sample. In the context of stereology a uniform random sample does not require all elements of a particular population (e.g. the alveolar surface in a given lung) to be pre-numbered. The intersection of a uniform random (or systematic uniform random) geometrical probe with the feature of interest is sufficient to ensure that a uniform random sample has been taken (see Chapter 2).

10.3 Unbiased estimates

We have already introduced the idea that stereological methods provide ‘unbiased estimates’ of structural quantities. This concept is quite subtle and requires some further explanation.

Suppose the aim of an experiment is to find out the number of particles, N, in a particular object (e.g. glomeruli in a kidney). If there are a large number of particles, complete enumeration will be extremely time consuming (though not impossible, see Kittelson 1916, for an example of a complete count of glomeruli in rat and human kidney). We therefore seek an estimate of the true number. An estimate of the required number N is usually indicated by the notation estN or [image]. In the case of count-ing particles a three-stage fractionator method could be applied, as described in Chapter 5. For example, the sampling fractions could be 1/20th, 1/30th and 1/50th respectively. This sampling scheme relies upon three independently selected uniform random numbers, z1 which is between 1 and 20, z2 which is between 1 and 30 and z3 which is between 1 and 50. For example, these numbers could be 12, 29 and 2 respectively. If this scheme was carried out then we would obtain a first estimate of particle number est1N. Suppose now that we could completely undo the process of slicing, making blocks, embedding and sectioning and ‘glue’ the object back together exactly as it was. If we now repeated the three-stage fractionator scheme with the same sampling fractions but new random numbers z1, z2 and z3, for example 15, 4 and 43, we would obtain a second estimate of N, that is est2N. It would be very unlikely to obtain a second estimate that was exactly the same as est1N.

The process of estimation and re-gluing can be continued indefinitely for the same object. This process would generate a whole series of estimates of particle number, est1N, est2N,…estMN, where M is the number of times the process has been repeated.


Page 146

This series of estimates represents a distribution of estimates of the true number of particles N. If these estimates were sorted into a histogram it would give us the sam-pling distribution of the three-stage fractionator, using fractions of 1/20th, 1/30th and 1/50th, as applied to the single fixed object. If the mean of this sampling distribution is equal to the true number N then we say that the estimator of N is unbiased (Stuart, 1984). Furthermore, the sampling distribution of estimates will have a standard deviation, which gives an idea of the spread of the distribution. The standard deviation of a sampling distribution is generally referred to as the standard error of the estimator of N. There are four important features of this argument.

1. An estimator of a quantity inevitably introduces a variability that is solely related to the sampling process involved. There cannot be any inherent variability in the parameter we required, N, because it is fixed.

2. For scientific purposes an unbiased estimate is the most we can hope to achieve if we cannot directly measure a quantity.

3. The width of the sampling distribution, as assessed using the standard error, relates to the properties of the estimation method. Two estimators may be unbiased but have different standard errors. For example, for a given object a four-stage fractionator may be found to be more precise (i.e. smaller standard error) than a three-stage fractionator.

4. In general an estimator is very unlikely to give an estimate that is exactly equal to the true value. Reconsider Figure 5.17 for a fractionator example that illustrates this.

The situation described above becomes a bit more complex when considering a sample of objects selected from a larger population with a uniform random sampling mechanism. In this case we are now interested in estimating the mean number of particles in the population of objects. Clearly for each object the estimator of particle number that is used will introduce variability and there is also an inherent variability between individuals within the population. How does an unbiased estimate of the number of particles in any one object help us in this situation? The property of unbiasedness in these circumstances becomes critical. The sample mean of the estimates of number for each of the randomly selected objects will become closer and closer to the true population mean as the sample size increases if (i) the number estimator used for each object is unbiased, (ii) the objects are a uniform random sample from the population and (iii) the variance among number estimates is finite. The sample mean in these circumstances is said to be consistent (i.e. it approaches the true value as the number of objects in the sample increases). It should be noted that if the number estimators are not unbiased then increasing the number of objects in the sample merely ensures that the sample mean will converge on a value other than the true population mean: in short it is biased.

Given the above discussion perhaps it is now a little clearer why so much effort has been spent in developing unbiased methods in Stereology. As mentioned in Chapter 1 the unbiasedness of an estimation scheme is not empirically verifiable. This is hard to swallow for experimentalists who often insist that stereological methods should be ‘validated’ against other (usually biased) methods that they have ‘always used’. However, an unbiased method cannot be validated with data. An unbiased sampling and estimation scheme is guaranteed to deliver unbiased estimates if it is followed slavishly.

10.4 Elements of good statistical practice

Statisticians will often give slightly differing advice about what constitutes good statistical practise. However, good statistical practise is based upon good experimental


Page 147

Table 10.1 A simple illustration of the use of ‘blinding’ in experiments

Case a | Case b | Control (c) | Randomization
a1 | b1 | c1 | b1, a1, c1
a2 | b2 | c2 | c2, b2, a2
ai | bi | ci | …
aM | bM | cM | …

practise. These ideas are found again and again in different disciplines, largely because they are very useful aids to help experimental results become good research papers.

1. Always try to perform a smaller scale pilot study before a full study is carried out. A pilot study may consist simply of trying a point or line grid on a few micrographs or it may be a scaled-down version of the full study.

2. Record data in a hardback laboratory notebook in ink. Make contemporaneous records of anything that may have a bearing on the results. Sketch apparatus, stick micrographs into the lab book, note anomalies and so on. Keep intermediate results, for example point counts on each section used for Cavalieri estimates of volume. If histological slides are used make sure each slide is uniquely numbered and labeled and kept in suitable storage boxes. Labeling is a basic method to allow suspect results to be checked or repeat analyses to be carried out.

3. Experimental material should be labeled in a way that ‘blinds’ the analyst to what specimen or condition is represented by the slide. For example, if the study comprises two treatments, a and b, and a control group c, then the material should be ranked by class and then randomized across the three groups. This is illustrated in Table 10.1. The table should not be tackled from top to bottom in each case because the results will then be susceptible to changes in technique during the course of the experiment, which can sometimes be subliminal. The horizontal randomization illustrated minimizes this risk.

4. Briefly summarize data and results as they are collected. This will highlight any problems at the point where they can be solved. New hypotheses may be suggested by early results.

5. Always make careful records of calibration standards such as magnification, light levels, concentration.

6. Check that the results have the correct dimension, the correct units and that they are roughly the right magnitude (see Box 1.1). For example, the total cortical volume of a human brain could plausibly be 550 cm3, but is unlikely to be 550 mm3 (units problem), 550 cm2 (dimensions problem) or 5500 cm3 (magnitude problem).

7. If possible try to frame the aim of the experiment in terms of a clear scientific and statistical hypothesis. For example, ‘H0=the mean kidney volume in a population of rats treated with drug B is the same as the mean kidney volume in a population of control rats’ is far clearer than ‘We’ll treat the rats with the drug and see what happens to the kidneys’.

8. Understand the type of study you are carrying out. It could be a purely observational investigation where you have no control over different treatments or other confounding factors. It could be an interventional experiment where the make-up of the different groups is fully described in a protocol. Many pathological studies on human tissue are by definition observational studies (the controls are still walking around quite happily).


Page 148

9. Be cautious with experiments that compare the left- and right-hand sides of an organ or animal. These experiments constitute examples of paired samples and the analysis of the results must take into account this pairing (Zar, 1996).

10. When plotting data on a graph each ‘dot’ should represent a fundamental sampling unit. In biology this means one dot per animal (not one per block or micrograph). Axes should be labeled clearly and correctly with the correct units. If the axes are split this should be indicated clearly on the graph and in the caption. In general axes should not be split and should include a real zero. Logarithmic scales should be used carefully, even decidedly non-linear relationships look linear on log-log paper. Do not carry out ‘linear regression’ or ‘correlations’ between sets of parameters unless there is a good reason to. Many completely unrelated sets of quantities can show strong correlations, for example there is a perfect positive correlation between a person’s age and the expansion of the universe over the past 5 years (Gould, 1987).

11. Unless the parameter you are interested in has a strong suggestion of allometric scaling, quantities per animal should not be normalized for body weight. If quantities are normalized then show both normalized and non-normalized data so that the reader can be convinced of your methodology.

12. Quite a few modern experts in statistics (see particularly Chatfield, 1995) suggest that informal plotting of results and calculation of simple descriptive statistics are in many circumstances as useful as formal statistical procedures. The routine and uncritical use of standard statistical tests ‘so that my boss can quote a p-value in his talk’ should be avoided. Implicit in many well-known statistical tests are assumptions that may be completely inappropriate for your stereological data.

13. Wherever possible a scientific hypothesis should not be proposed and tested from the same set of experimental data. Thus experimentalists should be careful of noting an effect in an experiment and then proving it is significant using the same set of data. We have all done this but it is statistically questionable (Chatfield, 1995). If a data set suggests a particular effect this should be tested in a repeat of the experiment. Although this is hard to swallow if the technique is costly in terms of time it should be considered. In some circumstances the original data set can be split and used in a technique called cross-validation to establish how robust the conclusions are (Chatfield, 1995).

14. Statisticians have a different intellectual training from scientists. However, they have become statisticians primarily because they are fascinated with real data. Therefore it is well worth seeking help from them if they are available.

15. Statistical advice is almost always most effective when it is given before the experiment is begun.

16. You should be warned that many statisticians are unaware of the latest stereological methods as discussed n this book. Work with them and get them ‘hooked’ and it should pay off. One way to begin this is to show them this book and carefully explain your problem.

10.5 Quantities of interest

In this section we introduce in a more formal way some of the statistical quantities that we are most interested in. Suppose that we have a population of objects or animals comprising N individuals. For each individual there is an associated quantity R (which could be number, length, surface or volume of a particular set of features). Thus we can consider the population as a list of values Ri, i=1, 2,…, N. The population mean of these values, denoted by the Greek letter μ, is defined as


Page 149

(10.1)

where E[R] denotes mathematical expectation. The population variance between the values, or mean square deviation, is defined as

(10.2)

The population standard deviation among the values is the square root of the population variance,

(10.3)

These three quantities are the basic tools for quantifying the location (mean) and dispersion (variance and standard deviation) of a population of values. The larger the variance the more disperse, or spread out, a population of values is. It should be noted that many natural populations are asymmetrical and the mean may not represent the most probable value (see Zar, 1996 for examples).

The population standard deviation has the same units as the mean. Thus if the standard deviation is divided by the population mean a dimensionless form is obtained, which is known as the coefficient of variation

(10.4)

Equations 10.1–10.4 all refer to natural populations of quantities. However, these quantities can only be calculated explicitly if the whole population is available. Clearly in many cases this is not possible and estimates of these population quantities are made from a simple random sample of n individuals.

The values of R obtained in the sample are renumbered and used to estimate the sample mean from

(10.5)

If the sampling was simple random then the sample mean is an unbiased estimator of the population mean. As explained in Section 10.2 this implies that if the sampled individuals were returned to the population and the process repeated, we would obtain a sampling distribution of estimates, [image], and so on, the mean of which would be equal to μ. The sampling distribution of estimates obtained with a sample size of n also has a variance, which is related to the population variance of the values of R by the relation

(10.6)

This is approximately equal to σ2/n if N is large compared with n.

The implication of Equation 10.6 is that estimates of population mean made from samples composed of, say, 25 individuals will cluster more closely about the population mean than estimates made from samples of five individuals.

The standard deviation and coefficient of variation of the sampling distribution are generally known as the standard error (SE) and coefficient of error (CE) respectively and are given by

(10.7)


Page 150

Note that whereas CV relates to the variability of the values of R in the population, the SE and CE reflect the variability of the estimated means [image] with respect to the population mean μ. This is the reason that they are referred to as standard errors and coefficients of error. It should be noted that the increase in precision of an estimate, as quantified by the SE, reduces in proportion to [image], that is the reciprocal of the square root of the number of individuals in the sample.

So far the variance of the values of R composing the sample of n objects has not been calculated. This is known as the sample variance, s2, which is calculated from

(10.8)

The sample variance is an unbiased estimator of

which for large values of N is effectively equal to σ2. The square root of the sample variance is known as the sample standard deviation s. The sample standard deviation can be used to estimate the population standard deviation, SD(R), and also estimates of the standard error and coefficient of error,

(10.9)

The presentation above is best illustrated with a simple example. An investigation was carried out to determine the mean volume of 20-day postnatal Wistar rat neocortex. A simple random sample of six animals was taken and the volumes of the neocortex are presented in Table 10.2. The sample mean, [image], is 149 mm3 and the sample standard deviation, s, 9.7 mm3. The standard error and coefficient of error are therefore estimated from

(10.10)

and

(10.11)

respectively. The sample standard deviation is also an unbiased estimate of the population standard deviation and we can therefore make an estimate of the population coefficient of variation.

Table 10.2 20-day postnatal neocortex volume in a random sample of six Wistar rats

Animal | Neocortex volume (mm3)
1 | 153
2 | 141
3 | 139
4 | 145
5 | 153
6 | 165
Data from Table 3.3.2c, Benham-Rassoli (1990).


Page 151

(10.12)

Of these quantities the estimate of CV(V) refers to the parent population of Wistar rats and is information that is independent of the number of animals that were sampled, that is, if the sample size had been larger or smaller we would still have obtained similar results in the long run. However, the estimates of [image] and [image] give information about both the underlying population variation and the variability introduced by the sampling procedure. These quantities are clearly dependent upon the sample size, hence the subscript n, and would become smaller simply by increasing the number of sampling units within the sample. As noted both SE and CE reduce in proportion to the square root of n, therefore a doubling of the sample size does not lead to a halving of the CE. For example, if a sample of 12 rats had been taken we would expect the CE to reduce to about 1.9% and not 1.5%. You should note that the level of coefficient of variation of 7% is low in comparison to many other biological variables. With this level of biological variability precise estimates of volume are essential.

If a single estimate of a parameter is made, known as a point estimate, we intuitively want to report how reliable we think it is, to give some measure of our confidence. For example, given the raw data shown in Table 10.2 how can we report confidence intervals? In many circumstances scientists simply report the standard deviation, or twice the standard deviation, of the set of data. However, as explained above, the sample standard deviation is an estimate of the population standard deviation and on its own does not give any idea of the confidence we should have in the result. The standard error does give some indication of the reliability of the result, because it reduces as the sample size n increases. However, even the standard error is still not a confidence interval.

A confidence interval should give a range of values, normally as a mean±a value, in which we believe with a certain probability that the true value lies. Thus to construct a confidence interval we not only require the standard error but we also need to know (or assume) the shape of the sampling distribution for the estimator. If the population mean is being estimated and the true population variance is unknown, then the Student’s t-distribution is often used as a model of the sampling distribution. This distribution is a modified form of the well-known Gaussian distribution and changes width according to the number of data points, n, that were in the sample.

Suppose that we wanted to obtain a 95% confidence interval for the estimate of population mean we made from the data shown in Table 10.2. This is given by the equation

(10.13)

where t.975,v is the value of the t-distribution used for a 95% confidence interval for v degrees of freedom (available in most statistics books). In this context v is equal to n−1 and t.975,v is 3.18. Thus for the data shown in Table 10.2 the mean and 95% confidence interval can be given as

(10.14)

This means that given the sample mean of brain volumes, [image], we are 95% confident that this interval will contain the true population mean μ. This statement should be interpreted as follows: if for each experiment we performed like this one we claimed that μ lay within such a confidence interval then 95% of these claims


Page 152

would be true in the long run (see Chatfield, 1996). It should be noted that for small sample sizes t.975,v can be quite large, but for n>25 a useful approximation is that it is equal to 2.

10.6 Application to a single object

All of the above discussion has concerned the variance between either a population or sample of objects or animals. However, a similar approach can be applied for calculating the coefficient of error of an estimate made on a single object. Consider the problem of estimating the true value of R for a single object (e.g. the object volume V using the Cavalieri method). We can carry out the estimation to obtain a single estimate of R, [image]. Let us imagine that we can perfectly undo the process involved in estimation, that is, ‘glue’ the object back together if necessary, and repeat the process. By repeating the process we would obtain the sampling distribution of estimates of the true value R, that is [image]. In this context R and [image] therefore play the roles that μ and [image] did for a population of objects. Given that we have a sampling distribution we can also have a sampling variance, standard error and coefficient of error for the single estimate of R, given by

(10.15)

where [image] is the variance of the sampling distribution of [image] for a fixed single object and R is the true value.

10.7 Addition of variances

Consider a simple experiment to estimate the population mean of R for a population of N animals. A simple random sample of n animals is taken. In this case the value of R cannot be measured exactly for each animal and is estimated, [image]. Therefore the sample mean is now estimated from

(10.16)

If the estimator used for Ri is unbiased, so that [image], then the sample mean is a consistent estimator of the population mean μ. An estimator is consistent if it approaches the true value as the sample size, n, increases.

Clearly the variance of the sample mean will have two contributions: (i) inherent ‘between animal’ or biological variation and (ii) variation introduced by the estimation method used for each animal. These variances are combined in the following manner:

(10.17)

where the individual components have the following meaning:

is the observed variance of R between the n animals,

is the variance of the expectation of the estimates of R conditional on the true values of R, and

is the expectation of the sampling variances of the individual estimates of R for the different animals.


Page 153

If the method used to estimate R is unbiased then [image] is equal to R by definition and therefore [image] is equal to Var(R). Under these circumstances Equation 10.17 simplifies to

(10.18)

This equation is important because it provides a way of decomposing the observed variance into its two component parts, (i) the biological variance of the parameter R between animals and (ii) the average sampling variance. In general component (i) is fixed for a given population but component (ii) can be affected by the stereological sampling design applied to each animal. If the observed variance is large it is useful to know whether it is worth increasing the workload per animal or taking more animals (Gundersen and Østerby, 1981). In practise this type of calculation would not be carried out for every study but is ideal for analyzing a pilot study with the aim of distributing sampling effort at the right level of the overall experimental design. In many biological situations the biological variance will be much larger than the sampling variances (e.g. Cruz-Orive, 1994).

Often the variance is not as widely used as the squared coefficient of variation and coefficient of error where appropriate. Thus Equation 10.18 will often be encountered in the approximate form

(10.19)

where CV2(R)=σ2/μ2 is the squared coefficient of variation of the population values of R and [image] is the squared coefficient of error of the estimate of R obtained for the ith animal.

Consider the data set shown in Table 10.3 , which shows estimates of the total number of neurones obtained for six uniform randomly selected animals. The coefficients of error for each individual estimate have also been estimated (see later). From these data the sample mean, [image], and standard deviation, s, have been calculated as 1.16×108 and 0.33×108 respectively. The mean of [image] is 0.162 and the observed CV was 0.284 (28.4%) giving a [image] of 0.0809. These figures can be substituted into Equation 10.19 to give

which on rearranging gives

Table 10.3 Number estimates for six uniform randomly selected individuals

Animal |  |
1 | 1.26 | 0.132
2 | 1.64 | 0.192
3 | 0.99 | 0.152
4 | 1.27 | 0.192
5 | 1.12 | 0.172
6 | 0.65 | 0.132
Mean | 1.16 | 0.162


Page 154

The biological CV of the true numbers of neurones in the animals is therefore the square root of 0.0553, which is 0.235 (23.5%). Thus the overwhelming factor in the observed variability is the biological variation between animals and estimates that have on average about 16% coefficient of error are more than precise enough for this study. Given that the observed coefficient of error is proportional to the observed coefficient of variation the conclusion that can be drawn about this analysis is that in order to increase the overall precision of the study more animals need to be examined and the same, or possibly even less, work needs to be carried out per animal.

10.8 Two-stage estimation

Many of the methods described in this book make estimates of total quantities via a two-stage estimation procedure in which (i) the volume of the reference space is estimated and (ii) the density of the quantity of interest per unit volume is estimated. These quantities are multiplied together to obtain a final estimate of the total quantity. In each case the density can be written in a general form as a ratio:

(10.20)

where ‘Amount of feature Y’ can be volume, surface, length or number. Thus the two-stage estimation can be written generally as

(10.21)

where [image] is an estimate of the total amount of Y in the object. Thus R will be the total number, length, surface area or volume of the feature Y. As a specific example the total number of particles in an object could be estimated from

(10.22)

Clearly for a given object the coefficient of error in the overall estimate will be influenced by the coefficients of error of both the volume and density estimates. The overall coefficient of error for a single object is a combination of the two components. If the estimates of volume and density are independent, an estimate of the coefficient of error squared, [image], for a single animal is given by

(10.23)

where [image] and [image] are estimates of the coefficients of error squared of the volume and density estimates respectively. The bracketed quantity, [image], is usually omitted as it is negligible compared with the other two components; in these circumstances Equation 10.23 will become

(10.24)

The following two sections give details of how these quantities can be calculated for both the Cavalieri estimator of volume and ratio estimators of density.

10.9 Calculation of CE for the Cavalieri method

The coefficient of error of the Cavalieri estimate of volume from m sections can be predicted in two ways, (i) by sub-sampling from a larger number of sections (typically


Page 155

5–10 times m) or (ii) by using a predictive formula that takes into account the systematic nature of the sampling. The difference between these two approaches can be illustrated with an example. The following data set is an ordered list of the cross-sectional areas of 56 sections through a bounded object, given in mm2 to the nearest mm2.

{2, 3, 5, 6, 8, 8, 11, 9, 12, 13, 16, 17, 19, 25, 27, 25, 21, 21, 19, 18, 17, 16, 19, 24, 28, 29, 30, 32, 32, 33, 34, 29, 29, 28, 27, 24, 21, 21, 20, 24, 25, 26, 27, 29, 29, 14, 9, 19, 12, 12, 14, 9, 15, 11, 6, 4}.

The total of these 56 values is 1063 mm2, which, multiplied by the slice thickness of 1 mm, gives an unbiased estimate of the object’s volume of 1063 mm3. The overall trend of the values rises from each end towards the middle; this is typical of many Cavalieri data sets.

This data set can be split into seven systematic sub-samples each containing m=8 values. These are shown in Table 10.4. In each case the sum of areas in the sample is given, ∑A, and an estimate of V. Note that due to the overall sampling design each of these estimates of object volume is unbiased. In effect this sub-sampling method gives seven values from the sampling distribution of the Cavalieri method on this object for m=8 slices. In this case the values from the sampling distribution comprise the following:

{1043, 1092, 1092, 1043, 1022, 1071, 1078}.

The mean of this distribution is 1063, which is exactly equal to the volume estimate for the whole data set, thereby illustrating the unbiasedness of the Cavalieri approach. The standard deviation of these values, with seven degrees of freedom, gives a precise estimate of the standard error of the sampling distribution (Equation 10.15). This value divided by the mean is the coefficient of error, [image], for a systematic sampling estimate utilizing m=8 data values. For the data in Table 10.4 , [image] is 2.4%.

The sub-sampling approach is inevitably wasteful of resources and in general what we require is a prediction of [image] from the data obtained in just one of the systematic samples of eight sections. Unfortunately the normal way of estimating CE from the sample standard deviation, s, and square root of m,

is not applicable in this case because the values in each set of m=8 slices are not independent. For example, consider data set I, {2, 9, 27, 16, 32, 24, 27, 12}. What is

Table 10.4 Seven systematic samples of size m=8 values from 56 values in data set

 | I | II | III | IV | V | VI | VII
 | 2 | 3 | 5 | 6 | 8 | 8 | 11
 | 9 | 12 | 13 | 16 | 17 | 19 | 25
 | 27 | 25 | 21 | 21 | 19 | 18 | 17
 | 16 | 19 | 24 | 28 | 29 | 30 | 32
 | 32 | 33 | 34 | 29 | 29 | 28 | 27
 | 24 | 21 | 21 | 20 | 24 | 25 | 26
 | 27 | 29 | 29 | 14 | 9 | 19 | 12
 | 12 | 14 | 9 | 15 | 11 | 6 | 4
Sum, ∑A (mm2) | 149 | 156 | 156 | 149 | 146 | 153 | 154
Volume, T×∑A (mm3) | 1043 | 1092 | 1092 | 1043 | 1022 | 1071 | 1078
Note that T=7 mm.


Page 156

important about this list of values is that their order in the list cannot be ignored. In short, the values have a dependency or correlation structure. If the CEs of the sub-sampled data sets are calculated as if they were independent, the values range from 14.4 to 19.9%, all of which are overestimates of [image] by a factor of between 6 and 8 times.

In Stereology the most popular method employed for predicting the coefficient of error for a systematically sampled quantity such as the Cavalieri estimator, is based upon the transitive theory of Matheron (1971). This method was developed for mining applications but was modified for stereological applications by Gundersen and Jensen (1987). Further theoretical work in this area has been carried out by Cruz-Orive (1989a, 1993), Mattfeldt (1989) and Thioulouse et al. (1993).

The estimate of CE developed by Gundersen and Jensen (1987) is based on a covariogram analysis of the list of data values. In the case of the Cavalieri method these data consist of an ordered set of m measurements, or estimates, of cross-sectional area A1, A2,…Am. In order to estimate the volume the sum of these values,

is required and, to estimate the CE, three other sums are calculated:

(10.25)

Using these four sums the Gundersen and Jensen (GJ) prediction of CE is given by

(10.26)

It should be noted that the GJ approach is not unbiased as it requires certain model assumptions to be made. If the GJ estimator of CE is carried out for the sub-sampled data sets in Table 10.4 the list of CE predictions is as follows: 7.4%, 6.7%, 5.9%, 3.7%, 4.4%, 3.6%, 5.6%. Clearly these are all overestimates of the CE obtained by sub-sampling (2.4%) but are much better predictions than those obtained from the inappropriate classical CE prediction (14.4–19.9%). In many practical applications the predictive formula developed by Gundersen and Jensen (1987) has been found to be extremely useful; see Mayhew and Olsen (1991), Pache et al. (1993), Pakkenberg et al. (1989) and Roberts et al. (1993). One important thing to note about the Cavalieri estimator is that the coefficient of error tends to decrease in proportion to 1/m as opposed to [image] which would be expected for independent samples.

If the cross-sectional areas are estimated by point counting then a modified version of Equation 10.26 is required (Cruz-Orive, 1993; Roberts et al., 1994b). In order to estimate the volume using point counting the sum of the point counts on each section is required,


Page 157

the following three sums are also calculated for predicting CE:

(10.27)

The prediction of CE is given by

(10.28)

If the contribution of the point counting to [image] is required it may be predicted from

(10.29)

The contribution to the overall CE due to the variation between section areas can thus be predicted from

(10.30)

Equations 10.28 and 10.29 involve the dimensionless shape coefficient [image] where Ā and [image] are the mean transect area and boundary length respectively. These may be estimated from point counting, to get Ā, and counting the number of intersections between an isotropic line grid and the boundaries to get [image]. For a particular object the relevant shape coefficient is found to be fairly stable and it will usually only be estimated once for a study. Further details of the application of these error-prediction formulae are given by Pache et al. (1993) and Roberts et al. (1994b, 1997a). The major contribution to the overall CE for the Cavalieri estimator is often found to be the ‘point-counting’ contribution, that is, the section variation adds a negligible amount to the overall coefficient of error. If the object is particularly regular in shape, a so-called quasi-ellipsoid, then the error prediction formulae (Equations 10.26 and 10.28) may overestimate the CE by a factor of 10–20 times. Under these circumstances a modified form of Equation 10.26 can be applied (Cruz-Orive, 1993).

10.10 Calculation of the CE of a ratio estimator

All of the ratio estimators described in this book have been of the general form

(10.31)

where ui and vi are the counts of profiles, intersections, points or frame-associated points depending upon the application. For example, if k micrographs are used for surface density estimation a separate count is made of the number of intersections between the linear test probe and interfaces (Ii) and the number of points hitting the


Page 158

reference space (Pi) on each image. The surface density of the surface of interest is then estimated from Equation 6.4,

where l/p is the length of test line per point at the level of the tissue (i.e. corrected for linear magnification).

Ratio estimators of this type have a small intrinsic bias that rapidly decreases as the number of fields k increases (Baddeley, 1993; Chia and Baddeley, 1997; Cruz-Orive, 1980b). The coefficient of error of a ratio estimate, [image], can be approximated using the following formula:

(10.32)

where there are k images and each summation is over 1 to k (see Cochran, 1977; Cruz-Orive, 1980b; Hansen et al., 1953). An example of the application of this type of calculation is given in Table 10.5 , which shows the counts of points used for estimating the volume fraction of a phase of interest, Y, within a polymeric material. The volume fraction of the phase Y was estimated as

(10.33)

The coefficient of error of this estimate was approximated using Equation 10.32, that is

(10.34)

It should be noted that Equation 10.32 considers each micrograph to be independent. However, if a hierarchical sampling regime is applied there may be important ‘between block’ and ‘between section’ contributions to the overall CE. An example of how to quantify the error contribution between blocks, sections and point counts for a ratio estimator is described by Karlsson and Cruz-Orive (1991).

Table 10.5 Raw data used to estimate volume fraction and intermediate data for use in Equation 10.34

Image | P(ref) | P(Y) | P(ref)×P(Y)
1 | 150 | 34 | 5100
2 | 144 | 33 | 4752
3 | 144 | 33 | 4752
4 | 96 | 19 | 1824
5 | 114 | 31 | 3534
6 | 114 | 13 | 1482
7 | 147 | 26 | 3822
 | ∑P(ref)=909 | ∑P(Y)=189 | ∑P(ref)·P(Y)=25266
k=7 | ∑P(ref)2=120789 | ∑P(Y)2=5501 |


Page 159

10.11 Prediction of CE for two-stage estimation

In order to illustrate the approach shown in Equation 10.24 the full data set used for illustrative purposes in Table 10.3 is shown here in Table 10.6. As stated above the observed coefficient of variation was 28.4%, of which the biological CV of the true numbers of neurones in the animals was 23.5%. Suppose that the observed CV, and hence also observed CE, was too high and we wanted to reduce it. There are two ways to approach this problem: first, we could increase the precision of the number estimate per animal, or second, increase the number of animals in the study. The information shown in Table 10.6 allows us to decide where to put our effort.

Suppose that the precision of the number density estimates was improved by doubling the number of sections and micrographs analyzed. Assume for the present that this would lead to a halving of the average coefficient of error squared of the number density estimates. What impact would this increase in precision have on the overall coefficient of variation? The result is that the mean squared coefficient of error within each animal would be reduced to 0.102 from its previous 0.162. Bearing in mind that the biological variability is unchanged the overall coefficient of variation would be reduced from 28.4% to 25.6%. Thus doubling the amount of effort at the level of numerical density estimation has led to a reduction in observed CV of 2.8%. The effect on observed CE, that is [image] would reduce it from [image] to [image]. In terms of our confidence in the result we have worked twice as hard for a negligible increase in overall precision!

Suppose now that instead of increasing precision per animal we add an extra two animals to the study. The observed CE would be expected to reduce to [image] (making a reasonable assumption that mean and standard deviation of number estimates is about the same). Thus by retaining the same sampling density at the level of the individual animal and increasing the number of animals by two we have obtained a larger overall improvement in precision than by doubling the effort per animal! The conclusion is clear—for cohort studies where the biological variability is larger than the sampling variability it is generally better to take a bigger group of animals than improve the precision of the estimates per animal, provided the cost in time or money of adding extra animals is not excessive. This is the reason that Ewald Weibel’s motto ‘Do more, less well’ has become widely quoted amongst stereologists (Gundersen and Østerby, 1981). The type of analysis carried out here would be invaluable in assessing the outcome of a pilot study before commencing upon a larger study. Once the true variance of a parameter has been estimated, using the approach we describe here, and more fully in Gundersen and Østerby, it is then possible to use this to predict the likely sample size required to reveal a given ‘true’

Table 10.6 Complete version of data set shown in Table 10.3

Animal |  |  |  |
1 | 1.26 | 0.132 | 0.052 | 0.122
2 | 1.64 | 0.192 | 0.082 | 0.172
3 | 0.99 | 0.152 | 0.062 | 0.142
4 | 1.27 | 0.192 | 0.072 | 0.182
5 | 1.12 | 0.172 | 0.082 | 0.152
6 | 0.65 | 0.132 | 0.042 | 0.122
Mean | 1.16 | 0.162 | 0.0652 | 0.152
 | 0.33 |
 | 0.28
 | 0.0809


Page 160

difference between two experimental groups. To achieve this two assumptions have to be made; firstly, the size of difference between groups that you wish to detect and secondly, the degree of certainty with which you want to detect that difference, if it is present. It is commonsensical that you will need a bigger sample to detect a 1% difference between groups than a 10% difference. Likewise, if you want to be 99% certain you will have to work harder than if you are satisfied with 80% certainty. A description of the method, with a fully worked example, is provided in section 9.8 of Sokal and Rohlf (1981).

10.12 Precision of Cavalieri estimation for single objects

The analysis described above is very widely used for cohort studies, that is, making estimates of population averages from a group of similar individuals. However, if a single object is considered, the precision of the estimate may need to be increased. For example, if the volume of an organ has been estimated with the Cavalieri method from MRI before and after a course of treatment, the level of precision required may have to be higher than that indicated above. Consider the following situation. An organ’s volume has been estimated using the Cavalieri method on m=10 slices to be 125 cm3 with a predicted CE of 5%. It is strictly inappropriate to provide confidence intervals for this estimate. However, for purely illustrative purposes (i.e. never do this in practice) suppose we adopted a crude confidence interval of mean ±2×SE. For this example data we would obtain 125±(2×125×0.05)=125±12.5 cm3. Thus if the volume of the same organ was found to be 135 cm3 after treatment we would struggle to say whether the effect was real or not. In these circumstances more work should be done, that is a higher number of slices and points counted, to obtain a CE of say 1%. Under these circumstances our crude confidence interval would then become 125±(2×125×0.01)=125±2.5 cm3 which would allow us to have more confidence that the increase of organ volume to 135 cm3 was a real effect. The application of the Cavalieri method to single objects and the prediction of CE in these circumstances has been thoroughly investigated by Roberts, Cruz-Orive and co-workers (Cruz-Orive, 1993; Pache et al., 1993; Roberts et al., 1993, 1994b, 1997a).

Box 10.1 How to round numbers for reports

The methods we have described throughout this book are all concerned with providing estimates of quantities. When reporting these estimates some consideration should be given to how many significant figures should be used.

The problem of how many decimal places should be reported has become more acute in recent years due to the advent of pocket calculators and computers which list far more digits than are actually required. For example, a study was carried out to estimate the surface density of an interface within a single animal and the following data were recorded: the number of intersections (l) was 129, the number of points hitting the reference space (P) was 98 and the length of line per point (l/p) was 110 μm at the level of the tissue. Using a pocket calculator and Equation 6.4 the result was given as 0.023933209 μm−1. Certainly we cannot report all of these numbers as being significant, but how many should we report?


Page 161

Many statistical texts avoid this problem, but Chatfield (1996) describes clearly how to deal with it. The recommendation is that the ‘two variable digits rule’ should be used for rounding numbers. This means that data in general, and final statistical estimates in particular, should be rounded to two variable digits, where a variable digit is one that varies in the kind of data being considered. This rule cannot be applied to a final number unless the data used to estimate that number are available. Consider the following data set given by Chatfield (1996):

181.633, 182.796, 189.132, 186.239, 191.151.

In this data set the first digit is always ‘1’, so is not a variable digit. The second is either ‘8’ or ‘9’ and so does not vary over the whole of the range 0–9 (or even a large part of it) so this also is not really a variable digit. The remaining four digits are all variable digits. If the two variable digit rule is applied this means that the mean should be reported with one decimal place rather than the three decimal places given in the original data. Given the range of the original data, of about 10, we are very unlikely to be really interested in variation of smaller magnitude than the range divided by 100 (i.e. the second and third decimal places give us very little information), Chatfield (1996) also suggests that the two-digit rule should be applied to data collection, for the data set above this would mean that the following values were recorded:

181.6, 182.8, 189.1, 186.2, 191.1.

By rounding before any further calculations are carried out virtually no real information is lost!

In the case of stereological count data, such as the point and intersection counts recorded for the surface density calculation above, the situation is slightly different. When counting events, Poisson statistics usually apply, and in these circumstances the standard deviation is equal to the square root of n, where n is the number of counts. Therefore for count data such as that given above where there are about 100 counts it would not be worth reporting more than two decimal places (the square root of 100 is 10) in the estimate (i.e. 0.024 μm−1). Note that the leading zero is not a significant figure as we could have reported the number as 2.4×10−2 μm−1. However, we can use trailing zeros to indicate significant figures, thus 3.0×10−2 μm−1 would indicate that both figures were significant. In many applications using powers of ten is a convenient way of drawing attention to the number of significant figures used.

Acknowledgment

In writing this chapter we have used ideas from two sets of excellent unpublished lecture notes, ‘Basic ideas of sampling and statistics’ and ‘How many animals? Optimizing sampling designs’, written by Professor Luis Cruz-Orive (University of Cantabria, Santander, Spain). We would like to thank Professor Cruz-Orive for making these notes available to us.


Page 162

Exercise 10.1

The following data were taken from a study by Pakkenberg et al. (1989) into the ventricular volumes of the brains of several cases of hydrocephalic children. The volumes were estimated with parallel computerized tomography scans and the Cavalieri method. The list of points given in the following table were obtained on a series of 14 sections.

Slice number | Points hitting ventricles (Pi)
1 | 6
2 | 10
3 | 20
4 | 26
5 | 28
6 | 26
7 | 26
8 | 30
9 | 28
10 | 26
11 | 24
12 | 12
13 | 6
14 | 4

PROCEDURE

Using this set of data carry out the following calculations.

1. If the area per point, a/p, was 1.83 cm2 at the level of the brain tissue and the inter-slice spacing was 1.53 cm, estimate the volume of the brain using the Cavalieri method.

2. Given that the shape coefficient of the ventricles, [image] was estimated to be 1.45, use Equation 10.28 to estimate the coefficient of error for the data in the table.

3. Using Equations 10.29 and 10.30 calculate the contribution to the overall CE made by the use of point counting.


Page 163

Exercise 10.2

The following data were obtained to estimate the surface density of an interface in a two-phase polymeric material. Vertical sections were used and the points and intersection counts shown in the table below were made. The length of cycloidal test line per reference point was l/p=d∙8/π. At the magnification used d was 121 μm.

PROCEDURE

Using this set of data carry out the following calculations.

1. Estimate the surface density of the interface per unit volume.

2. Use Equation 10.34 to estimate the coefficient of error for the data in the table.

Image | P(ref) | l
1 | 11 | 119
2 | 12 | 149
3 | 11 | 145
4 | 7 | 62
5 | 9 | 83
6 | 5 | 66
7 | 9 | 110


Page 164

This page intentionally left blank.


Page 165

11
Single-object stereology

Contents

11.1 Introduction | 165
11.2 Volume of single objects—arbitrary orientation designs | 166
11.3 Surface of single objects—isotropic or vertical orientation designs | 167
11.4 Length estimation in vertical orientation designs | 175
Exercise 11.1 | 180

11.1 Introduction

Previous chapters of this book have described both the general principles for stereological estimation and also the details of a number of specific techniques. In both cases we have implicitly referred either to a global quantity, such as total number of cells within a reference space, or an average size over all objects within that reference space. However, the same general approach both to sampling and use of geometrical probes can be applied to individual objects. Over recent years this approach has become known as ‘single-object’ stereology. An excellent review of the mathematical basis of single-object stereology and its relationship with classical stereology is provided by Cruz-Orive (1997).

Although previous examples of stereological techniques have been primarily about microscopic features and objects, candidates for study by single-object stereology can have a large range of sizes. For example, individual neurones less than 100 μm in diameter (Howard et al., 1993; Yaegashi et al., 1992), anatomical features of insects less than 1 mm in diameter, the length of roots of plants grown in hydroponic solution centimeters in length (Kubinova et al., 1999) and whole human body scale (Roberts et al., 1993).

Among the enabling technologies that make single-object stereology possible is a whole range of non-destructive imaging methods that are now commonly available. These include confocal microscopy, high-resolution conventional light microscopy, X-ray microtomography, magnetic resonance microscopy, MRI whole-body imaging and ultrasonography.

For single-object stereology relevant parameters for estimation are total feature length, surface area and volume. In most cases we need to employ a set of probes distributed through a 3D volume to obtain our estimates. For example, we have already described in some detail in Chapter 3 the Cavalieri method which is the most commonly used ‘single-object’ method for estimating object volume. In the Cavalieri method the set of parallel plane sections that are used to intersect the object occupy a 3D space that is larger in extent than the object being examined (e.g. Figure 3.1).

To obtain unbiased estimates with single-object stereological methods the probe must always be uniform random in position. In addition for estimating length and surface the probes must have isotropic orientation. While probes for global stereology are usually applied to single sections, or in the case of the physical disector pairs of sections, the word ‘probe’ in the context of single-object stereology normally indicates a ‘stack’ of sections registered in 3D space ( Figure 2.10 ). As discussed in the chapters


Page 166

on number estimation and particle sizing the sampling of objects prior to measurement needs some thought (Section 9.1). This is true both for discrete objects (human body, individual insects, pieces of material) and objects embedded within a matrix (neurones within the brain, metallic inclusions within an alloy). The methods used for fair sampling of macroscopic objects are well described (e.g. Stuart, 1984). With embedded objects the disector method and its variants, described in Chapters 5 and 9, are the basic sampling methods.

In recent years a number of techniques have been described for single-object stereology that make use of computer-generated Virtual probes’ linked to scanning optical microscopes. Examples include the unbiased brick (Howard et al., 1985), the spatial grid (Sandau, 1987), the vertical spatial grid (Cruz-Orive and Howard, 1995), the ‘Fakir’ method (Cruz-Orive, 1993; Kubinova and Janacek, 1998).

11.2 Volume of single objects—arbitrary orientation designs

This subject has been covered in great detail in Chapter 3. The Cavalieri principle can be applied to uniform random sections through a 3D object to give a high-precision estimate of object volume. The basic approach is to sum the cross-sectional areas on an exhaustive stack of serial sections. However, in our general explanation of the technique in Chapter 3 it was not a requirement that the sections should be perfectly registered. In addition, the examples we provided were all based on physical sections through the object.

Here we introduce the concept of a ‘stack probe’, composed of a registered stack of sections obtained with a non-destructive scanning technology, such as MRI or confocal microscopy. A ‘stack probe’ can be used to estimate volume using the spatial grid of points variant of the Cavalieri method ( Figure 11.1 ). By thinking about such a ‘stack probe’ in applying the Cavalieri principle, this will form the basis for then extending such 3D ‘stack probes’ to the measurement of surface and length.

Figure 11.1 shows a spatial grid of points embedded in an object. For the application of the Cavalieri estimator described in Figure 3.3 , the uniform random position of the points was achieved in two steps. For a spatial point grid such as shown in Figure 11.1 the uniform random position must be achieved in a single step. That is to say the first plane of points must be UR with respect to the object in x, y and z. Thereafter, the remainder of the systematic probe will automatically be UR. In such a lattice of points it is easy to visualize the size of the ‘structuring element’, VP, i.e. the volume associated with each point. The volume of the object is simply the number of points in total that land within it multiplied by VP.

The exercises for the Cavalieri estimator will not be repeated here but you should perhaps re-consider the exercises that were presented in Chapter 3. It should be noted that the spatial grid of points used to estimate volume can be the vertices or intersections of a spatial linear grid.

Another method for estimation of volume that has been used in single-object Stereology is the Pappus method. This method requires images that are co-axial sections taken through the vertical axis about which an object has been randomly rotated. This has been used to estimate bladder volume using ultrasound (Cruz-Orive and Roberts, 1993) and to estimate eye volume in both fish and rats (Reed et al., 2002). If the object is rotated around an axis of rotational symmetry then the estimator is highly efficient and a single co-axial section can be used. The related rotator (Jensen and Gundersen, 1993) and optical rotator (Tandrup et al., 1997) are used for estimation of mean particle volume.


Page 167

Figure 11.1

An illustration of a spatial grid of points in three-dimensional space that has been randomly translated in the x, y and z directions with respect to a fixed 3D object. The volume associated with each point in the grid is denoted by V. A number of points intersect the object (i.e. lie within it) and this number multiplied by the volume associated with each point is an unbiased estimate of the object volume. Note that if the grid point marked Z is randomly located within the volume V then all other points in the grid will be randomly located with respect to the object. Figure used with kind permission of Prof. Luis Cruz-Orive and Journal of Microscopy.

11.3 Surface of single objects—isotropic or vertical orientation designs

The isotropic ‘spatial grid’

We described in Chapter 6 how a set of isotropic uniform random (IUR) lines in 3D space can be used to estimate the surface area of an interface. The critical aspect of the estimation is that the lines have been generated in such a way that all possible orientations of the lines in 3D space were equally likely. When estimating the surface area of a single object this requirement cannot be relaxed. Methods for orienting an object isotropically are mentioned in Section 7.1.

The spatial grid of points shown in Figure 11.1 can be transformed into a spatial grid of lines by connecting all orthogonally adjacent points with lines, as shown in Figure 11.2. The length of line associated with each point in the grid is indicated. Clearly the whole grid needs to be both isotropic and UR with respect to the single object. Thus while for volume estimation the spatial grid of points in Figure 11.1 needed only to be UR with respect to the object in x, y and z, for the spatial grid of lines there is an additional requirement that the first plane of the grid must in addition be isotropic. Then the remainder of the systematic grid will automatically be IUR.


Page 168

Figure 11.2

A spatial grid of line probes is generated by joining all points in a 3D point grid with their orthogonal neighbors. The length of line associated with each point where lines in the grid cross is shown and is equal to x plus y plus z units. Figure used with kind permission of Prof. Luis Cruz-Orive and Journal of Microscopy.

The isotropic spatial grid method was proposed by Sandau (1987) and was designed to estimate the surface area of an arbitrary object from a stack of registered serial sections. The method was used by Howard and Sandau (1992) to estimate the surface area of an isolated cell using confocal microscopy. The method is based on the classical stereological relationship given in Equation 6.3

(11.1)

Rearranging the preceding equation we get, for a bounded surface S

(11.2)

where l/v is the mean test line length per unit test volume (Figure 11.2) and I is the total number of intersections between the spatial grid of lines and the object’s surface.

Sandau (1987) proposed the use of a 3D system of test lines in which the structuring element or ‘box’ was a rectangular prism of side lengths lx, ly and lz. For this test system

(11.3)

If the position and orientation of the test system with respect to the object is IUR, then an unbiased estimator of the total surface S is:

(11.4)

where Ix, Iy and Iz denote the total number of intersections between the surface and the test lines in the x,y and z directions respectively.

Figure 11.3a shows a schematic diagram of an apple intersected by an IUR spatial linear grid. Three perfectly registered x,y planes that intersect the apple are shown.


Page 169

Figure 11.3

A schematic drawing of an apple intersected by a spatial grid such as that shown in Figure 11.2. The positions where the grid lines intersect the surface of the apple are illustrated. Reprinted from Methods (previously Neuroprotocols: A Companion to Methods in Neurosciences), Vol 2, Howard et al. ‘Measurement of total neuronal volume, surface area, and dendritic length following intracellular physiological recording.’ pp 113–120, © 1993, with permission from Elesevier.

The number of intersections between the spatial grid and the surface of the apple are as follows.

Direction | Counts
x | 10
y | 12
z | 8

Now we need to imagine that the whole apple is not visible and that the planes represent optical sections.

In practice the spatial grid is generated as a ‘virtual probe’ (Howard and Sandau, 1992). Consider a 2D rectilinear grid with lines in x,y as it is scanned through space in a direction orthogonal to the plane of the grid. The loci of the points at the x,y intersections in the grid describe a set of ‘virtual’ lines in the z direction. The assemblage of x, y and z lines is a 3D spatial grid. Therefore a spatial grid can be created in the microscope by scanning a 2D grid down through an object on a series of systematic ‘optical’ sections ( Figure 11.4 ).

To estimate the surface area of the apple ‘down the microscope’, it is necessary to count the number of intersections of the 3D spatial line grid with the surface of the apple, in x, y and z. While it is easy to realize the counts in x and y, the trick for counting in z is less obvious and was first described by Sandau (1987). Each of the intersections


Page 170

between the x and y grid lines is a grid point. Each grid point can be considered as the ‘end on’ view of a line travelling in the z direction ( Figure 11.4 ). Therefore when any grid point moves from ‘outside’ a transect of the object to ‘inside’ or vice versa, while moving from one section to the next, then that particular line in the z direction must have penetrated the surface of the object. Thus a total count of the intersections of the z-axis lines of the grid with the object can be obtained by tracking whether grid points on a perfectly registered set of sections, move either from ‘in’ to ‘out’ or from ‘out’ to ‘in’.

While this is a relatively simple task to both appreciate and perform in a simply shaped object such as an apple, as shown in Figure 11.3 , for more complex non-convex shapes the task can become very tedious and, under such circumstances, can be greatly assisted by the use of interactive software. The preferred method is to make the grid points respond as a color-coded toggle switch. If the mouse is clicked with the cursor near to a grid point the color of that point changes. If it is clicked again, then the color reverts to what it had been. Therefore when an optical section is scanned down through an object initially, on the first section that hits a transect of the object, all grid points are toggled to the alternative color to represent a change of status from ‘out’ to ‘in’. As the optical section moves to its next systematic position in z, the

Figure 11.4

An x–y plane carrying four lines arranged in a rectangular grid is shown. The plane has been moved smoothly downwards through the z direction. In so doing the grid crossing points have swept out a set of lines in 3D space that are perpendicular to the grid on the x–y plane. The spatial grid thus formed is a virtual probe, in the sense that the movement in z was required to generate it. Reprinted from Methods (previously Neuroprotocols: A Companion to Methods in Neurosciences), Vol 2, Howard et al. ‘Measurement of total neuronal volume, surface area, and dendritic length following intracellular physiological recording.’ pp 113–120, © 1993, with permission from Elesevier.


Page 171

pattern of toggled grid points is retained as an overlay. Now, for each grid point there are three possible actions:

1. If the status of the grid point has not changed, i.e. if it was ‘in’ and remains ‘in’ or if it was ‘out’ and remains ‘out’ then no action is taken.

2. If a grid point was outside any transect of the object on the previous section but is now inside, then it should be toggled to ‘on’.

3. If a grid point was inside any transect of the object on the previous section and is now outside, then it should be toggled to ‘off’.

To ensure that the process leads to a count of all intersections in x, y and z, there must be an ‘empty’ section both above and below the object. The software can then interpret the number of toggled changes of status on grid points to give a total count of intersections of lines in z of the spatial grid and the object. The use of an interactive software approach, such as that described above, removes the need for the operator to have to memorize the status of every grid point from one section to the next. There are a number of commercial software packages now available which provide this toggling approach (e.g. EasyMeasure www.easymeasure.co.uk).

In order to clarify how the spatial grid is applied we have worked through an example below. Figure 11.5 is a set of 18 perfectly registered optical confocal sections through a single Golgi stained neurone and its proximal neurites (Howard et al., 1992). The neurone is also used in a length estimation exercise below and is shown in Figure 11.7. Note that the stack of sections also includes an empty section above and below the neurone. On each micrograph a grid has been superimposed and the grids are all perfectly registered with each other in the z direction.

The first task is to calibrate the spatial grid in both the x–y plane and the z direction. The distance between grid lines we measured to be 11.1 μm, and the distance between each micrograph, in the z direction is 3 μm. Using equation 11.3 we get a grid constant l/v of

Next we counted the intersections of the lines of the spatial grid in the x, y and z directions, according to the description given above and recorded them in the following table.

Section number | lx | ly | lz
1 | 0 | 0 | 0
2 | 24 | 20 | 5
3 | 10 | 8 | 5
4 | 2 | 4 | 1
5 | 4 | 2 | 3
6 | 2 | 4 | 2
7 | 2 | 0 | 0
8 | 6 | 6 | 2
9 | 4 | 4 | 1
10 | 6 | 4 | 0
11 | 6 | 6 | 1
12 | 6 | 6 | 1
13 | 6 | 6 | 1
14 | 4 | 6 | 0
15 | 4 | 6 | 0
16 | 2 | 4 | 2
17 | 0 | 2 | 0
18 | 0 | 0 | 0
Totals | 88 | 88 | 24


Page 172

Figure 11.5

A complete series of serial sections obtained from a single Golgi-stained neurone. The stack comprises an empty ‘guard’ section above and below the sections that intersect the neurone. On each section is a rectangular line grid that is exactly co-registered on each section. The crossing points in the line grid on each section thus lie on sets of parallel lines running perpendicularly into the plane of the paper. Each section is 3 μm apart.


Page 173


Page 174


Page 175

The surface area of the neurone is then estimated by using equation 11.4.

In practise there are a number of issues that need to be resolved in order to apply the spatial grid. For example, the distance between sections needs to be matched to the complexity of the surface of the object being analysed. Simple convex shapes such as roughly ellipsoidal objects require far fewer sections to get a precise estimate compared with something as complex as the neurone described above. In common with other estimators of surface area the effect of image resolution also needs to be considered. These issues are perhaps best resolved by carrying out a small-scale pilot study prior to full analysis.

It should be noted that the set of grids used for surface estimation can also be used to estimate the volume of the neurone by the Cavalieri method. This is left for the reader to try as an exercise.

The vertical spatial grid

The advantages of ‘vertical’ designs over isotropic designs have been extensively discussed in Chapter 6. Most laboratories performing routine stereological analysis use vertical designs as a default. This leaves a problem for those that wish to pursue measurements of single objects embedded in blocks of tissue that have been ‘vertically’ sampled.

There is a version of the spatial grid which can be used in vertical designs. Its first description in theory was by Cruz Orive and Howard (1995), who recognized that it would be impossible to use without the aid of computer graphics and therefore provided an algorithm to aid implementation. A good software realization has since been achieved by M.Puddephat (www.easymeasure.co.uk).

The principle of the vertical spatial grid will already be partially familiar to the reader. Systematic grids of cycloids with their minor axes parallel to the known vertical direction must be applied to the systematic optical sections. As the optical section moves through the object in the z direction, the cycloidal test system in the x,y plane has to ‘ride’ on cycloids travelling in the z direction, which also have their minor axes parallel to the known vertical direction. The problem is to determine the number of intersections between the vertical spatial grid in the z direction and the object. The solution is essentially the same as that developed in software for the isotropic spatial grid using a toggling system.

When implemented in software, movements of the optical section in z have to be accompanied by vertical shifts up or down the screen, of the cycloidal test system. The actual position depends upon the location of the optical section on the z-orientated cycloids. The total vertical distance that the x,y cycloidal test system will have to travel up or down on the screen is the height of the minor axis of the cycloids. The fact that the points on the x,y grid will move in location between one optical section and the next adds a further level of complexity in tracking whether they move ‘in’ or ‘out’ of transects of the object. This can only be achieved by the use of a software/ hardware-based intersection toggling system, as described above for the isotropic spatial grid. The software needs to be interfaced electronically to a precise z-positioning reporter system, such as a microcator.

11.4 Length estimation in vertical orientation designs

Length density

In thin sections length density can only be estimated unbiasedly from IUR sections, as described in Chapter 7. However, a method of estimating length density in ‘vertical


Page 176

slabs’ of a known thickness does exist (Gokhale, 1990). The method requires that sections of known thickness are available which are thin enough to provide transmission images that contain all the linear features within the section thickness. There are two key concepts that are required to understand this method.

Projecting a space curve in 3D onto a 2D plane

Consider Figure 11.6. This shows a thick VUR slab of material containing some linear features travelling in 3D space of length density Lv. If we viewed this slab in a light microscope, using a low-power lens, we would see linear features from the whole thickness of the slab in focus. For example, the space curve in 3D shown in the slab in Figure 11.6 is seen in projection as a set of linear features on the 2D ‘shadow graph’ plane immediately behind it.

Figure 11.6

A vertical uniform random slab is shown with the known vertical axis marked. Within the slab there are some real linear features and a ‘virtual’ cycloidal surface of area A, which is given by the slab thickness h multiplied by the edge length l. One of the intersections between the linear feature and the cycloidal surface is marked Q. In addition the projection through this slab is shown. On the projected image the intersections that occur between the cycloidal surface and linear feature within the slab are seen as intersections between the cycloid line and the projected linear feature. One of the intersections between the cycloid line and projected linear feature is marked l. Figure used with kind permission of Prof. Luis Cruz-Orive and Journal of Microscopy.


Page 177

Simulating a cycloidal surface in 3D by projection of a 2D test system

If we place a cycloidal test system onto the front face of a slab and projected it through the slab we would simulate a virtual cycloidal surface within the slab.

Now if we combine these steps we can quantify the number of intersections in a slab between a virtual cycloid surface and the real 3D space curve purely by considering what we see on the projection plane ( Figure 11.6 ).

In order to apply this there are two key details. Firstly, the slab should have been generated by a vertical uniform random sampling design in which the vertical direction should be known. Secondly, the cycloids projected through such a slab have to be oriented with their long axes parallel to the known vertical direction. You will note that this cycloid orientation is different to that required for surface estimation, see Gokhale (1990) for a full explanation of this difference.

The result of using the above scheme is that we have generated an isotropic surface within 3D space and intersected with a set of space curves of arbitrary orientation. Gokhale (1990) uses this fact and the classical method for estimating length density with isotropic sections described in equation 7.2 to derive the following estimator of length density

(11.5)

where t is the slab thickness and IL is the number of intersections between the cycloidal test system and the projected linear features. The reader is referred to Batra et al. (1995) for an excellent example of the practical application of this method.

Total feature length

There are many occasions in microscopy when it is difficult or impossible to know the section thickness t as required in equation 11.5. Additionally there are often sound scientific reasons for wanting to know the total length of a linear feature. Cruz-Orive and Howard (1991) proposed that in a ‘vertical’ projection of unknown thickness containing a complete space curve, the total length of the space curve could be estimated, as an extension of the approach of Gokhale. For an example of the concept see Figure 11.7 , which shows a vertical slab containing a single neurone with its dendritic tree. A cycloidal test system is also shown being projected through the slab to generate virtual cycloidal surfaces. Note that because the slab contains the whole dendritic tree the total length can be estimated directly without knowing the slab thickness t. In addition to total length the length of a feature per object can also be estimated from a slab of unknown thickness. In this approach both Lv and Nv are estimated and their ratio taken (Cruz-Orive, 1997; Howard et al., 2004).

In order to apply the total vertical projections method of Cruz-Orive and Howard (1991) we require a series of images that are projections of the whole curve with the projection plane being vertical and the curve rotated randomly around the vertical direction. For example, consider Figure 11.8 , which shows a series of projections of a twisted wire of length 30.7 cm. The first projection was obtained by randomly rotating the wire and the remaining six by systematically rotating the wire by 30°.

On each projection image a cycloidal grid, which has its longest axes parallel with vertical direction, is randomly translated. The number of intersections between the cycloidal test system and the curve is recorded. The total length of the curve is then estimated from

(11.6)


Page 178

Figure 11.7

An illustration of how the total vertical projections method can be applied to estimate the total length of dendrite associated with the sampled neurone. A set of cycloids has been projected through the slab, of unknown thickness h, to generate a set of virtual cycloidal surfaces. The number of intersections between these virtual surfaces and the dendrites gives an unbiased estimate of dendrite length. Reprinted from Methods (previously Neuroprotocols: A Companion to Methods in Neurosciences), Vol 2, Howard et al. ‘Measurement of total neuronal volume, surface area, and dendritic length following intracellular physiological recording.’ pp 113–120, © 1993, with permission from Elesevier.

where a/l is the reciprocal of the test grid constant length of cycloid per unit area (l/a) and I is the number of intersections.

Using the example given in Figure 11.8 the following intersections were recorded.

Rotation angle/degrees | I
10 | 22
40 | 19
70 | 18
100 | 16
130 | 22
160 | 20
Total | 117


Page 179

Figure 11.8

A systematic sample of six vertical projections of a twisted wire. The straight stippled piece of wire represents the vertical axis about which the wire was rotated by increments of 30°. The cycloid grid used to estimate the wire length is shown randomly translated over the 10° projection. Note that the major axis of the cycloid grid is parallel with the vertical axis. Figure used with permission of Journal of Microscopy.

The grid constant a/l for the cycloidal test system was 0.132 cm at the magnification used. The total length of the wire was then estimated as

The variability in this type of estimator is found to be surprisingly low, it can be calculated from the data using the method developed by Gual-Arnau and Cruz-Orive (2000).


Page 180

Exercise 11.1

AIM

The aim of the exercise is to estimate the total length of all neurites from the projection of a single neurone. This was made from reconstructing serial confocal optical sections through a Golgi-stained neurone (Yaegashi et al., 1993). Figure 11.9 shows a series of vertical projections of the reconstructed neurone with a rotation angle of 30°. The series has been split such that Figure 11.9a has rotation angles 0°, 60° and 120° and Figure 11.9b rotation angles 30°, 90° and 150°.

PROCEDURE

Make two separate estimates from Figures 11.9a , b.

Figure 11.9

Six systematic vertical projections of a 3D reconstruction of a Golgi stained single substantia nigra neurone obtained from confocal optical sections (Howard et al., 1992). Figure used with permission of Acta Neuro Scand.


Page 181

1. Photocopy grid C1 onto acetate and place it with uniform random x,y translation over each projection in turn, ensuring the major (long) axis of the cycloids is parallel to the indicated vertical axis.

2. Count the number of intersections of the cycloids with the neurites of the cell. An ‘intersection’ occurs when the cycloid (choose one edge, e.g. the left-hand edge) crosses the imaginary central spine of the neurite. Note that this can be achieved in one of two ways, either try to estimate where the central spine is or, alternatively, count each intersection of the cycloids with an edge of a neurite and then divide the final total by 2. We recommend the second method. If the intersection occurs over a position where one neurite is passing behind another one, then extrapolate the number of hits that would have occurred had the ‘masked’ neurite been directly visible.

3. Use the scale bar on Figure 11.9a to calibrate the cycloidal grid and estimate a/l.

4. Apply Equation 11.6 and estimate total neurite length.


Page 182

This page intentionally left blank.


Page 183

12
‘Petri-metrics’

Contents

12.1 Introduction | 183
12.2 Counting methods | 183
12.3 Length estimation in 2D | 187
12.4 Combined length and number estimation | 189
Exercise 12.1 | 191
Exercise 12.2 | 193

12.1 Introduction

As we have stressed in the previous chapters the word stereology implies measurement in 3D. Therefore it is something of a tautology to discuss ‘2D stereology’. However the application of survey sampling techniques in 2D to common biological problems makes good sense and, in passing, can teach a lot about the way that these methods can then be applied in 3D in a true stereological setting (Miles, 1978).

Many 2D in vitro culture techniques require quantitation for the results to be useful. Common examples include colony counting in bacteriology and mycology, cell counting in cytology and carcinogenesis, angiogenesis assays and neurite outgrowth assays in toxicology. In addition there is a considerable literature on counting axons in single transverse sections of peripheral nerves. Although 2D in vitro methods are much more amenable to automatic image analysis than 3D tissue histology, many methods continue to be carried out manually in routine toxicology screening tests. The application of a stereological sampling approach in 2D to such assays can make enormous savings in time without loss of accuracy, whether applied manually or by automatic image analysis.

In the following we will talk about Petri dishes simply as a shorthand to represent the bounded 2D space in which your objects are contained.

12.2 Counting methods

The 2D fractionator

A Petri dish can contain many hundreds of cell colonies. One way of discovering how many there are is to use ‘brute force’ and count them all. It should be noted that no sampling has taken place and therefore we obtain an identity, i.e. the actual number, provided that no miscounting has taken place. In comparison any sampling method will end up with an estimate and this comes with some degree of ‘uncertainty’. However the level of this uncertainty can be very low indeed if correct sampling methods are used.

The concept of the fractionator is explained in Sections 5.15–5.17 and illustrated in Figure 5.17. The essence of the technique is to count exhaustively everything within a ‘known’ fraction of the Petri dish or object (Gundersen, 1986). As long as the fraction has been generated with a suitable random sampling protocol the


Page 184

Figure 12.1

A diagram indicating how a two-dimensional fractionator grid is generated. In (a) a square unbiased counting frame of side length 1 unit is shown within a square of side length 5 units. The counting frame thus covers 1/25th of the area of the larger square. If the larger square is tesselated to form a grid of counting frames (b) the total area of the whole grid occupied by counting frames is also 1/25th of the total—in other words there is an area sampling fraction of 1/25.

resulting estimate of total quantity is unbiased. In a 2D setting one way to achieve this fractionator design is by throwing an array of 2D unbiased counting frames (Gundersen, 1977) onto the object, with uniform random position.

This is illustrated in Figure 12.1a. The essential aspect of the grid design that we need to know is the area-sampling fraction, i.e. the proportion of each unit area that is covered by some portion of a sampling frame. For example, an area-sampling fraction of 1/25th is obtained by placing a square unbiased counting frame of side length 1 unit at the centre of (for convenience only) a square of sidelength 5 units (i.e. area of frame=1×1=1 units squared and area of square=5×5=25 units squared).

In practise we need to tesselate (i.e. cover space) each of these squares with its associated counting frame, see Figure 12.1b. Because we add the same proportion of sampling frame to each additonal tesselation of the square the total area of the counting frames in the tessellated set is still 1/25th of the area of the total tessellation. The fraction of the tesselation occupied by unbiased counting frames (in this case 1/25th) is called the area-sampling fraction (asf).

This tessellation is thrown over a 2D area at random and a count is made of all 2D objects sampled by any of the unbiased counting frames. This count multiplied by 1/asf is an unbiased estimate of the total number of 2D objects! Figure 12.2 is an exercise for you to complete, using the sampling frame F5.

Step 1. | Throw an acetate version of grid F5 with random translation and at an arbitrary angle over Figure 12.2.
Step 2. | Count all ‘blobs’ that are sampled in any of the counting frames according to the unbiased counting rule that is carefully and fully explained in Section 5.7.
Step 3. | Multiply this number by 25.
Step 4. | Repeat until convinced!

In our experience the apparent simplicity of this 2D fractionator approach causes some disbelief. However, it should be noted that there is nothing missing in the method and there is no trick. You did not need the magnification nor any calibration step. The method is based purely on sampling theory!


Page 185

Figure 12.2

A 2D object containing a number of ‘blobs’. The total number of blobs can be estimated using the fractionator grid F5 shown in Appendix B.

Practical application at the microscope

In applying the 2D fractionator principle at the microscope we will not use a grid to obtain a known sampling fraction but instead make an x–y raster over the whole object in x-steps and y-steps of known size. This can usually be achieved with a manual graduated stage or with a programmable electronic stage. Within the microscope image, either as a graticule or superposed on a video screen, is a single unbiased sampling frame. In this application the asf is then the ratio of the area of an unbiased counting frame at the scale of the object to the area of the ‘domain’ of one counting frame. This can be seen in Figure 12.3 where the area of the domain of one counting frame is simply the product of the known x-step size and y-step size. Readers should note that they have met this set up before as part of the optical fractionator (see Figure 5.19b).

The whole area of the Petri dish must be sampled in a uniform random manner. This requires a starting point that is random with respect to the dish. In practise if a starting point ‘outside’ the dish is selected with random numbers and the dish is then ‘stepped’ across in a predetermined x,y meander, then each stopping point will be systematic uniform random within the Petri dish. At each stopping point the


Page 186

number of objects captured by the unbiased counting frame, Q, is counted and added to a running total, ∑Q, for all frames hitting the reference space. The total number of objects, Ntotal, in the Petri dish is estimated by:

(12.1)

Although this method can be applied using a suitably graduated manual stage, there is no doubt that a programmable motorized stage does make the task very much easier and must be considered if it is intended to use this method routinely.

To optimize the sampling regime you will need to try out a number of area sampling fractions. In practise the following steps need to be observed. Firstly, choose a magnification at which you can unambiguously identify the smallest of the objects of interest. Secondly, choose an unbiased counting frame size such that if the objects were closely packed together you would count no more than about three to five objects per frame. Finally, adjust the size of the x and y steps in the raster to obtain an overall area-sampling fraction such that your total count of objects ∑Q is, in the first instance, between 100 and 300. Depending on the variability between Petri dishes it may be possible to settle in the final design on a lower count.

There are many possible variations on the above design. For example, each field of view could contain multiple small frames, in which case the area-sampling fraction needs to take account of the total frame area used for counting per x–y step. Another variation might be to use both small and large frames simultaneously to count common and rare objects respectively.

The counting of particles in 2D continues to be an area of research interest. For example, recent papers by Mayhew and co-workers (Mayhew et al., 2002, 2003,

Figure 12.3

Implementation of the 2D fractionator at the microscope. In this design the sampling fraction is calculated from the area of the unbiased sampling frame in real units divided by the area of the stepping area (obtained by multiplying dx by dy). The stepping distances dx and dy can be generated easily using either electronically or manually driven stepping stages in a light microscope. It should be noted that counts should be obtained from any part of any of the unbiased sampling frames that overlay the ‘Petri dish’.


Page 187

2004) describe the application of 2D counting methods for colloidal gold particles in immunogold EM experiments.

12.3 Length estimation in 2D

The theoretical basis of the methods described in this section were first introduced in Section 2.9 and are based on the Buffon (1777) principle. In this section we will firstly describe a number of simple variants on the Buffon method for estimating total length, then describe the fractionator version of the Buffon principle for application to a Petri dish situation.

Examples of application areas for this estimator include assays assessing the degree of neurite outgrowth in neurone cultures, vessel growth in angiogenesis studies and the growth of fibrous mycelia in fungal growth. Any model that produces structures that are linear and which lie in the plane of the dish is amenable to this approach.

With reference to Figure 2.16 the Buffon approach is to use a linear grid which has a known interline spacing, T, and thus a known relationship between area and length of test line. This grid MUST be randomly rotated as well as randomly translated over the object. The estimate of length is then obtained by simply counting the number of intersections between the grid and the linear feature and multiplying by π/2 times the grid constant a/l.

In the case of a simple set of parallel lines of spacing T units the grid constant a/l, which has the dimension of length, is given by the area of test system per unit length, i.e. T2/T=T units. For a rectilinear grid of spacing T units, e.g. Grid L2, the grid constant, a/l, is T2/2T=0.5T. For example, Figure 12.4a shows a linear feature within a bounded object superposed with a rectilinear grid of spacing T units. There are 28 intersections between the feature and the lines of the grid, giving an estimate of total length of 14×π/2×T units.

In practise the need to randomly rotate the grid for each estimate of length is tedious. A more efficient solution is to use a grid that has a linear test system that has

Figure 12.4

This figure shows a linear feature within a bounded object. In both (a) and (b) the object has been superposed with a sampling grid for length estimation. In (a) we show a rectilinear grid of spacing T units that has been randomly rotated and translated. In (b) a more efficient solution is shown that uses a linear test system with built in isotropy—the well-known Merz grid.


Page 188

isotropy built in. This condition is met in 2D by the use of circles, e.g. the well-known Merz grid as shown in Figure 12.4b. In this figure there are 27 intersections between the test grid and linear feature. The grid constant, a/l, for a Merz grid is arrived at by considering Figure 12.5. The area of each basic tile of the grid is d multiplied by 2d. Within this basic tile is a semicircle of length πd. Thus the grid constant a/l is simply 2d/π units.

In the two examples in Figure 12.4 the whole of the object is covered by the grid and thus by definition we get an estimate of total length. However, in most practical situations it will be necessary to sample by fields using the microscope. Under these circumstances we can apply a variant of the 2D fractionator to achieve an estimate of total length. This is a single-stage estimate and does not require independent estimates of length per unit area and total area to be made. It does however require an estimate of the linear magnification being used.

Consider a sampling design such as the one shown in Figure 12.3a. The basic tile of the system has area of x multiplied by y square units. Within each field of view observed through the microscope at each stopping position there is a Merz test grid, which has a grid constant, a/l, which has been estimated directly from comparison with a graticule imaged under the same conditions as the sample of interest. Taking a random start outside the object an exhaustive x–y scan is made across the Petri dish and the total number of intersections between the Merz grid and the linear features of interest are recorded and summed, ∑I, from these values the total length L is estimated by

(12.2)

where asf is the area of the Merz grid divided by the area of the basic tile (x·y). Figure 12.5 shows a basic unit of a Merz grid, of height d units and width 2d units. The length of the line in this grid is πd units. The grid constant a/l is thus 2d/π units. Note that although this ‘grid’ is minimal, i.e. composed of only two semi-circles, if it was tiled on the plane, the grid constant would be the same for the whole grid as it is for this minimal part of it. Thus the fractionator principle allows us to arrive at

Figure 12.5

The grid constant, a/l, for a Merz grid is obtained as follows. The area of each basic tile of the grid is d multiplied by 2d. Within this basic tile is a semicircle of length πd. Thus the grid constant a/l is simply 2d/π units.


Page 189

equation 12.2. If we were to tile the whole Petri dish with a line grid at the same dimension as the small portion we see in each field of view, we would estimate the total length. However, we only see an areal fraction of the whole Petri dish, and thus the reciprocal of this fraction multiplied by the number of intersections and known grid constant gives us a fractionator estimate of the total length.

12.4 Combined length and number estimation

In the case of differentiating neurones, where their trees overlap, it is sometimes desirable to obtain an estimate of the average neurite length per neurone or additional information about the topology of the tree. This can be achieved by combining the 2D number and length fractionators described above.

Figure 12.6b shows a neuroblastoma cell culture as used in McLean et al. (1999). Mouse NB2a neuroblastoma cells were placed in serum-free medium containing 0.5 mM dibutyryl cyclic AMP to induce differentiation. Differentiation led to the growth of neurites by the cells. After 24 h, cells were fixed in 4% w/v formaldehyde and stained with Coomassie Blue stain (0.6% Coomassie Brilliant Blue G in 10% (v/v) acetic acid, 10% (v/v) methanol in phosphate-buffered saline). Cells were viewed in a Zeiss Axiovert 35M microscope on PH1, ×20. The full-field width of the image is 315 μm. The image is one of a series that has been taken with a 1 mm by 1 mm step length.

Superposed on one of the images is a test system composed of two elements. A counting frame of width 232 μm and height 112 μm. Thus the area-sampling fraction for number estimation is

Figure 12.6

(a) A composite length and number estimation frame for use in ‘Petrimetrics’ applications. (b) Image of mouse NB2a neuroblastoma cells after serum-free medium incubation containing 0.5 mM dibutyryl cyclic AMP to induce differentiation. Differentiation led to the growth of neurites by the cells. After 24 h, cells were fixed in 4% w/v formaldehyde and stained with Coomassie Blue stain (0.6% Coomassie Brilliant Blue G in 10% (v/v) acetic acid, 10% (v/v) methanol in phosphate-buffered saline). Cells were viewed in a Zeiss Axiovert 35M microscope on PH1, ×20. The full field width of the image is 315 μm.


Page 190

On the same micrograph is a Merz grid of width 103 μm. This gives an area-sampling fraction for length estimation of

and a grid constant a/l of

We count 16 cell bodies within the unbiased counting frame and four intersections between the Merz grid and the neurites. This is clearly a very small sample for illustrative purposes, however from these data we estimate the total number of cells in the dish, N, is 615 and total neurite length, L, is 38400 μm giving an estimate of neurite length per neurone of 62 μm.


Page 191

Exercise 12.1

AIM

The aim of this exercise is to estimate the total length of neurite and number of neurones using images of mouse NB2a neuroblastoma cells prepared as per caption of Figure 12.6.

PROCEDURE

1. Copy the combined Merz grid and counting frame shown in Figure 12.6a onto a transparency. Using the scale information that full width of each micrograph is 315 μm and step length is 1 mm by 1 mm calculate the area-sampling fraction for number estimation, asf[N], the area-sampling fraction for length, asf [L] and the grid constant a/l.

2. Throw the grid randomly within central portion of each of the three images in Figure 12.7a , b , c in turn. On each image count the number of cell bodies that are correctly sampled by the counting frame and the number of intersections between the Merz grid and neurites. Using these counts and the area-sampling fractions estimate total length of neurite and total number of neurones within the Petri dish.

RESULTS

Image | Cells in frame N (cells) | Intersections between neurites l (neurite)
a |
b
c
Sum | ∑N (cells)= | ∑l (neurite)=


Page 192

Figure 12.7

A further three images as described in Figure 12.6(b).


Page 193

Exercise 12.2

AIM

The aim of this exercise is to estimate the total number of axons within two fascicles of the trigeminal nerve of a horse. See Mayhew (1990) for details about other applications of this approach. The sections are taken transversely and the estimation is in two dimensions. The sections have been stained with toluidine blue and are shown in Figure 12.8. Myelinated fibres are white profiles with black ring.

PROCEDURE

1. Copy grid F5 from the back of the book onto a transparency.

2. Throw the grid randomly over each of the images in turn. On each image count the number of mylenated fibres sampled by any of the frames. Now multiply by 1/asf (i.e. by 25) to get an estimate of the total.


Page 194

Figure 12.8

Two transverse sections of horse trigeminal nerve. The sections have been stained with toluidine blue and show the myelinated fibres as white profiles with a black ring. Sections prepared by Dr Stacey Newton, University of Liverpool and imaged by Mike Ashton, Intertek Caleb-Brett.


Page 195

13
Second-order stereology

Contents

13.1 Introduction | 195
13.2 Second-order methods for point patterns | 195
13.3 Second-order methods for volumetric features | 198
13.4 The covariance estimator | 199
13.5 Linear dipole probes | 203
13.6 Making sense of covariance | 205
13.7 Example of the application of linear dipole probes | 207
13.8 Using isotropic rulers to get ‘one-stop stereology’ | 208

13.1 Introduction

In this chapter we describe how to use stereology to estimate statistical descriptions of the local spatial arrangement of a phase or tissue compartment. A number of pioneering studies, that we refer to later in the chapter, have shown that in biological systems the spatial arrangement of a tissue compartment may reflect important aspects of growth, maturation and disease. Spatial distribution cannot be summarized by a single number in the way that particle number and surface area can. Instead it requires a graph relating a suitable spatial description versus distance. In our opinion the additional complexity of the information obtained is well worth coming to terms with as it can provide a rich additional source of ideas concerning the way tissues, organs and other materials are structured. Surprisingly, although additional information is obtained, little or no additional practical work is required to obtain the correct type of data.

Stereological methods designed for quantifying local spatial arrangements are known as ‘second-order’ stereology (Cruz-Orive 1989b). Many of the methods have been well known in the image analysis and mathematical morphology communities for more than 20 years (Serra, 1982). Recently we have spent time trying to make second-order methods easy to apply without using image analysis methods. It is that approach which we describe in this chapter. Second-order methods can be used to summarize the spatial arrangement of both discrete objects and continuous phases. In our experience the methods used for discrete objects have to be applied carefully and consideration has to be given to the hypotheses that are to be tested and the practical constraints of the data-collection regime.

In the next section we consider point patterns, mainly to ‘clear the decks’, and caution readers to think carefully before undertaking a study that relies on them. We then move on to the much more fruitful topic of the spatial distribution of volume.

13.2 Second-order methods for point patterns

Consider a collection of discrete objects within an embedding matrix, e.g. neurones within neo-cortical tissue. It is easy to appreciate that the spatial location of each object can be approximated by the location of a point placed at the centre of mass of


Page 196

the object. Once transformed in this manner the spatial distribution of the objects can then be quantified as if it were a three-dimensional point pattern.

There are a large number of methods that are used to statistically analyse the spatial arrangement of point patterns (Cressie, 1993; Diggle, 2003; Ripley, 1981). These methods were originally developed for two-dimensional point patterns but can easily be extended into three dimensions. The statistics that are commonly used for analysis of point patterns include the nearest-neighbor distribution, the empty space function and the K-function. In each case the aim of the analysis is to discern whether the point patterns have a spatial structure that could not be explained simply by having the objects thrown randomly into space. Thus the analysis has an explicit null hypothesis against which the empirical statistic is compared. For example, consider Figure 13.1 , which shows three point patterns each having a numerical density in 2D of 100 points per unit2. Clearly they are qualitatively different in texture. Figure 13.1a shows a point pattern that has been generated by a Poisson process. In generating the pattern, each point has been independently randomly distributed in the square with no reference to any of the points already there. Some of the points can therefore be very close together. This type of Poisson process is widely used as a model of Complete Spatial Randomness (CSR) and is used as the null hypothesis model. Now consider Figure 13.1b , c. These patterns are not Poisson. Both have been generated in such a way that the spatial location of each new point that has been added is influenced by what is already there. In Figure 13.1b the points are more spread out and cover the area more regularly than the Poisson pattern. This pattern type is also known as a ‘hard-core’ pattern. Pairs of points do not get any closer than a fixed hard-core distance. In Figure 13.1c the points are more clustered together than the Poisson pattern, that is, there has been some positive association between neighboring points. Although it is easy by eye to notice the qualitative differences between the three types of pattern shown, the statistics referred to above can distinguish between them quantitatively. For a much more thorough, yet readable,

Figure 13.1

An illustration of three 2D point patterns each containing 100 points within a square of side length 1 unit. The point patterns show three distinct types of spatial arrangement. (a) The points in this pattern have been distributed according to the Poisson process. Each point is uniformly randomly located in x and y with no reference to previous points. This type of point pattern is commonly used as a model of complete spatial randomness (CSR) when analyzing two-dimensional point patterns. (b) The points in this pattern have been distributed by a simple inhibition process. The position of each new candidate point is generated uniform randomly. It is only accepted into the point pattern if it is greater than a fixed distance from all previous points in the pattern. This type of pattern is more ‘regular’ than a Poisson pattern and is also known as a hard-core point pattern. (c) The points in this pattern have been generated to show a clustered behaviour. A small number of parent points are generated with uniform random position. For each of these parents a small number of daughter points are generated close to the parent.


Page 197

introduction to the analysis of 2D point patterns we would recommend the reader to the monograph by Diggle (1983).

All well and good! However, even if one can collect the coordinates describing the locations of objects in 3D it is almost impossible to analyze the patterns qualitatively by eye to decide whether they are Poisson, clustered or regular. Fortunately, although much of the literature on point pattern analysis refers to single examples of two-dimensional patterns, the extension of these methods to 3D point patterns is relatively straightforward. Furthermore, because with 3D problems it is often possible to take replicated samples from the overall 3D pattern, the type of assumptions made in the analysis can be relaxed and some measure of the variability of the spatial pattern can be made (Baddeley et al., 1993).

An early example of the application and extension of 2D spatial statistics to replicated 3D data sets was given by Baddeley et al. (1987). In this paper the spatial distribution of the centroids of osteocyte lacunae (the spaces in bone occupied by cells in life) in four skulls of the same species of monkey was analyzed. Data were collected using confocal microscopy to record the spatial positions of lacunae from ten volumes (or bricks) per animal. The analysis, which was more comprehensively described in Baddeley et al. (1993), indicated that although estimates of the numerical density of lacunae showed large inter-animal variability, the spatial statistics showed a much smaller inter-animal variability. In fact, the spatial statistics were sufficiently low in variation to detect that one of the specimens was different from the other three. Upon re-examination of the gross anatomy of the skull it was found that this skull had been mis-classified and was in fact from a different species!

The raw data required for a 3D point analysis are sets of x, y, z co-ordinates describing the 3D locations of the centres of mass of the objects of interest (e.g. biological cells, foam vertices, grain triple points, etc). In addition to the locations of the objects it is also necessary to record where the edges of the sampling brick are. This additional information is vital, because when estimating a spatial statistic one has to take account of the fact that one only considers the points within a small volume from an extended 3D spatial pattern. Points near the edge of the sampling brick tell us nothing about what the point pattern may be like outside the brick. This problem is known as the ‘edge effect’ (Reed and Howard, 1997). You have already encountered, and overcome, the ‘edge effect’ in 2D when using the unbiased counting frame (Gundersen, 1977).

In addition to the edge effect there are often considerable experimental difficulties associated with collecting reliable point data. Experimental techniques that have been used include physical serial sectioning, X-ray microtomography and confocal scanning light microscopy. If optical or confocal microscopy is used to collect this type of data, the optical properties of the material will dictate the depth over which data can be collected. For example, in a study we carried out in collaboration with the Statistics Department at Lancaster University we recorded the locations of neuronal and glial cells in neo-cortical tissue using high-magnification light microscopy. The use of high NA lenses and methylacrylate embedding allowed us to routinely collect ‘bricks’ of x, y, z dimensions of 70×90×15 microns. The use of an accurate stepping stage allowed us to extend these bricks in their x and y extent by a factor of between two and ten times. However, it was the optical properties of the dense neo-cortical tissue that was the main limit on the z depth. Furthermore, on the basis of computer simulations in ‘bricks’ of the same size as the experimental bricks we found that at inter-point distances above the cube root of the shortest side length of the brick there was a considerable bias introduced into estimates of spatial statistics due to edge effects. Thus for the real tissue we looked at when we estimated spatial statistics for inter-point spacings above about 3 microns the estimates were biased. Given that the


Page 198

cells were about 10 microns in diameter all of the spatial statistics that we estimated included some bias!

On the basis of this and other studies we have carried out we have come to the conclusion that great care must be exercised when collecting 3D point data for spatial statistical analysis. The time and effort required to apply these methods should only be invested when it can be guaranteed that the x, y and z size of the sampling volume is in excess of the inter-point distances of interest, we would suggest that a factor of at least five times would be appropriate. A materials science example where samples of polymeric foams of suitable dimensions have been used for point pattern analysis is given in Reed and Howard (2003).

13.3 Second-order methods for volumetric features

Despite some of the practical difficulties associated with collecting 3D point data it is at least conceptually easy to visualize how collections of points can be arranged in space with different statistical properties. However, for many systems, including particulate systems that could be analyzed with point pattern methods, the most useful way to apply second-order methods is to consider the spatial arrangement of volume. It should be stressed that we are not trying to describe the global arrangement of volume here but the local spatial arrangement of volume at a microscopic scale. To illustrate the difference, consider a fruitcake. A global description of spatial arrangement would answer the question of whether the fruit was mainly at the top, middle or bottom of the cake. A local description of spatial arrangement answers the question of what the local environment of a piece of fruit (e.g. a sultana) looks like—is it mainly occupied by other sultanas or is there an association with raisins? And furthermore, how does this association depend on distance from a point chosen at random within the sultana phase? We describe the analysis of global spatial arrangement of a feature as homogeneity analysis (for an example see Orton 2003) and the analysis of local spatial arrangement as second-order stereology.

Consider now Figure 13.2. In this figure we have generated three artificial 2D patterns, each composed of two phases. In all three cases the total area represented by the gray phase is identical. This means that they have an identical area fraction. However, clearly the patterns are different. The aim of a second-order analysis of this type of pattern, and analogous situations in three dimensions, is to describe how

Figure 13.2

An illustration of three 2D area patterns each containing the same number of gray squares within the same reference area. (a) This pattern shows a large number of spatial discrete squares and ‘snakes’ of width 1 square unit fairly uniformly over the reference area. (b) This pattern shows a smaller number of squares and ‘snakes’ of side length 2 units. (c) This pattern shows an interconnected pattern composed of larger regions with no obvious ‘size’. Note that despite having widely varying spatial arrangements each pattern has an identical area fraction of the gray phase.


Page 199

patterns of the same or similar volume fractions differ in spatial arrangement. In analogy with the point pattern situation illustrated in Figure 13.1 we will also need to define a suitable model of complete spatial randomness. In addition there is a need to consider two different cases: (a) patterns that we know a priori are composed of discrete objects such as biological cells and (b) patterns that are composed of highly interconnected and complexly shaped phases such as porous media and organs such as placenta.

13.4 The covariance estimator

The basic tool used in second-order stereology for volumetric features is the set covariance. This method and its related theoretical framework of mathematical morphology was originally developed by Matheron, Serra and co-workers at the École des Mines de Paris (Serra, 1982). The research was motivated precisely by the problem shown in Figure 13.2—how to quantify spatial structure. It was ‘kick started’ by the appearance in the late 1960s of the earliest computerized image analysis machines. Readers who wish to explore the fascinating mathematical and computational ramifications of mathematical morphology are referred to the recent book by Soille (2003) for up-to-date examples and references.

In this section we describe in simple terms what the set covariance is and describe some simple methods for estimating the set covariance of a 3D structure from suitable 2D sections. In addition to being a well-known technique of quantitative image analysis the set covariance has been well known in the statistical physics literature for more than 40 years, where it is referred to as the two-point probability function (e.g. Torquato, 1998).

There is a close relationship between the covariance and volume fraction and it may be worth re-reading Chapter 4 to refresh your memory on volume fraction estimation. Previously we have described volume fraction as the volumetric proportion of a tissue compartment or phase per unit of reference volume. However, it can also be considered as the probability that a uniform random point that is thrown into the reference space will land within that phase. As discussed in Chapter 4, estimation of volume fraction proceeds by throwing a point grid onto a section and counting the total numbers of points that respectively hit the compartment and the reference space. It pays to think of the points as being sensitive to the volume of the tissue compartment of interest. By simply counting points we have a probe that is sensitive to volume but not its spatial arrangement. In second-order studies we want to retain this sensitivity to volume, but now we need to record not just its presence but also its relative spatial arrangement.

To allow us to develop a probe with volume sensitivity at a distance we need to record not just the total number of points that hit the tissue compartment but also their relative position. One way of achieving this is to use a simple point probe composed of a pair of points separated by a fixed distance h. This probe, which we describe as a dipole, is sensitive to spatial arrangement at a distance h units.

Consider a straight line of length h units. The two end points of the line can be considered to be a single zero-dimensional entity which is especially sensitive to features that have volume at a distance h units apart in 3D space! Each point is independently sensitive to volume, exactly like the points in the volume fraction grid, but in combination the dipole is sensitive to volume arrangement. In order to make a geometric grid sensitive to a particular feature we must, in addition to its inherent geometry, define an unambiguous way of understanding how the grid and feature interact. In practice this means we need to describe a counting rule for how we define an intersection between the grid and feature (e.g. how we define the way a point hits a tissue


Page 200

Figure 13.3

The concept of a linear dipole probe is shown here. (a) A number of lines each of same length has been generated on the area pattern. A dipole is said to ‘hit’ the gray phase if both ends of the line land within the gray phase regardless of what happens in between the ends. Consider the line marked with a star. Both ends of the line land (i) and (ii) land within the gray phase so it is a ‘hit’—even though the central portion of the line goes outside the gray phase. (b) A rudimentary linear dipole probe is shown here of length six times the interpoint spacing of ∆ units.

compartment is a critical aspect of volume fraction estimation). With this in mind let us propose the following rule:

a dipole is said to ‘hit’ a particular phase or tissue compartment if both of the endpoints land within that compartment regardless of whether the line joining the two endpoints stays fully within that same compartment or not (see Figure 13.3a.).

Using this approach we can define the covariance of a volumetric feature at a distance of h units as the probability that an isotropic uniform random (IUR) dipole of length h units hits the feature given that it has also hit the reference space (Reed and Howard, 1999).

Practical estimation could be achieved by throwing a number of IUR dipoles of length h units into the reference space ( Figure 13.3a ). The number of dipoles hitting the reference space DP(ref, h) and the number hitting the compartment Y, DP(Y, h) are then recorded and used to estimate covariance from the ratio

(13.1)

Although a range of dipoles of fixed lengths could be used to estimate covariance this would be inordinately time consuming. In practise it is easier to use a regular point grid and record the positions of all points hitting the tissue compartments. From these raw data a whole range of dipole lengths can be considered. Although quadratic and hexagonal grids have been used a simple linear grid of points, or linear dipole probe, is the easiest device to use ( Figure 13.3b ).

If we divide a line into m segments, each of equal length ∆ units, by a series of n points we can obtain dipoles at discrete distances of ∆, 2∆, 3∆,…, (n−1)∆ units. Thus each application of the linear dipole probe can be used to estimate covariance for a range of distances at the same time. When used in practise, the dipole probe is thrown onto the section such that it has random position and isotropic orientation in 3D space. The phase that each point along the dipole grid lands within is recorded


Page 201

Figure 13.4

An illustration of how to relate a 2D spatial pattern to a covariance plot. (a) A small portion of a two-dimensional spatial pattern is shown composed of a number of black circles of diameter 39 pixels. (b) The covariance estimated from the image. The covariance begins at the value of 0.31 which is the area fraction covered by the black circles. It then rapidly reduces, and at a value of about 23 pixels, indicated by letter R, crosses the so-called reference line given by the area fraction squared (i.e. 0.31×0.31=0.096). After dipping to a minimum the plot then rises above the reference value again and passes a local maximum. At longer distances than those shown the plot will settle down to the reference value which indicates that there is no long range correlation in the pattern.

Values of the covariance below R represent dipole lengths whose ends both lie predominantly within the same circles. At distances between R and about 40 pixels the probability that both dipole ends land within the same circle is low, indicating the gap between the circles. At dipole distrances above 40 the plot again increases indicating a higher probability of both ends of the dipole landing within the black phase, but now in separate circles. This sharp peak actually indicates that there is a ‘preferred’ separation of the circles, i.e. they are not completely randomly arranged on the plane.

as a list. The simplest way of doing this is to use a numerical code, e.g. 0=neurophil, 1=neurone, 2=glial cell, 3=blood vessel, etc., and record, for each point, the code into a lab notebook, electronic text file or spreadsheet. A simple computer program can then be applied to the numerical data to estimate covariance for all of the inter-point distances within the dipole.

In practise the covariance is estimated at a number of distances and the covariance estimates are then plotted versus distance h. Covariance is thus an example of a distance-resolved statistic. This is best understood by reference to a worked example. Consider Figure 13.4a. This figure shows four examples of a two-dimensional pattern composed of just two compartments, a white background and a black compartment that is of particular interest (it happens that in this example the black compartment is composed of black circles each 39 pixels in diameter). Figure 13.4b shows the covariance of the black compartment estimated from the four images. There are several very important general features of covariance plots that we can highlight using this example:

1. At a distance of h=zero pixels the covariance is equal to the area fraction (or in 3D to the volume fraction). This is because for a distance of zero units each ‘dipole’ will consist of a pair of points that are coincident in 3D space and thus covariance at zero distance is simply equal to the probability that a point will hit the tissue component of interest (i.e. the volume fraction).


Page 202

2. The covariance always drops for distances just above zero. That is, C(h) never gets bigger than Vv. Furthermore, the slope of the drop off of covariance at h=zero is related to the surface area of the compartment of interest.

3. At very long distances the covariance is equal to volume fraction squared, i.e. . This is because at large distances the probability that both points hit the tissue component will essentially be independent, the probability of two independent events is found by multiplying the probabilities i.e. . This value of volume fraction squared is sometimes known as the ‘reference value’, meaning that it is the covariance that would be expected for a ‘completely random’ structure.

4. The first distance at which the estimated covariance crosses the reference line is known as the ‘range’ of the structure (R on Figure 13.4b).

Now apply the above to Figure 13.4b. The area fraction represented by the black compartment is 0.31 and the covariance plot therefore starts from 0.31. The covariance then drops steeply away from this maximal value. This can be explained by considering a small distance, say 5 pixels. The probability that both of the endpoints of a dipole of 5 pixels length hits a circle must be lower than 0.31—quite a few of the dipoles that will intersect a circle will have an end land in a circle and the other end in the background. As the inter-point distance increases so the covariance will decrease. At a distance of 24 pixels the estimated covariance crosses the reference line given by 0.312. This distance, R, is the range of the black compartment. Note that although in this example it is clear that the range must be strongly related to the diameter of the objects, for many real systems there is no such simple relationship. For all of the distances between zero pixels and the range (in this case 24 pixels) the estimated covariance is above the reference line. This indicates that there is a higher probability of the end points of a dipole both landing within the black compartment than what could be expected for a completely random structure—we say that there is a positive structural correlation.

For distances between 24 and 41 pixels the estimated covariance is below the reference line. This indicates a negative structural correlation. Intuitively we see that this corresponds to the fact that there is a gap between the circles. At these distances it is pretty improbable that both dipole ends will land within the black compartment. For distances between 41 and 65 pixels the estimated covariance again goes above the reference line. This range of distances now corresponds to the probability that both ends of the dipole will land in the black compartment by the points landing in ‘neighbouring’ circles.

Although covariance gives a useful statistical description of spatial arrangement it is dependent upon volume fraction and therefore making comparisons between the covariance of two phases occupying different volume fractions can be problematic (see Mattfeldt et al., 1993 for examples). The dependence on volume fraction can be overcome be estimating the pair correlation function, g(r), which is independent of volume fraction. The pair correlation function is the normalized covariance function, obtained by dividing covariance by the ‘reference value’.

The reference line for the pair correlation function becomes 1. Values of g(r) greater than 1 indicate positive correlations of the volumetric feature and values of g(r) less than 1 indicate negative correlations. If estimates of covariance and volume fraction are available, the pair correlation function can be estimated from

(13.2)

(see Mattfeldt et al., 1993). It should be clear that the pair correlation is the covariance ‘normalized’ by the ‘reference value’.


Page 203

13.5 Linear dipole probes

Practical stereological estimation of covariance with linear dipole probes requires that a number of IUR dipole probes can be generated. For example, IUR sections from ‘isector’ (Nyengaard and Gundersen, 1992) or ‘orientator’ (Chapter 7 and Mattfeldt et al., 1990) sampling could be used, in which case the linear dipoles need to be isotropically rotated on the IUR plane section. More conveniently IUR dipoles can also be generated on vertical uniform random (VUR) sections (Baddeley et al., 1986). If VUR sections are used the vertical direction must be known and dipoles with a sine weighting with respect to the vertical must be used (see Chapters 6 and 9). Recent application of linear dipole probes to placental tissue was described by Mayhew and Jairam (2000).

In order to illustrate the application of the linear dipole probe method we show a typical sampling scheme used in our group to generate vertical uniform random sections of placenta for subsequent second-order analysis ( Figure 13.5 ). Systematic uniform random fingers of tissue are generated using a randomly translated perspex plate containing a regular hole grid. Each position of the placenta covered by a hole

Figure 13.5

A typical sampling scheme used by Dr Charlie Orton to generate vertical uniform random sections of placenta for subsequent second-order analysis. (a) A randomly translated perspex plate containing a regular hole grid was used to highlight areas for samples to be taken. These were marked with pins and full-depth fingers of tissue then cut out. (b) The full-depth fingers were randomly rotated before being processed, embedded and sectioned on a microtome. (c) Vertical sections were stained and mounted on microscope slides such that the vertical direction was retained. Linear dipole probes which have a sine-weighted random distribution with respect to the vertical axis were then generated. (d) A schematic diagram of a vertical section of placental tissue complete with linear dipole probes.


Page 204

Figure 13.6

Plots of pair correlation function for (a) intervillous space and (b) terminal villi. In each plot the mean over ten cases is plotted with a point-wise confidence interval based on Students’ t-distribution with n−1(=9) degrees of freedom.

was marked with a pin and a full-depth finger of tissue cut out. Each of the full-depth fingers was then randomly rotated before being processed, embedded and sectioned on a microtome. Vertical uniform random sections were then stained and mounted on microscope slides such that the vertical direction was retained. Linear dipole probes which have a sine-weighted random distribution with respect to the vertical axis were then generated. Figure 13.5d shows a schematic diagram of a vertical section of placental tissue complete with linear dipole probes.

The pair correlation function plot for intervillous space (IVS) ( Figure 13.6a ) shows fairly narrow 95% confidence intervals. These confidence intervals include contributions to overall variability due to biological variation between the placentas, between tissue blocks, between frames and also due to the use of dipole probes. The reference line, expected for a ‘completely random’ volume distribution, is shown as a dashed line. The empirical line for the IVS remains above the reference line until about 1.1 mm. The value at which pair correlation first falls to the reference value is known as the ‘range’ of the structure and is an indicator of its average 3D size. At longer distances the empirical pair correlation does not significantly differ from the reference value. The pair correlation function plot for terminal villi ( Figure 13.6b ) also shows fairly narrow confidence intervals. The empirical pair correlation falls rapidly to the reference value at about 0.3 mm and continues along this line until about 0.8 mm.

All of the above discussion refers to the covariance for a single phase or tissue compartment—i.e. quantifying spatial architecture of a tissue compartment with respect to itself. However, in multi-phase materials dipoles often hit two different phases simultaneously. These dipoles can therefore be used to obtain information about the spatial association between two different phases. The function used to quantify spatial association at a range of distances is the cross-covariance.

The cross-covariance for two phases Ai, Aj, denoted by C(r)i,j, is defined as the probability that an isotropic dipole of length r units hits phases Ai and Aj simultaneously. At a radius of zero the cross-covariance for any pair of phases is zero (a point simply cannot simultaneously hit two phases). In common with the covariance a reference value corresponding to a ‘random’ structure can also be calculated. The equivalent reference line for the cross-covariance between two phases Ai and Aj is simply the


Page 205

Figure 13.7

Plots of cross-correlation function for (a) stem and intermediate villi and (b) stem and terminal villi. In each plot the mean over ten cases is plotted with a point-wise confidence interval based on Students’ t-distribution with n−1(=9) degrees of freedom.

volume fraction of Ai multiplied by the volume fraction of Aj. As an illustration of the application of linear dipole probes to estimate cross-covariance Figure 13.7 shows how we have applied covariance for quantifying the spatial structure of placental villi. The cross-correlation plot for stem and intermediate villi ( Figure 13.7a ) shows a significant negative correlation between these two tissue components up until about 1 mm. There is a wider confidence interval than in the pair correlation plots which are usual for cross-correlation analyses. The plot indicates quantitatively that the stem and intermediate villi are not co-localized in space within the placenta. This result supports the currently accepted model of villous tree structure but does so in a quantitative manner; the intermediate villi branch away from the stem villi and preferentially remain away from each other up to distances of 1 mm.

The cross-correlation plot for stem and terminal villi ( Figure 13.7b ) again shows a significant negative correlation between these two tissue components up until about 0.75 mm. This is what we might expect, terminal villi do not branch directly off stem villi. However, more interestingly there is a marked positive correlation between these villous types from about 0.75 to 1.2 mm. This positive correlation is a strong indication that there is a preferred separation between stem and terminal villi at these distances. This result is different from the stem/intermediate relationship.

13.6 Making sense of covariance

As we stated in the introduction to this chapter covariance is a more complex way of describing a structure than we have previously dealt with in this book. If linear dipole probes are used for data collection then the experimental requirements are only marginally more demanding than many of the other techniques we describe. However, it is in interpretation that things become more complex. It is here that ‘making sense of covariance’ requires a higher investment of thought, both prior to and after a study has been designed and undertaken.

One of the key aspects of using covariance is to ask the question ‘how does the observed covariance differ from that expected from a “random” structure’. We mentioned above that the ‘reference’ line given by the square of the volume fraction is


Page 206

often taken to indicate a random structure. Yet this is clearly unrealistic. For example, at small distances we know that covariance must begin at Vv and reduce rapidly and is nowhere near the reference value. It is therefore useful to find other covariance functions that could be taken as ‘null’ models, i.e. that can be used for comparison between empirical covariance plots. Below we propose two.

A basic model of covariance used in the statistical physics community is that provided by the exponential covariance. This model was first proposed as the covariance expected for a ‘Debye random medium’, which is a structure composed of elements of ‘random shape, random size and random orientation’. For a structure of volume fraction Vv, the exponential covariance is given by:

where α is a positive parameter describing the degree of variability or randomness in the random closed set (Stoyan et al., 1995). The exponential covariance can also be shown to be approximately the same as that obtained from a Boolean model (Stoyan et al., 1995). The reciprocal of α is sometimes referred to as the correlation length of the structure and is an indicator of the structure’s ‘average size’.

The exponential covariance also has the useful property that the parameter α can be directly related to Vv and Sv for the material (Underwood, 1970), i.e.

This relationship is particularly useful when we are using the exponential covariance as a model. In addition to estimating the covariance for the structure we can also independently estimate Vv and Sv. This then gives us the chance to compare two functions: (i) the empirically estimated covariance C(r), and (ii) the exponential covariance Ce(r), we would expect for random material of the same volume and surface fractions.

The exponential covariance curve that is generated is particularly useful for comparing the initial portion of the covariance plot. The exponential covariance is a simply shaped function that has a rapid decay to a fixed value equivalent to [image]. Thus we think it provides a more sophisticated reference line for use as a model than a flat line at [image], as it is ‘structure specific’. Structures that are not well modelled by a Debye random medium will give rise to covariances that have clear deviations from the exponential covariance reference line.

If the material under study is a system composed of discrete particles embedded in a matrix the estimated covariance C(r), can be compared with that expected for a random distribution of spheres of the same diameter and the same volume fraction as the system under investigation (Torquato, 2001).

In addition, for a system composed of discrete particles embedded in a matrix, the estimated covariance C(r), can be considered as the linear combination of two independent covariance functions;

C1(r)—this is the connected component covariance defined as the probability that two points separated by a distance r are joined by a line that is fully within the phase of interest.

C2(r)—this is the non-connected component covariance defined as the probability that two points separated by a distance r are joined by a line that begins in the phase of interest, passes through the matrix and back into the phase of interest.

In short C1(r) summarizes the average size and shape of the particles within the system and C2(r) the spatial arrangement of the particles. An example of the


Page 207

analysis of a metal structure using this approach is described by Weincek and Stoyan (1993).

It should be noted that all of the methods described for second-order stereology of volumes are assumption free. Furthermore, use of careful sampling designs and isotropic dipole probes yields relatively efficient estimates. For example, when analyzing lung tissue we compared manual linear dipole estimation with a full image analysis method and found that the bulk of the overall variability was due to section by section variation not use of dipoles (Reed and Howard, 1999).

All of the above discussion refers to the set covariance for a single phase—i.e. quantifying spatial architecture of one phase with respect to itself. However, the dipole method can also be used to obtain information about the spatial association between two different phases. The function used to quantify spatial association at a range of distances is the cross-covariance.

The isotropic cross-covariance for two phases A and B, is denoted by C(r)A,B, and is defined as the probability that an isotropic dipole of length r units simultaneously hits both phases.

At a radius of zero the cross-covariance for any pair of phases is zero (a point simply cannot simultaneously hit two phases). In common with the covariance a reference value corresponding to a ‘random’ structure can also be calculated. For a cross-covariance analysis the equivalent reference line for the cross-covariance between two phases A and B is simply the volume fraction of A multiplied by the volume fraction of B.

13.7 Example of the application of linear dipole probes

In order to illustrate a complete application of the linear dipole probe method we describe here a small part of a larger study into placental microstructure carried out by Dr Charlie Orton (Developmental Toxico-Pathology, University of Liverpool). For the purposes of the linear dipole study the placentas from ten randomly selected cases of normal birthweight babies at term (>10th centile) from non-smoking mothers were sub-sampled from an exhaustive collection of 200 intact placentas collected in series over a period of a month from the Liverpool Women’s Hospital. The medical records for each case were checked for any unusual events during pregnancy, such as hypertension, drug abuse, infectious disease and congenital abnormalities of the neonate.

After delivery of the baby the umbilical cord was clamped and cut in the usual manner. The placentas were then stored in a fridge kept at 4°C until sampling (2–24 h after delivery). The membranes were trimmed and the umbilical cords removed at the point of insertion. The placenta was laid maternal side down on a cutting board and a perforated perspex plate equipped with a quadratic array of 10 mm diameter holes with a center to center separation of 60 mm was overlain with uniform random position. Each of the holes fully or partially overlying the placenta was marked with a dressmaker’s pin and the grid removed ( Figure 13.5a ). The marked tissue areas were cut out with scissors and toothed forceps to obtain full thickness samples. These tissue samples were then fixed in formalin for approximately one week. Typically the sampling procedure gave rise to 8–10 pieces of tissue per placenta. After fixation two pieces of tissue were randomly selected and then cut down to fit into standard histological cassettes. Before insertion into the cassette the tissue pieces were given a random rotation about the vertical axis ( Figure 13.5b ). The tissue samples were automatically processed and embedded in paraffin wax using traditional methods. From each embedded tissue one 5-μm section was cut and mounted onto standard glass microscope slides. The mounted sections were then stained using Harris’


Page 208

haematoxylin and eosin yellow. The sampling protocol described thus generates vertical uniform random (VUR) sections (Baddeley et al., 1986).

On each mounted slide microscopic fields of view were selected in a systematic random fashion. For each tissue section a rotational slide holder was used to orient the section vertically. An arbitrary point outside of the tissue was taken as a starting point and fields of view were then imaged using systematic steps down and across the section. The fields of view were projected onto a white table top using a modified projection microscope as described in Howard and Reed (1999). A ×10 magnification air objective was used which gave images of final linear magnification, determined from a calibrated graticule of ×200.

On each field of view linear dipole probes which had a sine-weighted orientation distribution with respect to the known vertical direction were generated ( Figure 13.5c ). A schematized micrograph drawn from one of the fields of view is shown in Figure 13.5d , with a pair of linear dipole probes superposed. The tissue was considered to be composed of three types of fetal villi, stem, intermediate and terminal and an inter villous space (IVS) that is occupied by maternal blood. The data extracted from dipole sampling of Figure 13.5d are shown immediately below the schematic micrograph.

A small ‘C' program was used to analyze the dipole data for each case and the mean and standard deviation of the covariance functions used to estimate pair correlation functions with pointwise 95% confidence intervals assuming Students’ t distribution. Examples of pair correlation and cross-correlation plots are presented in Figures 13.6 and 13.7 respectively. Figure 13.6 shows pair correlation plots for both IVS ( Figure 13.6a ) and terminal villi ( Figure 13.6b ). In both cases the empirical pair correlation trace decays in a simple exponential fashion. The range of the IVS (first time trace crosses reference line) is about 1 mm, indicating open structure of the IVS, whilst that of the terminal villi is about 0.2 mm. For both structures the variability in spatial arrangement between the ten cases analysed is small—reflected in the tightness of the pointwise 95% confidence intervals.

Figure 13.7 shows cross-correlation plots between stem and intermediate villi ( Figure 13.7a ) and between stem and terminal villi ( Figure 13.7b ). In Figure 13.7a there is no marked structure in the trace. There is an exponential increase in cross-correlation with increasing distance. In the case of the stem-terminal villi plot shown in Figure 13.7b the plot goes above the reference line between 0.75 and 1.1 mm. This suggests that there is a preferred spacing between terminal and stem components of the villous tree.

13.8 Using isotropic rulers to get ‘one-stop stereology’

Although the linear dipole method we describe above is a useful and low-cost way in which to apply second-order stereology, a more comprehensive approach suggests itself. This approach, which we call ‘one-stop’ stereology was motivated by us trying to improve on the dipole technique. However, in so doing we observed that we could not only get better estimates of covariance and cross-covariance we could also estimate volume fraction, surface density, star volume and mean particle volume all at the same time and with a very simple data collection protocol.

In the following we will consider a non-random multi-phase material composed of N different phases, A1, A2,…, AN, the union of which comprises a well-defined reference space (ref). This material could be an alloy, a multi-phase polymeric composite or the multiple tissue compartments within a well-defined organ such as the lung, brain, kidney, placenta, etc. Although we consider a deterministic material (thus adopting the design-based approach), for the time being we will assume that the


Page 209

Figure 13.8

The isotropic ruler probe illustrated. A section through a multiphase material is shown with a superposed isotropic line. Beginning at the lower left corner each interface crossed by the line is indicated. The line shown is a one-dimensional sample of the two-dimensional image, which is in turn a two-dimensional sample of the 3D structure. Beginning with a zero at the lower left end of the isotropic ruler we have recorded the distance between the zero and each interface crossed by the line and the phase into which the line passes. Note that we record the phase that the zero point is in, in this case 2=background and indicate that the end of the line as a−1.

length scale of the microscopic structure of the material is much smaller than the object—what Miles (1978) called the ‘extended deterministic’ case.

In the defined reference space we will generate a series of independent and vertical uniform random (VUR) or isotropic uniform random (IUR) sections using a suitable sampling and sectioning protocol. At a suitable magnification we image fields of view. On each of these we generate one or more isotropic ‘rulers’ each of known length. On IUR sections the rulers should be isotropically oriented in the image plane (Cruz-Orive, 1997) and on VUR sections their orientation distribution should be sine-weighted with respect to the known vertical direction (Baddeley et al., 1986). Each of these rulers should be graduated in a sufficient number of divisions, e.g. 100–500 (see Figure 13.8).

For each ruler one applies the following simple protocol:

1. Record the phase that the zero on the rule at the bottom left of the ruler lands within.

2. Then move steadily rightwards and record for each phase boundary encountered the distance along the ruler from the origin to the phase boundary and the phase that the rule moves into.

An example of this type of sampling protocol for a simplified biological image is shown in Figure 13.8 along with the extracted data. Readers will no doubt appreciate that this is a simple procedure. No distances between divisions are measured, only the absolute distances from the zero to each phase boundary are recorded.

Using the data that are extracted by the above protocol and a suitable computer program unbiased estimates of the following 3D parameters can be made:

1. the volume fraction, Vv(Ai, ref), for each phase from the Rosiwal (1898) relationship LL=Vv;


Page 210

2. the surface density for each phase, Sv(Ai, ref), from the classical relation Sv=2IL (e.g. Smith and Guttman, 1953);

3. the volume-weighted star volume of each phase, which is equal to the volume-weighted mean particle volume for a phase consisting of discrete particles, using the methods of Miles (1985), Serra (1982) and Gundersen and Jensen (1985);

4. the contiguity and matrix of surface affinities between all pairs of phases (Kroustrup et al., 1988);

5. if VUR sections are used, the ‘volume anisotropy’ using star-volumes (e.g. Cruz-Orive et al., 1992);

6. the volumetric set covariance, C(h, Ai) for each phase, i.e. the probability that a pair of points separated by a distance h units will simultaneously hit phase Ai;

7. all cross-covariance functions, C(h, Ai, Aj), for each pair of phases (i≠j), i.e. the probability that a pair of points separated by a distance h units will hit phases Ai and Aj;

8. the ‘star’ covariance for each phase, C*(h, Ai), i.e. the probability that a pair of points separated by a distance h units will both hit phase Ai and be joined by a straight line fully within the phase (Cabo and Baddeley, 2003);

9. a range of linear contact distribution functions (Saxl, 1993).

Note that all of the above estimation methods are well known in the literature. With the exception of number (which requires pairs of serial sections), and length (which requires IUR sections or projections through thick vertical sections), the list above exhausts the possible 3D parameters that can be estimated from independent sections.


Page 211

Appendix A:
Practical gadgets for stereology

Sampling grid

The perforated Perspex grid ( Figure A.1 ) is translated in x and y and thrown with uniform random probability over a slab of tissue used for Cavalieri estimation of volume. For each hole that lands over the tissue slab a core of tissue is produced using the trocar. The trocar fits snugly into the drilled holes and has a sharp edge; if it is introduced through a hole in the Perspex grid a core of tissue can be removed. The tissue core can then be removed from the trocar by introducing the tightly fitting obturator. The series of uniform randomly located cores, if randomly rotated, are convenient for generating VUR sections (see Figure 6.8).

The Perspex grid and trocar can also be used for fractionator sampling. The fraction of the total grid area occupied by holes is known and in this case is π/36. If a core is taken for each hole that covers the tissue slab a fraction of π/36 of the volume of the slab has been sampled. If every nth hole in a regular raster is taken then a lower fraction of the slab can be obtained. For example, if every second hole is taken then a fraction of π/144 of the slab has been sampled.

Tandem projection microscope

The physical disector described in Chapter 5 requires that two sections are registered exactly with respect to each other. The essential idea of a tandem

Figure A.1

A perforated Perspex sampling grid. Trocar design and construction by Z.Ansari; grid design by M.G.Reed. (Photograph by John O’Sullivan.)


Page 212

Figure A.2

(a) A tandem projection microscope. Designed jointly by C.V.Howard, M.G.Reed and M.C.Moss. (b) The rotational slide holder with x–y movement. (Photograph by John O’Sullivan.)

microscope ( Figure A.2 ) is to place both physical sections of the disector pair on to the same microscope stage. This stage is then moved precisely in x and y in the common focal plane of two barrel-focusing microscope heads. The stage is also equipped with two independent slide holders that have x, y and rotational adjustments. The two slides are located in the holders and then an easily recognized feature, such as a large blood vessel, is brought into the field of view on each section by using the individual x, y controls. Perfect registration of the sections is then achieved with the aid of rotation. Once registered, both sections can then be moved in congruence by using the x, y controls of the tandem stage. In practise the use of a tandem stage allows rapid sampling of fields of view to be performed.

The other novel feature of note in the tandem projection microscope is the use of fiber optic light sources in place of condensers. A fiber optic light source is ideal for projection microscopy as it provides a high-intensity cool light source that does not bleach the specimen. However, the role of a condenser in a light microscope set up


Page 213

for Köhler illumination is not just to provide sufficient light; the light that is transmitted through the specimen to the objective should be composed of parallel rays of light and should be of uniform intensity across the field of view of the specimen (Richardson, 1991). The optic fiber bundle successfully achieves both of these requirements as will be described below.

Each of the individual optic fibers in the fiber bundle effectively acts as a point source of light giving uniform hemispherical illumination. If a single fiber was used, without a lens system, then the light reaching the specimen would not be parallel. However, the fiber bundle consists of hundreds of fibers uniformly spread over a bundle 4 mm in diameter. The effect of having hundreds of point sources in a plane is to produce uniform-intensity illumination of approximately parallel light rays if the distance between the plane (i.e. the end of the optic fiber guide) and specimen is large compared with the distance between the individual fibers. For the optic fiber light guides used in the tandem microscope the average diameter of each fiber, and distance between centres of the fibers, was found to be about 60 μm. The distance between the top face of the optic fiber guide and the specimen is approximately 1 mm. This means that the specimen is at a distance of about 20 times the inter-fiber distance from the face of the optic fiber. Thus the light that is transmitted through the specimen is effectively parallel and of uniform intensity over the field of view used. In practise we have found that the image quality obtained using the optic fiber condenser is excellent using both ×10 and ×40 objectives.

The light path for production of projected images on a flat work surface was achieved by equipping both microscopes with a projecting prism in place of the eyepiece, which in turn projected on to front-silvered mirrors. It is important to ensure that these are oriented correctly by calibrating in both x and y on the final image. An alternative strategy would be to use conventional condensers in conjunction with video cameras and display the two images on adjacent television screens.

There are three design requirements for the basic tandem stage to work correctly.

1. It should move normal to the parallel optical axes of the two microscopes. This means that both slides will remain in focus under x, y translation.

2. The two apertures in the tandem stage should be large enough to allow full viewing of the whole specimen under x, y translation and rotation of the individual adjusters.

3. There should be no appreciable ‘whip’ in the movement of the tandem stage.

Small object slicer

The small specimen, for example rat kidney, is embedded in stiff agar on the corrugated rubber mat on the moving stage (see Figure A.3). The stage is advanced by rotating the white knurled knob, which advances along a screw thread of known pitch. Slices of tissue are taken off by running a knife down the knife guides with a to-and-fro motion. Serially sectioned slabs as thin as 0.5 mm can be cut by this method. For an alternative design, see Michel and Cruz-Orive (1988).

Large object slicer

The specimen, for example an adult human brain, is embedded in stiff agar on the corrugated rubber mat on the moving stage, between the Perspex shuttering (see Figure A.4). When the agar has set the shutters are removed. The stage is then advanced by turning the wheel, which drives a screw thread of known pitch. Slabs can be generated by introducing a standard pathologist’s knife into one of the pairs of knife guides. Slabs of average thickness of 5 mm can easily be cut using this slicer.


Page 214

Figure A.3

A small object slicer. Designed in the lab of H.J.G.Gundersen, Aarhus, Denmark. (Photograph by John O’Sullivan.)

Figure A.4

A large object slicer. Designed by C.V.Howard. (Photograph by John O’Sullivan.)

Mechanical microcator

The optical disector requires a measurement of the z movement of the microscope’s focusing stage. Commonly, optoelectronic microcators with an accuracy of 0.5 μm are used for this purpose. However, a much lower-cost mechanical microcator of comparable accuracy can be used.


Page 215

Figure A.5

A mechanical microcator. Designed and constructed by M.G.Reed. (Photograph by John O’Sullivan.)

A mechanical microcator was fabricated ( Figure A.5 ) by mounting a mechanical jewelled movement dial gauge (Radio Spares Ltd, Cat. No 733–638) on to a standard optical component positioner. The positioner allows coarse movement of the dial gauge which is necessary because the range of movement of the mechanical microcator is limited to 200 μm. Once the slide is focused the lever arm tip of the microcator is brought into contact with the microscope stage using the positioner. The dial gauge is then zeroed by rotating the dial face. The dial face gives direct reading of 2 μm divisions, which can be interpolated to 1 μm accuracy.

A series of experiments was carried out to assess the positional accuracy of the dial gauge. Direct comparison with a Heidenhain Model MT12 optical microcator indicated that the mean absolute deviation between the mechanical dial gauge and


Page 216

Figure A.6

Dial gauge versus microcator readings for the mechanical microcator.

Figure A.7

A rotational stage. Designed and constructed in the lab of H.J.G.Gundersen, Aarhus, Denmark. (Photograph by John O’Sullivan.)

microcator was 0.5 μm. A plot of dial gauge reading versus microcator reading for a series of 28 measurements is shown in Figure A.6. The slope of the best fit regression line was 1.00 with an intersection of—0.19 μm and a regression coefficient of 0.999.

In order to reduce whip in the movement of the stage a miniature spring-loaded shock absorber (RS 733–637) was mounted beneath the focusing stage of the microscope. The total cost of the set-up is less than £200 at 2004 prices.

Rotational stage

A rotational stage adapter for an Olympus BH-2 microscope is shown in Figure A.7. This slide holder facilitates alignment of the vertical axis of vertical sections with the side of the screen in stereological software.


Page 217

Appendix B:
Set of stereological grids

The following set of grids will allow the exercises in the book to be carried out and will also be useful in many stereological studies.

When using the point, line and cycloid grids they should be enlarged so that they are larger than the micrograph.

Point grids

In each case (P1 to P5) the grids are quadratic and a multiple of the fundamental inter-point spacing of the grid, ∆x, is shown. The calculation of the area per point (a/p) of the grid, corrected for magnification, is explained in Box 3.2. For the multipurpose grids the following information is relevant:

1. P4—The ratio of plain points to circled points is 9:1.

2. P5—The ratio of plain points to circled points is 25:1.

Sampling frames

In each case (F1 to F4) the frames are square and a multiple of the frame width, ∆x, is shown. The calculation of the area per frame-associated point (a/f) corrected for magnification is explained in Box 3.2.

Line grids

In each case (L1 to L3) a multiple of the length of line associated with each point (l/p) is indicated.

Cycloidal grids

In each case (C1 to C4) the vertical direction that should be used for the cycloid grid and a multiple of the length of cycloidal line associated with each point (l/p) is indicated.

Orientator clocks

Two clocks suitable for use with the orientator method are shown. The Ø clock is marked out in uniform divisions and the θ clock in cosine-weighted intervals with respect to the 0–0 direction. The use of the clocks for the orientator method is fully described in Chapter 7 (see Figure 7.4).


Page 218


Page 219


Page 220


Page 221


Page 222


Page 223


Page 224


Page 225


Page 226


Page 227


Page 228


Page 229


Page 230


Page 231


Page 232


Page 233


Page 234


Page 235


Page 236


Page 237


Page 238

This page intentionally left blank.


Page 239

Appendix C:
Worked answers to exercises

In the following worked examples we have used the images and grids at the magnification found in the book. Therefore in each case calculation of linear magnification and grid constants (i.e. a/p, a/f, etc.) should be very similar to the calculations you carry out. For exercises that require the random casting of a test grid there will inevitably be differences in the actual number of points (P), intersections (I), etc., that are obtained. In addition small differences in the interpretation of the lung images used for Exercise 6.1 can give rise to relatively large differences in the number of intersections counted. However, for all exercises your answers should be expressed in the correct dimensions and units, and be of the same order of magnitude as ours.


Page 240

Exercise 3.1

Slice | Points hitting transect (Pi)
1 | 3
2 | 4
3 | 2
4 | 3
5 | 3
6 | 2
Sum |

Estimate of volume of object:


Page 241

Exercise 3.2

Slice | Points hitting transect (Pi)
1 (i.e. 71) | 2
2 | 5
3 | 4
4 | 9
5 | 7
6 | 8
7 | 3
8 | 3
9 | 2
Sum |

Estimate of volume of kidney:


Page 242

Exercise 3.3

Slice | Points hitting transect (Pi)
a | 1
b | 2
c | 4
d | 8
e | 9
f | 10
g | 9
h | 10
i | 10
J | 8
k | 4
l | 1
Sum |

Estimate of volume of ventricle:


Page 243

Exercise 3.4

Stratum | Sections |  |  |  |  |  | Total points | Volume of stratum
 | 1 | 2 | 3 | 4 | 5 | 6
A | 3 | 8 | 7 | 6 | 4 | – | 28 | 12580
B | 0 | 1 | 4 | 4 | 5 | – | 14 | 6290
C | 2 | 3 | 4 | 6 | – | – | 15 | 6740
D | 1 | 4 | 6 | 7 | 6 | 6 | 30 | 13480
Total |  |  |  |  |  |  | 87 | 39090

Volume of stratum A:

Volume of stratum B:

Volume of stratum C:

Volume of stratum D:

Total volume of lung:


Page 244

Exercise 3.5

In this exercise we carried out the estimation with a fine grid (P1) and a coarser grid (P2) to illustrate the efficiency of estimation.

COARSE GRID (P2)

Slice | Points hitting cortex (Pi)
1 | 1
2 | 2
3 | 6
4 | 10
5 | 10
6 | 14
7 | 9
8 | 11
9 | 11
10 | 5
11 | 5
Sum |

Estimate of neocortical volume:


Page 245

FINE GRID (P1)

Slice | Points hitting cortex (Pi)
1 | 4
2 | 19
3 | 34
4 | 37
5 | 40
6 | 50
7 | 43
8 | 45
9 | 40
10 | 30
11 | 24
Sum |

Estimate of neocortical volume:

Estimate of neocortical volume (grid P2)=322.6 cm3.

Estimate of neocortical volume (grid P1)=296.5 cm3.

The estimate made using the coarse grid took about 3 min of counting, that made with the fine grid took about 15 min (and two aspirin). The use of a finer grid only improves the precision of the estimates of cross-sectional area and cannot affect the ‘between-slice’ precision. Hence the use of a finer grid often has a negligible effect on the overall coefficient of error of a Cavalieri estimate.


Page 246

Exercise 4.1

Image | Points hitting nerve cell bodies [P(nc)] | Points hitting image [P(sc)]
a | 31 | 165
b | 23 | 180
c | 44 | 165
d | 34 | 165
e | 23 | 165
f | 18 | 176
Sum | ∑P(nc)=173 | ∑P(sc)=1016

Estimate of volume fraction of nerve cells:

The total volume of nerve cell bodies is estimated as 49×0.17=8.3 mm3.


Page 247

Exercise 4.2

Image | Points hitting nuclei [P(nuclei)] | Points hitting nerve cell bodies [P(nc)]
a | 2 | 32
b | 4 | 23
c | 3 | 44
d | 2 | 33
e | 3 | 22
f | 2 | 20
Sum | ∑P(nuclei)=16 | ∑P(nc)=174

Estimate of volume fraction of nuclei in nerve cell bodies:

The total volume of nuclear material is estimated as 8.3×0.09=0.75 mm3.


Page 248

Exercise 4.3

The ratio of plain points to circled points, q, is 25.

image | Points hitting blood vessels [P(vessel)] | Points hitting reference space [P(sc)]
a | 2 | 6
b | 4 | 6
c | 2 | 6
d | 4 | 6
e | 0 | 6
f | 2 | 6
Sum | ∑P(vessel)=14 | ∑P(sc)=36

Estimate of volume fraction of blood vessel per unit volume of spinal cord tissue:

The total volume of blood vessel is estimated as 49×0.016=0.78 mm3.


Page 249

Exercise 5.1

Image | 2D particles sampled
a | 4
b | 1
c | 3
d | 4
Sum | ∑Q=12

Estimate of number per unit area:


Page 250

Exercise 5.2

Image | Frame-associated points | Particles counted
a | 3 | 4
b | 4 | 6
c | 4 | 5
Sum | ∑P=11 | ∑Q−=15

Estimate of number per unit volume:

The total number of particles is estimated as (8.1×109)×(5.9×10−7)=4779.

Note that to obtain total number we converted the volume of the object into μm3 then multiplied by numerical density. Number has no dimension.


Page 251

Exercise 5.3

1. The slice sampling fraction (ssf) is 1/7th.

2. The area associated with each frame (a/f) is 652 μm2=4225 μm2.

3. The area of each step in x and y is 400×550=220000 μm2. Therefore the area-sampling fraction (asf) is 4225/220000.

4. The height sampling fraction (hsf) is 12/25.

An estimate of total number is given by:


Page 252

Exercise 5.4

Image | Particles counted
a | 8
b | 4
c | 6
Sum | ∑Q−=18

Estimate of number per unit volume:

The total number of particles is estimated as (257×1012)×(1.5×10−4)=39×109.

This estimate is at the high end of the range of total neurone counts found in practise. Clearly a larger number of optical disectors would normally be used in a real study.


Page 253

Exercise 6.1

Image | Points in reference space | Intersection between cycloid and gas exchange surface
a | 5 | 66
b | 6 | 78
c | 6 | 86
d | 9 | 63
Sum | ∑P=26 | ∑l=293

Estimate of surface area of gas exchange surface (g.e.s.) per unit volume of lung:

The total lung volume was estimated to be 10750 mm3. Therefore the total gas exchange tissue surface area is estimated from 10750×109×0.046=4.9×1011 μm2 (about 0.5 m2).


Page 254

Exercise 6.2

Image | Points in reference space | Intersection between test lines and nerve cell surface
a | 23 | 10
b | 24 | 7
c | 24 | 11
d | 26 | 12
e | 24 | 7
f | 24 | 6
Sum | ∑P=145 | ∑l=53

Estimate of surface area of nerve cell body (n.c.b.)) per unit volume of spinal cord (s.c.):

The total surface area is estimated as (49×109)×0.035=1.7×109 μm2.


Page 255

Exercise 7.1

Image | Points in reference space | Number of blood vessel transects
a | 9 | 3
b | 9 | 3
c | 12 | 2
d | 12 | 1
e | 9 | 2
f | 9 | 1
Sum | ∑P=60 | ∑Q=12

Estimate of length of blood vessel per unit volume of spinal cord (s.c.):

The total blood vessel length is estimated as (49×109)×(1.72×10−3)=8.4×107 μm, which is 84 m!


Page 256

Exercise 10.1

The sums required for estimation of volume and coefficient of error were calculated as follows.

Pi | Pi×Pi | Pi×Pi+1 | Pi×Pi+2
6 | 36 | 60 | 120
10 | 100 | 200 | 260
20 | 400 | 520 | 560
26 | 676 | 728 | 676
28 | 784 | 728 | 728
26 | 676 | 676 | 780
26 | 676 | 780 | 728
30 | 900 | 840 | 780
28 | 784 | 728 | 672
26 | 676 | 624 | 312
24 | 576 | 288 | 144
12 | 144 | 72 | 48
6 | 36 | 24 | 0
4 | 16 | 0 | 0
∑P=272 | a=6480 | b=6268 | c=5808

From the summations given in the table the ventricular volume is estimated from:

The prediction of CE for this type of estimate is predicted by:

thus for the ventricular data

The contribution to this CE due to the point counting is predicted from

which for these data gives

which gives a predicted contribution to the overall CE of 0.0094.


Page 257

Exercise 10.2

The summations required to estimate surface density and the CE using Cochran’s formula are given in the following table.

p | l | P2 | l2 | P·l
11 | 119 | 121 | 14161 | 1309
12 | 149 | 144 | 22201 | 1788
11 | 145 | 121 | 21 025 | 1595
7 | 62 | 49 | 3844 | 434
9 | 83 | 81 | 6899 | 747
5 | 66 | 25 | 4356 | 330
9 | 110 | 81 | 12100 | 990
∑P=64 | ∑l=734 | ∑P2=622 | ∑l2=84 576 | ∑P·l=7193

From the data given l/p=d·8/π and d=121 μm, therefore l/p=308 μm. The surface density is estimated from

The CE of this estimate can be predicted approximately from the following general formula:

where the summations are over the k images used and u and v in this case are equal to the number of points P and intersections l, respectively. Thus for the data given above


Page 258

Exercise 11.1

Image | Intersections between cycloid and neurites
0 | 14
60 | 11
120 | 13
30 | 9
60 | 15
150 | 12
Sum | ∑l=74

Estimate of total length of neurite:


Page 259

Appendix D:
Useful addresses

These are some addresses at which information about meetings, courses and/or ancilliary equipment for stereologists can be obtained.

International Society for Stereology (ISS)

ISS Web Page at http://www.health.aau.dk/stereology/iss/

e-mail: stereo@svfcd.aau.dk

Royal Microscopical Society (RMS)

RMS Web Page at http://www.rms.org.uk e-mail: info@rms.org.uk
37/38 St Clements, Oxford OX4 1AJ, UK
Tel +44 (0)1865 248768; Fax +44 (0)1865 791237

Owners of the Journal of Microscopy, also the official publication of ISS. The Society organizes scientific meetings and courses in Europe. Details of its activities are available from the Web Page.

Agar Scientific Ltd

66a Cambridge Road, Stanstead, Essex CM24 8DA, UK
Tel +44 (0)1279 813519; Fax +44 (0)1279 815106

Provides a pack of 30 high-resolution, full-sized A4 stereological grids, designed by ISS members, to augment those found in this book. The grid pack covers most of the experimental conditions likely to be encountered in applying stereology manually. All profits from sales of the pack go directly to the International Society for Stereology.

Quan ToxPath

Web Page at http://www.quantoxpath.com

Consultancy offering advice and expertise in the design and execution of quantitative toxico-pathological investigations. Services include: initial review of project, running on-site courses in stereology and training of staff, design and monitoring of pilot experiments, statistical analysis and optimization of main investigation, protocolization of routine measurements, on-site quality control monitoring. Particularly geared to industrial pharmaceutical research and drug licensing studies.

Dr C.Vyvyan Howard

Head of Research, Developmental Toxico-Pathology,
University of Liverpool, Liverpool L69 3BX, UK
Tel/fax +44 (0)151 794 7833, e-mail: c.v.howard@liv.ac.uk

Dr Matt.G.Reed

Advanced Measurement and Imaging, Unilever Research,
Oliver van Noortlaan 120, 3130 AC Vlaardingen, Netherlands.
Tel: 07789925256, e-mail: matthew.reed@unilever.com


Page 260

This page intentionally left blank.


Page 261

References

Anderson, H.R., Gardiner, T.A. and Archer, D.B. (1995) Stereological analysis of changes in the 3-dimensional structure of the retinal vasculature during diabetes. Acta Stereol. 15 (2):103–111.

Antunes, S.M.G. (1995) The optical fractionator. Zoological Studies. 34 (Suppl I):180–183.

Artacho-Pérula, E. and Roldán-Villalobos, R. (1997) Unbiased Stereological estimation of the number and volume of nuclei and nuclear size variability in invasive ductal breast carcinomas. J. Microsc. 186:133–142.

Baandrup, U., Gundersen, H.J.G. and Mulvany, M.J. (1985) Is it possible to solve the problem: hypertrophy/hyperplasia of smooth muscle cells in the vessel wall of hypertensive subjects? Progress in Applied Microcirculation 8:122–128.

Baddeley, A.J. (1993) Stereology and survey sampling theory. Bull. Intern. Statis. Inst., Proceedings 49th Session, Florence 1993. 52(2), 435–449.

Baddeley, A.J. (2001) Is stereology ‘unbiased’?. TINS 24:375–376.

Baddeley, A.J., Gundersen, H.J.G. and Cruz-Orive, L.M. (1986) Estimation of surface area from vertical sections.J. Microsc. 142(3):259–276.

Baddeley, A.J., Howard, C.V., Boyde, A. and Reid, S. (1987) Three-dimensional analysis of the spatial distribution of particles using the tandem-scanning reflected light microscope. Acta Stereol. 6 (Suppl II):87–100.

Baddeley, A.J., Moyeed, R.A., Howard, C.V. and Boyde, A. (1993) Analysis of a three-dimensional point pattern with replication. Appl. Statist. 42:641–668.

Batra, S., König, M.F. and Cruz-Orive, L.M. (1995) Unbiased estimation of capillary length from vertical slices.J. Microsc. 178:152–159.

Bedi, K.S. (1991) Effects of undernutrition during early life on granule cell numbers in the rat dentate gyrus.J. Comp. Neurol. 211:425–433.

Beech, D.J., Howard, C.V., Reed, M.G., Sibbons, P.D. and van Velzen, D. (2000) Unbiased and efficient estimation of the total number of terminal bronchiolar ducts in lung; a modified physical disector. J. Microsc. 197:36.

Benes, F.M. and Lange, N. (2001) Two-dimensional versus three-dimensional cell counting: a practical perspective. Trends in Neuroscience. 24:11–17.

Benham-Rassoli, M. (1990) Studies of the differential effects of pre- and post natal tri-iodothyronine (T3) and thyroxine (T4) deficiency on the cellular development of rat neocortex, using unbiased Stereological methods. University of Liverpool, Ph.D. Thesis.

Benham-Rassoli, M., Herbert, L.C., Howard, C.V., Pharoah, P.O.D. and Stanistreet, M. (1990) The effect of propyl-thiouracil (PTU) treatment during pre-natal and early post natal development on the neocortex of rat pups. Neuroendocrinology 53:321–327.

Bjugn, J. (1991) Estimation of the total number of cells in the rat spinal cord using the optical disector. Micron Microscopica Acta 22:25–26.

Bjugn, J. (1993) The use of the optical disector to estimate the number of neurons, glial and endothelial cells in the spinal cord of the mouse—with a comparative note on the choroid plexus ependyma. Brain Res. 166:1717–1718.

Bjugn, J. and Gundersen, H.J.G. (1993) Estimate of the total number of neurons and glial and endothelial cells in the rat spinal cord by means of the optical disector. J. Comp. Neurol. 328:406–414.

Brændgaard, H. and Gundersen, H.J.G. (1986) The impact of recent Stereological advances on quantitative studies of the nervous system.J. Neurosci. Meth. 18:39–78.

Brændgaard, H., Evans, S.M., Howard, C.V. and Gundersen, H.J.G. (1990) The total number of neurons in the human neocortex unbiasedly estimated using optical disectors. J. Microsc. 157:285–304.

Buffon, G.L.L.Comte de (1777) Essai d’Arithmétique Morale. In: Supplement à l’Histoire Naturelle, v.4. Paris: Impimerie Royale.


Page 262

Burston, W.R. and Thurley, K. (1957) A technique for the orientation of serial histological sections. J. Anat. 91:409–412.

Cabo, A. and Baddeley, A. (2003) Estimation of mean particle volume using the set covariance function. Adv. in Appl. Probab. 35:27–46.

Cavalieri, B. (1635) Geometria Indivisibilibus Continuorum. Bononi: Typis Clemetis Feronij. Reprinted as Geometria degli Indivisibili. Torino: Unione Tipografico-Editorice Torinese, 1966.

Chatfield, C. (1995) Problem solving. A statisticians guide (2nd Edition). Chapman and Hall, London.

Chatfield, C. (1996) Statistics for technology. A course in applied statistics. (3rd Edition). Chapman and Hall, London.

Chia, L.C.J. and Baddeley, A.J. (1997) Estimating a ratio from bivariate count data in stereology. Research Report 97–19. Dept. of Mathematics, University of Western Australia.

Cochran, W.G. (1977) Sampling techniques (3rd Edition). Wiley. New York.

Coggeshall, R.E. and Lekan, H.A. (1996) Methods for determining numbers of cells and synapses: A case for more uniform standards of review. J. Comp. Neurol. 364:6–15.

Cox, D.R. and Snell, E.J. (1981) Applied statistics. Principles and examples. Chapman and Hall, London.

Cressie, N.A.C. (1993) Statistics for Spatial Data (2nd Edition). Wiley, Chichester.

Cruz-Orive, L.M. (1980a) On the estimation of particle number. J. Microsc. 120:15–27.

Cruz-Orive, L.M. (1980b) Best linear unbiased estimators for stereology. Biometrics 36:595–605.

Cruz-Orive, L.M. (1982) The use of quadrats and test systems in stereology, including magnification corrections. J. Microsc. 125:89–102.

Cruz-Orive, L.M. (1987) Particle number can be estimated using a disector of unknown thickness: the selector. J. Microsc. 145:121–142.

Cruz-Orive, L.M. (1989a) On the precision of systematic sampling: a review of Matheron’s transitive methods. J. Microsc. 153:315–333.

Cruz-Orive, L.M. (1989b) Second-order stereology: estimation of second moment volume measures. Acta Stereol. 8:641–646.

Cruz-Orive, L.M. (1993) Systematic sampling in stereology. Bull. Intern. Statis. Inst., Proceedings 49th Session, Florence 1993 52(2):451–468.

Cruz-Orive, L.M. (1994) Toward a more objective biology. Neurobiology of Aging 15:377–378.

Cruz-Orive, L.M. (1997) Stereology of single objects. J. Microsc. 186:93–107.

Cruz-Orive, L.M. and Hunziker, E.B. (1986) Stereology for anisotropic cells: application to growth cartilage. J. Microsc. 143:47–80.

Cruz-Orive, L.M. and Howard, C.V. (1991) Estimating the length of a bounded curve in three dimensions using total vertical projections. J. Microsc. 163:101–113.

Cruz-Orive, L.M. and Howard, C.V. (1995) Estimation of individual feature surface area with the vertical spatial grid. J. Microsc. 178:146–151.

Cruz-Orive, L.M. and Roberts, N. (1993) Unbiased volume estimation with co-axial sections: an application to the human bladder. J. Microsc. 170:25–33.

Cruz-Orive, L.M., Hoppeler, H., Mathieu, O. and Weibel, E.R. (1985) Stereological analysis of anisotropic structures using directional statistics. Appl. Statist. 34:14–32.

Cruz-Orive, L.M., Karlsson, L.M., Larsen, S.E. and Wainschtein, F. (1992) Characterising anisotropy: A new concept. Microscopica Acta 23:75–76.

DeGroot, D.M.G. and Bierman, E.P.B. (1983) The complex perforated synapse, a problem in quantitative stereology of the brain. J. Microsc. 131:355–360.

DeHoff, R.T. (1983) Quantitative serial sectioning analysis: preview. J. Microsc. 131(3): 259–263.

Delesse, M.A. (1847) Precede mécanique pour déterminer la composition des roches. C.R. Acad. Sci. Paris 25:544–545.

Diggle, P.J. (2002) Statistical Analysis of Spatial Point Patterns. (2nd Edition). Hodder Arnold, London.

Evans, S.M. and Gundersen, H.J.G. (1989) Estimation of spatial distributions using the nucleator. Acta Stereol. 8(2):395–400.


Page 263

Gittes, F. (1990) Estimating mean particle volume and number from random sections by sampling profile boundaries. J. Microsc. 158:1–18.

Gokhale, A.M. (1990) Unbiased estimation of curve length in 3-D using vertical slices. J. Microsc. 159(2):133–143.

Gokhale, A.M. (1992) Estimation of length density Lv from vertical slices of unknown thickness. J. Microsc. 167:1–8.

Gokhale, A.M. (1993) Utility of the horizontal slice for stereological characterisation of lineal features. J. Microsc. 170:3–8.

Gokhale, A.M. and Underwood, E.E. (1990) A general method for estimation of fracture surface roughness: Part I. Theoretical aspects. Metall. Trans. 21A:1193–1199.

Gould, S.J. (1987) An urchin in the storm. Essays about Books and Ideas. Penguin. London.

Gual-Arnau, X. and Cruz-Orive, L.M. (2000) Systematic sampling on the circle and sphere. Adv Appl. Prob. 30:628–647.

Gundersen, H.J.G. (1977) Notes on the estimation of the numerical density of arbitrary profiles: the edge effect. J. Microsc. 111:219–223.

Gundersen, H.J.G. (1981) Stereologi: eller hvordan tal for runlig form og indhold opnas ved iagttagelse af struktureer pa snitplaner. Laegeforeningens Forlag, Copenhagen.

Gundersen, H.J.G. (1986) Stereology of arbitrary particles. A review of unbiased number and size estimators and the presentation of some new ones, in the memory of William R.Thompson. J. Microsc. 143:3–45.

Gundersen, H.J.G. (1988) The nucleator. J. Microsc. 151:3–21.

Gundersen, H.J.G. (2002) Estimation of tubular length. J. Microsc. 207:155–160.

Gundersen, H.J.G. and Jensen, E.B. (1985) Stereological estimation of the volume-weighted mean volume of arbitrary particles observed on random sections. J. Microsc. 138(2):127–142.

Gundersen, H.J.G. and Jensen, E.B. (1987) The efficiency of systematic sampling in Stereology and its prediction. J. Microsc. 147:229–263.

Gundersen, H.J.G. and Østerby, R. (1981) Optimizing sampling efficiency of stereological studies in biology: or ‘Do more less well!’. J. Microsc. 121:65–73.

Gundersen, H.J.G., Boysen, M. and Reith, A. (1981) A comparison of semiautomatic digitizer tablet and simple point counting performance in morphometry. Virchows Arch. (Cell Pathol.), 37:317–325.

Gundersen, H.J.G., Bagger, P., Bendtsen, T.F., Evans, S.M., Korbo, L., Marcussen, N., Møller, A., Nielsen, K., Nyengaard, J.R., Pakkenberg, B., Sørensen, F.B., Vesterby, A. and West, M.J. (1988a) The new stereological tools: disector, fractionator and point sampled intercepts and their use in pathological research. Acta Pathol. Microbiol. Immunol. Scand. (APMIS) 96:857–881.

Gundersen, H.J.G., Bendtsen, T.F., Korbo, L., Marcussen, N., Møller, A., Nielsen, K., Nyengaard, J.R., Pakkenberg, B., Sørensen, F.B., Vesterby, A. and West, M.J. (1988b) Some new simple and efficient stereological methods and their use in pathological research and diagnosis. Acta Pathol. Microbiol. Immunol. Scand. (APMIS) 96:379–394.

Gundersen, H.J.G., Boyce, R.W., Nyengaard, J.R. and Odgaard, A. (1993) The conneulor: unbiased estimation of connectivity using physical disectors under projection. Bone 14:217–222.

Hansen, M.H., Hurwitz, W.H. and Madow, W.G. (1953) Sample survey methods and theory. Volume I- methods and applications. (2nd Edition 1993). Wiley. New York.

Haug, H. (1955) Die Treffermethode, ein verhafen zur quantitativen analyse im histologischen schnitt. Z. Anat. Entwickl. Gesch. 118:302.

Haug, H., Kühl, S., Mecke, E., Sass, N. and Wasner, K. (1984) The significance of morphometric procedures in the investigation of age changes in cytoarchitechtonic structures of human brain. J. Hirnforsch. 25:353–374.

Hedreen, J.C. (1999) Unbiased Stereology? Trends In Neuroscience 22:346.

Hilliard, J.E. (1967). Determination of structural anisotropy. In Elias, H (Ed). Stereology. Proceedings Second International Congress for Stereology. Springer-Verlag. New York.

Hinchliffe, S.A., Sargent, P.H., Howard, C.V. and van Velzen, D. (1991) Human intrauterine renal growth expressed in absolute number of glomeruli assessed by the “disector” method and Cavalieri principle. Lab. Investig. 64:777–784.


Page 264

Hinchliffe, S.A., Lynch, M.R.J., Sargent, P.H., Howard, C.V. and van Velzen, D. (1992) The effect of intrauterine growth retardation on the development of renal nephrons. Brit. J. Obst Gynaecol 99:296–301.

Howard, C.V. (1985) Rapid nuclear volume estimation in malignant melanoma using point sampled intercepts in vertical sections: A review of the unbiased quantitative analysis of particles of arbitrary shape. In Mary, J.Y. and Rigaut J.P. (Eds) Quantitative image analysis in cancer cytology and histology, pp. 245–256. Elsevier, Amsterdam.

Howard, C.V. and Sandau, K. (1992) Measuring the surface area of a cell by the method of the spatial grid with a CSLM—a demonstration. J. Microsc. 165:183–188.

Howard, C.V., Scales, L. and Lynch, R. (1980) The numerical densities of alpha and gamma motoneurons in the trigeminal motor nucleus of the rat: a method of determining the separate numerical densities of two mixed populations of anatomically similar cells. Mikroskopie (Wien) 37 (Suppl.):229–236.

Howard, C.V., Reid, S., Baddeley, A. and Boyde, A. (1985) Unbiased estimation of particle density in the tandem scanning reflected light microscope. J. Microsc. 138:203–212.

Howard, C.V., Cruz-Orive, L.M. and Yaegashi, H. (1992) Estimating neuron dendritic length in 3D from total vertical projections and from vertical slices. Acta Neurol. Scand. Suppl. 137:14–19.

Howard, C.V., Jolleys, G., Stacey, D., Fowler, A., Wallén, P. and Browne, M.A. (1993) Measurement of total neuronal volume, surface area and dendritic length following intracellular physiological recording. Neuroprotocols 2:113–120.

Howard, C.V., Beech, D.J., Reed, M.G. and Moss, M.C. (1999) A double microscope for the efficient application of the physical disector—the tandem projection microscope. Jnl. Cell. Pathol 4:26–32.

Howard, C.V., Reed, M.G., Southgate, A., Greenberg, G.L. and Uylings, H.B.M. (2004) A time saving stereological method for dendritic tree analysis. J. Microsc. (At press).

Huggins, R.A. (1956) Quantitative metallography by lineal analysis. Met. Prog. 69:94.

Huijsmans, D.P., Lamers, W.H., Los, J.A. and Strackee, J. (1986) Toward computerized morphometric facilities. A review of 58 software packages for computer aided three dimensional reconstruction, quantification and picture generation from parallel serial sections. Anat. Rec. 216:449–470.

Hurlbut, G.S. (1939) An electric counter for thin section analysis. Amer. J. Sci. 237:253.

Jansson, A.M. and Møller, A. (1993) Chronic nicotine treatment counteracts nigral cell loss induced by a partial mesodiencephalic hemitransection: an analysis of the total number and mean volume of neurons and glia in substantia nigra of the male rat. Neuroscience 57:931–941.

Jensen, E.B. and Gundersen, H.J.G. (1989) Fundamental stereological formulae based on isotropically oriented probes through fixed points with applications to particle analysis. J. Microsc. 153:249–267.

Jensen, E.B. and Gundersen, H.J.G. (1993) The rotator. J. Microsc. 170(1):35–44.

Jensen, E.B., Kiêu, K. and Gundersen, H.J.G. (1990) Second-order stereology. Acta Stereol. 9:15–35.

Jolleys, G.D. (1995) Qualitative and quantitative image analysis. University of Liverpool. Ph.D. Thesis.

Jolly, G.M. (1979) Sampling of large objects. In: Cormack, R.M., Patil, G.P. and Robson, D.S. (Eds) Sampling Biological Populations. International Co-operative Publ. Fairland, Maryland.

Karlsson, L.M. and Cruz-Orive, L.M. (1991) The new stereological tools in metallography: estimation of pore size in aluminium. J. Microsc. 165:391–415.

Karlsson, L.M. and Cruz-Orive, L.M. (1997) Estimation of mean particle size from single sections. J. Microsc. 186:121–132.

Karlsson, L.M. and Liljeborg, A. (1994) Second-order stereology for pores in translucent alumina studied by confocal scanning laser microscopy. J. Microsc. 175:186–194.

Katschenko, N. (1886) Methode zur genauen Rekonstruktion kleinerer makroskopischer Gegenstände. Arch. Anat. Physiol. Abt. 388–394. Cited in el-Gammal, S., Altmeyer, P. and Hinrichsen, K. (1989). ANAT3D: Shaded three-dimensional surface reconstructions from sections. Acta Stereol. 8:543–550.


Page 265

Kendall, M.G. and Moran, P.A.P. (1963) Geometrical probability. Ch. Griffin. London.

Kieu, K. and Vedel-Jensen E.B. (1993) Stereological estimation based on isotropic slices through fixed points. J. Microsc. 170(1):45–51.

Kittelson, J.A. (1916) The postnatal growth of the kidney of the albino rat, with observations on an adult human kidney. Anat. Rec. 13:385–408.

Klein, H.A. (1988) The Science of Measurement: a historical survey. Dover, New York.

König, D., Caravajal-González, S., Down, A.M., Vassy, J. and Rigaut, J.P. (1991) Modelling and analysis of 3-D arrangements of particles by point processes with examples of application to biological data obtained by confocal scanning light microscopy. J. Microsc. 161:405–433.

Korbo, L., Pakkenberg, B., Ladefoged, O., Gundersen, H.J.G., Arlien-Soborg, P. and Pakkenberg, H. (1990) An efficient method for estimating the total number of neurons in the rat brain cortex. J. Neuroscience Methods 31:93–100.

Kroustrup, J.P., Gundersen, H.J.G and Vaeth, M. (1988) Stereological analysis of 3-dimensional structure organisation in multiphase specimens—statistical-methods and model-inferences. J. Microsc. 149:135–152.

Kubínová, L. (1993) Recent Stereological methods for the measurement of leaf anatomical characteristics: Estimation of volume density, volume and surface area. Jnl. Exp. Botany 258:165–173.

Kubínová, L. and Janacek, J. (1998) Estimating surface area by the isotropic Fakir method on thick slices cut in an arbitrary direction. J. Microsc. 191:201–211.

Kubínová, L., Janacek, J., Guilak, F. and Opatrny, Z. (1999) Comparison of several digital and Stereological methods for estimating surface area and volume of cells studied by confocal microscopy. Cytometry. 36:85–95.

Liu, G., Yu, H. and Li, W. (1994) Efficient and unbiased evaluation of size and topology of space filling grains. Acta. Stereol. 13:281–286.

Lucoq, J. (1992) Quantitation of gold labelling and estimation of labelling efficiency with a Stereological counting method. J. Histochem. Cytochem. 40:1929–1936.

Marcussen, N. (1992) The double disector: unbiased Stereological estimation of the number of particles inside other particles. J. Microsc. 165:417–426.

Mashayekhi, Y. (1996) The effect of locally administered growth hormone on the microstructure of the tibial growth plate in immature rabbits: a Stereological study. University of Liverpool, Ph.D. Thesis.

Matheron, G. (1971) The theory of regionalised variables and its applications. Les Cahiers du Centre de Morphologie Mathématique de Fontainebleau, No 5. Fontainebleau: École Nationale Supérieure des Mines de Paris.

Mathieu, O., Cruz-Orive, L.M., Hoppeler, H. and Weibel, E.R. (1981) Measuring error and sampling variation in stereology: comparison of the efficiency of various methods for planar image analysis. J. Microsc. 121:75–88.

Mattfeldt, T. (1987) Volume estimation of biological objects by systematic sections. J. Math. Biol. 25:685–695.

Mattfeldt, T. (1989) The accuracy of one-dimensional systematic sampling. J. Microsc. 153:301–313.

Mattfeldt, T., Mall, G., Gharehbaghi, H. and Möller, P. (1990) Estimation of surface area and length with the orientator. J. Microsc. 159:301–317.

Mattfeldt, T., Frey, H. and Rose, C. (1993) Second-order stereology of benign and malignant alterations of the human mammary gland. J. Microsc. 171:143–151.

Mattfeldt, T., Clarke, A. and Archenhold, G. (1994) Estimation of the directional distribution of spatial fibre processes using stereology and confocal scanning laser microscopy. J. Microsc. 173:87–103.

Mattfeldt, T., Schmidt, V., Reepscläger, Rose, C. and Frey, H. (1996) Centred contact density functions for the statistical analysis of random sets. J. Microsc. 183:158–169.

Mayhew, T.M. (1990) Efficient and unbiased sampling of nerve fibres for estimating fibre number and size. In: Conn, P.M. (Ed.) Methods in Neurosciences, Vol. 3. Academic Press, London, pp. 172–187.

Mayhew, T.M. (1997) Recent applications of the new stereology have thrown fresh light on how the human placenta grows and develops its form. J. Microsc. 186:153–163.


Page 266

Mayhew, T.M. and Desoye, G. (2004) A simple method for comparing Immunogold distributions in two or more experimental groups illustrated using GLUT1 labelling of isolated trophoblast cells. Placenta 25:580–584.

Mayhew, T.M. and Gundersen, H.J.G. (1996) ‘If you assume, you can make an ass out of u and me’: a decade of the disector for stereological counting of particles in 3D space. J. Anat. 188:1–15.

Mayhew, T.M. and Jairam, I.C. (2000) Stereological comparison of 3D spatial relationships involving villi and intervillous pores in human placentas from control and diabetic pregnancies. J. Anat. 197(2):263–274.

Mayhew, T.M. and Olsen, D.R. (1991) Magnetic resonance imaging (MRI) and model-free estimates of brain volume determined using the Cavalier principle. J. Anat. 178:133–144.

Mayhew, T.M. and Simpson, R.A. (1994) Quantitative evidence for the spatial dispersal of trophoblast nuclei in human placental villi during gestation. Placenta 15:837–844.

Mayhew, T.M., Wadrop, E. and Simpson, R.A. (1994) Proliferative versus hypertrophic growth in tissue subcompartments of human placental villi during gestation. J. Anat. 184:535–543.

Mayhew, T.M., Lucocq, J.M. and Griffiths, G. (2002) Relative labelling index: a novel stereological approach to test for non-random immunogold labelling of organelles and membranes on transmission electron microscopy thin sections. J. Microsc. 205:153–164.

Mayhew, T.M., Griffiths, G., Habermann, A., Lucocq, J., Emre, N. and Webster, P. (2003) A simpler way of comparing the labelling densities of cellular compartments illustrated using data from VPARP and LAMP-1 immunogold labelling experiments. Histochem. Cell Biol. 119:333–341.

McLean, W.G., Holme, A.D., Janneh, O., Southgate, A., Howard, C.V. and Reed, M.G. (1998) The effect of benomyl on neurite outgrowth in mouse NB2A and human SH-SY5Y neuroblastoma cells in vitro. Neurotoxicol. 19:629–632.

McMillan, A-M. and Sørensen, F.B. (1992) The efficient and unbiased estimation of nuclear size variability using the ‘selector’. J. Microsc. 165:433–437.

Michel, R.P. and Cruz-Orive, L.M. (1988) Application of the Cavalieri principle and vertical sections method to lung: estimation of volume and pleural surface area. J. Microsc. 150:117–136.

Miles, R.E. (1978) The importance of proper model specification in stereology. In R.E.Miles and J.Serra (eds) Geometrical Probability and Biological Structures: Buffons’s 200th Anniversary. Springer-Verlag, Berlin.

Miles, R.E. (1978) The sampling, by quadrats, of planar aggregates. J. Microsc. 113:257–267.

Miles, R.E. (1985) A comprehensive set of stereological formulae for embedded aggregates of not-necessarily-convex particles. J. Microsc. 138:115–125.

Miles, R.E. and Davy, P.J. (1976) Precise and general conditions for the validity of a comprehensive set of stereological fundamental formulae. J. Microsc. 107:211–226.

Møller, A., Strange, P. and Gundersen, H.J.G. (1990) Efficient estimation of cell volume and number using the nucleator and disector. J. Microsc. 159:61–71.

Moss, M. and Howard, C.V. (1988) Look before you leap. Lab. Pract. 37:15–23.

Mulvany, M.J., Baandrup, U. and Gundersen, H.J.G. (1985) Evidence for hyperplasia in mesenteric resistance vessels of spontaneously hypertensive rats using a three-dimensional disector. Circulation Res. 57:794–800.

Nyengaard, J.R. and Gundersen, H.J.G. (1992) The isector: a simple and direct method for generating isotropic, uniform random sections from small specimens. J. Microsc. 165:427–431.

Ogbuihi, S. and Cruz-Orive, L.M. (1990) Estimating the total number of lymphatic valves in infant lungs with the fractionator. J. Microsc. 158:19–30.

Orton, C. (2002) Stereological analysis of human placental microstructures from pregnancies complicated with intrauterine growth retardation and maternal cigarette smoking: a prospective case-controlled study. University of Liverpool, Ph.D. Thesis.

Pache, J.C., Roberts, N., Vock, P., Zimmermann, A. and Cruz-Orive, L.M. (1993) Vertical LM sectioning and parallel CT scanning designs for stereology: application to human lung. J. Microsc. 170(1):9–24.


Page 267

Pakkenberg, B. and Gundersen, H.J.G. (1988) Total number of neurons and glial cells in human brain nuclei estimated by the disector and fractionator. J. Microsc. 150(1):1–20.

Pakkenberg, B., Boesen, J., Albeck, M. and Gjerris, F. (1989) Unbiased and efficient estimation of total ventricular volume of the brain obtained from CT-scans by a stereological method. Neuroradiology 31:413–417.

Press, W.H., Flannery, B.P., Teukolsky, S.A., Vetterling, W.T. (1993) Numerical Recipes in C: The Art of Scientific Computing. Cambridge University Press, Cambridge.

Reed, M.G. (1997) The statistical description of 3 dimensional spatial architecture: second order stereology. University of Liverpool. Ph.D. Thesis.

Reed, M.G. and Howard, C.V. (1997) Estimation of the nearest-neighbour distribution function for 3 dimensional point patterns. J. Microsc. 186:177–184.

Reed, M.G. and Howard, C.V. (1999) Stereological estimation of covariance using linear dipole probes. J. Microsc. 195:96–103.

Reed, M.G. and Howard, C.V. (1999) Unbiased counting rules in optical sectioning light microscopy. Proc. RMS. 34/3:431–438.

Reed, M.G. and Howard, C.V. (2003) The spatial pattern of open cell polyurethane foams characterised by MRI microscopy. Journal of Physics D: Applied Physics (At press).

Reed, M.G., Howard, C.V. and Shelton, C.G. (1997) Confocal imaging and second-order stereological analysis of a liquid foam. J. Microsc. 185:313–320.

Regeur, L., Badsberg Jensen, G., Pakkenberg, H., Evans, S.M. and Pakkenberg, B. (1994) No global neocortical nerve cell loss in brains from patients with senile dementia of Alzheimer’s type. Neurobiol. Aging 15:347–352.

Richardson, J. (1991) Handbook for the Light Microscope: A User’s Guide. Noyes Publications, New Jersey.

Ripley, B.D. (1981) Spatial Statistics. Wiley, New York.

Ripley, B.D. (1987) Stochastic simulation. Wiley, New York.

Roberts, N. and Cruz-Orive, L.M. (1993) Spatial distribution of curve length: concept and estimation. J. Microsc. 172(1):23–29.

Roberts, N., Howard, C.V., Cruz-Orive, L.M. and Edwards, R.H.T. (1991) The application of total vertical projections for the unbiased estimation of the length of blood vessels and other structures by magnetic resonance imaging. Magnetic Resonance Imaging 9:917–925.

Roberts, N., Cruz-Orive, L.M., Reid, N., Brodie, D., Bourne, M. and Edwards, R.H.T. (1993) Unbiased estimation of whole body composition in humans by Cavalieri’s method using magnetic resonance imaging. J. Microsc. 171(3):239–255.

Roberts, N., Nesbitt, G. and Fens, F. (1994a) Visualisation and quantification of oil and water phases in a synthetic porous medium using NMRM and stereology. Nondestr. Test. Eval. 11:273–291.

Roberts, N., Garden, A.S., Cruz-Orive, L.M., Whitehouse, G.H. and Edwards, R.H.T. (1994b) Estimation of fetal volume by MRI and stereology. Brit. J. Radiol.67:1067–1077.

Roberts, N., Cruz-Orive, L.M., Bourne, M., Herfkens, R.J., Karwoski, R.A. and Whitehouse, G.H. (1997a) Analysis of cardiac function by MRI and stereology. J. Microsc. 187:31–42.

Roberts, N., Reed, M.G. and Nesbitt (1997b) Estimation of the connectivity of a synthetic porous medium. J. Microsc. 187:110–118.

Rosiwal, A. (1898) Uber geometrische Gesteinsanalysen. Verh. K.K. Geol. Reichsanst., Wien 13:143–175.

Saltykov, S.A. (1946) Zavodskaja laboratorija. 12, p. 816. (Cited in Weibel 1979).

Sandau, K. (1987) How to estimate the area of a surface using the spatial grid. Acta Stereol. 6/III:31–36.

Santaló, L.A. (1976) Integral Geometry and Geometrical Probability. Addison-Wesley, Reading, Mass.

Saper, C.B. (1996) Any way you cut it: A new journal policy for the use of unbiased countng methods. J. Comp. Neurol. 364:5.

Saxl, I. (1993) Contact distances and random free paths. J. Microsc. 170(1):53–64.

Scheidegger, A.E. (1974) The physics of flow through porous media (3rd Edition). University of Toronto Press. Toronto.

Scherle, W. (1970) A simple method for volumetry of organs in quantitative stereology. Mikroskopie 26:57.


Page 268

Serra, J. (1982) Image Analysis and Mathematical Morphology. Academic Press, London.

Simpson, R.A., Mayhew, T.M. and Barnes, P.R. (1992) From 13 weeks to term the trophoblasts of human placenta grows by the continuous recruitment of new proliferative units: a study of nuclear number using the disector. Placenta 13:501–512.

Smith, C.S. and Guttman, L. (1953) Measurement of internal boundaries in three-dimensional structures by random sectioning. Trans. AIME 197:81.

Soille, P. (2003) Morphological Image Processing: Principles and Applications. Springer Verlag, Berlin.

Sokal, R.R. and Rohlf, F.J. (1981) Biometry. The principles and practice of statistics in biological research. (2nd Edition). W.H.Freeman and Co., San Francisco.

Sørenson, F.B. (1991) Stereological estimation of the mean and variance of nuclear volume from vertical sections. J. Microsc. 162:203–231.

Sterio, D.C. (1984) The unbiased estimation of number and sizes of arbitrary particles using the disector. J. Microsc. 134(2):127–136.

Stoyan, D., Kendall, W.S. and Mecke, J. (1995) Stochastic Geometry and Its Applications (2nd Edition). Wiley, Chichester.

Stuart, A. (1984) Basic ideas of sampling. Griffin and Co. London.

Suzuki, M., Takahashi, T. and Ohuchi, K. (1988) Three dimensional reconstruction of semi-gross biostructures using ‘macroserials’—1 mm thick serial organ slices. J. Microsc. 149:175–183.

Tandrup, T. (1993) A method for unbiased and efficient estimation of number and mean volume of specified neuron subtypes in rat dorsal root ganglion. J. Comp. Neurol. 329:269–279.

Tandrup, T., and Braendgaard, H. (1994) Number and volume of rat dorsal root ganglion cells in acrylamide intoxication. J. Neurocytology. 23:242–248.

Tandrup, T., Gundersen, H. .J.G. and Vedel-Jensen, E.B. (1997) The optical rotator. J. Microsc. 186:108–120.

Thioulouse, J., Royet, J.P., Ploye, H. and Houllier, F. (1993) Evaluation of the precision of systematic sampling: nugget effect and covariogram modelling. J. Microsc. 172:249–256.

Thompson, E. (1930) Quantitative microscopic analysis. J. Geol. 38:193.

Torquato, S. (1991) Random Heterogeneous Media: Microstructure and Improved Bounds on the Effective Properties. Applied Mechanics Reviews 44:37–76.

Torquato, S. (2001) Random Heterogeneous Materials: Microstructure and Macrostructure Properties: v. 16 (Interdisciplinary Applied Mathematics S.). Springer-Verlag, New York.

Underwood, E.E. (1970) Quantitative Stereology. Addison-Wesley, Massachusetts.

Vedel-Jensen, E.B. and Gundersen, H.J.G. (1993) The rotator. J. Microsc. 171:35–44.

Vedel-Jensen, E.B. and Kiêu, K. (1992) A note on recent research in second-order stereology. Acta Stereol. 11(Sul I):569–579.

Vesterby, A. (1990) Star volume of marrow space and trabeculae in iliac crest: sampling procedure and correlation to star volume of first lumbar vertebra. Bone 11:149–155.

Vesterby, A., Gundersen, H.J.G. and Melsen, F. (1989) Star volume of marrow space and trabeculae of first lumbar vertebra: sampling efficiency and biological variation. Bone 10:7–13.

Weibel, E.R. (1979) Stereological Methods. Vol. 1: Practical methods for Biological Morphometry. Academic Press, London.

Weibel, E.R. (1980) Stereological Methods. Vol. 2: Theoretical Foundations. Academic Press, London.

West, M.J. (1999) Stereological methods for estimating the total number of neurons and synapes: issues of precision and bias. TINS 22:51–61.

West, M.J. and Gundersen, H.J.G. (1990) Unbiased Stereological estimation of the number of neurons in the human hippocampus. J. Comp. Neurol. 296:1–22.

West, M.J., Coleman, P.D. and Fllod, D.G. (1988) Estimating the number of granule cells in the dentate gyrus with the disector. Brain Research 448:167–172.

West, M.J., Slomianka, L. and Gundersen, H.J.G. (1991) Unbiased Stereological estimation of the total number of neurons in the subdivisions of the rat hippocampus using the optical fractionator. Anat. Rec. 231:482–497.


Page 269

Wiencek, K. and Stoyan, D. (1993) Spatial correlations in metal structures and their analysis. 2. The covariance. Mater. Charact. 31:47–53.

Wojnar, L. (1992) Unbiased estimation of fracture surface area. Acta Stereol. 11:651–656.

Yaegashi, H., Takahashi, T. and Kawasaki, M. (1987) Microcomputer-aided reconstruction: a system designed for the study of 3-D microstructure in histology and histopathology. J. Microsc. 146:55–65.

Youngs, T.A., Boyce, R.W., Mosekilde, L., Søgaard, C.H., Paddock, C.L. and Gundersen, H.J.G. (1994) Direct stereological estimation of 3D connectivity density in human iliac cancellous bone: the effect of age and sex. Acta Stereol. 13:55–60.

Zar, J.H. (1996) Biostatistical analysis. (3rd Edition). Prentice Hall. London.

Zhao, H.Q. and MacDonald, I.F. (1993) An unbiased and efficient procedure for 3D connectivity measurement as applied to porous media. J. Microsc. 172:157–162.


Page 270


Page 271

Index

This is not a reference book but rather a structured tutorial which is designed to be read in sequence. Therefore this index is arranged to first give the location of any major definition of the item sought and then to some selected important further citations.

acceptance,

line, 71

plane, 82

accuracy, 4, 6

aggregate, 134

allometric scaling, 148

analysis of variance, 152–154

angiogenesis, 183

anisotropy, 104

axis of, 120

perfect, 120

arbitrary,

orientation, 108, 142

sample, 19

area,

cross-sectional, 37

fraction, 53

guard, 72

per frame (a/f), 76, 89

per point (a/p), 37

sampling fraction (asf), 89–90, 184

aspect ratio of pixels, 41

associated,

plane in optical disector, 83

point of cross, 29

point counting rule, 68

assumption,

based correction factors, 66

free stereology, 6

single section disector, 89

backlash, 80

bias,

sampling, 2–3

sources of, 4

systematic, 3

biological variability, 154

biopsy, 127

blinding in experiments, 147

Boolean model, 206

boundary length, 32

brick (unbiased), 78–82

bronchial duct counting, 92

Buffon estimator, 32, 187

calibration, 5, 40

cardinality, 9, 66

Cavalieri method, 28, 35–39, 166

coefficient of error 37, 154–157

section for physical disector, 77

volume element in, 37

cell number, 65

in cytology, 183

clinical pathology, 127

coaxial section, 166

coefficient,

of error (CE), 149

of variation (CV), 149

cohort studies, 159

colony counting, 183

complete spatial randomness,

for point patterns, 196

for volumes, 199

condenser, 79

confidence interval (CI), 151–152

confocal microscopy, 7

connectivity, 93

continuous scan, 68

Conneulor method, 93

consistent estimator, 146

containing space, 12–13, 103

contiguity, 210

correlation length, 206

correlations, 148

countable events, 11

counting rules, 68–82


Page 272

conversion of units, 14

covariance, 199

connected component

cross, 204, 210

isotropic cross, 207

non-connected component

star

covariogram, 156

cross-covariance, 204

cross-validation, 148

cycloid,

definition, 109

length estimation with, 123–124

major axis, 109

minor axis, 109

projection of, 123, 177

surface estimation with, 110

test grids, Appendix B, 110

cycloidal surface, 177

data plotting, 148

Debye random medium, 206

deduction, 83

degrees of freedom, 151

Delesse principle, 53, 59

density,

definition, 12

dimensions and units, 14

length, 119

number, 65–76

surface, 103

volume, 53

design,

based stereology, 6, 18

based counting, 66

of sampling scheme, 17

digitizing pad, 39, 41

dimensions,

and sectioning, 9

and units, 14

dimensional analysis, 14

dipole, 199

directional counting rule, 70

directional randomness,

2D, 30

3D, 105–108

discrete objects, 65

dish, Petri, 183

disector,

cheating, 89

closed space curve, 92

double, 90

golden, 91

height, 76

molecular, 91

of unknown depth, 137

optical, 78

particle sampling with, 137

principle, 12, 69

physical, 74

single section, 89

special cases, 89–92

two-way, 75

volume of, 76

edge effect, 72, 197

efficiency, 3

embedding,

cryo, 80

methyl methacrylate, 80

wax, 80

empty space function, 196

error, coefficient of, 149

estimate, 2, 145

estimation,

prediction of CE, 159

two stage, 154

estimator, 145

ratio, 59

symbol of, 27

exponential covariance, 206

extended deterministic case, 209

Fakirs bed, 105, 120, 166

forbidden,

line, 72

surface, 82

fixation shrinkage, 80

fractionator, 85

2D, 183

area sampling fraction (asf), 89

combined, 189

final sampling fraction, 98

height sampling fraction (hsf), 90

length, 189

multi-stage, 87

optical, 87

physical, 85

principle, 85

section sampling fraction (ssf), 87

frame,

associated point, 76

computer generated, 80

unbiased counting, 72


Page 273

fundamental,

rectangles, 26

sampling units (FSU), 12, 144

tile, 28

Gaussian distribution, 151

geometric probability, 20–33

geometrical probe, 7–12

Golgi stain, 180

graticule, 40

grids, Appendix B,

area per point (a/p), 40

constant, 33

inter-point distance, 28

multi-purpose, 58

3D point grid, 29

guard,

area, 72

volume, 82

hard core pattern, 196

height,

disector, 76

of layer, 127

sampling fraction (hsf), 90

weighted sampling, 67, 134

hierarchy of sampling design, 6

histogram,

by number, 135

by volume, 135

histopathology, 129

horizontal reference plane, 108

hot air, politician, 53

image analysis,

automatic, 6, 39

and stereology, 41

volume fraction estimation with, 60–61

immuno-colloidal gold, 91

inferences, 19

instrumentation, Appendix A

intersections,

between line probes and surface, 8, 104

between planes and linear feature, 9, 119

isector, 110, 123

isotropic,

direction in 3D, 105

orientation, 105

plane, 110

rulers, 208

uniform random in 2D space, 32

uniform random in 3D, 203

isotropy,

in 2D, 30, 105

in 3D, 105–108

Journal editorial policy, 65

Journal of Microscopy, Appendix D

K-function, 196

laboratory notebook, 147

lark pie, 136

layered structures, 127

mean layer height, 128

projected unit area, 128

vertical sections in, 128

length,

density, 119, 170

dimensions and units, 14

estimation, 119

estimation from vertical designs, 123

fractionator, 183

in 2D, 187

total, 121, 177

length per point (l/p),

of cycloid, 110

of Merz grid, 188

of quadratic grid, 117, 188

line,

acceptance, 71

forbidden, 72

linear,

contact distance distribution, 210

dipole probe, 200, 203

integration, 54

regression, 148

test probe, 104

local stereology,

of particle characteristics, 136

of spatial architecture, 195

logarithmic plots, 148

magnification,

calculation, 40

linear, 40

magnitude of measurements, 14

manual tracing, 39, 41

mass, 14, 35

maximum diameter, 134

mean,

layer height, 127

particle surface, 134

particle volume, 134


Page 274

measurement science, 14

Merz grid, 188

methyl methacrylate, 80

microcator,

mechanical, Appendix A

opto-electronic, 80

microscope,

camera lucida, 80

confocal light, 7

drawing tube, 80

electron, 1, 90

oil immersion, 80

stage backlash, 81

tandem projection, Appendix A, 93

microtome, 77

minimum diameter, 134

multi-phase material, 55

multiple-stage sampling,

fractionator, 87

two stage estimation, 154

nearest neighbour distribution, 196

negative structural correlation, 202

neurite outgrowth, 183

neuron, Golgi stained, 180

non-convex particles, 69

non destructive testing (NOT), 130

nuclear volume, 138

nucleator, 138

nucleolus, 139

number, 65

density, 65,

dimensions and units, 14

estimation, 65

rounding for reports, 160

total, 65

numerical aperture, 80

observed variance, 153

oil immersion objective lens, 80

one-stop stereology, 208

optical,

disector, 78

fractionator, 87

rotator, 166

sectioning, 80

organ volume, 35

orientator, 122, 203

orientation,

arbitrary, 108, 142

in 2D space, 32

in 3D space, 104

isotropic, 104

of linear probes, 104

of sections, 110, 122

vertical, 108

osteocyte lacunae, 197

overprojection, 60

p value, 148

pair correlation function, 202

paired sample test, 148

Pappus methods, 166

parameter, 144

particle,

counting convex, 82

indirect estimation of mean surface, 141

indirect estimation of mean volume, 141

number, 65

number weighted volume distribution, 134

population of, 133

second moment of distribution, 141

selection, 133

shape, 133

sieving, 134

size distribution, 141

sizing, 133

“tops”, counting, 70

volume measurement, 133, 140

volume weighted volume distribution, 136

periodicity, natural, 25

perspex template, 112, Appendix A

Petri dish, 183

Petrimetrics, 183

physical,

disector, 74

fractionator, 85

pilot experiment, 7, 153

plane orientation, 119

planimeter, 54

plastic sections, 80

point,

associated, 29, 68

counting, 54

definition of, 29

frame associated, 76

patterns, 195

sampled intercepts,136

Poisson process, 196

population,

defined, 144

mean, 148

of animals, 148

of particles, 133


Page 275

parameters, 144

public opinion polls, 2

standard deviation, 148

variance, 148

porosity, 53

positive structural correlation, 202

precision, 3, 6

in microscopy, 7

preferred directions, 107

probability,

symbol, 19

uniform, 19

probes,

areal, 119

geometrical, 7, 20–33

linear, 104

planar, 119

point, 8

random geometrical, 20–33

stack, 166

virtual, 166, 168

volume (3D), 9

profile,

counts, 65

in maximal focus, 82

nuclear, 82

projected unit area, 127

projection plane, 177

public opinion polls, 2

quadratic test grids, Appendix B

random,

direction in 2D, 30

direction in 3D, 105

geometry, 20–33

number table, 21

orientation in 3D, 105

psuedo-random number, 21

sample, 17

sampling, 17

systematic random, 23

systematic random in 2D and 3D, 24

translation, 30

uniform random, 3

range, 202

rare phase, 55

raster, 78, 185

ratio,

and reference space, 12

coefficient of error, 157

densities, 12

estimate, 12

estimator, 59

particle size from, 141

quantity, 12

reducing fraction, 1

reference,

line, 201

plane, 108

space, 5, 12

space, lack of, 127

trap, 12, 127

value, 202

volume, 35, 12

refractive index, 80

resin embedding, 80

rotational slide holder, Appendix A

rotator, 141, 166

rounding numbers for reports, 160

rule, counting, 68–82

rule-of-thumb,

amount of effort in counting, 7

disector height, 77

optical disector size, 83

section thickness (volume fraction), 60

two-variable digit rule, 160

safety, xvi

sample, 2, 144

arbitrary, 19

size, 7, 159

statistics, 149–150

systematic, 23

uniform random, 145

sampling,

bias, 2

central paradox of, 19

design, 17

distribution, 145

effort, 7, 153, 159

fraction, 85

fundamental units, 12, 144

hierarchical nature, 6

non-uniform, 66

random, 17

regime for optical disector, 83

regime for physical disector, 77

simple random, 17

survey sampling, 18

theory, 18

uniform random, 19

unit, 144

scale bar, 40


Page 276

second-order stereology, 195

for points, 196

for volumes, 198

section, 36, 142

arbitrary, 108, 142

Cavalieri, 77

coaxial, 166

disector pair, 77

exhaustive, 39

isotropic uniform random, 110, 122

look-up, 73

optical, 78

parallel, 35

perfectly registered, 79

polished, 74

reference, 73

sampling fraction (ssf), 87

serial, 39

serial without reconstruction, 69

thick, 36

thickness in volume fraction estimation, 60

vertical uniform random, 108

selector, 137

shadow graph, 176

shape coefficient, 157

shrinkage,

measurement of, 80

of brains, 13

of layered structures, 130

of sections, 74, 80

sieving distribution, 135

significant figures, 160

simple random sampling, 17

single object stereology, 165

size distribution, 135

slab, 36, 176

slice, 36

slicer,

large object, Appendix A

small object, Appendix A

small specimens, 110

Snells law, 80

space curve, 130, 176

spatial distribution,

of points, 196

of volume, 198

spatial grid, 166

isotropic, 167

vertical, 175

specimen bleaching, 80

sphere,

co-latitude, 107

isotropy of, 104

longitude, 107

unit, 107

stage,

micrometer, 40

programmable electronic, 185

standard error (of the mean), 145

star volume, 210

statistical,

advice, 146

hypothesis, 145

practice, 145

statistically typical, 19

statistics,

confidence interval, 151

for stereologists, 143

mean, 150

standard deviation, 150

stereology,

2D, 183

defined, 7

design-based, 6

model-based, 177

one-stop, 208

second order, 195

single object, 165

unbiased, 6

steric hindrance, 91

structuring element, 166, 168

students t distribution, 151

surface,

affinity, 210

density, 7, 103, 210

dimensions and units, 14

estimation, 103

particle mean, 141

roughness, 129

total, 103

weighted sampling, 134

survey sampling, 19

systematic random sampling, 19

tandem projection microscope, Appendix A

tesselate, 184

tesselation, area filling, 73

tissue shrinkage, 80

toggle switch, 170

toggling, 171

total quantity, 12

total vertical projections, 177

transect, 10

trochar, 111, Appendix A


Page 277

two-stage estimation, 154

prediction of CE, 159

two-way disector, 75

unbiased,

brick, 78

counts, 65

counting frame, 72

estimate, 145

estimator, 145

sampling frame, 72

stereology, 5

unbiasedness, 3

uniform random,

fields, 58

point in space, 21

sample, 145

variate, 24

units,

conversion, 14

SI (System International), 14

validation, 146

variability,

between blocks, 6, 157

between fields, 6, 157

between sections, 6, 157

biological, 152, 6

of fractionator, 87

overall, 6

variance,

addition, 152

analysis of, 152

decomposition, 153

vertical,

length estimation, 175

“local”, 111

sectioning protocols, 111

sections of layered structures, 127

spatial grid, 166, 175

total projection, 123, 177

uniform random, 203

video camera, 80

virtual cycloid surface, 177

virtual probes, 166

volume,

anisotropy, 210

density, 53,

dimensions and units, 14

element, 37

fraction, 53, 199, 209

guard, 82

of disector, 76

particle, 133

total, 35

volumetric feature, 198

volumetry, 35

weighting,

in height distribution, 133

in number weighted, 133

in volume distribution, 133

zero-dimensional,

probe, 10, 29

quantity, 66, 10


Page 278


Page i

Unbiased Stereology

Three-Dimensional Measurement in Microscopy

Second Edition


Page ii

This page intentionally left blank.


Page iii

Unbiased Stereology

Three-Dimensional Measurement in Microscopy

Second Edition

C.V.Howard & M.Reed
Developmental Toxico-Pathology Research Group, Department of Human Anatomy and Cell Biology,
University of Liverpool, Liverpool, UK


Page iv

© Garland Science/BIOS Scientific Publishers, 2005

First edition published 1998

Second edition published 2005

All rights reserved. No part of this book may be reprinted or reproduced or utilized in any form or by any electronic, mechanical, or other means, now known or hereafter invented, including photocopying and recording,
or in any information storage or retrieval system, without permission in writing from the publishers.

A CIP catalogue record for this book is available from the British Library.

ISBN 0-203-00639-9 Master e-book ISBN

ISBN 1 85996 0898 (Print Edition)

Garland Science/BIOS Scientific Publishers
4 Park Square, Milton Park, Abingdon, Oxon, OX14 4RN, UK and
270 Madison Avenue, New York, NY 10016, USA
World Wide Web home page: www.garlandscience.com

Garland Science/BIOS Scientific Publishers is a member of the Taylor & Francis Group.

This edition published in the Taylor & Francis e-Library, 2005.

To purchase your own copy of this or any of Taylor & Francis or Routledge’s collection of thousands of eBooks please go to www.eBookstore.tandf.co.uk.

Distributed in the USA by
Fulfilment Center
Taylor & Francis
10650 Toebben Drive
Independence, KY 41051, USA
Toll Free Tel: +1 800 634 7064; E-mail: taylorandfrancis@thomsonlearning.com

Distributed in Canada by
Taylor & Francis
74 Rolark Drive
Scarborough, Ontario MIR 4G2, Canada
Toll Free Tel.: +1 877 226 2237; E-mail: tal_fran@istar.ca

Distributed in the rest of the world by
Thomson Publishing Services
Cheriton House
North Way
Andover, Hampshire SP10 5BE, UK
Tel.: +44 (0)1264 332424; E-mail: salesorder.tandf@thomsonpublishingservices.co.uk

Library of Congress Cataloging-in-Publication Data

Howard, Vyvyan.
Unbiased stereology/C.V.Howard, M.Reed.—[2nd ed.].
p. cm.—(Advanced methods)
Includes bibliographical references and index.
ISBN 1-85996-089-8
1. Stereology. 2. Microstructure-Measurement. I. Reed, M.G.(Matt G.) II. Title
III. Series.
Q175.H86 2004
502′.8′2–dc22 2004015841

Production Editor: Catherine Jones

Pseudocolored image of neurons from Layer II of rat neocortex.
Image provided by Dr Gesa Staats de Yanes.


Page ix

Abbreviations

0D | zero-dimensional
1D | one-dimensional
2D | two-dimensional
3D | three-dimensional
A | total area
a/f | area of frame
a/p | area per point
asf | area sampling fraction
AUR | arbitrary uniform random
CCD | charge-coupled device
CD-ROM | compact disk read-only memory
CE | coefficient of error
CV | coefficient of variation
∆x | inter-point spacing in horizontal direction
∆y | inter-point spacing in vertical direction
FSU | fundamental sampling unit
h | disector height
hsf | height sampling fraction
I | intersection count
IUR | isotropic uniform random
L | total length
l/p | length per point
Lv | length density
M | linear magnification
MRI | magnetic resonance imaging
 | mean star volume
 | mean number-weighted particle volume
 | mean surface-weighted particle volume
 | mean volume-weighted particle volume
N | total number
Nv | numerical density
NA | numerical aperture
NDT | non-destructive testing
P | point count
PSI | point-sampled intercept
Q− | disector count
∑ | summation
S | total surface
Sv | surface density
SD | standard deviation
ssf | slice or section sampling fraction
T | inter-plane spacing
TVP | total vertical projection
UR | uniform random
V | total volume
Vv | volume density
VUR | vertical uniform random


Page v

Contents

 | Abbreviations | ix
 | Preface to the first edition | xi
 | Preface to the second edition | xiii
 | Acknowledgments | xiv
 | Dedication | xv
 | Safety | xvi
 | Foreword—L.Wolpert | xvii
1. | Concepts | 1
 | 1.1 Sampling and bias | 2
 | 1.2 Why unbiasedness is desirable | 3
 | 1.3 Sources of bias in microscopy | 4
 | Sampling bias | 5
 | Systematic bias | 5
 | 1.4 The hierarchical nature of microscopical investigations | 6
 | 1.5 Stereology—geometrical quantification in 3D | 7
 | 1.6 Think in three dimensions—a macroscopic analogy by thought experiment | 7
 | Points probe volume | 8
 | Lines probe surface | 8
 | Planes probe length | 8
 | Volumes probe number | 9
 | 1.7 Dimensions and sectioning | 9
 | 1.8 Geometrical probes | 11
 | 1.9 Ratios and densities | 12
 | 1.10 The reference space | 12
2. | Random sampling and random geometry | 17
 | 2.1 Stereology and randomness | 17
 | 2.2 Two simple experiments | 18
 | 2.3 Take a sweet, any sweet | 19
 | 2.4 A uniform random (UR) sample | 20
 | 2.5 A single UR point in 1D, 2D and 3D | 21
 | 2.6 Repeat the process… | 23
 | 2.7 A systematic random sample in 2D and 3D | 26
 | 2.8 Random geometry | 26
 | 2.9 Randomizing directions—isotropy in the plane | 30


Page vi

3. | Estimation of reference volume using the Cavalieri method | 35
 | Exercise 3.1 | 43
 | Exercise 3.2 | 44
 | Exercise 3.3 | 45
 | Exercise 3.4 | 47
 | Exercise 3.5 | 50
4. | Estimation of component volume and volume fraction | 53
 | 4.1 Estimation of volume fraction | 53
 | 4.2 Estimation of total volume of a defined component | 55
 | Exercise 4.1 | 62
 | Exercise 4.2 | 63
 | Exercise 4.3 | 64
5. | Number estimation | 65
 | 5.1 Some useful ‘definitions’ | 66
 | 5.2 Some ‘non-definitions’ | 66
 | 5.3 A cautionary tale | 66
 | 5.4 On the right road | 68
 | 5.5 Continuous scanning of a plane | 68
 | 5.6 The disector principle | 69
 | 5.7 From theory to practise | 71
 | 5.8 Implementation of the physical disector | 74
 | 5.9 Typical sampling regime for the physical disector | 77
 | 5.10 Optical section ‘scanning’ methods—the unbiased brick and optical disector | 78
 | 5.11 The unbiased brick-counting rule | 82
 | 5.12 Application of the optical disector counting rule | 82
 | 5.13 Typical sampling regime for the optical disector | 83
 | 5.14 Direct estimation of number—the fractionator | 85
 | 5.15 A 2D example of the f ractionator principle | 85
 | 5.16 The multi-stage fractionator | 87
 | 5.17 The optical fractionator | 87
 | 5.18 Some special designs for counting in 3D | 89
 | The single section or ‘cheating’ disector! | 89
 | The double disector | 90
 | The ‘molecular’ or ‘golden’ disector | 91
 | Counting closed space curves—Terminal bronchial ducts in lung | 92
 | Counting complex shaped objects in 3D and connectivity estimation | 93
 | Exercise 5.1 | 94
 | Exercise 5.2 | 96
 | Exercise 5.3 | 98
 | Exercise 5.4 | 99
6. | Estimation of total surface area and surface density | 103
 | 6.1 Estimation of surface density | 104
 | 6.2 Random directions and orientations in 3D space | 105
 | 6.3 Generating isotropic line probes—1 Vertical sections | 108


Page vii

 | 6.4 Generating isotropic line probes—2 Isotropic sections | 110
 | 6.5 Estimation procedure | 110
 | 6.6 Examples of vertical sectioning protocols | 111
 | Exercise 6.1 | 113
 | Exercise 6.2 | 117
7. | Length estimation | 119
 | 7.1 Generation of IUR sections—the orientator and isector | 122
 | Exercise 7.1 | 125
8. | Stereological analysis of layered structures | 127
 | 8.1 Stereological ratios | 127
 | 8.2 Vertical sections of layered structures | 127
 | 8.3 Practical example | 129
 | 8.4 Application areas | 130
 | 8.5 Worked example of application | 130
9. | Particle sizing | 133
 | 9.1 Step 1—selecting particles | 133
 | 9.2 Step 2—measuring the size of the selected particles | 134
 | 9.3 The difference between the number-and volume-weighted distributions of size | 134
 | 9.4 Direct estimators of mean particle volume | 136
 | The ‘point-sampled intercept’ (PSI) method | 136
 | The ‘selector’ | 137
 | The ‘nucleator’ | 138
 | 9.5 Indirect estimation of mean particle size from Stereological ratios | 141
 | 9.6 Distributions of particle volume | 141
 | Indirect estimation of the second moment of the number-weighted particle volume distribution | 141
 | Direct estimation of particle volume distributions | 142
10. | Statistics for stereologists | 143
 | 10.1 ‘Quantifying is a committing task’ (Cruz-Orive, 1994) | 143
 | 10.2 Preliminary concepts | 144
 | Population | 144
 | Parameter | 144
 | Sampling unit | 144
 | Sample | 144
 | Estimate | 145
 | Estimator | 145
 | Uniform random sample | 145
 | 10.3 Unbiased estimates | 145
 | 10.4 Elements of good statistical practice | 146
 | 10.5 Quantities of interest | 148
 | 10.6 Application to a single object | 152
 | 10.7 Addition of variances | 152
 | 10.8 Two-stage estimation | 154
 | 10.9 Calculation of CE for the Cavalieri method | 154
 | 10.10 Calculation of the CE of a ratio estimator | 157
 | 10.11 Prediction of CE for two-stage estimation | 159


Page viii

 | 10.12 Precision of Cavalieri estimation for single objects | 160
 | Exercise 10.1 | 162
 | Exercise 10.2 | 163
11. | Single-object stereology | 165
 | 11.1 Introduction | 165
 | 11.2 Volume of single objects—arbitrary orientation designs | 166
 | 11.3 Surface of single objects—isotropic or vertical orientation designs | 167
 | The isotropic ‘spatial grid’ | 167
 | The vertical spatial grid | 175
 | 11.4 Length estimation in vertical orientation designs | 175
 | Length density | 175
 | Total feature length | 177
 | Exercise 11.1 | 180
12. | ‘Petri-metrics’ | 183
 | 12.1 Introduction | 183
 | 12.2 Counting methods | 183
 | The 2D fractionator | 183
 | Practical application at the microscope | 185
 | 12.3 Length estimation in 2D | 187
 | 12.4 Combined length and number estimation | 189
 | Exercise 12.1 | 191
 | Exercise 12.2 | 193
13. | Second-order stereology | 195
 | 13.1 Introduction | 195
 | 13.2 Second-order methods for point patterns | 195
 | 13.3 Second-order methods for volumetric features | 198
 | 13.4 The covariance estimator | 199
 | 13.5 Linear dipole probes | 203
 | 13.6 Making sense of covariance | 205
 | 13.7 Example of the application of linear dipole probes | 207
 | 13.8 Using isotropic rulers to get ‘one-stop stereology’ | 208
Appendix A: | Practical gadgets for stereology | 211
Appendix B: | Set of stereological grids | 217
Appendix C: | Worked answers to exercises | 239
Appendix D: | Useful addresses | 259
 | References | 261
 | Index | 271


Page x

This page intentionally left blank.


Page xi

Preface to the first edition

This book addresses a problem common to almost all scientists who use a microscope in their work. Consider a ‘lump’ of something of interest. To the biologist it might be a kidney or piece of brain, for the materials scientist a piece of ceramic or steel and for the geologist a flake of rock. In each case the investigators are interested in the internal microstructure of their respective lumps of material. These microstructures are generally beyond the resolving power of the naked eye and are furthermore concealed within the object. For these reasons the investigators must rely upon sectioning to reveal the inside of the object and microscopy to visualize the interesting detail of the structure.

To gain a qualitative feel for a particular microstructure it may be sufficient to take a few sections, choose some interesting-looking regions and record a small number of micrographs. If the structure has not been observed before these micrographs may well be published with an interpretation of what has been observed. This type of subjective analysis and interpretation of microscopic features has been the foundation of many new areas of scientific microscopy. However, it is not the only way to employ microscopy in a scientific manner and in this book we focus on its use as a tool for objective analysis. For example, the specimens being analysed may be part of an experimental series in which there are important but subtle changes between groups. If these changes are not qualitatively obvious it is then natural to turn to quantitative microscopy.

Qualitative microscopic studies, with expert interpretation and analysis, will continue to play a valid and useful role in the initial stages of many scientific problems. However, it is the use of quantitative methods that is the hallmark of modern scientific research. Once the results of a study are to be used in a quantitative way then it must be planned and executed with a more rigorous approach than is employed in a qualitative analysis. If this is true for any macroscopic measurement then it is thrice so for a microscopic analysis, because of the following questions:

1. Is the ‘lump’ that is brought to the laboratory bench representative of the whole?

2. Is my sub-sample representative of that particular ‘lump’?

3. Are the measurements that are being made on the sub-sample sensible and useful with respect to the underlying scientific question?

Most scientists are well trained in ensuring that the first question is addressed properly. For example, biologists will try to reduce variability in their system by using an inbred strain of animals, all of the same age and possibly sex, with similar diets, and so on. It is clearly and rightly beyond the scope of this book to try to describe sampling regimes for the multitude of scientific disciplines that can successfully apply quantitative microscopy. Therefore in this text it will always be assumed that the sample being ‘brought to the table’ is representative of the greater whole, however that may be defined. For life scientists the lump brought to the table will usually be the whole of an organ or identifiable organ component from within one animal or plant, that is, the fundamental sampling unit in biology. For materials science where the ‘greater whole’ is often more difficult to define, the sample brought to the table may be several sub-samples from the output of a production process over a given time period, and so on.

It is our experience that many scientists are not trained to consider the second question and in general tend to make arbitrary decisions about where to take their ‘within-lump sample’. However, although arbitrarily chosen samples may suffice for qualitative analysis they are usually inadequate for objective quantitation.


Page xii

We will devote a considerable part of this book to addressing ways of sampling specimens in three dimensions so that every part of the specimen has the same chance of being in the final sample, before sampling commences. Clearly some element of randomness has to be introduced into this process and in general this is uniform randomness. The process of randomizing the sampling continues throughout the many hierarchical levels inherent in a quantitative microscopical analysis. The golden rule at each stage is that the investigator should never choose things to measure (for example because they look interesting or they have high contrast).

Finally, with most of the sampling complete, slides are prepared, stained and viewed in the microscope and now the third question looms into sight. What to measure? Most modem image analysers provide a plethora of things that can be measured—boundary lengths, profile numbers, Feret diameters, shape factors, and so on. Unfortunately most of these parameters are rooted firmly in the two-dimensional ‘flat-land’ of the microscope image and have remarkably little to do with the three-dimensional real world we are interested in. Fortunately all is not lost. If the sections have been obtained using the sampling methods we describe here then it takes no more effort (and often considerably less) to use the two-dimensional slides to make the highly relevant and intuitively understandable three-dimensional measurements that stereology has to offer.

As always in science the most important step is to formulate sound hypotheses and ask the right questions. Given good scientific questions it is then possible to decide which measurements are required to answer them. With stereology we can ask very penetrating questions. Does drug A cause a loss of cells in the development of this organ? Does exercise cause an increase in the surface area of this absorptive membrane? Does the continued heat treatment of this steel change the mean grain volume? (It should be noted that in each case the form of the high-level scientific question will dictate which parameters should be measured, not vice versa.)

In this book we describe practical methods for obtaining stereological estimates of feature volume, surface, length and number and mean particle size. We believe our audience will primarily be experimental scientists who want to apply stereology to their problems. For this reason we have largely hidden the underlying theory and have instead focused upon clear and unambiguous presentation of the practical essentials. We see this book very much as an introduction to a fascinating and diverse field and hope that we have provided enough material to aid further reading. With these thoughts in mind readers who are experienced in statistics and probability theory may find Chapters 1 and 2 a bit ‘slow’. We make absolutely no apology for this! It is the statistical and probabilistic ideas underlying unbiased stereology that, in our experience, cause problems amongst newcomers to stereology. We have therefore made efforts to illustrate the theory by using examples drawn from everyday experience.

The presentation in the book is as near as we can get to the way we present these ideas in taught courses. We have tried to make the narrative logically structured and it should be followed in the order presented. Important material that does not fit easily into the flow of the book is included in ‘boxes’. In common with many other areas of microscopy there is no substitute for practical experience. The book therefore includes a considerable number of exercises either developed by ourselves or kindly donated by expert stereologists from around the world.

We hope you enjoy reading this book as much as we did writing it.

Vyvyan Howard
Matt Reed
Liverpool, UK
September 1997


Page xiii

Preface to the second edition

It is now over six years since the first edition of Unbiased Stereology was published. During that time it has been gratifying to have an enormous amount of feedback from readers who have found the book to be of use. As we stated in the preface to the first edition, our motivation for writing the book was to give practitioners a firm basis on which to undertake real research with stereological tools. We set ourselves the imaginary task of writing a guide book for a complete novice, who was stranded on a desert island with his or her slides and microscope with no recourse to outside help. On the whole our readers have told us that we have succeded in doing this. An interesting fact is that a number of companies who write stereology software include a copy of this book as part of the background reading for new users.

In our opinion there have been no fundamental theoretical developments in first-order stereology since 1997. Indeed our own research efforts have tended to focus on other aspects, for example second order methods for describing spatial distribution of features. This work on second-order stereolgy was begun as part of a PhD study and has led to the development of the ‘One-Stop’ Stereology approach described in Chapter 13. In this new approach, a range of first-and second-order quantities are obtained from very simple use of isotropic ‘rulers’ from a single ‘visit’ to the micrograph. Our experience with ‘One-Stop’ is that we can estimate a range of parameters at least ten times faster than previously.

In this edition we continue to emphasise the use of the human eye/brain for image segmentation and either simple overlays or computer overlays for grids. One day, this approach may well be obsolete. Although the measurement techniques may be overtaken in the fullness of time by advances in image analysis, the underlying sampling considerations will remain valid.

We have added three chapters to the book which expand on aspects of the first edition. Chapter 11 is a much more detailed introduction to single-object stereology, Chapter 12 expands the scope to include 2D versions of the stereological methods, something we have called ‘Petri-metrics’. Chapter 13 gives a much fuller explanation of second-order stereology than the original. In addition to newer material we have reviewed other chapters and made small changes, adding fresh references as appropriate.

Vyvyan Howard
Matt Reed
Liverpool, UK
September 2004


Page xiv

Acknowledgments

The authors wish to thank Professor Luis Manuel Cruz-Orive for his helpful and constructive critiques of two earlier versions of the manuscript. We would like to acknowledge the improvements that have resulted from his involvement.

We would like to thank all of the other members of the International Society for Stereology we have worked with over the past years, in particular: Adrian Baddeley, Arun Gokhale, Herbert Haug, Bob de Hoff, Hans Jørgen Gundersen, Eva Jensen, Dominique Jeulin, Torsten Mattfeldt, Terry Mayhew, Bente Pakkenberg, Jean-Paul Rigaut, Konrad Sandau, Jean Serra and Ewald Weibel. Many of their ideas are synthesized within this book and the subsequent reference list.

We would also like to thank our families, Dawn, Lorna and Ben Reed, Stephanie, Emily, Alice, Charles and Clara Howard, for the support and encouragement they provided whilst we wrote this book.


Page xv

Dedication

Professor Ronnie Finn FRCP (1930–2004)

Professor Ronnie Finn received the Albert Laskar award (often known as the American Nobel prize in medicine) in 1980 for his contribution in the development of an effective treatment for Rhesus haemolytic disease. The resulting anti-Rh(D) injection, which is given to thousands of women worldwide every year, is estimated to have saved some half a million lives to date.

As a practising physician, he developed a strong interest in food intolerance and the effect of the environment on health. Ronnie Finn was a founder member of the British Society for Allergy, Environmental and Nutritional Medicine. One of Ronnie Finn’s pupils was Vyvyan Howard, then a medical student at the University of Liverpool. Much later they developed common interests in the ways that environmental pollution impacts upon human health. After his retirement from clinical medicine, Ronnie Finn became an honorary member of Vyvyan Howard’s research group and there met Matt Reed who became a personal friend.

Both of the authors sadly miss Ronnie—the regular Friday lunchtime meetings, his quiet wisdom, his sense of humour and his astounding capacity for ‘lateral thinking’. We are pleased to have known him and hope that, by dedicating this book to his memory, it will draw wider attention to the immense good that he achieved in his lifetime, which now lives on after his departure.


Page xvi

Safety

Attention to safety aspects is an integral part of all laboratory procedures, and both the Health and Safety at Work Act and the COSHH regulations impose legal requirements on those persons planning or carrying out such procedures.

In this and other handbooks every effort has been made to ensure that the recipes, formulae and practical procedures are accurate and safe. However, it remains the responsibility of the reader to ensure that the procedures which are followed are carried out in a safe manner and that all necessary COSHH requirements have been looked up and implemented. Any specific safety instructions relating to items of laboratory equipment must also be followed.


Page xvii

Foreword

A central issue in developmental biology is how genes control the behavior of cells in the embryo so that reliable functional organs, like kidneys and brains, develop. While there has been good progress in understanding the early specification of the cells in such organs much still needs to be learned about their later development and growth. Indeed, growth control of the fetus is of particular importance as there is evidence that failure of the human fetus to grow properly can lead to both cardio-vascular disease and diabetes in later life.

Studying the growth of organs like the kidney, brain and pancreas—and indeed other organs—presents a special problem as they are made up of a very large number of functional units. In the case of the kidney one needs to know both the number and size of glomeruli, while in the brain it is often necessary to count the number of a particular class of neurone or synaptic connections. However, with almost all pertinent studies, it is not possible to count the number of relevant units directly. Yet the information is essential if we want to know how changes in genetic constitution of an animal affect the organ’s development. For example, what effect does the absence of a particular growth factor or reduced nutrition have on the number or size of glomeruli in the kidney, and at what stage of development does this occur? Has behavioural experience or environmental insult affected the number of neurones in a particular brain structure such as the amygdala?

The only reliable way to obtain such information is by means of stereology. Stereology is an absolutely essential tool for any biologist who needs to know the number of units in any system—whether they be functional units like glomeruli or cell organelles like mitochondria. It also provides a means of obtaining both the size and surface area of the objects under consideration. Stereology is a technique that enables one to obtain data on the number of identifiable objects in a three-dimensional structure by sampling in two dimensions. That is, it provides a technique for counting the objects on a slice from the structure such as a histological specimen viewed under the microscope. It has the enormous virtue of having a rigorous mathematical foundation and rules for counting that also give a reliable measure as well as an indication of the precision. It is inexpensive and, once learned, easy to use.

Stereology has all too often been neglected, so this book provides the necessary information for all biologists interested in numbers of objects in a structure. It is thus invaluable for both developmental biologists and toxicologists. The book not only provides a detailed description of stereology and how to use it but also includes exercises, attempts at solutions of which could even be entertaining. They will certainly be rewarding.

Professor Lewis Wolpert FRS


Page xviii

This page intentionally left blank.